Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Programator Willem 7.1 - błąd przy programowaniu pamięci Flash 28F010

posek 11 Lut 2013 12:44 4176 11
  • #1 11 Lut 2013 12:44
    posek
    Poziom 13  

    Witam.
    Jestem nowicjuszem w dziedzinie programowania i chciałbym dosiąść jakąś wiedze na ten temat.
    Posiadam Programator Willem 7.1
    Niestety mam problem z wgraniem softu do kości
    Próbowałem na oprogramowaniu Willem Eprom (0.98D8), (0.97ja), (0.98D5)
    na
    Układach Flash INTEL P28F010 oraz AM28F010,

    Programator Willem 7.1 - błąd przy programowaniu pamięci Flash 28F010

    wyszukałem takie układy w programie willem I ustawiłem zworki zgodnie z rysunkiem

    Programator Willem 7.1 - błąd przy programowaniu pamięci Flash 28F010

    Posiadam około 10 takich układów, na każdym problem jest identyczny

    Test Hardware – Hardware present
    Programy bez problemu odczytują zawartośc kości,
    Verifity – Device Verifity OK
    Blank Test – Device is Emty
    Elektronic ID – Manufacture (0xFF) [----] / Device Code (0xFF)
    Przy kasowaniu / Erase Chip – Erase Completed
    Przy wgraniu jakiego kolwiek softu wyskakuje błąd:
    Error AT 0x000000 Chip = 0xFF Buffet = 0xA8

    Programator Willem 7.1 - błąd przy programowaniu pamięci Flash 28F010 Programator Willem 7.1 - błąd przy programowaniu pamięci Flash 28F010
    Szukałem w innych tematach podobnych problemów jednak nie uzyskałem interesującej mnie odpowiedzi.

    Chciałbym abyście mi polecili inne układy na których mógłbym nauczyć się programować
    Z góry dziekuje za pomoc

    0 11
  • #2 13 Lut 2013 22:59
    krzycho123
    Poziom 31  

    Willem jest bardzo problematyczny , stąd setki wątków na elektrodzie o nim.

    Czasem na problem z układem pomaga użycie starszej wersji softu tj 0.97 , nie zapomnii o zmianie zworki na PCB3.

    Można by o willemie książki pisać , ja używałem go również sporo czasu ale tych pamięci nie trafiłem.

    0
  • #3 14 Lut 2013 13:54
    posek
    Poziom 13  

    właśnie tez wyczytałem dużo wątków że jest problematyczny, jest wiele takich bez odpowiedzi z podobnym problemem do mojego w którym nie moga moga zaprogramować kostki, piszesz o zworce PCB3 , czy to jest ta zworka Vpp ?
    ustawiam wszystkie zworki zgodnie z tym co wyświetli program przy wyborze pamięci, DIP-SW - konfiguracja napięć - również jest na 12V.
    Zasilanie programatora podłączone przez USB , ale na zasilaczy tez próbowałem i podobny problem.

    0
  • #4 14 Lut 2013 16:39
    krzycho123
    Poziom 31  

    Wybór PCB to te dwie zworki po lewej stronie środkowego gniazda PLCC , przełącza się obie na jedną lub drugą .

    Sprawdź z softem 0.97 który pracuje z pcb3.

    0
  • #6 15 Lut 2013 17:18
    krzycho123
    Poziom 31  

    Tak chodzi o te zworki.

    0
  • #8 15 Lut 2013 20:32
    krzycho123
    Poziom 31  

    Jak na foto to ustawienie PCB3 dla softu 0.97 .

    0
  • #10 17 Lut 2013 00:06
    krzycho123
    Poziom 31  

    Najlepiej byłoby sprawdzić z nowym układem bo możliwe że są poprsotu uszkodzone.

    Ja niestety nie mam takiego ukłdu bo bym sprawdził ze swoim willemem.

    0
  • #12 26 Wrz 2013 22:10
    dawidlademann
    Poziom 8  

    Kolego rok temu też kupiłem Willema i jeszcze nic mi się nim nie udało zrobić....
    Niedawno kupiłem Welleo VP-390 z adapterami z firmy TOMSAD i jestem z tego sprzętu bardzo zadowolony.
    Polecam

    0