Elektroda.pl
Elektroda.pl
X
Relpol przekaźniki
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Przerzutnik RS na bramkach NOR nie załącza tranzystora

12 Lut 2013 16:12 2865 15
  • Poziom 10  
    Witam posiadam problem. Podłączyłem układ scalany jak na rysynku. Gdy do wyjścia nie podłączam nic przerzutnik działa. A jak podłącze do wyjścia tranzystor to nie chce działać i spada napięcie na wyjściu Q. Jakby zwarcie robiło albo układ za małą obciążalność miał. Tranzystor z mikroprocesora wysterowuje się prawidłowo. Tranzystor to BS170 MOSFET. Proszę o pomoc. Przepraszam za jakość rysunku. (Robiony na szybko.) Przerzutnik RS na bramkach NOR nie załącza tranzystora

    Układ scalony to HEF4001
    Tranzystor BS170
  • Relpol przekaźniki
  • Poziom 18  
    Czy mnie się wydaje czy tranzystor steruję się za pomocą bramki Gate. Czyli do G podajesz sygnał z mikroprocesora a D do 2 wyjścia a do S podpinasz napięcie.
  • Relpol przekaźniki
  • Poziom 43  
    daniel1587 napisał:
    Witam posiadam problem. Podłączyłem układ scalany jak na rysynku. Gdy do wyjścia nie podłączam nic przerzutnik działa. A jak podłącze do wyjścia tranzystor to nie chce działać i spada napięcie na wyjściu Q. Jakby zwarcie robiło albo układ za małą obciążalność miał. Tranzystor z mikroprocesora wysterowuje się prawidłowo. Tranzystor to BS170 MOSFET. Proszę o pomoc. Przepraszam za jakość rysunku. (Robiony na szybko.) Przerzutnik RS na bramkach NOR nie załącza tranzystora

    Układ scalony to HEF4001
    Tranzystor BS170
    A dlaczego wejścia R i S "wiszą w powietrzu", pytam?
    Powinny być one, poprzez rezystory rzędu kiloomów, podłączone do stanu nieaktywnego, a dla bramek NOR jest to zero logiczne, czyli do minusa zasilania - GND.
  • Poziom 10  
    To tylko tak narysowałem. W rzeczywistości do R i S są podłączone zanegowane sygnały z demultipleksera. Z założenia da się uaktywnić tylko jedno wyjście w nim więc stany zabronione nie wchodzą w grę.
    Powtarzam, że jak do wyjścia Q nic nie podłącze to układ działa prawidłowo załącza i trzyma stan wysoki. A jak podłączam moje obciążenie którym jest tranzystor MOSFET nie wysterowuje go. Jak mierze napięcie to jest ok 0,7V jak odłącze tranzystor to jest 4,9V. Jak do tego samego tranzystora podłączam wejście z Atmegi 32 to wysterowuje mi go i załącza przekaźnik. Atmega ma max obciążenie 20mA. Może to wina scalaka z bramkami. Jutro kupię i podłącze drugi na płytce testowej i sprawdzę. Myślałem że ktoś już miał taki problem.

    A kolego może u mnie tkwi problem w tym że sygnały bezpośrednio z negatorów idą na bramki. Może brakuje jakichś rezystorów z szeregu?
  • Poziom 43  
    Zmień egzemplarz układu scalonego typu HEF4001 na inny.
    A zasilanie w/w układu scalonego masz zablokowane kondensatorem bezindukcyjnym?
  • Poziom 34  
    Moim zdaniem tranzystor jest uszkodzony.
    Albo wkładasz go w rzeczywistości inaczej, niż na schemacie.
    Bramka w takim układzie potrzebuje prądu rzędu 1uA, a przy około 2.5V powinna już przełączać.
    Cytat:
    A kolego może u mnie tkwi problem w tym że sygnały bezpośrednio z negatorów idą na bramki. Może brakuje jakichś rezystorów z szeregu?

    Nie, rezystor byłby wskazany wtedy, gdybyś logiczne 1 chciał podawać z zasilania, wtedy przez 1k.
  • Poziom 34  
    A na pewno BS170 wkładasz?
    Bo mi to wygląda, jakbyś N-JFETa wkładał, np. BF245...
    Trudno uwierzyć, że kontroler go steruje, a 4001 nie.
  • Poziom 10  
    Rozwiązałem problem. Sygnał z przerzutnika puściłem na negator i wtedy na tranzystor. Bramki miały zbyt małą obciążalność prądową. Zmierzyłem prąd przy podaniu na G tranzystora +5V i wyszło 40mA. To chyba dużo. Zmierzyłem jaki prąd pobiera tranzystor IRFZ44N i wyszło podobnie. Moje pytanie brzmi czy to normalne czy jakoś źle podłączam? Tranzystor IRFZ44N wysterowany w taki sposób jak na górnym schemacie załącza mi cewkę 3,15A i się nie grzeje więc chyba dobrze. Czekam na odpowiedź
  • Poziom 34  
    40mA to ogromnie dużo, wręcz niemożliwe.
    Moim zdaniem Ty mówisz nam co innego, niż robisz w rzeczywistości.
    O jakiej cewce teraz mówisz? Skąd nagle te 3,15A się wzięło? Ty wczoraj chciałeś cewę potrzebującą przy 12V aż 3,15A sterować tranzystorkiem BS170?
    O jakim negatorze teraz mówisz?
    O ile to wszystko nie są zwykłe żarty...
  • Poziom 10  
    Sterowanie przekaźnika 12V tranzystorem BS170 i sterowanie cewki zaworu tranzystorem IRFZ 44N to dwie różne sprawy. Podałem dla przykładu, że oba tranzystory pobierają taki sam prąd bramki. A jaki twoim zdaniem powinien wynosić prąd bramki tranzystora MOSFET? Prawidłowo podłączam te tranzystory według schematu powyżej? A co do negatora to układ scalony 74HC04.
  • Moderator Projektowanie
    Doczytaj o MOSFET-ach.
    Te tranzystory nie pobierają prądu bramki jak tranzystory bipolarne - w sposób ciągły, lecz jedynie impuls prądu związany z ładowaniem pojemności wejściowej bramki w momencie włączania. Później, dla podtrzymania stanu potrzebują tylko określonego napięcia na bramce, pobierany prąd to µA, albo nA.
    Ten impuls jest dla Ciebie niemierzalny - jedynie dobrym oscyloskopem.
    A wydajność prądowa źródła ma wpływ tylko na czas włączenia , gdyż przeładowanie pojemności bramki to dostarczenie ładunku, a ładunek to prąd x czas.
    Bramki 74HC04 mają aż nadto wydajności prądowej (ok. 20-30mA) aby włączyć każdego (prawie) MOSFET-a w rozsądnym czasie.
    To wyjaśnienie, abyś zrozumiał co miał na myśli Kol. czarutek pisząc, że coś "kręcisz".
  • Poziom 34  
    daniel1587 napisał:
    ... oba tranzystory pobierają taki sam prąd bramki. ...

    I skąd dokąd według Ciebie miałby on płynąć?!
    Czy Ty nie mierzysz go przypadkiem z D do S przy wysterowanej bramce?
    A może z S do D, to i diodę upalisz...

    daniel1587 napisał:
    ... A jaki twoim zdaniem powinien wynosić prąd bramki tranzystora MOSFET? ...

    Jakiś taki niepozorny, nie rzucający się w oczy. Żeby go tam nikt nie przyuważył... ;)
    Daniel, już to przecież mówiłem, rzędu 1µA, czyli tu u Ciebie po prostu 'zerowy, żaden'.
    Ja, BSowi170, to na bramkę tylko spojrzę, i już załącza mi wszystkie przekaźniki w szafie, a Tobie i 30mA za mało... ;)
  • Poziom 10  
    Przepraszam za zamieszanie.
    Problem rozwiązany. A więc wyjaśnię:
    1. Tranzystor BS170 który przełączał przekaźnik okazał się uszkodzony. Działał ale pobierał większy prąd IGS dlatego z wyjścia przerzutnika RS nie dałem rady go wysterować.
    2. Źle mierzyłem prąd IGS na tranzystorach IRFZ44N. Podawałem napięcie nie wymontowując z układu, stąd taki duży prąd.

    Dokonałem pomiarów na płytce montażowej obu tranzystorów(stary IRFZ44N i nowy BS170) i jest tak jak powinno być. Moim mikroamperomierzem ciężko jest zmierzyć prąd (taki jest mały).
    Dziękuję za pomoc

    Temat można uznać za zamknięty.
  • Poziom 34  
    Bardzo mnie to ucieszyło, gratuluję!
  • Poziom 10  
    temat rozwiązany