Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

zasilacz symetryczny lm317/337 - nie działa regulacja natężenia

Kwaq 17 Feb 2013 20:05 5049 10
Altium Designer Computer Controls
  • #1
    Kwaq
    Level 9  
    Witam! poczułem potrzebę stworzenia symetrycznego zasilacza warsztatowego z regulacją napięcia oraz natężenia. W internecie nic mnie jakoś specjalnie nie zainteresowało więc postanowiłem samemu coś posklejać. Stworzyłem coś takiego:
    zasilacz symetryczny lm317/337 - nie działa regulacja natężenia

    Z tym, że zamiast TIP31/32 mam TIP35/36, po prostu tych drugich nie było w eagle.
    Gdy podłącze jedną żarówkę do zasilania czy to dodatniego czy ujemnego to wszystko ładnie działa, płynnie reguluje napięcie i natężenie. Problem zaczyna się gdy podłącze dwie żarówki jednocześnie tzn jedna pod zasilanie dodatnie jedna pod zasilanie ujemne wtedy regulacja napięcia działa poprawnie natomiast regulacja natężenia nie działa, cały czas jest maksymalne natężenie.

    Macie jakiś pomysł?
  • Altium Designer Computer Controls
  • #2
    goldi74
    Level 43  
    Dzieje się tak przez to, że masz jeden wspólny dla obydwu gałęzi rezystor pomiarowy R6.
  • #3
    netotron
    Level 26  
    Witam
    Normalne :) prądy w układzie pomiarowym się kompensują
    BC547 inny symbol
  • Altium Designer Computer Controls
  • #4
    jarek_lnx
    Level 43  
    Tak zrobiłeś to tak jest, ograniczenie prądu działa tylko na prąd płynący do masy jak prąd płynie pomiędzy wyjściami (+) i (-) to ograniczenie prądowe nie działa.

    Ciekawią minie osiągi tego zasilacza, o ile ci spada napięcie jak obciążysz wyjście nominalnym prądem (ograniczenie prądowe ustawione na maxa) A druga rzecz, ustaw prąd ograniczenia prądowego na jakąś wartość i sprawdź czy kiedy pobierasz 80% tego prądu układ stabilizuje napięcie?
  • #5
    Kwaq
    Level 9  
    Dzięki za szybką odpowiedź ale w takim razie mam kolejne pytanie: Jeśli dam dwa oporniki to zrobię jak gdyby dwie oddzielne masy, tak? Jak będę chciał zasilić cokolwiek symetrycznie to i tak będę musiał te masy zewrzeć i nadal nie będę miał regulacji natężenia?

    Przepraszam jeśli moje odpowiedzi są nie na poziomie ale jestem początkującym samoukiem.

    Moglibyście mi równie konkretnie powiedzieć jak to rozwiązać?

    Co do osiągów to jeszcze dokładnie nie testowałem ale podłączałem szeregowo 2 żarówki 12V (chyba 21W zwykłe samochodowe) to normalnie miałem regulacje 0-25V to na takim obciążeniu było 0-20V ale twierdzę, że to wina transformatora bo jest zaledwie 90W
  • #6
    jarek_lnx
    Level 43  
    Quote:
    Dzięki za szybką odpowiedź ale w takim razie mam kolejne pytanie: Jeśli dam dwa oporniki to zrobię jak gdyby dwie oddzielne masy,
    Zrób całkowicie oddzielne, oddzielne uzwojenia mostki i połącz dopiero na wyjściu.


    Quote:
    Co do osiągów to jeszcze dokładnie nie testowałem ale podłączałem szeregowo 2 żarówki 12V (chyba 21W zwykłe samochodowe) to normalnie miałem regulacje 0-25V to na takim obciążeniu było 0-20V ale twierdzę, że to wina transformatora bo jest zaledwie 90W

    Ustaw 12,0V bez obciążenia, podłącz żarówkę i zmierz o ile spadło.
  • #7
    Kwaq
    Level 9  
    Z 12,1V spadło do 10,7V. Przy takim trafie to wynik dobry? zły? tragiczny?

    Jutro zrobię tak jak radzisz zaprojektuje dwie oddzielne płytki i dam odzielne uzwojenia tylko powiedz mi jak mam wyprostować prąd na ujemne napięcie? Dać zwykły mostek prostowniczy i po prostu - uznać jako +? Czy to raczej nie wypali? Gorzej jak wypali i się wszystko spali...
  • #8
    jarek_lnx
    Level 43  
    Quote:
    Z 12,1V spadło do 10,7V. Przy takim trafie to wynik dobry? zły? tragiczny?
    Na wyjściu przyzwoitego stabilizatora napięcie spada maksymalnie o kilkadziesiąt mV u ciebie aż 1,4V, sam LM317 ma katalogowy typowy spadek napięcia pod obciążeniem o 0,1% masz ponad 100 razy gorzej, jest to wynik dwóch błędów zastosowania wtórnika emiterowego i układu ograniczenia prądowego poza pętlą sprzężenia zwrotnego stabilizacji napięcia.
    Właściwości transformatora nie mają tu znaczenia.

    Prostownik "ujemnego" napięcia taki sam jak "dodatniego", tylko że muszą być oddzielne uzwojenia jedno z odczepem się nie nada.
  • #9
    trymer01
    VIP Meritorious for electroda.pl
    Kwaq wrote:

    Jutro zrobię tak jak radzisz zaprojektuje dwie oddzielne płytki i dam odzielne uzwojenia tylko powiedz mi jak mam wyprostować prąd na ujemne napięcie? Dać zwykły mostek prostowniczy i po prostu - uznać jako +? Czy to raczej nie wypali? Gorzej jak wypali i się wszystko spali...

    Ten plus i minus ma być tak.
    zasilacz symetryczny lm317/337 - nie działa regulacja natężenia
    I popraw ten stabilizator bo teraz to tylko regulator napięcia jest, z bardzo kiepską stabilizacją.
  • #10
    Kwaq
    Level 9  
    Zastosowałem się do Waszych rad nie wiem czy w pełni bo nie wszystkie do końca zrozumiałem. Zrobiłem coś takiego (przepraszam za niechlujny schemat ale to na szybko żeby Wam pokazać, zrobię drugi tak jak należy )
    zasilacz symetryczny lm317/337 - nie działa regulacja natężenia
    Zastosowałem dwa zwoje oraz dwa mostki tak jak radziliście.

    Efekt jest zadowalający. Oba kanały można regulować płynnie oraz niezależnie. Co do spadku napięcia, w tej chwili wynosi on około 0,35V.
    Czy da się jeszcze coś zrobić aby to zniwelować, czy po prostu to zaakceptować?

    Jeszcze raz serdecznie dziękuję za pomoc, sam na pewno bym do tego nie doszedł.
  • #11
    trymer01
    VIP Meritorious for electroda.pl
    Pod wpływem obciążenia czyli zmiany Ic tranzystora zmienia się jego Ube w granicach ok. 0,6-1V - i stad zmiany Uwy.
    Zobacz sobie jak to proponuje producent http://www.ti.com/lit/ds/symlink/lm117.pdf Fig.30.
    Niezależnie od rozwiązania regulacji prądu tranzystor mocy musi być tej polaryzacji i tak włączony.