Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Atmega32 - programowanie usbasp

korzo123 05 Mar 2013 15:42 2985 9
  • #1 05 Mar 2013 15:42
    korzo123
    Poziom 12  

    Witam mam programator usb asp, z allegro, wgrałem sterowniki (poprawnie), podłączyłem go według dokumentacji do atmegi32a i w avrdude wywala :

    Code:
    C:\Users\Wiz3ard>avrdude -p m32 -c usbasp
    

    avrdude: error: programm enable: target doesn't answer. 1
    avrdude: initialization failed, rc=-1
             Double check connections and try again, or use -F to override
             this check.


    avrdude done.  Thank you.


    C:\Users\Wiz3ard>


    Na programatorze zamryga tylko czerwona lampa oznaczająca programowanie i to wszystko. Z zwrotką slow jak i bez tak samo.

    0 9
  • Pomocny post
    #2 05 Mar 2013 17:19
    Gienek
    Poziom 35  

    Niewiele napisałeś. Co za "model" programatora? Jak podłączyłeś procesor do programatora? Daj zdjęcie lub napisz dokładnie.

    0
  • Pomocny post
    #5 05 Mar 2013 18:55
    Gienek
    Poziom 35  

    Podłączenia w/g Twego opisu prawidłowe, ale czy jesteś pewny na 100%, że nie pomyliłeś podłączeń.
    Czy masz zworkę J1?
    Jak zasilasz procesor - z USB czy z zasilacza zewnętrznego?
    Jak z USB - czy założona zworka J3?

    Tyle pytań, bo masz komunikat byś sprawdził prawidłowość połączeń.

    0
  • #7 05 Mar 2013 19:31
    korzo123
    Poziom 12  

    Podłączyłem AVCC i drugi GND i to samo ;/

    Dodano po 2 [minuty]:

    A i zasilam procesor z programatora i tak mam zwrotke J3 założoną ;]

    0
  • #9 05 Mar 2013 20:45
    korzo123
    Poziom 12  

    Fabrycznie nowa, nie mam dzisiaj jak zdjęcia wrzucić, jutro to zrobię.

    0