Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Darmowy tunel - Działa wam usługa http://localtunnel.com ?

10 Mar 2013 12:52 1956 8
  • Poziom 36  
    Działa wam usługa http://localtunnel.com ?

    Ja próbowałem wykonać (za instrukcjami z tego forum)

    Kod: bash
    Zaloguj się, aby zobaczyć kod


    Ja probowalem udostepnic port 22, by moc logowac sie po ssh na Raspberry.

    Rezultat?

    Code:

    root@raspberrypi:/home/pi# localtunnel -k ~/.ssh/id_rsa.pub 22
    /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/packet_stream.rb:103:in `block in next_packet': connection closed by remote host (Net::SSH::Disconnect)
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/packet_stream.rb:93:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/packet_stream.rb:93:in `next_packet'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:172:in `block in poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:152:in `next_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/kex/diffie_hellman_group_exchange_sha1.rb:45:in `get_parameters'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/kex/diffie_hellman_group1_sha1.rb:118:in `generate_key'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/kex/diffie_hellman_group1_sha1.rb:51:in `initialize'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:348:in `new'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:348:in `exchange_keys'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:196:in `proceed!'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:187:in `send_kexinit'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:142:in `accept_kexinit'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:189:in `block in poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:204:in `block in wait'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:202:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:202:in `wait'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:81:in `initialize'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh.rb:186:in `new'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh.rb:186:in `start'
            from /var/lib/gems/1.9.1/gems/net-ssh-gateway-1.2.0/lib/net/ssh/gateway.rb:74:in `initialize'
            from /var/lib/gems/1.9.1/gems/localtunnel-0.3/lib/localtunnel/tunnel.rb:44:in `new'
            from /var/lib/gems/1.9.1/gems/localtunnel-0.3/lib/localtunnel/tunnel.rb:44:in `start_tunnel'
            from /var/lib/gems/1.9.1/gems/localtunnel-0.3/bin/localtunnel:47:in `<top (required)>'
            from /usr/local/bin/localtunnel:23:in `load'
            from /usr/local/bin/localtunnel:23:in `<main>'
    root@raspberrypi:/home/pi#



    Zdaje sie, ze cos nie zadzialalo...



    Próba utworzenia tunelu dla portu 80 kończy się tym samym.

    Code:
    root@raspberrypi:/home/pi# localtunnel -k ~/.ssh/id_rsa.pub 80
    
    /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/packet_stream.rb:103:in `block in next_packet': connection closed by remote host (Net::SSH::Disconnect)
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/packet_stream.rb:93:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/packet_stream.rb:93:in `next_packet'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:172:in `block in poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:152:in `next_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/kex/diffie_hellman_group_exchange_sha1.rb:45:in `get_parameters'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/kex/diffie_hellman_group1_sha1.rb:118:in `generate_key'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/kex/diffie_hellman_group1_sha1.rb:51:in `initialize'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:348:in `new'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:348:in `exchange_keys'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:196:in `proceed!'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:187:in `send_kexinit'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:142:in `accept_kexinit'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:189:in `block in poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:204:in `block in wait'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:202:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:202:in `wait'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:81:in `initialize'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh.rb:186:in `new'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh.rb:186:in `start'
            from /var/lib/gems/1.9.1/gems/net-ssh-gateway-1.2.0/lib/net/ssh/gateway.rb:74:in `initialize'
            from /var/lib/gems/1.9.1/gems/localtunnel-0.3/lib/localtunnel/tunnel.rb:44:in `new'
  • Pomocny post
    Poziom 27  
    Witam serdecznie,

    po pierwsze chciałbym podziękować koledze MES Mariusz za zaprezentowanie kolejnego ciekawego rozwiązania dotyczącego publicznego udostępniania usług/hostów.

    Co do problemu to prawdopodobnie brakuje którejś z bibliotek instalowanej przy standardowej instalacji gem.
    Kod: bash
    Zaloguj się, aby zobaczyć kod
  • Poziom 36  
    Ok :-) A powiedz mi, u ciebie ruszyło? Tunel zadziałał?
  • Pomocny post
    Poziom 27  
    Testowałem na zwykłym Debian lenny (płytka Alix 2c0) i działa prawidłowo dla popularnych portów (80/22). Na RP masz jakąś standardowa dystrybucje czy specjalnie przygotowaną ?
  • Poziom 36  
    Raspbian oparty na Debianie
  • Poziom 27  
    Proponuje spróbować uruchomić tunel bezpośrednio z ścieżki gdzie została zainstalowana
    Cytat:
    /var/lib/gems/1.9.1/gems/localtunnel-0.3/bin/localtunnel
    lub coś takiego
    Cytat:
    /var/lib/gems/1.9.1/bin/localtunnel
    Ewentualnie downgrade gem do wersji 1.8.
  • Poziom 36  
    Kostek7 napisał:
    Testowałem na zwykłym Debian lenny (płytka Alix 2c0) i działa prawidłowo dla popularnych portów (80/22). Na RP masz jakąś standardowa dystrybucje czy specjalnie przygotowaną ?


    Pamiętasz, jak go zainstalowałeś, jakie pakiety użyłeś?
  • Pomocny post
    Poziom 27  
    Z historii konsoli wynika że
    Kod: bash
    Zaloguj się, aby zobaczyć kod
  • Poziom 36  
    Kostek7 napisał:
    Proponuje spróbować uruchomić tunel bezpośrednio z ścieżki gdzie została zainstalowana
    Cytat:
    /var/lib/gems/1.9.1/gems/localtunnel-0.3/bin/localtunnel


    Code:
    pi@raspberrypi ~ $ /var/lib/gems/1.9.1/gems/localtunnel-0.3/bin/localtunnel -k ~/.ssh/id_rsa.pub 80
    
    /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/packet_stream.rb:103:in `block in next_packet': connection closed by remote host (Net::SSH::Disconnect)
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/packet_stream.rb:93:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/packet_stream.rb:93:in `next_packet'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:172:in `block in poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:152:in `next_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/kex/diffie_hellman_group_exchange_sha1.rb:45:in `get_parameters'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/kex/diffie_hellman_group1_sha1.rb:118:in `generate_key'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/kex/diffie_hellman_group1_sha1.rb:51:in `initialize'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:348:in `new'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:348:in `exchange_keys'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:196:in `proceed!'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:187:in `send_kexinit'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:142:in `accept_kexinit'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:189:in `block in poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:204:in `block in wait'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:202:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:202:in `wait'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:81:in `initialize'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh.rb:186:in `new'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh.rb:186:in `start'
            from /var/lib/gems/1.9.1/gems/net-ssh-gateway-1.2.0/lib/net/ssh/gateway.rb:74:in `initialize'
            from /var/lib/gems/1.9.1/gems/localtunnel-0.3/lib/localtunnel/tunnel.rb:44:in `new'
            from /var/lib/gems/1.9.1/gems/localtunnel-0.3/lib/localtunnel/tunnel.rb:44:in `start_tunnel'
            from /var/lib/gems/1.9.1/gems/localtunnel-0.3/bin/localtunnel:47:in `<main>'


    Ale udało mi się też uzyskać inny komunikat:

    Code:
    pi@raspberrypi ~ $ sudo /var/lib/gems/1.9.1/gems/localtunnel-0.3/bin/localtunnel -k ~/.ssh/id_rsa.pub 80
    
       [Error] Unable to register tunnel. Perhaps service is down?


    Ale ponowna próba pzyniosła znane komunikaty:

    Code:
    pi@raspberrypi ~ $ sudo /var/lib/gems/1.9.1/gems/localtunnel-0.3/bin/localtunnel -k ~/.ssh/id_rsa.pub 80
    
    /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/packet_stream.rb:103:in `block in next_packet': connection closed by remote host (Net::SSH::Disconnect)
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/packet_stream.rb:93:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/packet_stream.rb:93:in `next_packet'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:172:in `block in poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:152:in `next_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/kex/diffie_hellman_group_exchange_sha1.rb:45:in `get_parameters'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/kex/diffie_hellman_group1_sha1.rb:118:in `generate_key'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/kex/diffie_hellman_group1_sha1.rb:51:in `initialize'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:348:in `new'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:348:in `exchange_keys'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:196:in `proceed!'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:187:in `send_kexinit'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/algorithms.rb:142:in `accept_kexinit'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:189:in `block in poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:167:in `poll_message'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:204:in `block in wait'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:202:in `loop'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:202:in `wait'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh/transport/session.rb:81:in `initialize'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh.rb:186:in `new'
            from /var/lib/gems/1.9.1/gems/net-ssh-2.6.6/lib/net/ssh.rb:186:in `start'
            from /var/lib/gems/1.9.1/gems/net-ssh-gateway-1.2.0/lib/net/ssh/gateway.rb:74:in `initialize'
            from /var/lib/gems/1.9.1/gems/localtunnel-0.3/lib/localtunnel/tunnel.rb:44:in `new'
            from /var/lib/gems/1.9.1/gems/localtunnel-0.3/lib/localtunnel/tunnel.rb:44:in `start_tunnel'
            from /var/lib/gems/1.9.1/gems/localtunnel-0.3/bin/localtunnel:47:in `<main>'
    pi@raspberrypi ~ $


    Raz działa (przynajmniej jakiś ludzki komunikat o błędzie). A raz nie?



    Spróbowałem też wersji beta:

    Code:
    pi@raspberrypi ~ $ sudo apt-get install python-pip python-dev
    
    Czytanie list pakietów... Gotowe
    Budowanie drzewa zależności
    Odczyt informacji o stanie... Gotowe
    Zostaną zainstalowane następujące dodatkowe pakiety:
      idle libexpat1-dev libssl-dev libssl-doc libssl1.0.0 python python-minimal
      python-pkg-resources python-setuptools python2.6 python2.6-minimal
      python2.7-dev
    Sugerowane pakiety:
      python-doc python-distribute python-distribute-doc python2.6-doc
      binfmt-support
    Polecane pakiety:
      python-dev-all
    Zostaną zainstalowane następujące NOWE pakiety:
      libexpat1-dev libssl-dev libssl-doc python-dev python-pip
      python-pkg-resources python-setuptools python2.6 python2.6-minimal
      python2.7-dev
    Następujące pakiety zostaną zaktualizowane:
      idle libssl1.0.0 python python-minimal
    4 aktualizowanych, 10 nowo instalowanych, 0 usuwanych i 97 nieaktualizowanych.
    Konieczne pobranie 8446 kB/37,4 MB archiwów.
    Po tej operacji zostanie dodatkowo użyte 56,7 MB miejsca na dysku.
    Kontynuować [T/n]?
    Pobieranie:1 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libssl1.0.0 armhf 1.0.1e-1+rpi1 [1049 kB]
    Pobieranie:2 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-dev all 2.7.3-4 [904 B]
    Pobieranie:3 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python all 2.7.3-4 [180 kB]
    Pobieranie:4 http://mirrordirector.raspbian.org/raspbian/ wheezy/main idle all 2.7.3-4 [3022 B]
    Pobieranie:5 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-minimal all 2.7.3-4 [42,6 kB]
    Pobieranie:6 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python2.6-minimal armhf 2.6.8-1.1 [1409 kB]
    Pobieranie:7 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python2.6 armhf 2.6.8-1.1 [2442 kB]
    Pobieranie:8 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libssl-dev armhf 1.0.1e-1+rpi1 [1495 kB]
    Pobieranie:9 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libssl-doc all 1.0.1e-1+rpi1 [1200 kB]
    Pobieranie:10 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-pkg-resources all 0.6.24-1 [63,6 kB]
    Pobieranie:11 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-setuptools all 0.6.24-1 [449 kB]
    Pobieranie:12 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-pip all 1.1-3 [112 kB]
    Pobrano 8446 kB w 31s (270 kB/s)
    Prekonfiguracja pakietów ...
    (Odczytywanie bazy danych ... 79464 pliki i katalogi obecnie zainstalowane.)
    Przygotowywanie do zastąpienia pakietu libssl1.0.0:armhf 1.0.1c-4+rpi1 (wykorzystując .../libssl1.0.0_1.0.1e-1+rpi1_armhf.deb) ...
    Rozpakowywanie pakietu zastępującego libssl1.0.0:armhf ...
    Przygotowywanie do zastąpienia pakietu python 2.7.3~rc2-1 (wykorzystując .../python_2.7.3-4_all.deb) ...
    Rozpakowywanie pakietu zastępującego python ...
    Przygotowywanie do zastąpienia pakietu idle 2.7.3~rc2-1 (wykorzystując .../archives/idle_2.7.3-4_all.deb) ...
    Rozpakowywanie pakietu zastępującego idle ...
    Przygotowywanie do zastąpienia pakietu python-minimal 2.7.3~rc2-1 (wykorzystując .../python-minimal_2.7.3-4_all.deb) ...
    Rozpakowywanie pakietu zastępującego python-minimal ...
    Wybieranie wcześniej niewybranego pakietu python2.6-minimal.
    Rozpakowywanie pakietu python2.6-minimal (z .../python2.6-minimal_2.6.8-1.1_armhf.deb) ...
    Wybieranie wcześniej niewybranego pakietu python2.6.
    Rozpakowywanie pakietu python2.6 (z .../python2.6_2.6.8-1.1_armhf.deb) ...
    Wybieranie wcześniej niewybranego pakietu libexpat1-dev.
    Rozpakowywanie pakietu libexpat1-dev (z .../libexpat1-dev_2.1.0-1_armhf.deb) ...
    Wybieranie wcześniej niewybranego pakietu libssl-dev.
    Rozpakowywanie pakietu libssl-dev (z .../libssl-dev_1.0.1e-1+rpi1_armhf.deb) ...
    Wybieranie wcześniej niewybranego pakietu libssl-doc.
    Rozpakowywanie pakietu libssl-doc (z .../libssl-doc_1.0.1e-1+rpi1_all.deb) ...
    Wybieranie wcześniej niewybranego pakietu python2.7-dev.
    Rozpakowywanie pakietu python2.7-dev (z .../python2.7-dev_2.7.3-6_armhf.deb) ...
    Wybieranie wcześniej niewybranego pakietu python-dev.
    Rozpakowywanie pakietu python-dev (z .../python-dev_2.7.3-4_all.deb) ...
    Wybieranie wcześniej niewybranego pakietu python-pkg-resources.
    Rozpakowywanie pakietu python-pkg-resources (z .../python-pkg-resources_0.6.24-1_all.deb) ...
    Wybieranie wcześniej niewybranego pakietu python-setuptools.
    Rozpakowywanie pakietu python-setuptools (z .../python-setuptools_0.6.24-1_all.deb) ...
    Wybieranie wcześniej niewybranego pakietu python-pip.
    Rozpakowywanie pakietu python-pip (z .../python-pip_1.1-3_all.deb) ...
    Przetwarzanie wyzwalaczy pakietu man-db...
    Przetwarzanie wyzwalaczy pakietu menu...
    Przetwarzanie wyzwalaczy pakietu desktop-file-utils...
    Konfigurowanie pakietu libssl1.0.0:armhf (1.0.1e-1+rpi1) ...
    Konfigurowanie pakietu python-minimal (2.7.3-4) ...
    Konfigurowanie pakietu python (2.7.3-4) ...
    Konfigurowanie pakietu idle (2.7.3-4) ...
    Konfigurowanie pakietu python2.6-minimal (2.6.8-1.1) ...
    Linking and byte-compiling packages for runtime python2.6...
    Konfigurowanie pakietu python2.6 (2.6.8-1.1) ...
    Konfigurowanie pakietu libexpat1-dev (2.1.0-1) ...
    Konfigurowanie pakietu libssl-dev (1.0.1e-1+rpi1) ...
    Konfigurowanie pakietu libssl-doc (1.0.1e-1+rpi1) ...
    Konfigurowanie pakietu python2.7-dev (2.7.3-6) ...
    Konfigurowanie pakietu python-dev (2.7.3-4) ...
    Konfigurowanie pakietu python-pkg-resources (0.6.24-1) ...
    Konfigurowanie pakietu python-setuptools (0.6.24-1) ...
    Konfigurowanie pakietu python-pip (1.1-3) ...
    Przetwarzanie wyzwalaczy pakietu menu...
    Przetwarzanie wyzwalaczy pakietu python-support...



    Później

    Code:
    pi@raspberrypi ~ $ sudo pip install localtunnel
    
    Downloading/unpacking localtunnel
      Running setup.py egg_info for package localtunnel

    Downloading/unpacking eventlet (from localtunnel)
      Running setup.py egg_info for package eventlet

    Downloading/unpacking requests (from localtunnel)
      Running setup.py egg_info for package requests

    Downloading/unpacking greenlet>=0.3 (from eventlet->localtunnel)
      Running setup.py egg_info for package greenlet

    Installing collected packages: localtunnel, eventlet, requests, greenlet
      Running setup.py install for localtunnel

        Installing localtunneld script to /usr/local/bin
        Installing localtunnel-beta script to /usr/local/bin
      Running setup.py install for eventlet

      Running setup.py install for requests

      Running setup.py install for greenlet
        building 'greenlet' extension
        gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -I/usr/include/python2.7 -c greenlet.c -o build/temp.linux-armv6l-2.7/greenlet.o
        greenlet.c: In function 'g_switch':
        greenlet.c:593:5: warning: 'err' may be used uninitialized in this function [-Wuninitialized]
        gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro build/temp.linux-armv6l-2.7/greenlet.o -o build/lib.linux-armv6l-2.7/greenlet.so
        Linking /home/pi/build/greenlet/build/lib.linux-armv6l-2.7/greenlet.so to /home/pi/build/greenlet/greenlet.so

    Successfully installed localtunnel eventlet requests greenlet
    Cleaning up...


    Ale widzę, że tu też sypie błędami:

    Code:
    pi@raspberrypi ~ $ localtunnel-beta 22
    
    Traceback (most recent call last):
      File "/usr/local/bin/localtunnel-beta", line 9, in <module>
        load_entry_point('localtunnel==0.5.8', 'console_scripts', 'localtunnel-beta')()
      File "/usr/local/lib/python2.7/dist-packages/localtunnel/client/client.py", line 73, in run
        backend_port = util.discover_backend_port(host[0])
      File "/usr/local/lib/python2.7/dist-packages/localtunnel/util.py", line 45, in discover_backend_port
        headers={"Host": "_backend.{0}".format(hostname)}))
      File "/usr/lib/python2.7/urllib2.py", line 127, in urlopen
        return _opener.open(url, data, timeout)
      File "/usr/lib/python2.7/urllib2.py", line 401, in open
        response = self._open(req, data)
      File "/usr/lib/python2.7/urllib2.py", line 419, in _open
        '_open', req)
      File "/usr/lib/python2.7/urllib2.py", line 379, in _call_chain
        result = func(*args)
      File "/usr/lib/python2.7/urllib2.py", line 1211, in http_open
        return self.do_open(httplib.HTTPConnection, req)
      File "/usr/lib/python2.7/urllib2.py", line 1184, in do_open
        r = h.getresponse(buffering=True)
      File "/usr/lib/python2.7/httplib.py", line 1034, in getresponse
        response.begin()
      File "/usr/lib/python2.7/httplib.py", line 407, in begin
        version, status, reason = self._read_status()
      File "/usr/lib/python2.7/httplib.py", line 371, in _read_status
        raise BadStatusLine(line)
    httplib.BadStatusLine: ''
    pi@raspberrypi ~ $


    --- edit ---

    Kurcze, a na Ubuntu Server działa pięknie:

    Kurcze, a na Ubuntu Serwer śmiga idealnie:

    Darmowy tunel - Działa wam usługa http://localtunnel.com ?

    Ojjj... Chyba kupię drugą kartę i przesiądę się na Ubuntu...