Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Delta model: DPS-830AB A - Zasilacz nie generuje +5VSB

sajunky 12 Mar 2013 22:38 5613 9
  • #1 12 Mar 2013 22:38
    sajunky
    Poziom 10  

    Delta model: DPS-830AB A - Zasilacz nie generuje +5VSB
    Delta model: DPS-830AB A Rev. 02F wyjęty z serwera SC5400 (Intel).

    Nie znalazłem schematu i dostęp jest trudny, nie wszystko da się rozrysować. Wygląda na to, że 5VSB jest również używany do wewnętrznego zasilania, bo nie znalazłem innego żródła napięcia po stronie wtórnej.

    5VSB nie jest skomplikowany, generowany układem Infiniteon ICE2A280Z (zintegrowany Mosfet). IC inicjuje softstart, Vcc narasta do 13.5V, IC przechodzi w stan aktywny i Vcc obniża sie i (to jest spodziewane), w tym momencie Mosfet powinien zacząc siekać i dać Vcc podtrzymanie z uzwojenia pomocniczego transformatora T2 (pin 4,5, dioda D903) zanim zakończy się faza softstart. Podtrzymania nie ma, Vcc opada do poziomu w którym IC resetuje i ponawia cykl (około 4ms).

    Obraz na oscyloskopie jest podobny do Datasheet Fig. 21 (Overload/Open Loop with Normal Load) , z wyjątkiem że nie kończy się cykl Softstart, ponieważ napięcie na SoftS (pin 1) narasta tylko do 0.5V.

    Nie dopatrzyłem się żadnej aktywności Mosfeta. Wymieniłem IC. Teraz obraz na oscyloskopie jest taki sam jak poprzednio. Ale widzę że napięcie po wyprostowaniu na diodzie D903 narasta minimalnie, może 0.1V czyli Mosfet otwiera na krótko. Nie jestem w stanie obserwować, bo nie posiadam oscyloskopu z pamięcią.

    Zauważyłem że czasami Mosfet zaczyna siekać na dłużej, jakieś zakłócenia spowodowane dotknięciem sondy do Vcc, bo napięcie na D903 nagle rośnie do 4V, następnie powoli opada. Nadal za mało aby zapewnić podtrzymanie. Obciążyłem wyjście 5VSB opornikiem 5Ω (na płycie jest 50Ω), efekt nie zniknąl, ale zdarza się rzadziej. Zwarcie?

    Staram się znależć zwarcie na wyjściu 5VSB, dostęp jest trudny, wygląda na to że są trzy wyjściowe uzwojenia, dioda prostownicza do 5BSB, dwie mniejsze są OK i zwarcia chyba nie ma, nie jestem pewien. Nawet przy zwarciu Mosfet powinien otwierać się bardziej zdecydowanie aby zapewnic podtrzymanie, wedlug rysunku 21, czyli problem jest po stronie pierwotnej.

    Jestem w martwym punkcie, nie mam za dużo doświadczenia w naprawach zasilaczy. Układ jest w zasadzie katalogowy z dodaną stabilizacją napięcia podtrzymania, myślałem że potrafie to uruchomić. Czy jest coś co powinienem sprawdzić?

    Ostrzeżenie: Piszę tu o podłączaniu oscyloskopu do wysokonapięciowej części, więc dodaję dla pewności że badane urządzenie podłączone jest do sieci poprzez transformator izolujący! Oscyloskop ma typowo masę uziemioną, mój również!

    Na marginesie, na wypadek gdyby ktoś potrzebował, to poniżej jest mapa wyprowadzeń zasilacza, i połączenia aby zastartować główny obwód 12V.

    0 9
  • #2 16 Mar 2013 22:53
    sajunky
    Poziom 10  

    Usunąłem D903 i podpiąłem zewnętrznie diodę i kondensator, mierzę napięcie. Jest około 1V, podobnie jak poprzednio - mało. Czyli część podtrzymania napięcia Vcc nie jest odpowiedzialna. Załączam rozrysowany układ.
    Delta model: DPS-830AB A - Zasilacz nie generuje +5VSB

    0
  • #3 18 Mar 2013 21:04
    W.P.
    Specjalista - zasilacze komputerowe

    W podobnej sytuacji zasiliłbym kontroler napięciem z warsztatowego zasilacza (nóżka 7) by móc spokojnie obejrzeć potrzebne przebiegi.
    Wcześniej trzeba "udać" zamknięcie pętli - jakiś rezystor od FB do masy. Uzwojenie pierwotne T2 pin 1 także zasilane niskim napięciem ok. 20V.
    Taka konfiguracja pozwoli spokojnie przeanalizować zachowania układu.

    Dodano po 2 [minuty]:

    Z czym połączone są punkty 7,11,13,14 na Twoim schemacie?

    0
  • #4 19 Mar 2013 14:19
    sajunky
    Poziom 10  

    Dziękuję, powoli dedykuję, że to pozwoli ustalić czy uzwojenie transformatora nie ma wenętrznego zwarcia i czy Mosfet jest nadal sprawny.

    Te punkty (i inne) są podłączone do kontrolera PFC (przed B+) i kontrolera glównego zasilacza 12V. Rownież daje sprzężenie zwrotne do układu 5VSB i kontrola stabilizacji napięcia Vcc (jak na rysunku). Ta płyta ma dwie części: 19 punktów po wysokiej stronie i 20 punktów po niskiej, wlutowane na sztorc na krawędzi głównej płyty i blokujące dostęp. SMD montowane po obu stronach, jak coś jeszcze padło tutaj, to klapa.

    0
  • #5 27 Mar 2013 17:39
    sajunky
    Poziom 10  

    Podłączyłem podwójny zasilacz laboratoryjny, napięcie 20V do B+ na rysunku, regulowane wyjście 5-15V do Vcc (końcówki 7 IC8). Pętla podtrzymania nieaktywna (D903 usunięta), ale zmontowałem diodę z kondensatorem 220µF i opornikiem do monitorowania napięcia podtrzymania.

    Końcówkę FB (2) obciążyłem opornikiem 22OΩ do masy. To jest wartość wzięta ze wzorcowych schematów ograniczająca obciążenie transoptorem. Układ nie startuje. Podpiąłem dodatkowo potencjometr 5K. Przy zwiększonej rezystancji powyżej 300Ω (co daje napięcie na FB około 0.5V) układ startuje. Cecha nie opisana w katalogu.

    Mosfet zaczyna kluczować po osiągnięciu VCC +-14V, obniżam Vcc do 12V. Przebiegi na końcówce 5 (Drain) są prawidłowe. Tu mam pewne wątpliwości czy układ zachowuje się prawidłowo, ponieważ średnie napięcie w fazie rozładowania transformatora (przewodzi 904) jest 60V - trzykrotnie przekracza B+. Po dodaniu oscylacji, szczytowe napięcie Mosfeta przekracza 80V. Obciążam stronę wtórną opornikiem 5Ω, zmniejsza się z 60V do 40V (czyli 2x B+).

    Na stronie wtórnej pojawia się napięcie. Potencjometrem podwyższam napięcie FB. Układ zmienia częstotliwość kluczowania z 22KHz na 100KHz, czas załączenia, wszystko według katalogu. Napiecie po stronie wtórnej rośnie do 5.4V, po czym przestaje reagować na zwiększanie rezystancji. Wyrażnie pojawił się sygnał ze sprzężenia zwrotnego. Napięcie podtrzymania około 16V.

    Obniżam Vcc aby zatrzymać kluczowanie. Rozłączam potencjometr, FB jest uwolnione. Ponawiam zwiększenie Vcc, teraz następuje pojedynczy cykl "softstart" zakończony wykryciem, otwartej pętli. Wszystko OK, bo napięcie podtrzymania rośnie do 16V. Czyli wniosek że przy obniżonym napięciu B+ podtrzymanie Vcc powinno być i jest wystarczające. Przy pełnym napięciu B+ cykl "softstart" został przerwany zanim ustabilizowało się napięcie podtrzymania.


    Czy można wysunąć wnioski na podstawie tego co przedstawiłem?

    0
  • #6 27 Mar 2013 19:21
    W.P.
    Specjalista - zasilacze komputerowe

    Zachowania układu są poprawne.

    sajunky napisał:
    Przy zwiększonej rezystancji powyżej 300Ohm (co daje napięcie na FB około 0.5V) układ startuje.
    Napięcie na FB ma odpowiadać stanowi aktywnemu fototranzystora będącego elementem sprzężenia zwrotnego (na schemacie wyzej go nie ma ale zwykle zamyka pętlę). Stąd napięcie ok. 0,5V i wyżej.
    sajunky napisał:
    średnie napięcie w fazie rozładowania transformatora (przewodzi 904) jest 60V - trzykrotnie przekracza B+.
    Przy niewielkim obciążeniu napięcie na drenie może osiągać takie wartości spowodawane SEM samoindukcji po wyłączeniu tranzystora kluczującego.
    sajunky napisał:
    Potencjometrem podwyższam napięcie FB. Układ zmienia częstotliwość kluczowania z 22KHz na 100KHz, czas załączenia, wszystko według katalogu. Napiecie po stronie wtórnej rośnie do 5.4V, po czym przestaje reagować na zwiększanie rezystancji.
    Wyżej nie urośnie bo B+ ma niewielką wartość, przy której nawet po otwarciu pętli (cyt: przestaje reagować na zwiększanie rezystancji.) transformator nie wchodzi w niebezpieczny obszar nasycenia.
    sajunky napisał:
    Rozłączam potencjometr, FB jest uwolnione. Ponawiam zwiększenie Vcc, teraz następuje pojedynczy cykl "softstart" zakończony wykryciem, otwartej pętli.
    Tak ma być :) To rodzaj zabezpieczenia przed pracą w pętli otwartej. Większość kontrolerów sprawdza zamknięcie pętli.


    Jak wygląda napięcie na C918, C900 podczas testów, w momencie gdy cyt.: "Napiecie po stronie wtórnej rośnie do 5.4V"? Jak wtedy wypada próba obciążenia tego obwodu prądem ok. 15 mA?

    0
  • #7 27 Mar 2013 23:16
    sajunky
    Poziom 10  

    W.P. napisał:
    sajunky napisał:
    Potencjometrem podwyższam napięcie FB. Układ zmienia częstotliwość kluczowania z 22KHz na 100KHz, czas załączenia, wszystko według katalogu. Napięcie po stronie wtórnej rośnie do 5.4V, po czym przestaje reagować na zwiększanie rezystancji.
    Wyżej nie urośnie bo B+ ma niewielką wartość, przy której nawet po otwarciu pętli (cyt: przestaje reagować na zwiększanie rezystancji.) transformator nie wchodzi w niebezpieczny obszar nasycenia.

    Wygląda na to że mogłoby urosnąć, bo czas otwarcia nie dochodzi do limitu. Moim zdaniem pojawia się sprzężenie zwrotne, a napięcie 5.4V to jest dokładnie to co powinno być na wyjściu, uwzględniając OR-ing diodę Shottky napięcie spadnie do 5V. Ja mierzę napięcie wyjściowe przed diodą.

    Korekcja tak zgadza się, a zasugerowałem się wartością 5.4V. Nie da rady więcej, bo jest już pełne otwarcie klucza. Napięcie wyjściowe także spada przy obciążeniu.

    W.P. napisał:
    Jak wygląda napięcie na C918, C900 podczas testów, w momencie gdy cyt.: "Napięcie po stronie wtórnej rośnie do 5.4V"? Jak wtedy wypada próba obciążenia tego obwodu prądem ok. 15 mA?

    Ten układ jest odłączony, bo usunąłem diodę D903. Zastąpiłem własnym układem 200µF zblokowanym 600Ω. Napięcie na tym układzie rośnie do 16V. Jutro przy dziennym świetle podłączę D903 i dopiszę.

    Obwód wyjściowy jest na stałe obciążony 50Ω (wbudowany na płycie).

    Edit:
    Odpowiadam na pytanie:
    Przywróciłem D903. Nadal zasilam Vcc z zasilacza. Teraz napięcie na C918 wynosi 12.6V, czyli coś mocno obciąża. Układ nie zastartuje bez zasilacza. Spadło również napięcie wyjściowe do 4.5V. Tak ze sprawdzam dodatkowo:
    Napięcie na C900 11.8V, R925/R928 (końcówka 13) 0V, R12/R900/R944 100mV, Q21/Q16 nie przewodzą. Vcc 11.5V z diody (po odłączeniu zasilacza).

    Pozostają do sprawdzenia kondensatory elektrolityczne i końcówka 11 (nie ma tu dostępu). A może transformator powinien dostarczać większej mocy?

    0
  • #8 05 Kwi 2013 19:16
    matej_bb
    Poziom 2  

    Musíte vymeniť elektrolytické kondenzátory! Hlavne C14
    You need to replace the electrolytic capacitors ! Mainly C14
    Delta model: DPS-830AB A - Zasilacz nie generuje +5VSB

    Over time liquid-electrolyte capacitors increase their parasitic parallel resistance, in this case the C14 could not charge to specified voltage to start the supply. This is the case of almost all failed power supplies with these "Integrated-Switcher" or TopSwitch-like ICs.
    I just fixed this power supply.
    Enjoy!
    Delta model: DPS-830AB A - Zasilacz nie generuje +5VSB

    0
  • #9 09 Kwi 2013 00:29
    sajunky
    Poziom 10  

    matej_bb napisał:
    Musíte vymeniť elektrolytické kondenzátory! Hlavne C14

    děkuji!
    Wymienię jutro, chociaż to nie daje odpowiedzi na pytanie dlaczego cykl softstart nie kończy się przy pełnym napięciu B+.

    Mam pytanie ile pobiera układ podtrzymania jeżeli B+ jest nie podłączone (0V), a podłączam napięcie z zasilacza laboratoryjnego do C918? Jeżeli podaję 16V, układ pobiera 60mA czy nie jest to za dużo? Na R12 jest 2.5V (co daje 10mA), a napięcie wyjściowe na końcówce nr.11 jest 12.9V.


    English:
    I am going to replace tomorrow, but it still doesn't give the answer why softstart cycle is interrupted when powering B+ full voltage.

    I have a question. What is a load of this circuit if B+ is not connected (0V), and connecting to C918 from laboratory power supply?

    When supplying 16V, this circuit loads 60mA, Isn't it too much?
    On R12 there is 2.5V (it gives 10mA), and output voltage on pin 11 is 12.9V

    0
  • #10 09 Kwi 2013 11:39
    matej_bb
    Poziom 2  

    :arrow: sajunki, as the capacitor ages its capacity also decreases, for example on the 22µF capacitor from this supply I measured only about 2,0µF capacity! This decreased capacity is not enough for the supply to start working long enough to charge C918, C900 and supply itself from there 60mA at 16V is OK. The IC starts at 13,5V and has overvoltage protection at 16,5V during startup phase.

    Replace the capacitors and everything will be OK, yesterday I fixed another DPS-830 the same way.

    0
  Szukaj w 5mln produktów