Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

USB - masowe awarie i rozłączanie (kierownica, wrzutnik)

frogii1990 14 Mar 2013 22:11 2454 3
  • #1
    frogii1990
    Level 14  
    Witam wszystkich,
    Po kolei.
    Składam zestawy komputerowe pracujące jako symulatory gier.
    Zestaw składa się z komputera kierownicy, akceptatora monet (wrzutnika) oraz kierownicy G27 oraz monitora. Do całość podłączona jest do UPS 850VA. (czy z UPS czy bez problem ten sam)

    Komputer zasilacz Qoltec 520W płyta główna MSI-760GM P34 (reszta nieistotna dla tematu)

    Kierownica i wrzutnik podłączony jest pod USB (różne porty w różnych zestawach)

    Problem 1. Całość jest sprawdzana i podłączona w pełnym zestawie 2 tygodnie przed wysłaniem i wszystko działa bez problemu. Kiedy tylko zestaw jest przenoszony do klienta to za każdym razem następnego kierownica lub wrzutnika lub jedno i drugie traci połączenie (kierownica jest luźna a wrzutnik nie pobiera monet) wygląda tak jak by na sekundę było tracone zasilanie na USB z jakiegoś powodu. Po zresetowaniu komputera jest spokój na jakiś czas... miesiąc, dwa i problem pojawia się ponownie.




    Problem 2 Mają kilka takich maszyn rozstawionych po kraju co jakiś czas jest sytuacja kiedy nagle kilka maszyn powiedzmy 5-8 zgłasza problem z rozłączoną kierownicą lub wrzutnikiem lub jedna i drugim.


    Dodam, że komputery nie mają podłączenia do internetu ani nie są ze sobą w żaden sposób podłączone. Jedyną wspólna zmienną dla nich wszystkich jest data i godzina zapisana w biosie komputera która plus minus parę minut jest identyczna dla wszystkich maszyn.


    Moje pytanie co z tym zrobić ?

    Co do tej pory udało mi się ustalić...
    Wszystkie porty usb mają wyłączone zarządzanie energią
    Komputer jest podłączony do bolca z uziemieniem
    Były sprawdzane opcje z podłączeniem tych urządzeń przez HUB-USB ale bez osobnego zasilania i nic to nie dało.
    W windowsie jest opcja synchronizacji czasu ale nie wiem czy to może mieć aż taki wpływ jak nie ma połączenie z internetem to coś się sypie. Jedynie jest informacja w dzienniku że nie można było pobrać daty i na wszystkich komputerach w tym samym czasie.
    Całość zestawu jest zamontowana w formie z laminatu. Pytanie czy ludzie którzy wsiadają i wysiadają mogą w jakiś sposób powodować powstawanie ładunków elektrostatycznych które w jakiś sposób na to wpływają ?
    Dodatkowe "ręczne" uziemianie USB (łączenie masy w usb z obudowa usb) nic nie zmieniło.
    Zostaje mi opcja podłączenia tego wszystkiego przez aktywnego HUB-USB ale nie wiem czy to może mieć jakiś wpływ. Ponieważ urządzenia nie pobierają nawet 500mV (wrzutnik 250, kierownica ok 125) więc zostaje zapas.
    Podłączenie tych urządzeń do przednich portów usb gdzie jest to port "wpinany" do płyty głównej lub dokładanie karty na PCI-E też nic nie pomaga.
    Zauważyłem, że czasami kiedy wyciągnie się kierownice z portu USB albo wrzutnik albo zbiega się to akurat z awarią monitor traci połączenie na ok 1s (nie pokazuję się okno brak połączenia lecz tylko ekran robi się czarny)
    Przewody HDMI i zasilający monitora idą razem z USB kierownicy i zasilaniem kierownicy. Czy to może mieć jakiś większy wpływ ?

    W skrócie. Z jakiegoś powodu komputer podczas pracy zabiera zasilanie na USB na bardzo krótki czas z bliżej nieokreślonego powodu, który to powód chce właśnie ustalić.
  • #3
    frogii1990
    Level 14  
    EDIT2: Dodatkowy objaw.
    Niektóre komputery mają coś takiego dziwnego, że kiedy podłączona jest klawiatura pod port USB to w momencie kiedy ma się pojawić okno ładowania systemu stoi czarny ekran... dopiero po wyciągnięciu klawiatury startuje system. SPotkał się ktoś z czymś takim albo ma może jakieś podejrzenia ?


    EDIT: Ważna rzecz (tak mi się wydaje) obudowa tej maszyny to jest laminat dzisiaj dowiedziałem się że bardzo mocno się elektryzuje (na tyle, że jak jest wyciągany z formy to nigdy nie ma chętnych kto przejmie cały ładunek elektrostatyczny) Czy możliwym jest że osoby wsiadające i wysiadające oraz polerowanie przez transportem na tyle go naładowują że gdzieś ten ładunek trafia w przewody USB, HDMI powodując takie okresowe zakłócenia czy może raczej to jest mało prawdopodobne ?



    Zapomniałem dodać, że dwie sztuki były na początku produkcji sprawdzane na zasilaczu marki OCZ i po przewiezieniu na miejsce problem się powtórzył dlatego zrezygnowałem z dodatkowego wydatku jakim jest droższy zasilacz.

    Dodam, że problem dużo częściej występuje na windows xp niż na windows 7 czy coś to komuś mówi ?

    Zauważyłem jeszcze jedna rzecz. Czasami takie coś się dzieje jak przewodem od monitora (sygnałowym HDMI) dotknę obudowy to pokazują się iskry delikatne... to jest normalne i czy może mieć jakiś wpływ ?
    Albo jeszcze jakieś inne pomysły ?
    I co z ty hub-em aktywnym ? Może mieć pozytywny wpływ ?
  • #4
    frogii1990
    Level 14  
    Problem rozwiązany.
    Rozwiązanie okazało się dość zaskakujące, a mianowicie. Wszystkiemu winne były głośniki w których (co jest oczywiście normalne) zastosowane transformator i to on podczas pracy powodował zakłócenia zarówno na listwie zasilające mimo filtrów (130zł listwa shit...) i na wtyczce Jack. Przy normalnym użytkowaniu nie jest to zauważalny problem ponieważ takie urządzenia jak klawiatura, mysz, drukarka itp. nie są na tyle wrażliwe aby robiło im to różnicę. Natomiast dla wrzutnika który jest bardzo delikatnym i czułym urządzeniem to wystarczyło aby zakłócić jego prace. Rozwiązaniem problemu było kupienie tańszych głośników gdzie nie wykosztowano się na transformator ale zastosowano zwykły prosty zasilacz impulsowy. Do obecnych głośników transformator zastąpiono zasilaczem impulsowym i problem ustąpił.