Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Win XP Prof SP2 - Programy *.exe przestały działać na jednym z kont użytkowników

rider3 24 Mar 2013 16:20 1530 4
  • #1 24 Mar 2013 16:20
    rider3
    Poziom 9  

    Witam wszystkich,
    dawno już nie pisałem na elektrodzie, lecz natrafiłem na problem, z którym nie mogę sobie poradzić.
    Posiadam laptopa Dell Inspiron 1720 z oryginalnym Win XP SP2, który to system działał (prawie) bezawaryjnie od 2008 roku.Prawie, bo raz wymieniłem dysk Samsunga na Western Digital i sklonowałem system (jakieś 2 lata temu).

    Od kilku dni, nie mogę uruchomić pewnych programów, ale tylko na 1 użytkowniku (user1):
    1)eclipse.exe (IDE do programowania C/C++)
    2)java.exe (mam najnowszą wersję, aktualizowana jakiś czas temu, działała bez zarzutu)
    3)subedit.exe (odtwarzacz multimediów - niby działa, ale po pierwszym Alt+Tab przestaje reagować)
    4)gadu-gadu działa chwilę, po czym dosłownie znika bez ostrzeżenia(nie ma go ani w tray-u, ani na liście procesów)

    Sytuacja jest taka:
    -mam na tym systemie 3 konta - admin (prawa administratora, dostęp do wszystkiego), user1 i user2(zwykli użytkownicy,bez praw administratora, ale z pełnymi prawami dostępu do własnych katalogów domowych)
    -system był calkowicie skanowany Avirą Free Antyvirus dzisiaj, nie było żadnej infekcji
    -pod adminem chodzi wszystko, pod userem 2 też, natomiast pod user-em 1, z którego najczęściej korzystam, nie działają wyżej podane 4 programy
    -na każdym z dysków jest po kilkadziesiąt GB wolnego miejsca
    -próba wywołania w konsoli f:\program files\eclipse\eclipse.exe pod user-em 1 powoduje , że eclipse startuje, pasek postępu zamiera jednak w połowie i program się zawiesza, zaś menedżer zadań w zakładce Aplikacje pokazuje "eclipse brak odpowiedzi"
    -próba wywołania z konsoli f:\windows\system32\java.exe pod user1 nic nie powoduje, tzn przyjmuje polecenie, po czym nie pisząc żadnych komunikatów, ani też nie wracając do wiersza poleceń, konsola zamiera i zostaje w tym stanie.
    Oczywiście wejść do tego katalogu z 2 konsoli mogę, wyświetlić listę plików tak samo, mogę sobie java.exe czy inne pliki skopiować gdzie indziej, żaden problem
    -próba wywołania tego samego polecenia na koncie user2 , albo admina, powoduje, że zostają wypisane komunikaty pomocnicze (składnia polecenia java.exe, itp) po czym konsola wyświetla nowy wiersz poleceń i można wpisać następny rozkaz
    -raz mi się udało uruchomić eclipse pod user1, ale prosił o utworzenie nowego workspace2, utworzyłem i działał, lecz po przełączeniu do workspace1 przestał działać (nie wiem, czy można go uruchomić z workspace2 wpisując jakiś parametr, jeśli tak, to jaki?).User1 ma oczywiście pełny dostęp do obu workspace-ów, mogę podglądać pliki, kopiować je, kasować
    -nie zmieniałem nigdy żadnych praw dostępu do plików/katalogów
    -pozostałe aplikacje działają pod user1 bez problemów

    Teraz pytania:
    1)jak sprawdzić, co to może być?
    2)czy da się sprawdzić, czy konkretny proces "x" ma dostęp do wymaganych przez siebie plików?
    3)czy można sprawdzić, dlaczego ten proces javy nie wypisuje nawet
    komunikatów o składni polecenia, itp?
    4)czy można eclipse uruchomić z jakimiś parametrami, które zrobią log-a pokazującego na jakim etapie przestaje działać?
    5)czym sprawdzić rejestr systemu, dysk systemowy itd, na spójność systemu plików (czy nie ma jakichś błędów, czy prawa dostępu się nie pomieszały, itp)?
    6)jaki darmowy program antywirusowy użyć, by sprawdzić go dodatkowo?
    7)czym wykonać dobrą diagnostykę systemu i ewentualnie trochę go wyczyścić ?
    8)czy można przeinstalować explorer.exe (może to on jest źródłem problemów?)
    9)czy istnieją systemowe narzędzia, które sprawdzają system pod kątem brakujących bibliotek/innych plików?
    10)jakie inne kroki można wykonać?

    System jest mi potrzebny przede wszystkim do pracy, dopiero awaria eclipse zmusiła mnie do szukania rozwiązań (pozostałe problemy z gg i z subeditem były już od kilku miesięcy).Na razie nie chcę go instalować ponownie, bo z wszystkimi aplikacjami które mam, to musiałbym się bawić ze 2 dni.
    Za wszystkie rady z góry dziękuję, pozdrawiam
    rider3

    0 4
  • #4 24 Mar 2013 20:40
    rider3
    Poziom 9  

    Witam ponownie, dzięki za porady. :) Jeszcze leci skan tym Malware i znalazł 8 zarażonych plików, a co ciekawe Avira nie widziała ani jednego z nich, mimo że w RAM-ie nic nie siedziało wg Malware. Napiszę po zakończeniu, jak to wygląda.
    Pozdrawiam, rider3.

    0
  • #5 30 Gru 2015 23:01
    rider3
    Poziom 9  

    Witam po długim czasie. Skanowanie programami antymalware'owymi, a potem leczenie systemu i sprawa wtedy zakończyła się powodzeniem. Dziś nie używam już tego systemu, więc temat można zamknąć.
    Dzięki wszystkim za pomoc!
    Win XP Prof SP2 - Programy *.exe przestały działać na jednym z kont użytkowników

    0