Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Serwis aparatury badawczej, oprogramowanie sterujące

d_omin 29 Mar 2013 11:15 1149 4
  • #1 29 Mar 2013 11:15
    d_omin
    Poziom 12  

    Witajcie,

    Mam takie nietypowe pytanie, czy jest ktoś na forum kto zajmuje się szeroko pojętym serwisem aparatury badawczej?

    Problem jest następujący, jedno z naszych urządzeń (suszarka mikrofalowo-konwekcyjna) od jakiegoś czasu boryka się z poważnymi problemami związanymi z sterowaniem. Podczas procesu skaczą parametry nastawne (temperatura powietrza, prędkość przepływu itd.) co zmienia całkowicie jego przebieg. Całość pracuje pod sterownikiem Frisko S20 jednak ten jest raczej sprawny (był serwisowany) i problem tkwi gdzieś indziej. Niestety nie posiadamy dokumentacji technicznej urządzenia co stanowi bardzo poważny problem i główną przeszkodę dla serwisów zewnętrznych.
    Ponadto chcielibyśmy aby napisano nowe oprogramowanie dla tego urządzenia. Obecne jest bardzo problematyczne i nie pozwala na realizację procesów w zakresie nas interesującym.

    Będę wdzięczny za wskazanie osoby/firmy która podjęłaby się tego dość trudnego zadania.

    0 4
  • #2 29 Mar 2013 15:16
    biomedyczny
    Poziom 26  

    Problem tkwi w czujnikach na 99%. Często są osadzone na silikonie który odpuścił od blachy. Stracił właściwości i nie kontaktują. Lub też znajdują się w środku i utleniły się.

    Ewentualnie w zużytym magnetronie.

    Co do prędkości przepływu raczej macie tlen a nie azot? Wiec tu dziwna sprawa. Przepływomierze rzadko się psują. Chyba że jest tam aerometr i po prostu zarosły łopatki.

    Niestety aparatura badawcza w pl leży sam bym chciał w niej pracować :P
    A w Poznaniu totalnie nie kojarzę firmy. Z krk lub katowic jest kilka firm co pewnie by podołało comef czy bmt.

    Proponuję zapytać w http://wamed.pl/kontakt/
    Oni mieli kogoś z Poznania.

    A jeśli nie to może ktoś się odezwie z dawnych zakładów naprawczych. Poznań jest mi totalnie obcy.

    Proponuje przenieść temat przez moda do działu sprzęt medyczny.

    0
  • #3 29 Mar 2013 23:34
    d_omin
    Poziom 12  

    Niestety mam inne odczucia, problem ewidentnie sygnałowy, gdzieś coś miesza jakiś sumator czy coś i sterownik głupieje. Wszystkie czujniki i przetworniki po serwisie i kalibracji. Magnetron tak mały przebieg że tam nie ma co się zużyć. Przepływ powietrza, ale termoanemometr również nówka funkiel KIMO CTV100 AND... ogólnie obawiam się że albo jakaś płytka, scalak lub inny element padł i trudno to będzie wytropić.

    0
  • #4 30 Mar 2013 02:04
    biomedyczny
    Poziom 26  

    Po co tam miałby być "jakiś scalak" ?
    Co najwyżej przetworniki analogowo cyfrowe.
    Tyle że s20 takich nie potrzebuje. Bo są moduły do sterownika.
    Na 99% czujniki będą wpięte bezpośrednio do s20 lub do modułu.

    Czujniki łatwo pomierzyć. Bo wystarczy poszukać katalogów i zwykły multimetr. I wówczas sprawa czujników i przewodów odpadnie. Tyle że ty masz wszystko w jednym ctv100 ma wyświetlacz i będziesz na nim wszystko widział tmp + przepływ. I jeśli mniej więcej ci się zgadza z próbą np gorącej wody to ok.
    Możesz nawet czujnik tmp sprawdzić tam jest pt 100.
    http://www.ojelectronics.pl/ETF-xx97-/-PT100-4299.aspx

    Pozostaje komunikacja ctv100 z s20. Ale jak jest zrobiona...
    W instrukcji do ctv masz możliwe typy.
    http://www.kimocanada.com/Anglais/pdf/CTV100.pdf
    Też spokojnie możesz to pomierzyć.

    Jeśli tu też jest ok.
    Pozostaną moduły i program w S20.
    Więc wydaje mi się że w miarę dobry elektronik z analizatorem stanów by sobie z tym poradził.
    Ale takie rzeczy baaaaaaaardzo rzadko się psują.

    Problem nie bierze się znikąd. A ty piszesz że sterownik serwisowany, czujniki wymienione itd.

    Jeśli naprawdę fizycznie jest ok to pozostaje program. Może ktoś zmienił histerezę i dlatego ci wszystko skacze z 1% do 10% np.?

    No wywróżyć się tego nie da.

    Ale tak szczerze po namyśle obstawiam to ostatnie - problematyczne i chcieliście żeby służyło do czego innego więc poklikali. I zaczął bym od przywrócenia softu z jakiejś płyty / od producenta.

    0
  • #5 30 Mar 2013 10:09
    d_omin
    Poziom 12  

    Ok to po kolei. Cały układ jest dużo bardziej złożony i składa się z 3 głównych modułów:
    1. Układ generacji mikrofal (magnetron pracujący z falą ciągłą (stojącą) chłodzony wodą)
    2. Układ nagrzewania powietrza (grzałka o bardzo małej bezwładności - nagrzewa się niemal natychmiast, wentylator)
    3. Układ nawilżacza (nieużywany)

    no i jest jeszcze grzałka IR o mocy 350W, i waga do pomiaru masy w trybie on-line.

    Poza tym w systemie są następujące czujniki przetworniki:
    1. Wilgotności i temperatury (Testo Hygrotest DTH600 x 3) - po serwisie i kalibracji
    2. Pirometr Raytek chyba MI1
    3. Termoanemometr KIMO CTV100 AND (bez wyświetlacza) kiedyś był z wyświetlaczem (AOD) ale go zmieniłem na nowy bez wyświetlacza (AND)
    4. Inne czujniki sterujące pracą poszczególnych podsystemów m.in. układ opto-elektryczny kontroli przepływu powietrza.

    Całość jest podłączona pod Frisko S20 ale po drodze jest mnóstwo płytek drukowanych na których są właśnie owe scalaki.
    Są również 2 programy: 1. wewnętrzny sterownika i 2 do programowania sterownika z zewnątrz (z komputera). Oba są poza naszym zasięgiem ponieważ nie mamy kodów źródłowych o ile 1 da się chyba odczytać z Frisko o tyle 2 raczej ciężko będzie dekompilować.

    Problemem jest głównie układ nagrzewania powietrza, to tam skaczą parametry, ale bzdury pojawiają się również na innych parametrach np. masie mierzonej podczas pomiaru on-line.

    Generalnie ja z automatyką, sterowaniem i elektroniką nie mam nic wspólnego więc ciężko mi to opisać. Szukam więc firmy/osoby która by przyjechała zobaczyła co i jak i się wypowiedziała czy da się coś zrobić.

    0