Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Laptop Samsung R540 - Recovery nie bootuje

22 Kwi 2013 22:09 6657 12
  • Poziom 8  
    Witam.
    Zacznę od tego, że posiadam laptop Samsung R540 i jest problem z uruchomieniem recovery z dedykowanego klawisza F4.

    Problem zaczął się od momentu kiedy zainstalowałem UBUNTU na dysku. Linux zainstalował się wszystko ładnie lecz po restarcie systemu coś się posypało i nie mogłem uruchomić ani windowsa ani linuxa jak również recovery też nie działało

    Udało mi się częściowo naprawić to za pomocą płyty z systemem i narzędzi odzyskiwania. najpierw format partycji z ubuntu potem wiersz poleceń i wpisując komendy

    bootrec /fixmbr
    bootsect /nt60 all /force /mbr

    Po tych zabiegach udało się uruchomić windows oraz recovery. Z tą różnicą iż przy starcie systemu musiałem wybierać czy chce uruchomić:
    Windows Home Premium (Odzyskano)
    I Recovery (nie pamiętam co dokładnie pisało) w każdym bądź razie musiałem za każdym razem wybierać by uruchomić windows a nie partycje odzyskiwania

    Rzecz jasna chciałem to zmienić i przewrócić do stanu normalnego gdzie przy starcie systemu nie muszę nic wybierać a recovery jest uruchamiana jedynie z klawisza f4 w tym celu skorzystałem z syskey i usunąłem wpis o recovery z rozruchu pozostawiając jedynie wpis o Windows 7.

    To częściowo rozwiązało gdyż pozycja recovery faktycznie zniknela z listy rozruchu lecz niestety również przestała działać pod klawiszem F4:/ jak i samsungowy program Samsung Recovery Solution informuje mnie, że na komputerze nie znaleziono obszaru odzyskiwania. Lecz w zarządzaniu dyskami widzę partycje która jest aktywną partycją odzyskiwania.

    Laptop Samsung R540 - Recovery nie bootuje

    Damy radę to jakoś naprawić?:)

    EDIT:
    P.S. dopiero teraz zauważyłem, że partycja recovery jest czysta... nie wiem jak to się stało gdyż jej nie ruszałem przy żadnym formatowaniu ale to zapewnie jest przyczyną tego, że nie mogę jej uruchomić:/ Teraz inne pytanie czy jest możliwość odzyskanie tej partycji?
  • Spec od komputerów
    Uruchom komputer z linuksa live i zobacz czy na partycji recovery są pliki. Najważniejsze są pliki obrazu oryginalnego systemu. F4 nie działa bo instalując ubuntu nadpisałeś MBR. Jeżeli przed instalacją ubuntu zrobiłeś kopię MBR to przywróć. Testdisk nie używaj bo nieumiejętne użycie narobi więcej szkody niż pożytku. Wg mnie to pliki na partycji recovery są. Nie zaszkodzi jednak sprawdzić.
    Zmieniałeś oryginalny układ partycji to już recovery nie zadziała. Można przywrócić oryginalny system ręcznie i fabryczny układ partycji lub jeżeli system działa zrobić kopię systemu zewnętrznym programem (fsarchiver lub partimage) i tej kopi używać do przywrócenia w razie potrzeby.
    Pozdrawiam.
  • Poziom 8  
    ok zrobiłem archiwialna kopie partycji recovery za pomocą fsarchiver bo partimage nie mogłem za instalować korzystająć z płyty live cd. Co dalej zrobić?
  • Spec od komputerów
    Zrób na wszelki wypadek kopię systemu a potem przywracaj ręcznie system z plików obrazu. Ingerowałeś w boot partycji recovery to ona nie wystartuje. Pisałeś ,że zrobiłeś obraz partycji recovery. Obraz był robiony przed odbudowywaniem boot windowsa przy ustawionej fladze boot na partycji recovey czy przed ?
  • Poziom 8  
    Robiłem dwa obrazy partycji recovery. raz robiłem jeszcze z pod windowsa testdiskiem i był to obraz partycji recovery po tym jak okazało się, że została usunięta tablica tej partycji i windows pokazywał mi, że jest pusta.

    A drugi raz po tym jak połączyłeś, się z moim kompem i popatrzyłeś, że pliki na tej partycją są powiedziałeś bym zrobił sobie kopie wszystkich potrzebnych plików które miałem na dysku C plus zrobić jeszcze obraz partycji recovery oraz partycji C partimage lub fsarchive. ten pierwszy nie moegłem zainstalować na swoim leve cd a drugi udało się i zrobiłem nim archiwum z partycji recovery którą mam skopiowaną na dysk przenośny.

    Nie wiem czy kiedy podlączyłeś się do mnie przestawiałeś mi flagę z partycji recovery (sda1) na bodajzę sda2? Bo po zakonczeniu pracy z LIVE cd chciałem jeszcze uruchomić windowsa by skopiować zakąłdki z chrome ale już nie mogłem bo pisało BOOTMGR is misin. Widzę, że teraz flaga jest ustawiona na sda2 gdzie jest bodajże tablica windows a sam system znajduje się na sda3.

    EDIT:
    P.s. to komunikat działąnia programu fsarchive:

    Code:

    root@ubuntu:~# fsarchiver savefs /media/PRACOWNIA/OBRAZ_REC_FSARCH/obraz_rec_fsarch.fsa /dev/sda1
    Statistics for filesystem 0
    * files successfully processed:....regfiles=12673, directories=1056, symlinks=0, hardlinks=0, specials=0
    * files with errors:...............regfiles=0, directories=0, symlinks=0, hardlinks=0, specials=0
  • Spec od komputerów
    W dalszym ciągu nie wiem czy kopia partycji recovery była robiona test diskiem przed "naprawianiem" boot windowsa. Flagę boot możesz ustawić na recovery z linuksa w gparted opcja zarządzaj flagami. Miałeś ustawioną flagę boot na partycji recovery i w tym stanie naprawiałeś boot windowsa to zapisałeś dodatkowe pliki na recovery (czyli ją zmodyfikowałeś) Windows pokazuje partycję recovery jako pustą mimo że są tam pliki. Prawidłowo flaga boot powinna być na partycji sda2 (mała partycja 100MB). Dlaczego miałeś ustawioną flagę boot na recovery i w tym stanie naprawiałeś boot to nie mam pojęcia.Mogę się tylko domyślać ,że coś pokręciłeś testdiskiem. Gmeranie w partycjach bez zrobionych płyt DVD recovery to duża nieostrożność.
  • Poziom 8  
    obraz test disckiem był robiony po "naprawianiu" boot windowsa.

    Przestawiłem jak narazie flagę na recovery i faktycznie uruchomia się mi windows...

    sam nie wiem czemu misłem przestawioną flage... moze to dlatego ze wcześniej jak pisałem próbowałem instalować ubuntu i wtedy została przestawiona flaga a ja tego nie zauważyłem i kiedy wszystko się posypało odbudowałem boot windowsa niechcąco umieszczając go na recovery

    EDIT:
    Jak odpaliłem testdisk to on odrazu pokazywał ze flaga jest ustwiona na recovery jeszcze przed grzebaniem w tym programie. WIęc pewnie przestawienie flagi odbyło wcześniej jeszcze przed uruchomianiem testdiska.
  • Spec od komputerów
    Instalacja Ubuntu nie zmienia flag partycji tylko nadpisuje MBR bo prawdopodobnie tak wybrałeś. Prawdopodobnie testdiskiem coś pokręciłeś. Kopia recovery już z plikami bot windowsa to jest ta sama kopia co fsarchiverem robiłeś.
    Próbuj przez plop boot wystartować z recovery przy ustawionych prawidłowo flagach tylko zrób kopię systemu wcześniej żebyś nie został z niczym. Ręczne przywracanie systemu z plików obrazu to ostateczność.
  • Poziom 8  
    kopie systemu moge zrobić z poziomu windowsa czy lepiej z live ubuntu?
  • Spec od komputerów
    Oczywiście że nie z windowsa. Tak samo jak robiłeś kopię partycji sda1 to zrób sda2 i sda3. Widzę ,że kopię zrobiłeś na ten sam dysk. Zgraj na zewnętrzny nośnik. Kopię MBR też zrób. Do uruchomienia zamiast plop możesz użyć grub z CD partedmagic. Filmik poniżej.
  • Poziom 8  
    ok zabieram się do roboty. Zrobie obrazy sda2 i 3 oraz MBR. Tylko nie wiem czy jest sens robienia kopii MBR skoro w tym MBR już nie mam możliwości dostać się do recovery za pomocą przycisku? ale na wszelki wypadek zrobię...

    Pytanie. Skoro naprawiałem bootloader z ustawioną flagą na partycję recovery więc nadpisałem zapewnie pierwsze bajty tej partycji dlatego teraz zamiast recovery startuje windows. gdy bym zdobył skądś pierwsze bajty w wersji oryginalnej i nadpisał te zmienione to by naprawiło umożliwiło by rozruch partycji recovery zamiast winowsa?
  • Spec od komputerów
    Na partycji recovery utworzyłeś plik BCD w katalogu Boot. na których sektorach został zapisany to nie wiadomo. Nic tu nie da podmiana początkowych sektorów.
  • VIP Zasłużony dla elektroda
    \boot\BCD z partycji Recovery można zregenerować. Wcześniej możesz zatrudnić PC Inspector File Recovery, DMDE itd. i próbować odzyskać wcześniejszy plik.
    Jak nie da rady to podeślij listę plików z partycji Recovery na forum.

    Tak jak już zostało napisane ta mała partycja 100MB ma być systemową a nie partycja odzyskiwania - najpierw zrób z tym porządek.
    Przypisz na chwilę literę np. S: tej małej partycji i zobacz czy jest tam \bootmgr i folder \Boot, jeśli tak to ją uaktywnij i zdejmij literę (Zarządzanie dyskami ...) a jeśli nie to by wyjaśniało BOOTMGR is missing... no chyba, że jednak to trzecia partycja została uaktywniona to wtedy zachowanie prawidłowe.