Elektroda.pl
Elektroda.pl
X
Elektroda.pl
AdexAdex
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

PWM na ne555 - Regulator PWM na układzie ne555 - jak ustawić amplituę

04 Maj 2013 14:15 13311 40
  • Poziom 9  
    Zbudowałem prosty regulator PWM na popularnym układzie ne555. Wszystko działa prawie świetnie: regulacja wypełnienia prostokąta w zakresie 0-100%, częstotliwość pracy w zależności od zastosowania kondensatora od kilku Hz do 10kHz.

    Warunki wstępne: zasilanie 13.8V z zasilacza, żarówka H7 12V, 55W

    Problem mam następujący. Przy podłączeniu żarówki bądź silnika i ustawieniu potencjometru na wartość 100%, PWM daje pełną moc i żarówka świeci bardzo jasno a przy zmianie potencjometru na 0% ( czyli wyłączenie prądu - teoretycznie) żarówka tylko nieznacznie przygasa

    Na wykresie oscyloskopu widać, że tak jakby nie było pełnej regulacji amplitudy w zakresie od 0V do 13.8V a tylko w zakresie od 0V do 7.5V. Powstaje tak jakby grzebyk na szczycie przebiegu.

    Ustawienia oscyloskopu to 5V i czas 50ms na podziałkę. Górna kreska jest z drugiego kanału i oznacza poziom GND

    Moje pytanie. Co wpływa na wartość amplitudy?

    PWM na ne555 - Regulator PWM na układzie ne555 - jak ustawić amplituę PWM na ne555 - Regulator PWM na układzie ne555 - jak ustawić amplituę

    Schemat skopiowałem z internetu.
  • AdexAdex
  • Poziom 14  
    Pokaż schemat tego regulatora. Na NE555 można to na różne sposoby zrealizować, nie każdy daje pełną regulację 0-100%. Przebiegi oscyloskopem sprawdzasz na wyjściu całego układu, czy na wyjściu kostki 555?
  • Poziom 9  
    Schematy dołączyłem do pierwszego posta i dołączam jeszcze jeden z przebiegiem bezpośrednio na 3 nóżce układu 555. Przebiegi są inne. Do pomiaru wykorzystałem drugi kanał oscyloskopu i może się wydawać trochę nieczytelnie ale chciałem zachować ten sam punkt odniesienia masy.
    Na wcześniejszym obrazku jest pomiar na wyjściu układu a na tym obrazku bezpośrednio na kostce 555 na 3 nóżce.


    PWM na ne555 - Regulator PWM na układzie ne555 - jak ustawić amplituę


    Acha, na schemacie jest potencjometr 250k nie miałem takiego więc zamontowałem 1M Ohm. Kondensator ceramiczny C4 z oznaczeniem 104 czyli 100nF i C5 103 czyli 10nF.
  • Poziom 9  
    trymer01 napisał:
    Wygląda na to, że MOSFET-y nie są zamykane, gdyż napięcie na bramkach nie maleje do zera. Nie grzeją się przy wypełnieniu zbliżonym do zera?
    Pokaż schemat bo ten zamieszczony jest nieczytelny.


    Dalsza część schematu to tylko rząd MOSFET'ów. hmm

    Jeśli mosfety nie są zamykane to czy rezystory podciągające R11, R12 itd.. mogą wpuszczać prąd na bramkę? Wartości rezystorów są 47KOhm więc prawie nie przepuszczają prądu.

    Jeśli chodzi o temperaturę to mosfety zamontowałem na porządnym radiatorze więc nie zauważyłem żeby się grzały ale jak sprawdzałem układ przed zamontowaniem radiatora to jedynie na trzecim mosfecie był dosyć gorący reszta zimne.
  • Poziom 9  
    trymer01 napisał:
    Piszemy Ci, że schemat nieczytelny, a Ty chcesz dyskutować o nim.


    Wyłączyłem w programie siatkę i jeszcze raz zrobiłem zrzut i w jpegu.

    PWM na ne555 - Regulator PWM na układzie ne555 - jak ustawić amplituę
  • AdexAdex
  • Moderator Projektowanie
    Nie chodziło o siatkę, ale schemat był zbyt mały. Nadal nieczytelny jest typ MOSFET-ów.
    Tam jest jakaś "masakra" z tymi opornikami.
    Ile masz tych MOSFET-ów? jaki typ? - ależ "cedzisz" informacje....
    Z wyjścia NE555 daj opornik 100 Ohm do bramki każdego, z bramki każdego do masy opornik 1k.
  • Poziom 9  
    trymer01 napisał:
    Nie chodziło o siatkę, ale schemat był zbyt mały. Nadal nieczytelny jest typ MOSFET-ów.
    Tam jest jakaś "masakra" z tymi opornikami.
    Ile masz tych MOSFET-ów? jaki typ? - ależ "cedzisz" informacje....
    Z wyjścia NE555 daj opornik 100 Ohm do bramki każdego, z bramki każdego do masy opornik 1k.


    MOSFETy to IRF840 ośmio amperowe jest ich pięć w rzędzie.

    Podłączałem tak jak mówiłeś rezystor 100 Ohm ( u mnie jeszcze na bramkę idzie przez rezystor 330 Ohm więc razem daje 430 Ohm) i do masy podciągający 1k (dałem nawet mniejszy 200 Ohm bo taki miałem ). Przebiegi się nie zmieniły, były tylko bardziej wygładzone a amplituda nadal taka sama.

    Chodzi mi o to żeby obniżyć amplitudę do 0V bo teraz jest 7.5V tak jak na obrazku.

    PWM na ne555 - Regulator PWM na układzie ne555 - jak ustawić amplituę
  • Moderator Projektowanie
    Napisałem Ci jak masz spróbować, ale Ty robisz po swojemu. Wiesz lepiej? - to po co pytasz?
    To są nieodpowiednie MOSFET-y do tego - wysokonapięciowe i maja wysokie Rdson.
    Obejrzyj przebieg na wyjściu NE555 - jakie są napięcia w stanie niskim i wysokim?
  • Poziom 9  
    trymer01 napisał:
    Napisałem Ci jak masz spróbować, ale Ty robisz po swojemu. Wiesz lepiej? - to po co pytasz?
    To są nieodpowiednie MOSFET-y do tego - wysokonapięciowe i maja wysokie Rdson.
    Obejrzyj przebieg na wyjściu NE555 - jakie są napięcia w stanie niskim i wysokim?



    Zrobiłem tak jak mówiłeś i nie zaobserwowałem zmian. Nie wiedziałem jak dobrać mofety więc zastosowałem takie jakie miałem. Uznałem że napięcie nie ma znaczenia jeśli przewodzą prąd stały o wartości 8A prądu ciągłego to uznałem że się nadają. Nie chcesz chyba powiedzieć że dają 8A przy napięciu 500V a przy niższym napięciu 15V nie popłynie 8A? Faktycznie mogą być nieodpowiednie tranzystory. Jakie więc polecasz zastosować tak żeby nie przerabiać bardzo płytki?

    Jeśli chodzi o przebieg na wyjściu ne555 to jest taki jak zamieściłem w poscie #3. Jeszcze raz prześlę.

    PWM na ne555 - Regulator PWM na układzie ne555 - jak ustawić amplituę

    Nie mam pojęcia co ma wpływ na to że na wyjściu pojawia się przebieg od ok 5V do ok. 13 V a chcę żeby był to przebieg od 0V do 13V. Gdzieś jest albo błąd w układzie, w doborze elementów albo ne555 działa nieprawidłowo.
  • Poziom 38  
    arkomar napisał:
    Nie mam pojęcia co ma wpływ na to że na wyjściu pojawia się przebieg od ok 5V do ok. 13 V

    Tak działa NE555 . Aby uzyskać przebieg od 0,0 V trzeba dodać tranzystorka na wyjście ( 3) i z jego kolektora , po odpowiedniej polaryzacji bazy uzyskasz oczekiwany efekt .
  • Poziom 9  
    brofran napisał:
    arkomar napisał:
    Nie mam pojęcia co ma wpływ na to że na wyjściu pojawia się przebieg od ok 5V do ok. 13 V

    Tak działa NE555 . Aby uzyskać przebieg od 0,0 V trzeba dodać tranzystorka na wyjście ( 3) i z jego kolektora , po odpowiedniej polaryzacji bazy uzyskasz oczekiwany efekt .


    Czeka mnie więc kilka zmian. A czy ktoś orientuje się jak to zasymulować w protelu bo i tego mi się nie udało zrobić. Przebiegi są zupełnie bez sensu. Zanim wprowadził bym zmiany z tranzystorem pnp to zasymulował bym układ i pobawił się ustawieniami. Załączam wynik symulacji schematu z pierwszego postu. Po prostu zero oczekiwanych wyników. Ma ktoś pomysł co robię nie tak?

    PWM na ne555 - Regulator PWM na układzie ne555 - jak ustawić amplituę
  • Moderator Projektowanie
    MOSFET-y są nieodpowiednie bo mają wysokie Rdson - ok. 1 Ohm. Przy 5 szt. każdy pracuje z prądem niecały 1A co daje na nich ok. 1V spadku napięcia. To bez sensu.
    Jaki MOSFET? - jakikolwiek N-Channel o prądzie drenu min.10A, Uds>20V, Rdson<0,05 Ohm. Wystarczy 1 szt.
    Z tego co pisałeś nie zrobiłeś tak jak radziłem, bo zamiast 1k dałeś 200 Ohm, a zamiast 100 Ohm dałeś 100 Ohm+330 Ohm. Nie widzisz różnicy?

    brofran napisał:

    Tak działa NE555 . Aby uzyskać przebieg od 0,0 V trzeba dodać tranzystorka na wyjście ( 3) i z jego kolektora , po odpowiedniej polaryzacji bazy uzyskasz oczekiwany efekt .

    NE555 daje napięcie wyjściowe zbliżone do zera.
    http://www.datasheetcatalog.org/datasheet/stmicroelectronics/2182.pdf
    Str. 3 - VOL, VOH. Wszystko zależy od prądu obciążenia, ale w stanie niskim to opornik 1k miedzy bramką a źródłem te bramkę rozładowuje i napięcie Vgs powinno osiągać zero. Zresztą Vgdth (odcięcia) dla tego MOSFET-a wynosi 2-4V i nawet napięcie 2,5V na wyjściu NE555 powinno go zatykać.
    Tranzystor na pewno byłby tu wskazany, ale nie jest konieczny, dlatego wstrzymywałem się z taką poradą.
  • Poziom 9  
    trymer01 napisał:

    Z tego co pisałeś nie zrobiłeś tak jak radziłem, bo zamiast 1k dałeś 200 Ohm, a zamiast 100 Ohm dałeś 100 Ohm+330 Ohm. Nie widzisz różnicy?


    Zrobiłem tak jak mówiłeś tylko może źle napisałem co zrobiłem. Na rezystorze 330 Ohm zrobiłem zwarcie więc z 3 nóżki ne555 poszło bezpośrednio na rezystor 100 Ohm tylko, że podciągnąłem poźniej rezystorem 200 Ohm do masy. Pierwotnie był rezystor 47k Ohm. Czy taka wartość (200 lub 1k) miała by aż tak duże znaczenie?

    I jeszcze jedną rzecz zauważyłem. Jeśli podłączę obciążenie (żarówkę) do drenu i drugi koniec żarówki do plusa zasilania oraz masę zasilania do płytki czyli źródła (czyli zamyka się układ) to układ startuje i zachowuje się jakbym potencjometrem skręcił na 0%. Czyli nie doprowadzam vcc na kostkę 555. Zastanawiam się czy układ nie będzie się sam wzbudzał? jeśli było by to np. zasilanie do maty podgrzewającej siedzenia w samochodzie to nieszczęście gotowe.

    Ale ciągle mam wrażenie że szukamy nie tu gdzie trzeba bo wydaje mi się że to na nóżce 3 układu ne555 powinienem otrzymać idealną modulację od 0V do 13V bo przecież taka była chyba idea działania tego układziku. Mam wrażenie że tu może chodzić o jakieś napięcie referencyjne- odniesienia ale za bardzo tego właśnie nie rozumiem.
    Może ktoś ma jakieś sugestie?
  • Poziom 9  
    trymer01 napisał:
    Nie widzisz różnicy między 200 Ohm a 1k? - to ja wymiękam, szkoda mego czasu.


    Mosfety sterowane są napięciowo a mój mosfet sterowany jest VGS napięciem min 2V do max 4V. z wyjścia ne555 otrzymuję wartości od 5V do 13 V więc mój mosfet zawsze będzie otwarty co sobie właśnie uzmysłowiłem. Nie wiem w zasadzie jaka będzie różnica przy zastosowaniu rezystora 1k który sugerujesz skoro na 200 Ohm działa tak samo jak na 47kOhm to będzie działało tak samo na 1kOhm. Więc zmiana rezystora raczej nic nie wnosi do zmiany działania układu. Ale spróbuję, po prostu muszę tylko wylutować 5 rezystorów i wstawić chociaż jeden 1kOhm.
  • Moderator Projektowanie
    arkomar napisał:
    Mosfety sterowane są napięciowo

    Tylko pozornie. Aby naładować kondensator nie trzeba prądu?

    arkomar napisał:
    a mój mosfet sterowany jest VGS napięciem min 2V do max 4V.

    Nieprawda. 2-4V to Vgstreshold. Wklep w tłumacza w google "treshold" to może Ci się rozjaśni.
    W ogóle poczytaj o MOSFET-ach.

    arkomar napisał:
    z wyjścia ne555 otrzymuję wartości od 5V do 13 V

    Nieprawda. czytaj datasheet NE555 który wyżej podałem.

    arkomar napisał:
    więc mój mosfet zawsze będzie otwarty co sobie właśnie uzmysłowiłem. Nie wiem w zasadzie jaka będzie różnica przy zastosowaniu rezystora 1k który sugerujesz skoro na 200 Ohm działa tak samo jak na 47kOhm to będzie działało tak samo na 1kOhm. Więc zmiana rezystora raczej nic nie wnosi do zmiany działania układu. Ale spróbuję, po prostu muszę tylko wylutować 5 rezystorów i wstawić chociaż jeden 1kOhm.

    Nieprawda.
    Aby tranzystor się otworzył pojemność bramki naładowanej do napiecie otwarcia musi się rozładować do napięcia zatkania (poniżej Vgstreshold). Znasz pojęcie stałej RC? - od czego zależy czas rozładowania C?
  • Poziom 9  
    trymer01 napisał:
    arkomar napisał:
    Mosfety sterowane są napięciowo

    Tylko pozornie. Aby naładować kondensator nie trzeba prądu?

    Tak się przyjmuje więc napisałem upraszczając

    trymer01 napisał:

    arkomar napisał:
    a mój mosfet sterowany jest VGS napięciem min 2V do max 4V.

    Nieprawda. 2-4V to Vgstreshold. Wklep w tłumacza w google "treshold" to może Ci się rozjaśni.
    W ogóle poczytaj o MOSFET-ach.

    Zgadza się bo u mnie sterowany jest powyżej 5V do 13V

    trymer01 napisał:

    arkomar napisał:
    z wyjścia ne555 otrzymuję wartości od 5V do 13 V

    Nieprawda. czytaj datasheet NE555 który wyżej podałem.


    Właśnie o to mi się cały czas rozchodzi bo to właśnie w moim układzie dostaję takie napięcie na wyjściu (pin 3) od 5V do 13 V a chcę otrzymywać wartości od 0V do 13V Oczywiście że datasheet ne555 podaje coś innego.

    trymer01 napisał:

    arkomar napisał:
    więc mój mosfet zawsze będzie otwarty co sobie właśnie uzmysłowiłem. Nie wiem w zasadzie jaka będzie różnica przy zastosowaniu rezystora 1k który sugerujesz skoro na 200 Ohm działa tak samo jak na 47kOhm to będzie działało tak samo na 1kOhm. Więc zmiana rezystora raczej nic nie wnosi do zmiany działania układu. Ale spróbuję, po prostu muszę tylko wylutować 5 rezystorów i wstawić chociaż jeden 1kOhm.

    Nieprawda.
    Aby tranzystor się otworzył pojemność bramki naładowanej do napiecie otwarcia musi się rozładować do napięcia zatkania (poniżej Vgstreshold). Znasz pojęcie stałej RC? - od czego zależy czas rozładowania C?


    Czas rozładowania z tego wzoru zależy od pojemności i od rezystancji. Pojemność bramki jest stałą wartością więc manipulujemy rezystancją i jeśli dam rezystor 200 Ohm to się szybciej rozładuje? Czy tak?
  • Pomocny post
    Moderator Projektowanie
    arkomar napisał:

    trymer01 napisał:

    arkomar napisał:
    z wyjścia ne555 otrzymuję wartości od 5V do 13 V

    Nieprawda. czytaj datasheet NE555 który wyżej podałem.


    Właśnie o to mi się cały czas rozchodzi bo to właśnie w moim układzie dostaję takie napięcie na wyjściu (pin 3) od 5V do 13 V a chcę otrzymywać wartości od 0V do 13V Oczywiście że datasheet ne555 podaje coś innego.

    Oglądałeś oscyloskopem przebieg z wyjscia NE555? - jeśli napięcie nie sięga w "dołku" ok. 1V t.zn. że coś masz nie tak z generatorem.
    Zasilanie NE555 - po co ta stabilizacja? - jeśli NE555 ma dać impuls prądu np. 100mA do przeładowania bramki to jaki masz spadek napięcia na oporniku 68 Ohm?

    arkomar napisał:
    trymer01 napisał:

    arkomar napisał:
    więc mój mosfet zawsze będzie otwarty co sobie właśnie uzmysłowiłem. Nie wiem w zasadzie jaka będzie różnica przy zastosowaniu rezystora 1k który sugerujesz skoro na 200 Ohm działa tak samo jak na 47kOhm to będzie działało tak samo na 1kOhm. Więc zmiana rezystora raczej nic nie wnosi do zmiany działania układu. Ale spróbuję, po prostu muszę tylko wylutować 5 rezystorów i wstawić chociaż jeden 1kOhm.

    Nieprawda.
    Aby tranzystor się otworzył pojemność bramki naładowanej do napiecie otwarcia musi się rozładować do napięcia zatkania (poniżej Vgstreshold). Znasz pojęcie stałej RC? - od czego zależy czas rozładowania C?


    Czas rozładowania z tego wzoru zależy od pojemności i od rezystancji. Pojemność bramki jest stałą wartością więc manipulujemy rezystancją i jeśli dam rezystor 200 Ohm to się szybciej rozładuje? Czy tak?

    A jakie napięcie będziesz miał wtedy (dzielnik 100 Ohm +200 Ohm) w stanie wysokim?
    I jaki ten dzielnik stanowi obciążenie dla wyjścia NE555? - policz sobie ile wtedy prądu z NE555 idzie do masy niepotrzebnie.
    Opornik 1k jest wystarczająco mały dla prawie każdego MOSFET-a aby mu rozładować bramkę w rozsądnym czasie.
  • Poziom 38  
    trymer01 napisał:

    NE555 daje napięcie wyjściowe zbliżone do zera.

    Być może tak powinno być , ale w tych egzemplarzach które ja testowałem nigdy tak nie było . Zazwyczaj pozostawało dla wysokoomowego obciążenia na 3 pinie ok.20 - 30 % napięcia zasilania.
  • Poziom 9  
    trymer01 napisał:
    arkomar napisał:

    trymer01 napisał:

    arkomar napisał:
    z wyjścia ne555 otrzymuję wartości od 5V do 13 V

    Nieprawda. czytaj datasheet NE555 który wyżej podałem.


    Właśnie o to mi się cały czas rozchodzi bo to właśnie w moim układzie dostaję takie napięcie na wyjściu (pin 3) od 5V do 13 V a chcę otrzymywać wartości od 0V do 13V Oczywiście że datasheet ne555 podaje coś innego.

    Oglądałeś oscyloskopem przebieg z wyjscia NE555? - jeśli napięcie nie sięga w "dołku" ok. 1V t.zn. że coś masz nie tak z generatorem.
    Zasilanie NE555 - po co ta stabilizacja? - jeśli NE555 ma dać impuls prądu np. 100mA do przeładowania bramki to jaki masz spadek napięcia na oporniku 68 Ohm?


    Cały czas zamieszczam przebiegi a tu z komentarzem.

    PWM na ne555 - Regulator PWM na układzie ne555 - jak ustawić amplituę

    i właśnie nie wiem co jest nie tak.

    Nie wiem o co chodzi z tym opornikiem 68 Ohm. Jest przecież na wejściu i ma ograniczać wpływający prąd na ne555.



    trymer01 napisał:

    arkomar napisał:
    trymer01 napisał:

    arkomar napisał:
    więc mój mosfet zawsze będzie otwarty co sobie właśnie uzmysłowiłem. Nie wiem w zasadzie jaka będzie różnica przy zastosowaniu rezystora 1k który sugerujesz skoro na 200 Ohm działa tak samo jak na 47kOhm to będzie działało tak samo na 1kOhm. Więc zmiana rezystora raczej nic nie wnosi do zmiany działania układu. Ale spróbuję, po prostu muszę tylko wylutować 5 rezystorów i wstawić chociaż jeden 1kOhm.

    Nieprawda.
    Aby tranzystor się otworzył pojemność bramki naładowanej do napiecie otwarcia musi się rozładować do napięcia zatkania (poniżej Vgstreshold). Znasz pojęcie stałej RC? - od czego zależy czas rozładowania C?


    Czas rozładowania z tego wzoru zależy od pojemności i od rezystancji. Pojemność bramki jest stałą wartością więc manipulujemy rezystancją i jeśli dam rezystor 200 Ohm to się szybciej rozładuje? Czy tak?

    A jakie napięcie będziesz miał wtedy (dzielnik 100 Ohm +200 Ohm) w stanie wysokim?
    I jaki ten dzielnik stanowi obciążenie dla wyjścia NE555? - policz sobie ile wtedy prądu z NE555 idzie do masy niepotrzebnie.
    Opornik 1k jest wystarczająco mały dla prawie każdego MOSFET-a aby mu rozładować bramkę w rozsądnym czasie.



    Dlatego jutro sprobuje wszystko rozlutować i polutować na nowo.
  • Pomocny post
    Poziom 30  
    Witam
    W.g. mnie na schemacie pomylone są nóżki 5 z 6.
    5 (CV) na kondensator 10n
    6 do 2
  • Poziom 39  
    Na tym schemacie to w ogóle nic nie widać, nawet lupa nie pomaga. Swoją drogą nie rozumiem gościa - chce pomocy a nawet czytelnego schematu nie przedstawi, dziwny jakiś...
  • Poziom 38  
    Wielu ludzi ma dziwny problem z ogarnięciem PWM na NE555, już dawno w necie znaleźć można taki schemat i działa na pewno, tranzystor można dać IRFZ44N.
    PWM na ne555 - Regulator PWM na układzie ne555 - jak ustawić amplituę
    Cytat:
    Warunki wstępne: zasilanie 13.8V z zasilacza, żarówka H7 12V, 55W

    Regulator radził sobie i z halogenem, i z silnikami, niewiele się grzeje, regulacja jest w prawie całym zakresie.
  • Poziom 30  
    Po bliższym przyjrzeniu się schematowi to cały jest " jakiś dziwny ".
    Popatrz na to :Link
    Zostałem wyprzedzony :D
    Miałem na myśli schemat z tematu
  • Poziom 9  
    kicajbas napisał:
    Witam
    W.g. mnie na schemacie pomylone są nóżki 5 z 6.
    5 (CV) na kondensator 10n
    6 do 2


    Zgadza się, moja pomyłka. Gdy przeprowadzałem analizę w miejsce ne555 wmontowałem inny układ który miał inne wyprowadzenia nóżek. Po prostu pomyliłem podłączenia i zamieściłem błędny schemat po zmianach. Wyniki na oscyloskopie są z układu który realnie zmontowałem zgodnie z schematem który teraz zamieszczam. Teraz po zmianach i przeprowadzeniu analizy układu dostaję zupełnie inne wyniki choć znowu nie sa takie jak oczekuję.
    Pojawia się dziwny błąd po przebiegu 2ms. Po przebiegu 2ms analiza
    jest przerywana automatycznie i wywala błąd. : "doAnalyses : Timestep too small". mimo tego że Timestep jest ustawiony na bardzo wysoki.

    Zamieszczam poprawiony schemat i ustawienia.

    PWM na ne555 - Regulator PWM na układzie ne555 - jak ustawić amplituę

    Czyli pytanie nadal jest aktualne. Dlaczego amplituda na wyjściu ne555(pin3) zaczyna się od ok. 5V i przebiega do 13V? Jakie parametry układu na to wpływają? i nowe pytanie - co jest nie tak z tym symulatorem w protelu?
  • Pomocny post
    Poziom 39  
    Arkomar, przyznam, że nie rozumiem twoich dylematów z tym układem.

    1. Jeżeli nie ogarniasz symulacji to sobie je na razie odpuść, nie mnóż sobie problemów, najpierw zrób działający układ a potem ew. ucz się na nim symulacji.
    2. Sprawdź dokładnie twój układ 555 - np. podłączając go w najprostszej konfiguracji. W ten sposób sprawdzisz czy on sam nie jest uszkodzony.
    3. Podziel układ na bloki i sprawdzaj każdy z osobna - odepnij np. wszystko od nóżki 3 i zmierz na niej przebieg, sprawdź napięcia i przebiegi na innych nóżkach i punktach układu, czy są zgodne z dokumentacją i wyliczeniami itd. W ten sposób znajdziesz miejsca gdzie jest usterka.

    I najważniejsze: jeżeli już koniecznie potrzebujesz pomocy od forum to przedstaw nam klarownie "wystarczającą liczbę informacji umożliwiającej zajęcie merytorycznego stanowiska przez innych Użytkowników forum" (cytat z regulaminu). Dotyczy to w szczególności klarownych i czytelnych schematów z jasnym opisem i opisem usterki. Nie robiąc tego dajesz nam do zrozumienia, że masz nas tam gdzie słońce nie zagląda, że nie zamierzasz dać nic z siebie a jedynie brać. A taka postawa bardzo zniechęca ludzi do pomagania i do ciebie samego. Chcesz pomocy - pokaż że współpracujesz i szanujesz tych od których czegoś wymagasz.
  • Poziom 9  
    kybernetes napisał:
    Arkomar, przyznam, że nie rozumiem twoich dylematów z tym układem.

    1. Jeżeli nie ogarniasz symulacji to sobie je na razie odpuść, nie mnóż sobie problemów, najpierw zrób działający układ a potem ew. ucz się na nim symulacji.
    2. Sprawdź dokładnie twój układ 555 - np. podłączając go w najprostszej konfiguracji. W ten sposób sprawdzisz czy on sam nie jest uszkodzony.
    3. Podziel układ na bloki i sprawdzaj każdy z osobna - odepnij np. wszystko od nóżki 3 i zmierz na niej przebieg, sprawdź napięcia i przebiegi na innych nóżkach i punktach układu, czy są zgodne z dokumentacją i wyliczeniami itd. W ten sposób znajdziesz miejsca gdzie jest usterka.

    I najważniejsze: jeżeli już koniecznie potrzebujesz pomocy od forum to przedstaw nam klarownie "wystarczającą liczbę informacji umożliwiającej zajęcie merytorycznego stanowiska przez innych Użytkowników forum" (cytat z regulaminu). Dotyczy to w szczególności klarownych i czytelnych schematów z jasnym opisem i opisem usterki. Nie robiąc tego dajesz nam do zrozumienia, że masz nas tam gdzie słońce nie zagląda, że nie zamierzasz dać nic z siebie a jedynie brać. A taka postawa bardzo zniechęca ludzi do pomagania i do ciebie samego. Chcesz pomocy - pokaż że współpracujesz i szanujesz tych od których czegoś wymagasz.



    Wszelkie uwagi bardzo mile widziane. Kontakt na forum to ostateczność kiedy już wszelkie znane mi możliwości wyczerpały się i potrzebuję porady. W trakcie jak dyskutujemy wprowadzam dodatkowe informacje o które proszą forumowicze żeby nie wprowadzać zamieszania i gadać niewiadomo o czym. Na początku przedyskutowaliśmy z trymer01 sprawę z mosfetami bo faktycznie parametry rezystorów mogły być niepoprawne ponieważ były projektowane do innego mosfeta zdaje się do rfp30p06. Później kicajbas słusznie zauważył, że zamieniłem podpięcia pinów 5 i 6. Przyznaję to moja pomyłka co wprowadziło trochę zamieszania i symulacja w protelu nie dawała efektu. Generalnie chciałem żeby układ który zaprojektowałem i testuję na oscyloskopie również potwierdził przebiegi w protelu. Co prawda pytanie dotyczące symulacji w protelu nadaje się na oddzielny temat postu ale jak to czasamy bywa chciało by się upiec dwie pieczenie na jednym ogniu.

    Generalnie moje pytanie dotyczy analizy pracy układu. Dlaczego dzieje się tak a nie innaczej, przy takim układzie elementów i wartości ich parametrów a nie innych. Wiem że na tym układziku można zbudować wiele różnych wariantów. Ja zbudowałem właśnie taki.

    Pytanie dotyczy wartości amplitudy tak jak na obrazku z postu#22. przebiegi na pinie3 układu ne555 zaczynają się od wartości ok 5V do 13V. Nie jest to wartość którą chcę uzyskać bo chcę żeby zaczynało się od wartości 0V do 13V.

    Jeśli chodzi o to co daję od siebie to chociażby pozostanie ten założony temat i może komuś kto będzie miał podobny problem pomoże w rozwiązaniu.
  • Poziom 39  
    arkomar napisał:
    Pytanie dotyczy wartości amplitudy tak jak na obrazku z postu#22. przebiegi na pinie3 układu ne555 zaczynają się od wartości ok 5V do 13V. Nie jest to wartość którą chcę uzyskać bo chcę żeby zaczynało się od wartości 0V do 13V.

    W tym układzie nie ma prawa być takich Przebiegów, szukaj błędu w montażu lub uszkodzonego elementu.
    arkomar napisał:
    Jeśli chodzi o to co daję od siebie to chociażby pozostanie ten założony temat i może komuś kto będzie miał podobny problem pomoże w rozwiązaniu.

    Arkmar, musisz przewartościować swój system pojęć: założenie tematu to nie jest "danie coś od siebie" ale właśnie "żądanie czegoś od innych". W tym założonym przez ciebie temacie "dają coś od siebie" ci, którzy ci doradzaja w twoim problemie. Natomiast twoje "danie czegoś od siebie" to jest np. w naszym przypadku narysowanie czytelnego schematu, z czytelnymi wartościami elementów i wyprowadzeń, i czytelna (klasyczna) konfiguracja elementów na tym schemacie. Podanie nieczytelnego zrzutu z ekranu "na odwal się", którego rozszyfrowanie wymaga wysiłku i dodatkowej pracy to po prostu lekceważenie innych forumowiczów i tak właśnie jest odbierane.
    Nie chcę tu zresztą więcej na ten temat polemizować, zobaczyłem, że masz mało postów, wiec pomyślałem, że przyda ci się taka podpowiedź o tym "jak należy pisać posty na forum aby skutecznie uzyskać pomoc i nie zrazić do siebie innych użytkowników roszczeniową postawą". A zrobisz z tym oczywiście to co zechcesz.