Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Hub USB + HP LJ P1005 - Drukarka nie drukuje, jeśli jest podłączona do HUBa

Villen 06 Maj 2013 21:19 3804 11
  • #1 06 Maj 2013 21:19
    Villen
    Poziom 21  

    Witam,
    pierwszy raz zakładam temat w dziale komputery, więc jeśli trafiłem do nieodpowiedniego podforum to bardzo przepraszam.

    Wydaje mi się, że mój problem jest typowo hardwareowy. Do laptopa pracującego pod kontrolą systemu Windows 7 64bit mam podłączony typowy, tani hub oparty na układzie GL850G. Hub zainstalował się poprawnie. Peryferia typu HID (myszy, klawiatury, pady), pamięci pendrive, aparaty, stary skaner Microtek ScanMaker 3800 podłączone do tego huba pracują poprawnie, nawet wszystkie naraz. Problem zaczyna się po podłączeniu drukarki jak w tytule (HP LaserJet P1005). Drukarka również zainstalowała się bez problemu (dodam że była instalowana na świeżo postawionym systemie, najpierw hub, potem najnowsze sterowniki ze strony HP, drukarka podłączona bezpośrednio pod hub), system widzi ją poprawnie jednak przy próbie drukowania drukarka jedynie się rozgrzewa, pomiga diodkami i na tym się kończy. Po podłączeniu drukarki bezpośrednio do portu USB laptopa działa bez najmniejszego problemu.

    W czym może tkwić problem? Bardzo proszę o pomoc...

    Dodam też ciekawostkę: po wydrukowaniu czegokolwiek, kiedy drukarka podłączona jest bezpośrednio pod port USB laptopa, można drukarkę podłączyć do huba i pracuje poprawnie do momentu restartu komputera.

    0 11
  • #2 06 Maj 2013 21:34
    DriverMSG
    Admin grupy komputery

    Villen napisał:
    system widzi ją poprawnie jednak przy próbie drukowania drukarka jedynie się rozgrzewa, pomiga diodkami i na tym się kończy.
    Czy system komunikuje jakieś błędy?
    Czy w podglądzie zdarzeń są jakieś błędy dotyczące drukarki?
    Czy sprawdzałeś z innym kablem USB?

    0
  • #3 06 Maj 2013 21:42
    Villen
    Poziom 21  

    Nie komunikuje żadnych błędów, w zadaniach drukowania wisi po prostu jedno zadanie i nic poza restartem systemu nie zmienia tego faktu.
    Właśnie sprawdziłem używając innego kabla, efekt niestety ten sam...

    Żaden z opisanych problemów nie występuje jeśli drukarka pracuje podłączona bezpośrednio do portu USB laptopa. Żaden z problemów nie występuje również, tak jak pisałem, jeśli pierwsze zadanie drukowania wydrukujemy podłączając drukarkę bezpośrednio do laptopa, po czym można ją przepiąć pod hub i do restartu systemu wszystko działa dobrze...

    Ręce mi opadają. Fakt faktem ten hub nie kosztował nawet 20zł, ale z drugiej strony wszystkie inne urządzenia działają bez zarzutu. Czy wymiana huba na jakiś lepszy, markowy model może coś zmienić?

    0
  • #4 06 Maj 2013 21:44
    DriverMSG
    Admin grupy komputery

    Villen napisał:
    Czy wymiana huba na jakiś lepszy, markowy model może coś zmienić?
    Nie można tego wykluczyć, choć osobiście uważam, że winą są kable - drukarki lub huba.

    0
  • #5 06 Maj 2013 21:58
    Villen
    Poziom 21  

    No dobrze, ale w takim razie czemu sama drukarka, podłączona tym samym kablem ale bezpośrednio do laptopów (bo korzystam z dwóch) działa bez zarzutu?

    I czemu wszystkie inne urządzenia podłączone do tegoż felernego huba działają bez problemu nawet w przekombinowanych konfiguracjach (myszka + tablet widziany w systemie jako dwa urządzenia pamięci masowej + pendrive + skaner, wszystkie urządzenia używane naraz)?

    Zależy mi na korzystaniu z huba, ponieważ laptop żony ma tylko dwa porty USB (Asus X54H) i byłoby to najwygodniejsze rozwiązanie - jeden kabelek - 3 urządzenia naraz.

    0
  • #6 06 Maj 2013 22:26
    Lzep
    Poziom 39  

    Villen napisał:
    No dobrze, ale w takim razie czemu sama drukarka, podłączona tym samym kablem ale bezpośrednio do laptopów (bo korzystam z dwóch) działa bez zarzutu?
    To proste - hub nie wyrabia prądowo - daje drukarce za słabe zasilanie. Innym urządzeniom może wystarczać, dlatego działają poprawnie. Spróbuj znaleźć parametry prądowe huba i ewentualnie znaleźć mocniejszy, np. z dodatkowym zasilaniem.

    0
  • #7 06 Maj 2013 22:34
    Villen
    Poziom 21  

    Hm... Szczerze mówiąc nie wydaje mi się, a to z tego powodu, że robiłem próby w sytuacji, kiedy do huba były podłączone: skaner, odbiornik myszy bezprzewodowej, pendrive i ta nieszczęsna drukarka. Wszystkie urządzenia działały poprawnie, tylko ta drukarka nie. Wydaje mi się, że jeśli hub nie wyrabiałby prądowo, to reszta urządzeń tym bardziej by nie działała.
    Poza tym, czemu w opisanej przeze mnie sytuacji, czyli po wydrukowaniu czegokolwiek z drukarką podpiętą bezpośrednio do laptopa i przepięciu jej pod hub działa bez problemu? ;)

    Spróbuję pożyczyć od kogoś jakiś markowy hub i sprawdzić jak wtedy sytuacja będzie wyglądała.

    Btw, dodam jeszcze, ze sytuacja wygląda identycznie na dwóch laptopach, wspomnianym asusie i samsungu rf711.

    0
  • #9 06 Maj 2013 23:00
    Villen
    Poziom 21  

    Uzywam najkrotszych kabli jakie dalo sie kupic, 1.5 albo 1.8m. Przy podlaczaniu skanera czy tez drukarki bezposrednio do laptopow nie ma zadnych, nawet najmniejszych problemow. Kabel laczacy z hubem typu A-B, bardzo solidny od modemu dsl, jakies 30cm. Kabelka tego uzywalem na codzien z usbaspem, na pewno jest sprawny. Z reszta probowalem tez uzywac innych.

    0
  • #12 07 Maj 2013 15:58
    Villen
    Poziom 21  

    Problem rozwiązany. Kupiłem siedmio portowy hub Modecom "Wave Hub", aktywny, zasilacz w komplecie. Cały sprzęt działa bezproblemowo. Co ciekawe, w trybie pasywnym (bez podłączonego zasilacza) również :) Więc okazało się, że nie warto czasami kupować najtańszej chińszczyzny, choć szczerze mówiąc, ten modecom kosztował niewiele więcej ;)

    0