Elektroda.pl
Elektroda.pl
X
Sklep HeluKabel
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

przetwornica - piszczy rdzeń, układ źle pracuje z obciążeniem indukcyjnym

ziguś 09 Maj 2013 13:45 3813 21
  • #1 09 Maj 2013 13:45
    ziguś
    Poziom 23  

    Witam
    Zrobiłem przetwornicę żeby dawała na wyjściu napięcie regulowane 4 - 40 V. Bazowałem na schemacie zasilacza ATX. Jak na wyjście podłączę równolegle 2 żarówki 24V 100W przetwornica pracuje normalnie, do schłodzenia wystarczy zwykły wentylator z atx-a zasilony 5-ma voltami choć rdzeń delikatnie popiskuje, ale jak na wyjście podepnę silnik elektryczny prądu stałego 200 watowy to tranzystory wejściowe mi się gotują i tranzystory padają po minucie.

    0 21
  • Sklep HeluKabel
  • #2 09 Maj 2013 16:13
    _jta_
    Specjalista elektronik

    Może chodzi o to, że silnik, dopóki się nie rozpędzi, pobiera większy prąd, albo
    i przy kręceniu się ma wahania poboru prądu spowodowane przez komutator -
    może od tego "głupieje" sterowanie i przesterowuje tranzystory?

    0
  • #3 09 Maj 2013 17:23
    ziguś
    Poziom 23  

    Silnik jest ok. Myślę że problem leży w tym że przetwornica jest obciążana indukcyjnie. Co jej "dołożyć" albo które elementy zmienić żeby jej to nie przeszkadzało.

    0
  • #4 09 Maj 2013 21:51
    _jta_
    Specjalista elektronik

    Przecież na wyjściu jest kondensator do masy i dławik szeregowo...

    0
  • #5 10 Maj 2013 23:01
    _jta_
    Specjalista elektronik

    Tranzystory wejściowe (te, co się palą) to które? Q1 i Q2?
    Być może w układzie powstają zniekształcenia sygnału, jakieś oscylacje, te tranzystory zamiast
    dostawać coś w rodzaju prostokąta dostają jeszcze dodatkowe oscylacje i przez to przełączają się
    za często. A to trudno sprawdzić, może oscyloskopem... Układ jest dość zagmatwany przez to,
    że w Tr2 jest użyty odczep - to daje dodatnie sprzężenie zwrotne, sprzyjające oscylacjom - ale ono
    jest potrzebne do działania, pewnie te oscylacje powinny jakoś być wytłumiane - może przez Q3
    i Q4, może przez C11 i R14 - a może gdzieś na C11, albo R14 jest przerwa?

    0
  • Sklep HeluKabel
  • #6 11 Maj 2013 11:07
    ziguś
    Poziom 23  

    Tak, chodzi o Q1 i Q2 one się palą

    0
  • #7 15 Maj 2013 07:20
    ziguś
    Poziom 23  

    Chyba wiem co jest problemem - ale żeby to sprawdzić muszę mieć przetwornicę o większej mocy.
    Czy mogę 2 takie przetwornice połączyć szeregowo ?
    Wtedy 1 i 2 ustawił bym na 12V i na wyjściu uzyskałbym 24V i jakieś 500W spokojnie. Myślę że wtedy by to poszło. Tylko czy mogę je połączyć szeregowo ?

    1
  • #8 15 Maj 2013 15:22
    _jta_
    Specjalista elektronik

    Oj, łączenie zasilaczy impulsowych jest ryzykowne. Może lepiej: jeden układ sterujący,
    ale cała reszta podwójnie: tranzystory, transformatory, do każdego oddzielnie diody
    - wspólne ma być tylko sterowanie, do baz tranzystorów Q3 i Q4.

    0
  • #9 15 Maj 2013 20:57
    ziguś
    Poziom 23  

    Nie jestem za mocny w przetwornicach, a czas mnie goni. A gdyby tak dać trafo TR2 na większym rdzeniu Q1 i Q2 większej mocy a Q3 i Q4 też by mogły być trochę większe i wiadomo diody na wyjściu też większe.

    0
  • #10 15 Maj 2013 23:41
    _jta_
    Specjalista elektronik

    Przede wszystkim trzeba zobaczyć, co się dzieje, a nie działać na oślep - to jest technika, nie wróżenie z fusów.

    0
  • #11 17 Maj 2013 08:01
    CosteC
    Poziom 26  

    Po pierwsze przerysuj schemat aby był czytelny.
    Po drugie zobacz jak wygląda prąd obciążenia indukcyjnego. Możliwe, że wzbudza ci się pętla sprzężenia zwrotnego.

    Możesz wrzucić fotkę układu?

    Zgaduję że jest to przerobiony zasilacz do PC o mocy wyjściowej rzędu "300W"?

    0
  • #12 17 Maj 2013 09:10
    ziguś
    Poziom 23  

    Co masz na myśli mówiąc "czytelny schemat". Schemat jest zrobiony w Protelu i wydrukowany do pdf. Może wydrukuj go na kartkę to wszystko wyraźnie zobaczysz.
    U mnie na ekranie jest wszystko wyraźne. A jak mam "zobaczyć " to obciążenie indukcyjne.
    A dokładnie to obciążeniem jest prądnica P20S ( od ursusa c330) która ma pracować jako silnik obcowzbudny w pracy dyplomowej. Uzwojenia wirnika i stojana połączyłem równolegle. Wiem że prądnice nie są przystosowane do pracy silnikowej ale nie ma skąd wziąć silnika obcowzbudnego na niskie napięcie i w rozsądnej cenie. A musi to być silnik obcowzbudny bo psorki tak sobie zażyczyły i musi to być na zasilaczu impulsowym. Ten silnik ma napędzać prądnicę prądu stałego i program lab-view ma utrzymywać stałe obroty silnika przy zmiennym obciążeniu prądnicy przy jednoczesnym podglądzie prądów i napięć na silniku i prądnicy.
    I chyba te 300W przetwornicy to trochę za mało - 500 było by w sam raz. Tak jak napisałeś przetwornica to przerobiony ATX z przewiniętym trafem głównym - tylko że jak rozbierałem zasilacz to pisało na nim 500W a w środku tylko rdzeń EI33. Do poprawnej pracy potrzebował bym 390W.

    0
  • #13 17 Maj 2013 09:52
    _jta_
    Specjalista elektronik

    Zobaczyć na oscyloskopie - masz dostęp do takiego sprzętu, umiesz użyć?
    Jak nie - pozostaje kombinować, co się da zmierzyć, żeby wykryć, co się dzieje.
    Uruchamianie układu elektronicznego to trochę jak praca detektywa...
    Przypuszczalnie w układzie powstają jakieś oscylacje, inne niż powinny być.

    0
  • #14 17 Maj 2013 11:06
    ziguś
    Poziom 23  

    Do oscyloskopu nie mam dostępu. Można by połączyć 2 takie przetwornice w szereg tylko trzeba by zamiast potencjometru który jest na wyjściu dać transoptor i transoptorem sterować nóżkę 1 układu TL494. Szukałem takiego rozwiązania na necie ale nigdzie nie mogę znaleźć. Dwie takie przetworki pociągną na bank.

    0
  • #15 17 Maj 2013 13:20
    _jta_
    Specjalista elektronik

    W układzie dwu przetwornic jest więcej możliwości wzbudzenia się - a już jedna się wzbudza.
    Sprawdź, czy w nocie katalogowej (albo aplikacyjnej) TL494 nie ma jakiejś użytecznej wskazówki.
    Trzeba rozpoznać, co jest przyczyną wzbudzenia się i usunąć tę przyczynę.

    0
  • #16 17 Maj 2013 18:22
    ziguś
    Poziom 23  

    Wstyd się przyznać że wcześniej na to nie popatrzyłem, ale to nie były wzbudzenia. Rozebrałem rdzeń transformatora głównego, szyba o grubości 6mm, papier ścierny wodny o gradacji 1000 i polerka powierzchni przylegania. Na razie rdzeń obkleiłem taśmą od przenośnych drukarek brother - nie zalewałem go niczym - to tak na razie na próbę - efekt ... cisza - nawet pod obciążeniem 250W. Widocznie była jakaś nierówność. Podpiąłem też silnik i podnosząc napięcie na wyjściu obserwowałem też prąd. Cisza jest do 310W potem zaczyna coś być słychać, ale na tym rdzeniu raczej więcej nie wycisnę.
    Nie zmienia to jednak faktu że ta przetwornica jest za słaba i chciałbym połączyć szeregowo 2, jednak że pozostaje problem z transoptorem - nie wiem jak go tam wstawić. Miałbym wtedy galwaniczną izolację układów sterujących.

    0
  • #18 17 Maj 2013 21:48
    CosteC
    Poziom 26  

    Drogi Zigusiu,

    Narysowanie schematu w Protelu, Altumie, Eaglu, Orcacie czy innym CADzie nie zapewnia czytelności.
    Nie zaznaczyłeś początków uzwojeń na transformatorach. Są zaznaczone gdzieś z boku. Niewygodne i nieczytelne.

    Co najważniejsze albo schemat jest beznadziejny albo jesteś kłamcą, kiedy twierdzisz, że układ działa. Narysowałeś zwarcie uzwojenia wtórnego TR1.


    Użyłeś układu sterowania bramkami z użyciem prądu półmostka. Czy wiesz jak to ma działać? Szczerze wątpię. Ale użyłeś.

    Dobra rada: Uprość schemat. Masz za skomplikowany układ sterowania bramek, poczytaj noty aplikacyjne od TL494, obejrzyj jak takie rzeczy się robi. Narysuj dobry schemat.

    Dorzucam oryginalny schemat dla pamięci.

    0
  • #19 18 Maj 2013 01:50
    ziguś
    Poziom 23  

    CosteC jak ty się ładnie do mnie zwracasz - nawet żona mi tak nie mówi. Mea culpa. Poprawiłem załącznik w 1 poście - faktycznie źle narysowałem mostek, ale reszta na bank jest dobrze. Dorobiłem jeszcze zabezpieczenie zwarciowe/przeciążeniowe. Przy zwarciu na wyjściu układ ponownie się załączy po odłączeniu od sieci ( zatrzask ) i nie wystartuje ze zwartym wyjściem.

    0
  • #20 18 Maj 2013 07:49
    CosteC
    Poziom 26  

    Myślę, że zamiast dodawać i komplikować powinieneś upraszczać.
    Schemat jeszcze mniej czytelny. Dodałeś
    pytanie: jaka jest rola uzwojenia 4-8 w TR2? Jak ma działać sterowanie bramek?

    TR4 nie wiadomo jak poukładane są uzwojenia.

    0
  • #21 18 Maj 2013 09:56
    _jta_
    Specjalista elektronik

    Przypuszczam, że autor tego sam nie projektował, tylko skopiował ze schematu zasilacza PC i nie wie.
    Uzwojenie 4-8 w Tr2 daje dodatnie sprzężenie zwrotne (uzwojenia 4-5 i 6-7 powinny być w tę samą stronę, 4-8 w przeciwną). Kierunek uzwojeń Tr4 jest nieistotny - sygnał na wejściu jest symetryczny, na wyjściu jest dioda i filtr...

    0
  • #22 18 Maj 2013 18:06
    CosteC
    Poziom 26  

    _jta_ mam podobne podejrzenia, ale dajmy się zigusiowi obronić. Tak czy inaczej uważam, że początki uzwojeń powinny być znaczone na schemacie.

    co do TR2 średnio widzę potrzebę tak skomplikowanego układu. W ogóle to przypomina to zasilacz do PC poskładany od nowa. Lekko karkołomne przedsięwzięcie muszę przyznać.

    Chciałbym zobaczyć obliczenia dla układu sterowania bramką :) nie będą tutaj proste.

    0