Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

TL-WR642G - Brak dostępu do urządzeń WiFi z komputera stacjonarnego

09 Cze 2013 21:47 1620 14
  • Poziom 18  
    Witam

    Mam następujący problem. Mam internet podłączony przez modem/router adsl TP-Link TD8816. Cała sieć podłączona zarówno przez kabel jak również WiFi działa, tzn. mam dostęp do Internetu. Mam jednak problem z dostępem z komputera stacjonarnego do urządzeń podłączonych przez WiFi (telefon, laptop). Jako router WiFi mam TP-Linka WR642G. Jak z laptopa próbuję się dostać do komputera stacjonarnego (ping, udostępnione pliki, pulpit zdalny) to wszystko działa prawidłowo. Ze stacjonarnego do laptopa (czy innego urządzenia) już nic nie dochodzi. Mogę spingować ze stacjonarnego port WAN (192.168.1.50) oraz bramę WiFi (10.1.15.1) routera WR642G, ale nie mogę żadnych urządzeń podpiętych przez WiFi, czy porty wbudowanego switch-a.

    Czy ktoś spotkał się z taki problemem? Jeżeli ktoś wie, jak to dokonfigurować proszę o informację.
  • Moderator - Sieci, Internet
    Najprościej będzie ominąć port WAN w WR642G i wyłączyć na nim DHCP, zmieniając jednocześnie adresację na taką z puli pierwszego np. 192.168.1.250,
  • Poziom 18  
    Miałem kiedyś taką konfigurację, ale zmieniłem ją na rzecz tej wykorzystującej WAN. Skoro w jednym kierunku działa prawidłowo to w drugim również powinno. Nie rozumiem dlaczego router WiFi nie przekazuje pakietów do tej podsieci.
  • Moderator - Sieci, Internet
    Wieniu napisał:
    ie rozumiem dlaczego router WiFi nie przekazuje pakietów do tej podsieci.

    Bo NAT router nie pozwala na to. Jak dla mnie dwa routery w sieci są nie potrzebne.
  • Poziom 18  
    Oczywiście, że nie są potrzebne (mam w tej sieci WiFi jeszcze jeden - AP Client dla dekodera TVSat), ale nie w tym rzecz. Taka sieć oprócz dostarczania mi netu bezprzewodowo służy również do testów. Skoro to są routery to powinno się dać skonfigurować dostęp do urządzeń podłączonych za ich pomocą i NAT routerów nie powinien być przeszkodą, zwłaszcza, że w jednym kierunku działa jak należy. Przecież cały Internet zbudowany jest na routerach i przekazywanie danych między podsieciami.
  • Moderator - Sieci, Internet
    Wieniu napisał:
    Przecież cały Internet zbudowany jest na routerach i przekazywanie danych między podsieciami.

    Tak ale przy odpowiednio ustawionym routing-u czyli trasach jakimi mają poruszać się pakiety.
  • Poziom 18  
    Dokładnie. Widocznie nie wyraziłem się jasno. Jak (Czy da się) w tych TP-Linkach, które posiadam: (TL-WR642G, TL-WR543G) ustawić trasy routingu, aby swobodnie poruszać się po urządzeniach w LAN. Próbowałem do routera dostać się przez Telnet, żeby sprawdzić czy nie można czegoś ustawić bezpośrednio z wiersza (jak w przypadku TD-8816), ale w tym routerze chyba go nie ma uruchomionego. Dla jasności, firmware mam zaktualizowany do najnowszej wersji udostępnionej przez producenta..
  • Moderator - Sieci, Internet
    Możesz próbować przez "Add or Modify a Static Route Entry"
  • Poziom 18  
    Próbowałem, ale wówczas dostaje informację, że trasa nie może należeć do podsieci żadnego z interfejsów.
  • Poziom 43  
    NAT właśnie "robi" tak, że działa w jedną stronę, a w drugą nie, chociaż teoretycznie nie powinno to przeszkadzać, w praktyce takie routerki mają wbitą blokadę, która służy bezpieczeństwu użytkowników i nie daje jej się zazwyczaj wyłączyć.

    Pokaż w jaki sposób dodajesz tą trasę to coś poradzimy.

    PS. Internet nie jest zbudowany na TP-Linkach;)
  • Poziom 18  
    Trasę dodawałem z interfejsu www. Zrzut przedstawia dane hosta, które podawałem.
    Adresacja:
    WAN: 192.168.1.50
    LAN: 10.1.15.1
    HOST: 10.1.15.10

    P.S. Wiem, że nie na TP-Linkach, ale inwestowanie w CISCO w domowej sieci to drobna przesada.
  • Poziom 43  
    Na TD8816 musisz dodać trasę:
    Dest: 10.1.15.0
    Subnet: 255.255.255.0
    Gateway: 192.168.1.50
  • Poziom 18  
    Tą trasę już wcześniej dodałem. Dzięki niej mogę pingować adres 10.1.15.1 w routerze WiFi. Problem jednak z tym, że od tego miejsca pakiety nie idą dalej.
  • Poziom 43  
    To tak jak wspominałem, zablokowane jest to z poziomu firewalla ze względu na bezpieczeństwo wewnętrznej sieci. Zmień urządzenia na bardziej konfigurowalne i wtedy ustawisz tak jak będziesz chciał, lub przekombinuj sieć tak, by pozbyć się routingu.
  • Poziom 18  
    Macie jakąś propozycję jakim sprzętem zastąpić TP-Linki, aby dało się zrealizować takie założenia co do działania sieci?