Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

EXCEL - kopiowanie komórki do pustej komórki

kelels 13 Cze 2013 15:52 2064 7
  • #1 13 Cze 2013 15:52
    kelels
    Poziom 8  

    Cześć
    Natrafiłem na kolejną ścianę… mianowicie problem mam taki, potrzebuję skopiować wynik formuły (B1) do innej komórki (C1) tylko jeżeli w jeszcze innej komórce (A1) wpiszę x. Zachowując możliwość pisania w komórce C1, oczywiście jeżeli wpiszę x w A1 to C1 zostanie zastąpione wynikiem B1. Pomysł mam przez stworzenie funkcji kopiuj:
    =JEŻELI(A1=”x”;KOPIUJ(B1=>C1);””)
    Gorzej z wykonaniem. Chyba że macie jakiś inny pomysł?
    Może wcześniej powinienem zadać pytanie czy to jest w ogóle do zrobienia?

    Pzdr

    0 7
  • #3 14 Cze 2013 08:28
    kelels
    Poziom 8  

    Dzięki za odp. ale to nie jest rozwiązanie bo komórka C1 ma być pusta, nie mogę w niej umieścić żadnej formuły bo chcę w niej też pisać sam.

    0
  • #4 14 Cze 2013 08:47
    cbrman
    Poziom 27  

    W taki wypadku to bez VBA się nie obejdzie.

    0
  • Pomocny post
    #5 14 Cze 2013 14:42
    tttggg
    Poziom 15  

    Poniżej rozwiązanie z wykorzystaniem VBA

    Kliknij prawym przyciskiem na nazwie arkusza, z menu kontekstowego wybierz "wyświetl kod". W edytorze VBA wpisz:

    Private Sub Worksheet_Change(ByVal Target As Range)
    If Target.Address = "$A$1" Then
    If Target.Value = "x" Then
    Range("C1") = Range("B1")
    Else
    Range("C1") = ""
    End If
    End If
    End Sub

    Zapisz plik w formacie XLSM (z obsługą makr) i wypróbuj działanie w arkuszu.

    Na podstawie http://www.excelforum.pl/light.php/o_t__t_13730__start_0__index.html

    Pozdrawiam

    1
  • #6 17 Cze 2013 08:52
    kelels
    Poziom 8  

    Dzięki o coś takiego chodziło, a jest możliwość żeby działało to w tabeli dla całego zakresu kolumny a nie tylko dla jednej komórki?

    0
  • Pomocny post
    #7 17 Cze 2013 10:32
    adamas_nt
    Moderator Programowanie

    Testuj kolumnę, przypisuj na offsetach. Np

    Kod: vb
    Zaloguj się, aby zobaczyć kod

    0
  • #8 17 Cze 2013 12:14
    kelels
    Poziom 8  

    Dzięki o coś takiego mi chodziło, temat rozwiązany

    0