Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel 2007 - działania na komórkach - szukam sugestii

erimek 18 Cze 2013 00:21 1221 6
  • #1 18 Cze 2013 00:21
    erimek
    Poziom 10  

    Witam.

    Tworze sobie tabele w Excelu do zawodów. Mam problem ze stworzeniem pewnej formuły albo raczej nie mam na to pomysłu.

    W załączniku obrazek, i tłumacze na czym mój problem polega:

    w polu "Zajęte miejsce" chce wpisywać którą pozycje zająłem w danym turnieju. A następnie po wpisaniu cyfry z zakresu 1 -> 3 aby pobierało kwotę z małej tabelki obok i zapisywało sumę w rubryce "Wygrana kwota". Dodatkowy problem pojawia się kiedy takich "Zajętych miejsc" mam więcej niż 1.

    Może marudzę, ale chciałbym to sobie zautomatyzować, aby ograniczyć ilość wpisywania ręcznego.

    Dziękuje za ewentualną pomoc i sugestie.

    Pozdrawiam

    0 6
  • #2 18 Cze 2013 00:48
    markoz7874
    Poziom 31  

    Nie łatwiej byłoby, gdyby na zajęte miejsce było przeznaczone tyle kratek ile jest turniejów?
    Można korzystać z informacji wpisanej jednym ciągiem w kolumnę zajęte miejsce ale stanowi to pewne utrudnienie. Wpisywanie też może być kłopotliwe i powodować błędy przy większej ilości.

    0
  • #3 18 Cze 2013 00:53
    erimek
    Poziom 10  

    markoz7874 napisał:
    Nie łatwiej byłoby, gdyby na zajęte miejsce było przeznaczone tyle kratek ile jest turniejów?
    Można korzystać z informacji wpisanej jednym ciągiem w kolumnę zajęte miejsce ale stanowi to pewne utrudnienie. Wpisywanie też może być kłopotliwe i powodować błędy przy większej ilości.


    Byłoby - ale to jest liczba nie do określenia.. mogą być 3 jednego dnia, a może ich być i 16 :(

    0
  • #4 18 Cze 2013 01:34
    dt1
    Moderator - Komputery Serwis

    Można na makrach. Nawet nie będzie to skomplikowane za bardzo :)

    Kod: vb
    Zaloguj się, aby zobaczyć kod

    Te dwie funkcje policzą liczbę turniejów oraz zsumują zdobyte nagrody. Założyłem, że nie w każdym turnieju nagrody muszą być takie same i mogą być punktowane różne miejsca (np w jednym turnieju tylko pierwsze, w innym pierwsze pięć miejsc).

    Przykład warty więcej niż tysiąc słów, tak więc wrzucam. Oczywiście trzeba zezwolić na działanie makr. Komórki A2 i D2 korzystają z wymienionych makr. Zajęte miejsca i nagrody powinny być rozdzielone średnikami i nie powinny się już znaleźć tam spacje (albo można zmienić parametr w funkcji split i zdefiniować cokolwiek innego). Nagród może być wymieniona względnie dowolna ilość, czym dalej tym dalsze miejsce (np 1000;500;200 to odpowiednio 1000 za pierwsze, 500 za drugie i 200 za trzecie miejsce, wpisanie samego 1000 da 1000 tylko za pierwsze miejsce, a wpisanie 500;500 da 500 za pierwsze oraz drugie miejsce).

    0
  • Pomocny post
    #5 18 Cze 2013 08:44
    cbrman
    Poziom 26  

    Można na formułach tablicowych (zatwierdzanie CTRL+SHIFT+ENTER).

    Cytat:
    Nawet nie będzie to skomplikowane za bardzo.

    Formuła dla Excela >=2007
    Code:
    =SUMA(JEŻELI.BŁĄD(WYBIERZ(FRAGMENT.TEKSTU(C2;WIERSZ(ADR.POŚR("1:"&DŁ(C2)));1)*1;1000;500;250);0);0)

    Wersja dla Excela <2007
    Code:
    =SUMA(JEŻELI(CZY.BŁĄD(WYBIERZ(FRAGMENT.TEKSTU(C2;WIERSZ(ADR.POŚR("1:"&DŁ(C2)));1)*1;1000;500;250));0;WYBIERZ(FRAGMENT.TEKSTU(C2;WIERSZ(ADR.POŚR("1:"&DŁ(C2)));1)*1;1000;500;250)))

    Jeśli kwoty za zajęcie poszczególnych miejsc mają być gdzieś w arkuszu (np.: zakres H1:H3) to formuła będzie wyglądać następująco:
    Code:
    =SUMA(JEŻELI.BŁĄD(WYBIERZ(FRAGMENT.TEKSTU(C2;WIERSZ(ADR.POŚR("1:"&DŁ(C2)));1)*1;H1;H2;H3);0);0)

    0
  • #6 18 Cze 2013 10:10
    markoz7874
    Poziom 31  

    dt1 napisał:
    ..Nawet nie będzie to skomplikowane za bardzo :)..

    Makro nie, ale teraz wprowadź jakieś konkretne (nie przypadkowe) dane w ilości 15-50, a następnie popraw np. 7, 11, 37 wynik. Zrobić arkusz i napisać makro, to żadna filozofia. Zrobić to samo tak aby było ergonomiczne to już większa sztuka.

    0
  • #7 18 Cze 2013 13:30
    erimek
    Poziom 10  

    cbrman napisał:
    Można na formułach tablicowych (zatwierdzanie CTRL+SHIFT+ENTER).
    Cytat:
    Nawet nie będzie to skomplikowane za bardzo.

    Formuła dla Excela >=2007
    Code:
    =SUMA(JEŻELI.BŁĄD(WYBIERZ(FRAGMENT.TEKSTU(C2;WIERSZ(ADR.POŚR("1:"&DŁ(C2)));1)*1;1000;500;250);0);0)

    Wersja dla Excela <2007
    Code:
    =SUMA(JEŻELI(CZY.BŁĄD(WYBIERZ(FRAGMENT.TEKSTU(C2;WIERSZ(ADR.POŚR("1:"&DŁ(C2)));1)*1;1000;500;250));0;WYBIERZ(FRAGMENT.TEKSTU(C2;WIERSZ(ADR.POŚR("1:"&DŁ(C2)));1)*1;1000;500;250)))

    Jeśli kwoty za zajęcie poszczególnych miejsc mają być gdzieś w arkuszu (np.: zakres H1:H3) to formuła będzie wyglądać następująco:
    Code:
    =SUMA(JEŻELI.BŁĄD(WYBIERZ(FRAGMENT.TEKSTU(C2;WIERSZ(ADR.POŚR("1:"&DŁ(C2)));1)*1;H1;H2;H3);0);0)


    Super ! Bardzo dziękuje, teraz wszystko jest tak jak być powinno.
    Ładnie, przejrzyście i full automatyzacja :)

    Pozdro !

    0
TME logo Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
TME Logo