Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Autorun płyty CD ze zdjęciami w Windows 7

dominik_fil 24 Cze 2013 09:18 1110 6
  • #1 24 Cze 2013 09:18
    dominik_fil
    Poziom 17  

    Witam,
    zrobiłem autorun płyty CD

    [autorun]
    open=start a.jpg
    icon=a.ico

    na płycie są pliki:
    a.ico
    a.jpg
    aaa.inf

    W Windows 7

    0 6
  • #3 24 Cze 2013 13:18
    dominik_fil
    Poziom 17  

    No i nie działa mi autostart. Czy to jest dobrze napisane?

    0
  • #4 26 Cze 2013 12:28
    huluk
    Poziom 30  

    Ale jaki efekt przez ten "autostart" chcesz osiągnąć?
    Czy chciałbyś, aby płyta wystartowała i pokazało się zdjęcie? Jeśli tak, to musisz po pierwsze umieścić na płycie program, który to zdjęcie wyświetli, a następnie w autostarcie umieścić wpis do tego programu z odpowiednim parametrem który spowoduje wyświetlenie zdjęcia.
    Np. - wrzucasz na płytę w główny katalog przeglądarkę IrfanView (plik i_view32.exe) oraz zdjęcie (start_a.jpg) i w autostarcie wpisujesz open=i_view32.exe start_a.jpg - uruchomi to przeglądarkę z wyświetlonym zdjęciem.
    Podałem jako przykład gdyż nie wiem ciągle jaki efekt chcesz osiągnąć.

    0
  • #5 26 Cze 2013 12:39
    dominik_fil
    Poziom 17  

    Dokładnie o to mi chodzi co napisałeś. Za chwilę wypróbuję twój sposób.
    Ale mam taki problem w kmpie, że Win7 nie chce mi włączyć automatycznego odpalania płyty (tego menu z wyborem na starcie) więc nie wiem czy autorun pojdzie?

    0
  • #6 26 Cze 2013 12:46
    huluk
    Poziom 30  

    Sprawdź czy masz w panelu sterowania -> autoodtwarzanie zaznaczone "Użyj auto...." i czy dla opcji Oprogramowanie i gry masz "Zainstaluj lub uruchom..." - jeśli tak na pkt 1 i 2 to po włożeniu płyty z prawidłowym plikiem autorun i z aplikacją którą ten plik ma uruchomić program powinien wystartować automatycznie.

    EDIT: aby było "menu" na starcie (rozumiem, że chodzi o ekranik wyboru co zrobić) to dla danej zawartości powinno być ustawione "pytaj mnie za każdym razem".

    0