Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

BASCOM - Wysyłanie litery po rs232 do terminala

seba_x 28 Cze 2013 15:05 1503 5
  • #1 28 Cze 2013 15:05
    seba_x
    Poziom 31  

    Witam

    Napisałem prosty programik :

    Kod: basic4gl
    Zaloguj się, aby zobaczyć kod


    W bascomowym terminalu wyświetla się podkreślnik _ , wg mnie powinno być A .
    W Realterm jak przełączę na HEX to otrzymuję wartość 5F , dlaczego nie 41 ?

    A jak podłączę zamiast PC wyświetlacz VFD fc20x2ja-ab to ładnie wyświetla mi literę "A"

    0 5
  • #2 28 Cze 2013 18:16
    Press
    Poziom 22  

    A dobrze masz ustawiony terminal? Zwłaszcza prędkość transmisji?
    Obniż szybkość transmisji do 9600 lub niżej i sprawdź. Mnie też się kiedyś takie cuda działy.

    0
  • #3 28 Cze 2013 20:01
    maniek1818
    Poziom 22  

    Co jest źródłem taktowania :?: Wewnętrzny generator RC :?: Jeśli tak, to nic dziwnego.

    0
  • #4 29 Cze 2013 09:35
    seba_x
    Poziom 31  

    Witam

    Ręce opadają :-) , dzisiaj podłączyłem dwa różne terminale bezpośrednio kablami rs232 i działa idealnie, wcześniej miałem przejściówkę na max232 . Podłączyłem atmegę do rs-a przez przejściówkę (identycznie tak jak wczoraj) i działa ! Co było przyczyną błędów ? Już nie ważne. ;-) Pozdrawiam i dzięki za pomoc .

    0
  • #5 01 Lip 2013 23:46
    aklosek
    Poziom 12  

    Może gdzieś styku nie miałeś, to się często zdarza

    0
  • #6 03 Kwi 2014 10:34
    seba_x
    Poziom 31  

    Rozwiązanie jak post wyżej, admin kazał zamknąć temat więc zamykam .

    0