Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Windows 7 x64 Prof. - Aplikacje - Instalator Windows, błędne działanie.

MARCIN.SLASK 30 Jun 2013 19:05 1719 3
  • #1
    MARCIN.SLASK
    Home appliances specialist
    Od kilku dni zauważyłem, że coś jest nie tak z systemem. System 2 tygodnie po instalacji, ale mam kłopot z instalacją większości aplikacji. Zaczęło się od OpenOffice, Java i nowszych sterownikach do płyty. Po wybraniu składników, ścieżki (nawet jak zostawię domyślną) to instalator Windows stoi w miejscu. Przerwanie powoduje kolejne problem, bo przy ponownym uruchomieniu instalatora twierdzi, że już jedna instalacja trwa.
    Problemem jest chyba TEMP.

    Windows 7 x64 Prof. - Aplikacje - Instalator Windows, błędne działanie. Windows 7 x64 Prof. - Aplikacje - Instalator Windows, błędne działanie.

    Co prawda chciałem przenieść pliki TEMP na inną partycję i niby się powiodło, prze stworzenie skrótu, ale widać, że ta metoda jest obarczona wadą.

    Windows 7 x64 Prof. - Aplikacje - Instalator Windows, błędne działanie.

    Kiedyś był skrót do folderu na "D", teraz jest folder z brakiem dostępu i pewnie tu jest problem.
    Trochę się pospieszyłem z darowizną (nie szkoda mi podarowanych punktów), bo nadal TEMP niby jest na "C", a raczej go całkowicie brak. Pomijam fakt, że pagefile.sys ciągle powraca. Gdybym miał "lewy" system to OK, ale zakupiony OEM. Niestety pomoc Microsoftu jest płatna dla OEMów.

    Nie dość, że system działa wolno, to jeszcze wiem, że znajomi co mają także Windows 7, bez problemu przenoszą foldery tymczasowe. Dlaczego u mnie takie problemy. Czy to sprawa płyty głównej, bo raczej nie dysku SSD, bo większość teraz ma SSD.



    Ponowna instalacja systemu da pozytywne wyniki, ale to kolejny stracony czas, nie wiem jak zareaguje Antyvirus (licencja na 3 komputery), ustawienia, itp.

    Czy Wy użytkownicy Windows 7, też tak kombinujecie...?

    Znajomy raz dwa zmienił wpis ogólnie dostępny w zmiennych środowiskowych i od dawna ma TEMP na innej partycji:

    Windows 7 x64 Prof. - Aplikacje - Instalator Windows, błędne działanie.

    I tak ma od wielu miesięcy. Dlaczego u mnie po ponownym uruchomieniu systemu powraca na "C" oraz ten pagefile.sys.

    EDIT.

    Utworzyłem folder TEMP i system go scalił. Gdy wejdę to jest tylko folder o nazwie "IIF2". Jest pusty. Na dysku "D" folder TEMP systemowy jest także pusty. Instalator Windows dalej nie instaluje aplikacji. Zmienne środowiskowe bez zmian - ciągle wskazują, że TEMP/ TMP są na "C".
  • #2
    dark_skeleton
    Level 17  
    TEMP jest dość ważnym folderem, generalnie nie powinno się go ruszać. Tym bardziej przenosić i tworzyć skrótów - jeśli nie zrobiłeś skrótu np. programem junction (specjalny program robiący symlinki jak w linuksie na partycjach NTFS). Skrót to PLIK, który Eksplorator po jego uruchomieniu rozpoznaje i przechodzi do odpowiedniego folderu. Nie działa to jednak w przypadku ścieżek do folderów.
    Trzeba było najpierw zmienić zmienną środowiskową, zrestartować komputer i upewnić się, że się zmieniła, a dopiero potem ewentualnie przenieść zawartość folderu - żadnych skrótów!

    O co chodzi z powracaniem pagefile.sys? Ten plik też jest bardzo ważny, i powinien być na którymś z dysków, o rozmiarze porównywalnym z ilością twojej pamięci RAM, a zarządzać nim powinieneś tylko z panelu sterowania (Link)

    Problem jest tylko z systemem, żadna płyta główna ani dysk nie mają nic do rzeczy. Namieszałeś :)

    Skoro system jest w miarę świeży, na twoim miejscu zainstalowałbym go od nowa i nie bawił się w naprawianie. Stracisz mniej czasu niż na próbach naprawy.
  • #3
    DVDM14
    Level 35  
    Skróty były tworzone przez mklink, sprawdzona metoda...

    Zjawisko jest dziwne, nie stwierdziłem go na żadnej z maszyn, na których wykonywałem tą operację.

    Jesteś pewien, że folder docelowy tego skrótu istnieje?

    Pokaż screen z menu "właściwości" dla C:\Windows\Temp, zakładka "skrót".

    Można też spróbować usunąć C:\Windows\Temp i ponowić operacje utworzenia dowiązania, którą wcześniej podawałem.
  • #4
    MARCIN.SLASK
    Home appliances specialist
    Problematyczną aplikacją, która przy każdym uruchomieniu systemu przywracała TEMP na dysk "C", była: ASrock Extreme Tuner. Aplikacja dobra, bo szło podkręcać, ustawiać prędkość wentylatorów, monitorować temperaturę. Ale odinstalowałem i już od 3 dni mam spokojnie TEMPa na dysku "D".
    Podobnie jak Pagefile.sys.

    Połowa problemów opanowana, przez usunięcie programu użytkowego dołączonego do płyty głównej.

    Ale pozostał problem z instalatorem Windows przy niektórych aplikacjach. Problemy z niebieskim ekranem też znikły, ale np. programu Debugging Tools for Windows X64 nie mogę zainstalować, bo stai przy instalowaniu. I tak mogę go zostawić na tydzień, a pasek postępu się nie ruszy. OpenOffice, Libre Office, i wiele podobnych programów co mają podobne instalatory, stoją kiedy mają instalować. Co ciekawe do folderu TEMP podczas instalacji, zapisują się pliki, ale instalacja nie rozpoczyna się. Całkowicie wyłączyłem antywirusa (bo myślałem, że w ustawieniach namieszałem), ale nie pomaga.

    Jak się uporam z zaległościami, to zainstaluję system na nowo.