Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Android RKM MK802 IV TVN Player Ipla tną, cały czas kółeczko

Robert de Clair 03 Lip 2013 21:29 4572 10
  • #1 03 Lip 2013 21:29
    Robert de Clair
    Poziom 14  

    Jak w temacie.

    Leżą dwa urządzenia iPhone i RKM MK802 IV (android 4.2.2) wersja jądra 3.0.36+

    Na iPhone zarówno aplikacja IPLA jak i TVN player śmigają bez problemu, natomiast na tym urządzeniu tną i to tak, że mam co 30 sec film przez 3 sec potem znów kółeczko. Odległość od routera nie gra roli.

    Jakiś czas temu miałem urządzenie na andku i zachowywało się podobnie, ale wówczas zrzuciłem to na karb słabego procka tamtego urządzenia.

    Obecny sprzęt daje sobie radę z YT (tzn laguje DUŻÓ mniej, ale tez widac roznice w stosunku do iP czy PC podlaczonego do tego samego routera zwłaszcza w początkowej fazie odtwarzania, tak jakby "wąchanie" filmu zabierało mu dużo czasu.) tak więc nie jest to kwestia bezpośrednia w prędkości procesora/internetu. po prostu te aplikacje nie działają tak jak powinny.

    Wspólnym mianownikiem może być router Linksys WRT54GL fw v4.30.7
    Ale nie mam możliwości sprawdzenia tego na innym sprzęcie (to jest typowy dongle do TV), poza tym iP i PC podpięte do tego routera śmigają aż furczy.

    Na speedtest urządzenie na andku ma ping 32ms down5.5 i bardzo niski up 0.40
    na ip ping 82ms down 6.11 i up 0.48
    testy oczywiście chwilowe i ich wartość co test różni się nieco niemniej jednak parametry sieci są wystarczające do tego by korzystać z tych serwisów.

    Jakieś pomysły na ogarnięcie tematu?

    0 10
  • #3 04 Lip 2013 08:11
    Robert de Clair
    Poziom 14  

    Na MT7001 jest jednojajkowy procek 800mHz i 512ram, wiec ma prawo nie ogarniać części aplikacji.
    Ale MK802 IV to czterordzeniowy 1.6Ghz 2GB ram "potwór" Albo problem jest z jakimiś przekierowaniami z routera, albo za dużo sprzętu po drodze (są dwa routery z czego niestety jeden to livebox). zobaczę jeszcze czy lepiej będzie śmigał na routerze wifi hauwei z aero2 - teoretycznie powinno być gorzej bo aero ma max 512kB (ale film powinien rwać rzadziej niż w interwałach 3 sec odglądania i 30 bufora). O efektach oczywiście nie omieszkam poinformować.

    Sygnał idzie do liveboxa, ten podaje kabelkiem do wejscia LAN linksysa (wylaczony serwer dhcp coby się nie żarły) tak więc linksys robi tutaj tylko za "podaj dalej po wifi"

    P.S. do linksysa w akcie rozpaczy wrzucilem firmware tomato 1.28 (sytuacja bez zmian)

    Edit:13:06
    Odpowiedzialny za zamieszanie MOŻE być RTSP (real time stream protokol) zwyczajowo UDP port 554 który trzeba by puścić.

    0
  • #4 05 Lip 2013 14:46
    Robert de Clair
    Poziom 14  

    Modem Hauwei i Aero2 - efekt ten sam, ale....

    Problem rozwiązałem, tzn efekt przeszedł najśmielsze oczekiwania :)
    XBMC i wtyczka do polskich TV online (działa od XBMC 12.2 czyli aktualnej).
    W jednym miejscu IPLA WEEB TVN player + wiele innych.

    0
  • #5 19 Sie 2013 21:57
    tataolka
    Poziom 6  

    Witam wszystkich, to mój pierwszy post na forum.

    Mam podobny problem z boxem MK802+(Model:
    Android 4.0
    Allwinner A10/1.5G CPU 1.0GHZ + GPU 500MHZ
    Memory:1GB
    Graphical processor
    2D/ 3D/ OpenGL ES2.0(AMD Z430)/ OpenVG1.1(AMD Z160)@27M Tri/sec)

    Urządzenie odtwarza Youtube, Netflix, plynnie, bez problemow, natomiast weeb.tv nie daje rady. Mozna oglądac kanały niskiej jakości, wtedy lekko przycina tylko, do zaakceptowania. Kanały HD, tu jest różnie Muszę suwakiem obniżyć jakość do minimalnej i np. TVN24 przycinając idzie, inne nawet na minimalnej jakości, zachowują się różnie, od szarpania do całkowitego blokowania odtwarzacza.
    Próbowałem XBMC ale tam jest jeszcze gorzej - zresztą na XBMC tnie nawet zwykle radio a sama aplikacja dziala bardzo ociężale.
    JAkieś pomysły na rozwiązanie problemu?
    Internet to UPC(Irlandia) 50 MB przez router.

    0
  • #6 20 Sie 2013 12:26
    Robert de Clair
    Poziom 14  

    Hmm XBMC dziala u mnie o 500% lepiej niz natywne apki tvn player ipla itp.
    Przez PC odpala Ci normalnie weebtv? bo może problem jest z Twoją lokalizacją.
    Inna sprawa, że temat ten założyłem dla RKM MK802 IV czyli dość szybkiej czterordzeniowej maszynki/dongla, a XBMC hula na niej bez zarzutu.

    0
  • #7 20 Sie 2013 22:27
    tataolka
    Poziom 6  

    Na PC śmiga super, zarówno przez stronę jak i XBMC.
    Podpiąłem się pod temat bo nie chciałem śmiecić, urządzenie podobne, problem również, miałem nadzieję, że ktoś cos podpowie. Jeżeli naśmieciłem, sorry.

    I tak np. kanał Kiepskich moge oglądać praktycznie bez problemów, kilka dziecięcych rownież, TVP HD tnie minimalnie ale do obejrzenia przy pewnej dozie dobrej woli, TVN HD(np) juz tnie mocno. Nie umiem znaleźć zależności.

    0
  • #8 21 Sie 2013 10:28
    arnoldziq
    Moderator Programowanie

    Miałem podobny problem z UG007 opartym na RK3066 Dual Core ARM Cortex-A9 1.2GHZ oraz Mali-400MP4 Quad-core GPU oraz 1GB RAM.
    'Wąskim gardłem' okazał się nie procesor czy pamięć, tylko sterownik WiFi. Zmiana oprogramowania wraz z kernel-em na "nieoryginalne" załatwiła sprawę i wszystko śmiga.
    Oprogramowanie które wgrałem do tego dongla to bodajże modyfikowany Android/kernel dla iMito MX2.

    0
  • #9 25 Sie 2013 00:21
    tataolka
    Poziom 6  

    Jak mogę sprawdzić, gdzie, ewentualnie mam takie "wąskie gardło?

    0
  • #10 25 Sie 2013 07:50
    Pawel2420
    Poziom 30  

    Urządzenie ma tzw. akcelerator sprzętowy służący do dekompresji obrazu. Tylko dzięki niemu możliwe jest odtworzenie filmów w dużej rozdzielczości. Część playerów używa go domyślnie. Czasami jest opcja pozwalającą włączyć jego obsługę. Są również aplikacje, które nie będą współpracowały poprawnie z tym konkretnym rodzajem sprzętu.
    Oczywiście ważny jest również format filmu. Aplikacje dla części formatów usiłują użyć akceleratora a dla innych nie.
    Zwykle najskuteczniej działa palyer domyślnie zainstalowany w systemie.

    -1