Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

WD My Passport - System Win nie widzi dysku, natomiast widzi Linux i Mac OS X

leburaque 08 Lip 2013 13:54 21114 16
  • Poziom 17  
    Witam,

    wydaje się, że nie jest to odosobniony przypadek (vide forum Elektroda, Peb, PCLab i inne). Z dnia na dzień dysk przestał być strukturalnie widoczny w systemach operacyjnych Windows (testowane na XP, Vista i 7 i kilkunastu różnych komputerach), albo w ogóle nie jest widoczny w systemie, albo win7 życzy sobie formatowania. Nie reagują na niego programy diagnostyczne (HDTune i inne), czy programy niskopoziomowe takie jak TestDisk dla Windows, czy MHDD. Natomiast w systemie operacyjnym Linux, czy MacOs dysk jest widziany bez problemu i bez spadku szybkości czy jakości odczytu można z niego korzystać. W Linuxie można bez problemu uzyskać do niego dostęp także niskopoziomowo, generować raporty smart i inne. W tym systemie operacyjnym dowolne testy nie wykrywają żadnych błędów.

    Nie do końca jestem pewny, co może być przyczyną. Na tych samych komputerach system Win nie wykrywa dysku, niezależnie od przeinstalowania sterowników, usuwania sterowników, instalacji oprogramowania WD i emulacji portów USB na niższe standardy, zaś w Linux, czy MacOS na tych samych komputerach dostęp do dysku jest pełny i bezproblemowy.

    Co może być problemem? Czy ktoś ma pomysł jakie to dziwactwo może być przyczyną?

    Mój model to dokładnie WD5000BMVW

    Póki co napisałem do WD w tej sprawie, by dowiedzieć się co jest problemem i czy dysk podlega gwarancji. Zakładam wątek, by zebrać kilka innych w których problem podobny wystąpił. Jeśli ktoś miał podobny problem - niech dorzuci swoje trzy grosze do wątku, a ja będę na bieżąco informował, co odpowiedziało WD.

    Tutaj podobne wątki na Elektrodzie:
    https://www.elektroda.pl/rtvforum/viewtopic.php?t=2001391
    http://forum.cdrlab.pl/hdd-flash/9478-moj-komputer-nie-wykrywa-dysku-na-7-a.html

    I innych, niewiele wnoszą, ale widać, że problem występuje.
    http://www.ps3-hack.com.pl/index.php?topic=13371.0
    http://peb.pl/archiwum-forum-sprzet/704852-dysk-zewnetrzny-wd-my-passport-essential.html
    http://forum.dobreprogramy.pl/komputer-nie-widzi-passport-essential-t409017.html
  • Pomocny post
    Spec od komputerów
    Jak DMDE widzi dysk ? To są bardzo częste przypadki ,że windows nie widzi dysku i danych a na linuksie bez problemów wszystko działa. Dotyczy to dysków różnych producentów. Osobiście kilkadziesiąt takich przypadków widziałem. Kończyło się kopiowaniem danych. Zerowaniem początku dysku i zakładaniem tablicy partycji i partycji pod windowsem. Nie znam powodu dlaczego tak się dzieje bo niestety w windowsie się nie orientuję.
    Pozdrawiam
  • Poziom 17  
    Tak jak napisałem - dysk nie jest czytany w systemach Windows, widać go jedynie w Linux/MacOS a teraz jestem w delegacji i mam do dyspozycji w pracy jedynie Linux/Win. Próba wywołania dysku spod Win zwykle kończy się po prostu zawieszeniem programu. Wpierw próbowałem Data Lifeguard Diagnostic for Windows, który zalecił mi producent (odpisali i poprosili o raport). Wpierw pobrany program poszukuje aktywnych napędów. Po zakończeniu skanowania po prostu program nie odpowiada. Odłączenie dysku i program pracuje poprawnie, ale wykrywa tylko dysk w moim laptopie, to samo na dwóch komputerach stacjonarnych. Próba podłączenia dysku w momencie pracy programów nie przynosi również żadnych rezultatów.

    Jeśli chodzi o DMDE dla Windows to program zawiesza się przy próbie odczytu dysku. Napis głosi "Czekaj... dostęp do urządzenia P0" i jeśli ręcznie nie odłączę dysku, to nic się nie wydarzy, program nie pokaże nawet okna startowego z wyborem dysku/obrazu.

    Wcześniej wygenerowałem raport Smart poprzez GParted, które (nawiasem mówiąc) nie wykrywa absolutnie żadnych znanych mi błędów dysku. Niestety - co tu kryć, GParted niekoniecznie jest narzędziem do diagnostyki tego typu dysków, niemniej pozwala na bezproblemową komunikację z dyskiem. Raport również załączam.

    CrystalDiscInfo, HDTune jako programy pod Win mają dokładnie identyczny problem: dopóki dysk jest podpięty, dopóty nie zareagują one i zawieszają się po prostu.

    Jeszcze nie wiem, czy kopiować dane, czy nie, ale to naprawdę dziwna rzecz, że tak się dzieje. Skoro problem jest tak częsty, to może warto poczekać jeszcze z wyrokami?
  • Pomocny post
    Poziom 43  
    leburaque napisał:
    Smart poprzez GParted, które (nawiasem mówiąc) nie wykrywa absolutnie żadnych znanych mi błędów dysku.

    Mylisz się, wykrywa i jest to najpewniej przyczyną twoich problemów.
    197 Current_Pending_Sector - 1

    Zgrać dane i zrobić całą procedurę:
    https://www.elektroda.pl/rtvforum/topic1550200.html
    wstawić z jej etapów fotki oraz po niej nowy SMART (powinno się dać już z Win).
  • Poziom 17  
    Co racja to racja. Błąd pierwszego rodzaju. ;)

    A póki co - bardzo ciekawe i pozytywne zachowanie ze strony WD. Ponieważ nabyłem dysk po okresie obejmującym ten dysk gwarancję WD przedłużył mi ją i zaproponowali nadesłanie i wymianę. Co Wy na to? Póki co - wyślę, zobaczymy. Jeśli nie, to najwyżej będę się ciął i próbował niskopoziomowo go ogarnąć. Póki co - czas mi zajęło zdobycie pustego dysku na który mogłem zgrać to wszystko, zwłaszcza, że w GParted jakoś nie mogłem wynegocjować przez USB wyższego transferu...

    Nie zamykajmy jeszcze tematu - nie jestem jedyny z tym problemem, a kto wie, może mi tego dysiora nie wymienią?

    Póki co - bardzo dziękuję za pomoc.
  • Poziom 2  
    Witam. Mam chyba ten sam problem. Mój dysk to WD My Passport 1 TB. Używałem go od nowości przy TV Toshiba 40RL939 do nagrywania i odtwarzania nagranych filmów. No i tak czytając powyższe posty, wyczytałem ze komuś się tak stało gdy odłączył dysk podczas jego używania. No i ja kiedyś nagrywałem coś z TV, no i TV się zawiesił... czasem tak się z nim dzieję, byłem już z tym w serwisie, nic nie mogą poradzić:| no ale mniejsza z tym. No i gdy się zawiesił i to go z kontaktu wyłączyłem(TV). Uruchomiłem i od tego momentu dysk przestał działać. TV go nie widzi, i laptop tez go nie widzi. Na laptopie mam Win7. Nie mam możliwości sprawdzenia czy Linux go widzi. Po podłączeniu do laptopa zapala się dioda, mryga prze kilka sekund, potem się ciągle pali, słychać i czuć jak się kręcą dyski w środku, ale w systemie ani w managerze programów się nie pojawia. Gdy podłączam do TV dioda po zapaleniu się mryga przez jakieś 5 czy 10 minut i gaśnie, TV go nie wykrywa. Mam jeszcze konsole PS3, i tez go nie wykrywa, a dioda mryga i dysk wydaje co 3 sekundy "pip".

    Zgubiłem rachunek:/...

    Nie mam na tym dysku nic na czym mi zależy, ale nie chce go do śmietnika wyrzucać, bo to fajny i drogi gadżet, może mi ktoś poradzić co zrobić, gdzie z nim pójść?

    pzdr
  • Poziom 17  
    Najprościej spróbować uaktywnić sobie na jakimś nośniku USB http://www.ultimatebootcd.com/ - bez żadnego problemu znajdziesz tam instrukcję instalacji. Po uruchomieniu z tego nośnika dystrybucji Linuxa oznaczonej na zdjęciu http://www.ultimatebootcd.com/graphics/screenshot.gif jako Parted Magic możesz sobie zdziałać setki dobrych rzeczy z dyskiem. Pierwsza jednak sprawa - stwórz botowalnego z USB Linuxa z Parted Magic.
  • Poziom 17  
    Zasadniczo WD zachowało się bardzo, bardzo przyzwoicie. Wysłałem dysk, w ciągu tygodnia odesłali mi nowy. Elegancko i bez zmartwień. I to z polską obsługą. Niemniej tematu nie zamykam i o to proszę moderatora, bo jeśli komuś się przydarzy taki problem po gwarancji trzeba by wykorzystać wiedzę powyżej. :)
  • Poziom 2  
    Witam,

    Spotkało mnie dokładnie to samo.
    Ciekawe jest to, że dysku używałem od dawna zarówno pod linuxem jak i windowsem, i pod linuxem bez problemu używam nadal a na windows go nie ma, dokładnie z dnia na dzień. Dysk jest wylistowany w menadżerze użądzeń, zainstalowany poprawnie, wszystko ok, nie ma natomiast żadnych informacji o nim (pojemność itp), no i w "Komputerze" (win7) nie widać oczywiście żadnych partycji z tegoż dysku.
    Mój dysk jest niestety po gwarancji, więc nie mogę go odesłać. Zresztą tak czy inaczej, nurtuje mnie pytanie co się właściwie stało, i dla czego...
    Oczywiście mogę zgrać dane, po czym bawić się w "naprawianie", ale na razie szukam dalej, może da się jakoś jednak przywrócić dyskowi "życie pod windowsem" nie tracąc danych... Jeśli ktoś coś jeszcze wie na ten temat, proszę się podzielić! :)
  • Spec od komputerów
    Nie udało mi się zmusić windowsa do czytania takiego dysku. Nie znam się na windowsach to może dlatego. Zawsze kończyło się kopiowaniem danych i formatowaniem dysku pod windowsem.
    Pozdrawiam
  • Poziom 2  
    A ja właśnie postanowiłem dla pewności przetestować dysk w innym komputerze i... Działa pod windowsem. Wniosek jest prosty: nie z dyskiem coś nie tak lecz z systemem... Autor tego wątku pisał że testował swój dysk na kilku komputerach i nigdzie nie działał pod windowsem. Mój dysk zachowuje się identycznie, ale tylko na jednej konkretnej instalacji windowsa!

    Więc zamiast formata dysku czeka mnie reinstalacja windy chyba... Tymbardziej że nie wiedzieć czemu przestał mi też działać bezprzewodowy modem huawei na usb... (łączy się z siecią, lecz pisze że "brak dostępu do internetu"), ten sam modem używam również na linuksie bez żadnych problemów.

    A sterowniki sprawdzałem po raz kolejny, wszystko ok, USB zainstalowane prawidłowo, zresztą wszystkie sprzęty są poprawnie przez system rozpoznawane. Tylko treści dysku nie widzi.... (i połączenia z internetem :o)

    Wiedząc, że sprawa jednak leży w systemie, może jakiś znawca windowsa potrafi coś podpowiedzieć?
  • Poziom 2  
    Witam
    Mam podobny problem. Dysk dzialal bez problemow, nagle przestal. Problem wystepuje tylko pod usb 2.0. Na linuksie dziala i usb 3.0 rowniez dziala pod windowsem. Napewno nie wchodzi tutaj w rachube zla instalacja windowsa. Pod usb 3.0 wystepowal tylko problem ze sterownikiem sas ale po reczym doinstalowaniu problemu nie ma. Pozostaje tylko kwestia USB 2.0 (unknown device). Nie mam aktualnie opcji zdgarnia danych (1TB) i zabawe w firmware itp. Moze ma ktos jakies rozwiazanie? Pozdrawiam
  • Poziom 17  
    Jedyne co mogę dodać - dotychczas wszyscy to właśnie sugerowali. A tak z mojej strony - jeśli będzie trzeba grzebać przy konkretnych sektorach dysku i je zerować - i tak musisz zrobić kopię. Nie ma przebacz. Na razie nie mamy pewnej metody (i chyba jeszcze długo mieć nie będziemy), więc każda próba może się skończyć srogimi problemami ze strukturą danych. Rób kopię. Nie żyjemy w czasach dyskietek, po znajomych pewnie da radę znaleźć ten 1 TB. :)
  • Pomocny post
    Poziom 2  
    Witam
    Jak na początek sprawa zaczyna się robić prostsza. Podłączyłem dysk pod usb 3.0 i potestowałem w hd Tune. No i jak narazie widać jak byk że na dysku padł boot sector, który jest odpowiedzialny za wykrywnie na usb 2.0. Jak narazie dobry początek.
    Pozdrawiam
  • Poziom 17  
    Dzięki za to info, powinno się nam przydać. :)
  • Poziom 2  
    1. Odpiąć dysk
    2. Run as administrator: cmd
    3. set devmgr_show_nonpresent_devices=1
    4. start devmgmt
    5. Uninstall :
    a) WD SES Device (razem ze sterownikami)
    b) W Universal Serial Bus controllers
    - szary USB Mass Storage Device
    - szary Unknow Device (wszystkie)
    c) W Storage Volumes
    - szary generic volume (wszystkie)
    d) Wszystkie szare woluminy w Storage volume shadow copies
    e) W Disk drives
    - WD My Passport
    6. Uruchom ponownie komputer
    7. Podepnij dysk
    8. W miarę potrzeb formatuj.
    9* Panel Sterowania> Power Options > Change plan settings > Change advanced power setting > hard disc=never(0) > usb suspend setting=disabled"