Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

LM2678 - Zbyt wysokie napięcie wyjściowe

17 Lip 2013 18:30 2172 5
  • Poziom 10  
    Mam problem z układem opartym o przetwornicę LM2678T-5.0. Teoretycznie powinna na wyjściu dawać 5V jednak multimetr wskazuje 5,65V (na wejście podaję 9,5V). Elementy do układu dobierałem zgodnie z dokumentacją techniczną. Wszystkie wartości są na schemacie ideowym w załączniku. Dołączam też schemat płytki. Skąd może brać się taka różnica w napięciu, co zrobiłem źle?
  • Poziom 19  
    Napięcie mierzyłeś pod obciążeniem?
  • Poziom 39  
    Prowadzenie ścieżek nie jest dobre. Długie ścieżki przy dławiku, długa ścieżka feedback. Dioda też nie powinna być tak ustawiona.
    Dławik 15uH też jest za mały jak na takie napięcie wejściowe. Nie piszesz ile chcesz pobierać prądu z tego step-down'a a to też ważne przy doborze dławika.
    Ponadto na wyjściu masz "ogromny" kondensator 1000uF, który dodatkowo obciąża przetwornicę. Wystarczyłoby 330uF.

    I najważniejsze. Czy pomiarów napięcia wyjściowego dokonałeś pod obciążeniem, czy step-down pracował sam?
  • Poziom 10  
    Przepraszam, że tak długo nie odpisywałem.
    Okazało się, że jeden z elementów był źle przylutowany. Ale jeżeli mówisz, że płytka jest źle zaprojektowana to całkiem ją poprawię i sprawdzę wtedy dopiero układ na nowy.
    Co do prądu to pobierać chcę do 3A.
  • Poziom 10  
    Ok, znalazłem w końcu czas aby się tym zająć. Płytka na razie jest stara, poprawiłem tylko luty i... bez obciążenia na wyjściu mam napięcie ~5V. Ale gdy już coś podłączę zaczynają się problemy bo napięcie raz wynosi 5,5V, raz ok 5V. Zmienia się to co parę/paręnaście sekund.
    Jeżeli chodzi o sam układ to chcę z ok 10V zejść do 5V i jak już pisałem wyżej na wyjściu mieć do 3A.
  • Poziom 17  
    Czyli jak pisali koledzy wyżej, płytka do przeprojektowania - krótkie i grube ścieżki do dławika, najlepiej bez przelotek, sprzężenie zwrotne z dala od dławika. Do tego podejrzewam że wstawiłeś do układu zwykłe elektrolity, a powinny być low ESR. Przeczytaj porządnie notę katalogową, tam masz wszystko wyjaśnione.