Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

D-Link DSL-2750B - Rouer - wpływ port forwarding na problemy z WiFi (tylko WiFi)

10 Sie 2013 21:22 2322 7
  • Poziom 10  
    Oto mój magiczny problem z routerem D-Link DSL-2750B. Do routera podłączone są:
    1. notebook (DHCP, kabel lub WiFi)
    2. DVR (IP statyczny, połączenie kablem)
    Na notebooku jest program do obsługi DVR.
    Ponieważ DVR ma być dostępny z WAN, więc ustawiłem w routerze port forwarding.

    Wszystko gra, dopóki notebook jest podłączony do routera kablem - mam dostęp do DVR zarówno z notebook-a jak i z WAN. Jeśli jednak podłączę
    notebooka po WiFi, to tracę dostęp do DVR (i tylko tyle, poza tym internet działa a DVR odpowiada na pingi)! Jeśli zdejmę port forwarding to
    dostęp do DVR idzie także po WiFi (oczywiście już tylko w LAN).

    Czy połączenia kablem i WiFi nie powinny być traktowane tak samo? Dlaczego mój router dyskryminuje WiFi przy port forwarng?

    Aha - DVR podłączony jest przez ... bridge? chodzi o 2 kierunkowe anteny - "wirtualny kabel" (nie znam fachowej nazwy), ale one powinny być zupełnie przezroczyste...

    Postawiłem na błąd w fimware (EU_1.01) ale przy próbie aktualizacji dostaję komunikat "Ivalid image format" (update oczywiście po kablu, plik próbowałem ściągać z różnych źródeł).

    F1 !
  • Poziom 10  
    Adres DVR jest z puli DHCP (inaczej router nie pozwoliłby na ustawienie port forwarding dla tego IP), ale ustawiłem w routerze rezerwację IP routera po jego MAC-u, MAC odczytany bezpośrednio z DVR. Jednak istotonie nie widzę na liście klientów na routerze ani DVR, ani mostu.
    Most zbudowany na NanoStation5.

    "Możliwe że nie są do końca przezroczyste i maskują adres fizyczny DVR swoim mac-iem" - mogłoby to mieć wpływ na różną reakcję routera w zależności czy połączę się kablem czy bezprzewodowo? Poprzednio miałem inny router i nie było opisanych problemów, ruter musiałem zmienić bo nie obsługiwał DDNS.
  • Poziom 10  
    Tak jest ustawione:
    Wireless mode: Station, MAC Clone: wyłączone
    Nie znam się na tego typu sprzęcie, czy powinienem poprawić?

    Serdecznie dziękuję za pomoc, będę dalej z tym walczył w weekend :-)
  • Poziom 43  
    Dość ciekawa sprawa, wygląda na bug.

    Sprawdź, czy nie masz gdzieś włączonej opcji "AP Isolation", "Client Isolation" lub czegoś w ten deseń.
    Oczywiście sprawdzasz cały czas po wewnętrznym adresie DVRu, tak?

    Któraś z Nanostacji nie ma adresu, który pokrywa się z adresem laptopa? Pokaż wynik polecenia arp -a jak podłączony jesteś po WiFi i po kablu.
  • Poziom 10  
    Tak, cały opis dotyczy komunikacji po wewnętrznych IP-kach.
    IP-ki się nie pokrywają - sprawdziłem.

    W weekend zrobię jeszcze test z pominięciem NanoStation.
  • Poziom 15  
    Dołączę się do tematu, gdyż ja też mam problem ze skonfigurowaniem tego routera. Mnie boli to, że muszę lokalny adres IP urządzenia do przekierowania na zewnątrz wybierać z puli DHCP. To raczej nie jest norma... Mam również problem z dostępem do sieci WiFi, do skonfigurowanego połączenia z zaawansowanym szyfrowaniem nie można się podłączyć. Starszy model Dlinka nie robi z tymi zagadnieniami problemu. Stawiam na kilka grubych błędów w firmware.