Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu

mejbi 14 Sie 2013 19:15 1947 6
  • #1 14 Sie 2013 19:15
    mejbi
    Poziom 9  

    Witam

    Kolejna ofiara złośliwości, czy też zawodności rzeczy martwych...

    3 dni temu normalnie zacząłem pracę na komputerze, wszystko działało, i po jakimś czasie wyłączyli prąd. Po ponownym uruchomieniu komputera, podczas wczytywania Windowsa (XP Pro SP3) wyskoczył bluescreen i restart.

    Początkowo nie sprawdzałem nawet jaki kod się pojawiał, tylko wziąłem płytę z Windowsem i za pomocą konsoli próbowałem zadziałać CHKDSK /R. Wcześniej musiałem podać na dyskietce sterowniki do Gigabyteowego RAID-0. Przeskanowałem wszystkie 3 partycje, znalazło niby jakieś błędy i je naprawiło, pomyślałem, że po problemie.

    Niestety po ponownej próbie uruchomienia systemu sytuacja się powtórzyła (BSOD). Spróbowałem zmienić ustawienia w BIOSie, bo czasami podobno się resetują podczas zaniku prądu. "Coś" pogrzebałem i po kolejnej próbie uruchomienia systemu jeden dysk był non-raid, drugi pozostał w normie (raid-0).

    Poczytałem trochę inne wątki i chyba czeka mnie odbudowanie raida poprzez skopiowanie pierwszych 2049 sektorów z obydwu dysków, usunięcie raida i ponowne jego utworzenie, a następnie ponowne wgranie sektorów z pliku. Czyli procedura "Sposób na odbudowę RAID 0" z wątku https://www.elektroda.pl/rtvforum/topic1351430.html.

    Przed awarią dyski podpięte były pod porty GSATA-0 i GSATA-1.

    Teraz opiszę co zrobiłem do tej pory, poza tym, co opisałem wyżej.
    1. Podpiąłem dyski pod inne porty (SATA-0 i SATA-1) i zmieniłem w BIOSie ustawienia na IDE, żeby były widoczne oddzielnie.
    2. Zgrałem sektory 0-2048 z obydwu dysków na dyskietkę za pomocą MHDD.

    Jeśli miałbym się trzymać opisu, to teraz powinienem:
    1. Podpiąć dyski z powrotem pod GSATA-0 i GSATA-1 (oczywiście ten sam dysk do tego samego portu).
    2. Zmienić w BIOSie na RAID.
    3. Przejść do biosu RAIDa, usunąć RAID-0.
    4. Utworzyć nowy RAID-0.
    5. Wyłączyć komputer nie uruchamiając go z tego RAIDa.
    6. Podpiąć dyski pod porty SATA-0 i SATA-2 (lub którekolwiek, byle nie GSATA-0/GSATA-1), żeby były widoczne w MHDD.
    7. Zmienić w BIOSie ustawienia na IDE.
    8. Wgrać sektory do obydwu dysków.
    9. Podłączyć dyski do GSATA-0/1 i zmienić w BIOSie na RAID.
    10. System powinien ruszyć? A przynajmniej powinien być sprawny RAID-0?

    Proszę o potwierdzenie tych kroków, lub poprawienie mnie, jeśli gdzieś jest błąd. Zrobiłbym to bez pisania na forum, ale mam tam za dużo ważnych danych, aby ryzykować, zwłaszcza, że specjalistą od tego nie jestem.

    Załączam trochę screenów z biosów i MHDD. Jeśli coś jeszcze będzie potrzebne do udzielenia mi pomocy, to piszcie - uzupełnię dane możliwie szybko.

    Z góry dzięki za zainteresowanie i pomoc.

    BIOS - IDE/RAID:
    ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu





    MHDD - lista dysków
    ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu

    MHDD - EID dysk 1
    ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu

    MHDD - EID dysk 2
    ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu

    MHDD - SMART dysk 1
    ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu

    MHDD - SMART dysk 2
    ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu

    MHDD - zgrywanie sektorów
    ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu

    RAID BIOS - dysk 1 info
    ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu

    RAID BIOS - dysk 2 info
    ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu

    RAID BIOS - RAID info
    ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu

    0 6
  • #2 16 Sie 2013 08:48
    mejbi
    Poziom 9  

    Proszę też o ocenę stanu dysków, bo może po kolejnym, nagłym braku zasilania coś się z nimi stało. Chyba trzeba w końcu zainwestować w UPS...

    0
  • #3 16 Sie 2013 10:58
    migol21
    Specjalista HDD Recovery

    Stan dysków ok tylko tasiemki są uszkodzone lub nie stykają do wymiany lub poprawienia styki.

    Zasadniczo procedura prawidłowa.
    Najpierw jednak złożyć RAID w DMDE i wykonać kopie posektorową woluminu RAID od sektora 0.

    0
  • #4 20 Sie 2013 09:38
    mejbi
    Poziom 9  

    Witam

    Napiszę, co udało mi się zrobić, chociaż lepiej sytuację oddałoby określenie co się nie udało...

    Niestety nie wykonałem kopii posektorowej woluminu RAID po złożeniu go w DMDE (brak odpowiedniego dysku), ale widoczne były wszystkie 3 partcje jak i pliki na nich, tylko co do plików, to chyba nie wyświetlało wszystkich, albo wyświetlało, ale w katalogach o dziwnych nazwach.

    Po przejrzeniu partycji pod DMDE wziąłem się za wykonanie procedury, którą opisałem w pierwszym poście. Wgrałem więc skopiowane wcześniej sektory na odpowiednie dyski, ale niestety komputer z nowego RAIDa nie ruszył.

    Mając nadzieję na pomoc zdalną próbowałem podłączyć inny dysk z systemem (od laptopa) do swojego komputera, ale niestety wyskakiwał BSOD z tym samym błędem (W BIOSie kontroler ustawiony na IDE, a nie na RAID). Trochę mnie to irytowało, więc postanowiłem poodłączać wszystkie inne urządzenia i zostawiłem tylko ten dysk od laptopa - niestety ten sam rezultat - BSOD. I dzieje się tak niezależnie do którego gniazda ten dysk podepnę.

    Co jest nie tak? Co w tej sytuacji można zaradzić? Miałbym możliwość załatwienia jeszcze dysku z systemem na ATA, ale czy to pomoże? Jeśli nic innego nie zaproponujecie, to pewnie tego spróbuję...

    Pozdrawiam.

    0
  • #5 20 Sie 2013 15:47
    migol21
    Specjalista HDD Recovery

    Czy sterowniki sa ok ?
    Najlepiej jak podepniesz dyski RAID-owe po przez USB po uruchomieniu komputera.
    Czyli ustawiasz kontroler jak powinien być i jak działa z uruchomionym systemem i startujesz system np. Live Linux np. UBUNTU 13.04 nie install a wypróbuj. Po uruchomieniu systemu podpinasz dyski na USB. i ściągasz DMDE. Możesz również uruchomić UBUNTU z ISO które ma już wbudowane DMDE i Team Viuwer. od Linuksa.

    0
  • #6 20 Sie 2013 16:51
    mejbi
    Poziom 9  

    Sterowniki są raczej OK, ściągnięte ze strony producenta.

    Z podpięciem dysków przez USB będzie problem, bo nie mam kontrolera.

    LiveCD chyba działa zarówno jak ustawiony jest RAID, jak i IDE. Ubuntu z TeamViewerem mam załatwić, żebyś mógł zerknąć na dyski, tak? Ok, postaram się jak najszybciej to zrobić, a póki co przesyłam jeszcze zdjęcia ekranów: dwa pierwsze to widok po podpięciu starego dysku ATA 40GB i próbie instalacji na nim nowego Windowsa. Przy wyborze partycji widać oddzielnie jeden dysk spoza RAIDA i drugi dysk jakby RAID, bo są tam 3 moje partycje. Dwa kolejne to zdjęcia z uruchomionego Windows LiveCD - również widać pod nim moje partycje, więc może tragedii nie ma?

    ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu
    ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu
    ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu
    ST3250410AS - BSOD 0xBA4CF524 po zaniku prądu, jeden dysk non-raid, ocena stanu

    Zaraz zabieram się za tego linuksa z teamviewerem...

    0