Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Pulson gprs-n - Podłączenie do komputera przez rs232 (schemat kabla programujące

kiing 09 Sep 2013 11:42 10938 17
Optex
  • #1
    kiing
    Level 8  
    Witam mam taki moduł jak w tytule, chciałbym go zaprogramować ale nie mam kabla. Wiem że gniazdo w module to standard usb(sama wtyczka) ale pracuje jako rs232. Mam komputer z portem com chciałbym przez niego połączyć się z modułem. Ma ktoś pomysł ( schemat) jak połączyć poszczególne piny. Proszę o pomoc.
  • Optex
  • #2
    dariusz.bembenek
    Stationary Alarms specialist
    Nawet gdyby ktoś miał pomysł, to nie sposób tego opisać na forum bez wstawienia zdjęć podłączeń itp. Nie rozumiem po co kombinować, skoro to RS-232 to podepnij ten kabelek (USB), komputer Ci wykryje ten scalak wlutowany w płytkę modułu i ściągniesz jakieś sterowniki (ftdi etc.) i po problemie.
  • #3
    kiing
    Level 8  
    Kolego dziękuję za odpowiedź, ale ja nie mam kabelka ( właśnie w tym temacie proszę o pomoc w jego stworzeniu ) jak już będę go miał to na pewno go podłączę do komputera, bo właśnie po to go potrzebuje. A teraz wracając do tematu, znalazłem podobny temat ale tam podłączają z użyciem przejściówki usb-com, a ja chce bez niej podłączyć. Podaje link do tematu https://www.elektroda.pl/rtvforum/topic1610125.html. Jeszcze raz napisze o co mi chodzi, w module jest gniazdo usb żeńskie ale to tylko gniazdo styki pracują w standardzie rs232 w starym komputerze mam port com 9-pin , i chcę to podłączyć czyli który pin z którym pinem żebym mógł przeprogramować moduł. Czyli gdzie rx z com, tx z com , skąd masa itp. Proszę o pomoc
  • Optex
  • #4
    telesystem
    Level 22  
    Brak możliwości podłączenia tego modułu do com komputera, przejściówka rs na usb tez nic nie zmieni.Najlepiej użyć oryginalnego kabla i oprogramowania. Miedzy modułem a komputerem musisz zastosować interfejs oparty na jakimś układzie 232 np. max, hin itp. Gotowy kabel masz np. Satel ca5 lub inny do programowania(oparty na takim układzie). Napisz jaki masz i Koledzy podpowiedzą czy się nadaje czy nie. Może warto zrobić taki interfejs ? przyda się w przyszłości do innych urządzeń.
    Jak będziesz miał taki to ktoś podpowie jak go tam podłączyć i obyś pin do tego modułu znał bo inaczej będzie kiepsko.
    Pozdrowienia
  • #5
    kiing
    Level 8  
    Kodu pin oczywiście nie znam bo moduł z odzysku, a czy mozesz rozwinąć swoją wypowiedź na ten temat.
  • Helpful post
    #6
    telesystem
    Level 22  
    Musisz miec kabel (interfejs) do programowania wtedy będziesz wiedział co z pinem.
    Głównie chodzi tu o kod dostępu do tego modułu i często pasuje standardowy bo ktoś po prostu zostawił 1234 lub 1111 w przeciwnym razie moduł będziesz mógł odesłać do producenta gdzie przywrócą Ci kod fabryczny. Innego rozwiązania niestety ja nie znam.
    Pozdrawiam
    Michał
  • #7
    kiing
    Level 8  
    Zakupiłem taki oto interfejs usb - ttl pl2303hx, podłączam go zgodnie (mam nadzieje) z opisem w tym temacie https://www.elektroda.pl/rtvforum/topic1610125.html, efekty są takie że kiedy urządzenie jest odłączone od źródła zasilania i akumulatora, po podłączeniu kabla migają bardzo szybko równocześnie diody tryb/moc i transmisja, natomiast program do komunikacji z tym modułem wypisuje "błąd komunikacji lub niewłaściwy typ urządzenia". I teraz moje pytania:

    1. Jak podłączyć to urządzenie przez ten interfejs (tj. czy rx do 1 (pin na końcówce kabla usb (wtyczce męskiej) zgodnie z ilustracją usb, tx do 2 , 3 i 4 zewrzeć razem, gnd do ekranu (obudowy wtyczki).

    2.Czy migające diody to objaw prawidłowego podłączenia?

    3.Kiedy włączę zasilanie w module diody przestają migać, a program nie wysyła żadnych komunikatów.

    4.W programie jest wybarny poprawny moduł, kiedy z premedytacją zmienię go na gsm-1 pojawia się inny komunikat. Czy to oznaka że po prostu kod PIN urządzenia jest błędny i dlatego jest błąd komunikacji??

    5. Jak ustawić komunikację w przez port com bitrate itp. ?

    Sorry, że tyle pytań, ale nie wiem czy już wysyłać go do siedziby pulsonu, celem resetu do ustawień fabrycznych, czy na razie źle podłączam. Pozdrawiam i dzięki z góry za pomoc.
  • #8
    Ture11
    Level 38  
    Witaj.
    Miałem ten moduł, a właściwie mam nadal, ale okazał się uszkodzony.
    W mnie, po wpięciu wtyczki, jedna z diod zmieniała kolor, nie było żadnego migania ani nic. Dioda, która zmieniała kolor to była dioda transmisja - z koloru zielonego robiła się pomarańczowa - prawdopodobnie w zamyśle miała być czerwona, ale mój moduł był uszkodzony. Nie mniej jednak, bez problemu komputer połączył się z modułem, a kod zadziałał standardowy (nie pamiętam jaki, ale program na PC sam go sugeruje, chyba 1234).

    Co do sposobu podłączenia, jutro spróbuje zajrzeć, jeśli będziesz miał jeszcze jakieś wątpliwości.

    Pozdrawiam.

    Dodano po 4 [minuty]:

    Może dodam, że parametry transmisji są ustawiane przez program, więc nie przestawiaj ich (nie pamiętam, czy jest taka możliwość).
  • #10
    kiing
    Level 8  
    Program i instrukcje mam, chodzi mi o schemat kabla połączeniowego, które wtyczki zwarte a który to rx i tx, pozdrawiam. I po czym poznać ze podłączone wszystko jest ok tylko np. pin błędny. Kiedy zmienię podłączenie kabelków tj. według rysunku powyżej zewrę 1 z 2, tx do 3 a rx do 4, gnd do ekranu, to rzeczywiście na włączonym do prądu module dioda transmisja zmienia kolor na pomarańczowy, natomiast program nie komunikuje się z modułem i nie wypisuje żadnych komunikatów. Już sam nie wiem jak to podłączyć, proszę o jakiś konkretny schemat i opis zachowania modułu podczas łączenia z komputerem, kiedy pin jest błędny a kiedy dobry. Aha w module nie ma karty sim kiedy łącze go z komputerem, tez nie wiem czy ma to związek.
  • #11
    telesystem
    Level 22  
    Zakładając że patrzysz na moduł i gniazdo programowania masz po prawej to pierwszy pin od lewej idzie do 10 pinu w maxie232, drugi pin to 8 pin w maxie 232, 3 i 4 muszą być zwarte na czas programowania. Masa oczywiście z obudowy gniazda.
    Moduł musi być włączony najlepiej do akumulatora (zaciski bat.), bez karty sim a dioda transmisja w momencie wetknięcia kabla programującego swieci na pomarańczowo, w Twoim przypadku jest problem z komunikacją a nie z kodem. Jak program poinformuje Cię ze: " Błędne hasło... popraw i spróbuj ponownie !" to oznacza ze wpisałeś błędny kod a komunikacja jest ok. Zobacz, może masz zamieniony tx z rx, lepiej byłoby gdybyś próby robił na komputerze wyposażonym w sprzętowy rs 232 i kabel na max232 np. do programowania innych urządzeń jak satel ca 5, ropam itp. wtedy dołączysz tylko do maxa w tym kablu i gotowe. Różne konwertery usb różnie się zachowują a w Twoim przypadku trudno się skupić nad przyczyną braku komunikacji ponieważ problem może istnieć w kilku miejscach, musisz próbować ! w końcu się uda połączyc z tym modułem.

    Pozdrawiam
    Michał
  • #12
    kiing
    Level 8  
    Ok czyli podłączenie kiedy zaświeca się dioda na pomarańczowo jest ok, teraz zamienie rx z tx bo w sumie nie wiadomo czy w pl2303 rx to out czy in. Aha podłączam interfejs pl2303hx bezpośrednio do modułu gprs-n zakładam, że skoro na płytce jest opisane (na zdjęciu widać) usb - ttl to już nie potrzebuje układu max232 tak?
  • #13
    Ture11
    Level 38  
    Nie potrzebujesz, bo PL2303 konwertuje sygnały do interesujących cię poziomów, zwanych TTL (0-5V). W sumie nawet nie musi ich konwertować, bo sam działa na 5V max, ale wiadomo, że zmienia sposób transmisji. Układy MAX232 stosowało się, bo port RS232 komputera ma napięcia z zakresu -15V do +15V, a mikroprocesory zasilane są często z 5V.

    Co do samego połączenia, nie pamiętam jak, ale od razu wiedziałem, że komunikacja została poprawnie nawiązana... Więc, jak Ci się uda, to zapewne zorientujesz się szybko.
  • #14
    kiing
    Level 8  
    Witam udało się skomunikować moduł z komputerem, choć muszę przyznać, że połączenie jest bardzo nie stabilne. Na łączy się tak raz na dziesięć razy, choć może powodem jest prowizoryczność połączeń w kablu :), ale jak już wiem co i jak to zaraz poprawimy prowizorkę. Niestety po połączeniu wypisuje błędne hasło, więc czeka mnie wysyłka do warszawy, chyba że ktoś ma jakiś pomysł na ten nieszczęsny pin. Pozdrawiam i dziękuje wszystkim którzy pomagali.
  • #15
    Ture11
    Level 38  
    Czy mógłbym przy okazji skorzystać z tego, że kolega ma to urządzenie, i zadać jedno pytanko?

    Mój pulson po podłączeniu zasilania bez karty sim świeci obie zielone diody przez cały czas. Według instrukcji obsługi, dioda transmisji powinna zacząć migać po 10 sekundach... Czy u kolegi coś takiego ma miejsce bez karty?

    Pozdrawiam.

    Dodano po 1 [minuty]:

    Może też dodam, że po kilkunastu sekundach od włączenia, gdy łącze się z komputerem, urządzenie przestaje odpowiadać. By coś odczytać lub zapisać do urządzenia, muszę odłączyć zasilanie i podłączyć je ponownie, wtedy mam kilkanaście sekund komunikacji, potem znów martwy... Kolega też tak ma?

    Dodano po 2 [minuty]:

    Swoją drogą, czy próbował kolega zdjąć hasło za pomocą tego programu, który pojawił się w temacie, do którego podał kolega link w poście #3?
  • #16
    kiing
    Level 8  
    A więc, nie próbowałem tym programem, dziś może później spróbuje. A co do pytań to tak dioda transmisja na pewno nie świeci ciągle po jakimś czasie zaczyna migać (oczywiście bez podłączonego kabla programującego). Natomiast urządzenie łączy się z komputerem niezależnie jak długo było włączone, choć tak jak pisałem to połączenie zdarza się raz na 10, po prostu nic nie ruszam i wciskam przycisk "odczytaj gprs-n" i z reguły połączy się za pierwszym razem, później jak w programie raz jeszcze wybiorę "otwórz port" to znowu się połączy. Przy kablu nic nie ruszam, urządzenia nie resetuje itp. tylko cierpliwie ponawiam połączenie i za którym razem zadziała.
  • #18
    Grzesiek Lca
    Level 15  
    Podłączenie w/g schematu użytkownika tomhub działa 100%. Kupiłem 2 takie moduły, pobrałem program w wersji 3.6 i właśnie połączyłem się z modułem bez żadnych problemów za 1 razem.