Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

EXCEL - tabela piłkarska - sortowanie i zliczanie

black_91 15 Wrz 2013 14:31 5652 8
  • #1 15 Wrz 2013 14:31
    black_91
    Poziom 6  

    Witam. Chciałem sie zapytać gdyż nigdzie nie mogę znalezc o tym informacji, jaką/ jakie formuly trzeba wprowadzic aby tabelka pilkarska sama sie automatycznie sortowala po wpisaniu konkretnego wyniku?
    Pytanie 2. W załączniku przesylam to co aktualnie robie i mam problem, gdyz w kolumnie J (pkt) nie zlicza mi punktow z okreslonych komorek ( np. dla Manchesteru mam komorki z punktami a9,a14,g17,09,014 i h17). Nie wiem w czym tkwi problem.

    1 8
  • #2 15 Wrz 2013 16:25
    adamas_nt
    Moderator Programowanie

    Ad pyt.2 Formuły zwracają tekst (cudzysłowy), a nie liczbę. Jest: '=JEŻELI(A16=3;"1";"0")' powinno być: '=JEŻELI(A16=3;1;0)'
    Kilka poprawiłem.

    Ad pyt.1
    Najłatwiej określić kolejność za pomocą MAX.K w kolumnie pomocniczej, ukryć "sztywną" tabelkę i pokazywać tylko wynikową - jak w załączniku.

    0
  • #3 15 Wrz 2013 18:29
    black_91
    Poziom 6  

    Dzieki, o to mi chodzilo. A mam jeszcze pytanie, jak moge odkryc ta ukryta tabelke? bo chce zrozumiec w jaki sposob dziala to automatyczne sortowanie ;)

    0
  • #4 15 Wrz 2013 18:58
    adamas_nt
    Moderator Programowanie

    Luknij do pomocy... Excel2007-zaznacz cały arkusz - Narzędzia główne>Format>Odkryj wiersze

    0
  • #5 15 Wrz 2013 19:01
    black_91
    Poziom 6  

    juz mam ;) to ostatnie pytanie mam nadzieje: =J10+(12-WIERSZ())/10 do czego sluzy ta formula?

    0
  • #6 15 Wrz 2013 19:12
    adamas_nt
    Moderator Programowanie

    Żeby odróżnić te, które mają równą ilość pkt. Inaczej, żeby funkcja PODAJ.POZYCJĘ działała prawidłowo, nie mogą być identyczne wartości. Dlatego dodajemy ułamek WIERSZ()/10.

    Np dla wierszy 1-4
    pkt>wartość "indeksowa"
    0 > 0,0
    0 > 0,1
    0 > 0.2
    0 > 0,3

    Niżej trzeba odjąć górne. Dlatego w wierszu 10... Ojej! powinno być: 10-WIERSZ())/10
    Popraw i skopiuj w dół :)

    Jeśli będzie więcej niż 9 - dziel przez 100

    0
  • #7 15 Wrz 2013 19:16
    black_91
    Poziom 6  

    Aha, juz rozumiem ;) a np jesli druzyny maja rowna ilosc pkt to chcialbym zeby nastepny parametr to byl bilans, ktory by okreslal kolejnosc w tabeli. Co dopisac do formuly w glownej tabeli ?

    0
  • Pomocny post
    #8 15 Wrz 2013 19:33
    adamas_nt
    Moderator Programowanie

    Ech, pomyliłem. Nie tłumacząc zbyt wiele. Wpisz w K10: =J10+(13-WIERSZ())/100+I10/10
    i przeciągnij w dół. Zasada się nie zmienia, ale wartości chcemy od zera w górę.

    Dodajemy mały ułamek wiersza i dodajemy duży bilansu. Jeśli bilans ujemny - zmieni się znak (ułamka) na minus i przesunie w tabeli na koniec "równych".

    Tu: ManU na końcu
    EXCEL - tabela piłkarska - sortowanie i zliczanie

    0
  • #9 15 Wrz 2013 20:08
    black_91
    Poziom 6  

    Dziekuje pieknie ;) wszystko jasne ;)

    0