Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Panel Siemens KTP600 color DP - Nie idzie połączyć się z panelem KTP600 (s7-300)

Klucha93 29 Sep 2013 19:11 7107 9
SterControl
  • #1
    Klucha93
    Level 12  
    Witam! Mam taki sprzęt:
    hardware: simatic s7-300 CPU316-2DP, orginalny kabel USB/MPI, zwykły kabel rs męsko-męski, panel KTP600 Color DP
    Software: Step 7 v5.4, Wincc Flexible 2008 SP1

    Próbuje zestawić połączenie cpu-> hmi (profibusem)
    Panel mam połączony zwykłym kablem rs do złącza X2 DP. Kabel USB/MPI do złącza X1(MPI). Próbuje wgrać projekt z wincc do hmi, ale nie idzie się połączyć. Poniżej screeny jak to robię i nie wiem czy dobrze. Możecie mi pomóc zestawić połączenie tych dwóch urządzeń?
    W panelu mam ustawione: Enable channel 2, MPI/Profibus, w zakładce Advanced: Adress 1, timeout 10s, prędkość 187,5, highest station 31, profile DP

    Bawiłem się także po MPI, ale też nie szło. Poprostu coś gdzieś źle robię. Próbowałem także połączyć się po MPI bezpośrednio z kabla USB/MPI (ustawiając wszystko na MPI) ale też nie szło

    Panel Siemens KTP600 color DP - Nie idzie połączyć się z panelem KTP600 (s7-300) Panel Siemens KTP600 color DP - Nie idzie połączyć się z panelem KTP600 (s7-300) Panel Siemens KTP600 color DP - Nie idzie połączyć się z panelem KTP600 (s7-300)
  • SterControl
  • #2
    ILSSystem
    Automation specialist
    Witam
    1. Sprawdz przewód który wykorzystujesz HMI<->PLC. Do komunikacji na małych odległościach przy testach wystarczy, że połączone będą ze sobą piny 3,8 z DB 9 oraz masy obudowy
    Panel Siemens KTP600 color DP - Nie idzie połączyć się z panelem KTP600 (s7-300)
    (terminacja wg załączonego schematu)
    Link
    2. Sprawdz ustawienia HW PLC, powinno być tak:
    Panel Siemens KTP600 color DP - Nie idzie połączyć się z panelem KTP600 (s7-300)
    3. Sprawdź ustawienia Panela (aktywny interfejs, parametry DP):
    Link

    Pozdrawiam
  • SterControl
  • #3
    Klucha93
    Level 12  
    A jeżeli chce sterownik wraz z hmi puścić po profibusie i tak mam wszystkie ustawienia to mogę programować po MPI za pomocą USB/MPI?
  • #4
    ILSSystem
    Automation specialist
    Witam,
    Twój sterownik 316-2DP posiada dwa porty X1 i X2. Jeden z nich jest z MPI, drugi z DP. Nie widzę żadnych przeszkód żeby wykorzystać równolegle X1 w celu programowania, z resztą po to właśnie są dwa porty. Jeśli masz np taki adapter Link
    i jeśli posiadasz wtyczkę z gniazdem przelotowym na CPU mógłbyś sprawdzić co jest widoczne na segmencie DP (set pc/pg interface-> Profibus, upload station to PG -> lista stacji DP), czy widać panel. Druga sprawa to jeśli z DP nie wyjdzie to bez problemu możesz mieć połączenie MPI: Panel, PLC, PG.
    Pozdrawiam
  • #5
    Klucha93
    Level 12  
    Ale jeśli chcę mieć i panel i programator po MPI to także muszę mieć tą przelotówkę? Bo przecież mam jeden port MPI...
    Czyli czy ja dobrze rozumiem. Mam panel podpięty pod X2 (profibus) i w Step 7 i wincc ustawiam wszystko na Profibus, a pod złącze X1 podłączam ten programator i panel programuje po MPI? Bo nie wiem czy dobrze robię...
  • #6
    ILSSystem
    Automation specialist
    Witam,
    Tak, dobrze myślisz. Radzę na początek przeczytać trochę o budowie 300tekLink Link
    MPI i Profibus korzystają z tej samej warstwy fizycznej RS-485, z której wynika, że można łączyć do 32 urządzeń w segmencie, i do 126 w sieci przy wykorzystaniu repeaterów. Aby łączyć urządzenia powinieneś mieć wtyczkę przelotową, chyba, że chodzi jedynie o testy bez zastosowań w terenie to możesz wykonać swoje okablowanie, wg wcześniej zamieszczonych rysunków -> PC Aapter USB musi posiadać zasilanie od strony portu MPI dlatego konieczne jest wpięcie w złącze przelotowe CPU (Panele często nie mają wyprowadzonego zasilania na port).
    Sumując, radzę sprawdzić po kolei :
    1. Przewód HMI<->PLC ("przedzwonić")
    2. Ustawienia w projekcie HMI (Wincc FLex) i PLC (Step) Szybkośc transmisji, timeout, op connections, HSA, adresy stacji
    3. Ustawienia HMI (windows CE Control Panel)

    Jeśli urządzenia są sprawne to musi działać.

    Pozdrawiam
    Pozdrawiam
  • #7
    Klucha93
    Level 12  
    Dobra, a czy jeżeli podepnę kabel USB/MPI bezpośrednio do panelu to się z nim połacze i wgram program? Bo tak robię i nic nie chce rechnąć. Kabel po wpięciu do panelu ma zasilanie.
  • #8
    ILSSystem
    Automation specialist
    Witam
    Zapoznaj się z informacjami z rozdziału 4 i 5. Sprawdź ustawienie zworek. Podaj dokładny model wraz z nr zamówieniowym używanego programatora. Co oznacza "rechnąć" ? Zamieść zrzuty ekranu, ewentualne błędy.
    Ustawiłeś poprawnie interfejs w Wincc flexible? Panel odpowiada na próbę wgrania programu? Zeskanuj sieć MPI w Stepie, bezpośrednio podłączony do panelu - powinien się pokazać jako KT600 z adresem 1 lub samo "1".

    Wg mnie powinieneś najpierw skonfigurować panel pod MPI aby wgrać projekt w którym ustawiłeś komunikacje DP, po restarcie zmienić ustawienia panela na DP (Control Panel) i powinno zacząć działać.

    Pozdrawiam
  • #9
    Klucha93
    Level 12  
    Ok, poszło. Poprostu jak programuje KTP to w ustawieniach pg interface muszę zmienić na PC Adapter(MPI) natomiast jak programuje PLC to musi być PC Adapter(Auto) i to był cały problem. Narazie zamówiłem wtyczki profibusa i będę dalej męczył tą transmisje.

    A mam jeszcze takie pytanko. Panel TP177 Micro do s7-200 w czym się programuje? Bo patrzyłem w WinCC Flexible 2008 Advanced SP1 i go nie ma. Może będzie w SP2 albo SP3?
  • #10
    ILSSystem
    Automation specialist
    Witam,
    Wszystko w manualu
    Link

    Pozdrawiam