Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Pinnacle Studio 15 - Pinnacle Studio 15 - problemy z renderowaniem

08 Oct 2013 23:35 7023 10
  • Level 15  
    Witam!
    Zaistniała potrzeba w moim życiu stworzenia filmu DVD z plików AVCHD i wybór padł na Pnnacle Studio 15 Ultimate Colection. Przy stosunkowo niewysokiej cenie oferuje całkiem spore możliwości edycyjne - tyle teorii - praktyka pokazuje, że jest z tym programem duuuuużo problemów. Powiedzmy, że udało mi się zrobić film i chciałbym opisać jakie zabiegi musiałem wykonać to mogło by pomóc wielu użytkownikom tego programu, ale najpierw mam pytanie:

    Dlaczego zestaw plików wynikowych VIDEO_TS dla filmu o długości 67min (jakość najwyższa - 100%) mimo zaznaczenia opcji DVD 4,7GB ma tylko 3,7GB? Podjąłem kilka prób, efekt zawsze ten sam płyta nie zapełniona w całości. Próby wydłużenia materiału powodują drastyczny spadek deklarowanej jakości więc nie renderowałem. Czy jest jakaś opcja którą mogę zmienić wielkość ostateczną tego pliku?

    Wydaje mi się, choć mogę się mylić, że wypełniając płytę DVD do 4,7GB (4,3GB) można by wydłużyć ilość materiału o około 10- 15 min. Czy to możliwe?
    [Szkolenie 22.06.2021, g.9.30] Zabezpieczenia Internetu Rzeczy (IoT) programowe i sprzętowe. Zarejestruj się za darmo
  • Level 1  
  • Level 42  
    anmedia wrote:
    R_O_Y napisał:
    Czy jest jakaś opcja którą mogę zmienić wielkość ostateczną tego pliku?
    Nie w tym programie. Tzn masz opcje jakosc najlepsza srednia i o ile pamietam dobra


    Tu małe zastrzeżenie. Po ustawieniu opcji "Custom" można dowolnie zmieniać opcje strumienia video i audio (bitrate). Również (chyba?) jest możliwa opcja Auto, czyli dopasowanie do dysku.

    Również na wielkość plików na płycie ma wpływ rodzaj renderowania. Nie wiem czy to dobrze nazwałem. Mam na myśli to, że pliki video mogą być renderowane z stałą wartością kompresji (CBR) lub zmienną (VBR). Osobiście preferuję CBR :)
  • Level 15  
    Ok. Program nie jest ideałem, można by się pokusić o stwierdzenie, że mu do niego daleko. Wałkuję go od 3 tygodni i doszedłem już jak się z nim "obchodzić" choć początki były na prawdę trudne.

    Więc po pierwsze: materiał mam już nagrany w AVCHD i nie rozważam na razie innych formatów i rozdzielczości szkoda czasu - muszę "przemielić" to co mam.

    Wykonałem montaż, zaznaczam płyta DVD 4,7GB a otrzymuję pliki które łącznie zajmują 3,7GB to o jakieś 600MB za mało. Nie mam zastrzeżeń do jakości ponieważ w opcji "najwyższa jakość" (100%) lepiej nie będzie, 67min też mi pasuje, denerwuje mnie tylko fakt nie pełnego wykorzystania nośnika. Myślałem, że jest możliwość takiej zmiany ustawień żeby program tworzył VIDEO_TS o wielkości 4,3GB a nie 3,7.

    Dlaczego DVD a nie BR? To proste, zbyt mało osób które będą oglądały zrobiony przeze mnie materiał posiada odtwarzacze BR...

    Wymagania sprzętowe spełnione mam z nadwyżką, no może karta graficzna mogła by mieć więcej RAM ale ta daje radę.

    Wyraźnie brakuje opcji dopasowywania jakości konkretnego materiału do konkretnego nośnika, denerwujący jest dla mnie fakt że max jakości + max długości dla DVD4,7 daje plik wynikowy 3,7GB ale widać taka uroda tego programu.
  • Level 1  
  • Level 42  
    anmedia wrote:
    Co wiecej (jako uwaga) CBR nie nalezy stosowac szczegolnie dla starszych odtwarzaczy dvd, ktore moga sobie z tym nie radzic.


    Jesteś pewien tego stwierdzenia? Zawsze byłem przekonany, że VBR stwarza więcej problemów odtwarzaczom niż CBR.

    Swoją drogą, nie rozumiem "problemu" kolegi R_O_Y. Niby dlaczego, niezależnie od czasu materiału video, cała zawartość płyty ma być wykorzystana? Czy 10 minut czy 30 minut video to zawsze musi być 4,7 GB? Moim zdaniem to nonsens.
    Ale to tylko moje zdanie.
  • Level 1  
  • Level 15  
    anmedia wrote:
    Moze, zrobmy inaczej. Pokaz "drzewo" z mediaInfo pliku filmowego ktoregos VOB'a. Wedlug moich obliczen, parametry tego filmu sa takie:
    Bitrate 8.8 Mbps
    Audio 384kb/s
    Film masz bez menu. To daje okolo 3,7MB. W przypadku gdy masz jeszcze na plycie menu, bitrate bedzie duzo nizsze.


    Hmmm... VOBy są 4 (3 x 1024 i ostatni w każdym podejściu około 500 - 700), Jeśli chodzi o bitrate to program nie udostępnia zmiennego jedynie stały, nie można go też sobie zmieniać do woli - jest on uzależniony od opcji wyboru jakości tworzonego DVD i tak dla najwyższej jakości jest to 8500kb/s. Pinnacle ma tu dość mało rozbudowany interfejs, ogranicza się jedynie do wyboru typu dysku oraz jakości wideo/użycie dysku. Wcześniej już o tym pisałem dla najwyższej jakości jest to 67min materiału.
    Film który zrobiłem ma menu ale nie animowane, po prostu zwykłe menu z kilkoma przyciskami.
    Przyjrzałem się teraz jakości VOBów i tu ciekawostka: pierwszy VOB ma bitrate 20,1Mb/s (???) i trwa 7min 6s kolejne już normalnie między 8,1 - 8,4 Mb/s trwają ok 17min 38s - dziwne.
  • Level 1  
  • Level 15  
    Cóż miałem małą przerwę w pracy z Pinnacle ale w ten weekend wrócę do pracy i ostatecznie zweryfikuję wszystkie wątpliwości i uwagi.
    Jedno jest pewne i to będzie raczej przyczyną większości problemów w pracy z Pinnacle - mała ilość RAM-u. Niestety 4GB jakie umożliwia WinXP to zdecydowanie za mało.
  • Level 13  
    Witam
    Dolacze sie do dyskusji. Na poczatek przepraszam ze nie mam polskich znakow ale to dlatego ze pisze z firmowego komputera a pracuje w Irlandii.
    Otoz ja rowniez mam problemy z renderowaniem w Pinnaclu 15. Po przygotowaniu calego projektu przyszlo do renderowania i po ustawieniu parametrow program renderowal przejscia i po skonczeniu przejsc mial zaczac renderowanie pierwszej klatki i wystawil komunikat, ze renderowanie nieudane. Nie pamietam teraz dokladnej tresci ale nie bylo zadnych sensownych informacji. Ani nazwy klipu, ani pozycji na linii czasu, nic kompletnie. Jak juz udalo mi sie znalezc przyczyne (byl problem z jednym klipem ale zeby bylo smieszniej to nie z pierwszym w projekcie tylko gdzies daleko od poczatku bo okolo godzine) to zaczely sie problemy z przejsciami. Niektore wychodza normalne a niektore cale zielone. Myslalem, ze samo przejscie ma jakis problem ale nie, bo przy kolejnej probie renderowania znowu inaczej bylo, niektore z tych dobrych wczesniej teraz wszly zielone a te ktore wczesniej byly zielone byly dobre. Do tego wszystkiego doszly trzaski w dziwieku ze uszy rozwala, ale to tez tak bez skladu bo w roznych momentach, w przejscliu lub w srodku sciezki dziwekowej. I ponownie przy kolejnym renderowaniu trzaski zmienialy miejsce. Oczywiscie jak przegladalem projekt to nic z tych rzeczy nie mialo miejsca.
    Wyrzucilem calkowice z kompa program i zainstalowalem ponownie ale bez zmian.
    Macie jakies propozycje?
    Pozdrawiam serdecznie