Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Naprawa systemu windows XP sp3 po zmianie sprzętu

FaithNoMore 01 Lis 2013 23:19 4410 17
  • #1 01 Lis 2013 23:19
    FaithNoMore
    Poziom 9  

    Witam, otóż mam następujący problem z firmowym dyskiem twardym po zmianie płyty i okolic z chipsetu Intela na AMD.

    A więc, przed całą operacją usunąłem (przywróciłem wersje uniwersalne itp) wszystkich sterowników z chipsetu Intela jakie znalazłem w menadżerze urządzeń, tak żeby nie było konieczności stawiania systemu na nowo (jest to absolutna ostateczność). Po tej operacji próbowałem odpalać jak gdyby nigdy nic ale komputer restartuje się po wczytywaniu windowsa XP... Udawało mi się go odpalać w trybie awaryjnym z obsługą sieci, nawet jakieś tam sterowniki poinstalował niby do znalezionego sprzętu ale był dalej restart loop po wczytywaniu windowsa. Stwierdziłem że spróbuje z płytką oryginalną instalacyjną windowsa XP sp3 poprzez funkcje naprawienia istniejącej instalacji, co spowodowało tylko tyle, że teraz już nie mogę go odpalić w trybie awaryjnym bo atakuje mnie okienko "instalacja nie może być kontynuowana w trybie awaryjnym..(..)" przy próbie wejścia w tryb awaryjny i nic nie mogę zrobić tylko zrestartować.

    Podsumowując, prosiłbym o pomoc, ponieważ jedyne co udało mi się zrobić to postawić windowsa na innej partycji, lecz zależy mi na przywróceniu do sprawności tamtej instalacji i jej używaniu, jest na to jakiś sposób? Zakładam że problem leży w sterownikach i pewnie jakoś da się je ręcznie ogarnąć na starej instalacji, pytanie brzmi jak?

    Z góry dziękuje za odpowiedzi i przepraszam za przydługi tekst. Tak, wszystkie podobne tematy przeglądnąłem i żaden nie był w stanie mi pomóc.

    0 17
  • #2 01 Lis 2013 23:28
    mati211p
    Specjalista - HDD i odzyskiwanie danych

    No to niech kolega nie spod systemu kontynuuje naprawę, lecz zbootuj instalację z CD i wybierz opcję naprawy systemu, potem wybierając ten właściwy system, który chcesz naprawić z dwóch które masz w tej chwili.

    0
  • #3 01 Lis 2013 23:36
    FaithNoMore
    Poziom 9  

    Zrobiłem tak, bez żadnego efektu, jak napisałem nie mogę przez to już odpalić tej instalacji w awaryjnym.

    0
  • #4 01 Lis 2013 23:42
    mati211p
    Specjalista - HDD i odzyskiwanie danych

    Ale nie odpalaj żadnej instalacji w trybie awaryjnym. Zrób tak jakbyś miał zainstalować czystego windowsa, a po wczytaniu się instalacji przy wyborze partycji itd masz opcję napraw literka R.

    0
  • #5 01 Lis 2013 23:51
    FaithNoMore
    Poziom 9  

    I tak właśnie zrobiłem ~2 razy i nic to nie pomogło, analizował instalacje jakąś chwile, po czym restart i dalej restart po wczytywaniu windowsa xp. Po prostu efektem tych prób jest niemożność wejścia do awaryjnego. Próbowałem też z konsoli odzyskiwania skorzystać, ale tam opcje fixmbr itp nic nie pomogły.

    0
  • #6 01 Lis 2013 23:59
    mati211p
    Specjalista - HDD i odzyskiwanie danych

    FaithNoMore napisał:
    I tak właśnie zrobiłem ~2 razy i nic to nie pomogło, analizował instalacje jakąś chwile, po czym restart i dalej restart po wczytywaniu windowsa xp.

    Czyli po wyborze napraw analizuje tą obecną instalacje i się resetuje?

    0
  • #7 02 Lis 2013 00:02
    FaithNoMore
    Poziom 9  

    Analizuje, niby naprawia ale nic z tego niestety nie wynika. Potem mam tylko informację w menu naprawiania istniejącej instalacji że już były takie próby. Tak, po tej rzekomej naprawie dalej się restartuje po/podczas wczytywania windowsa XP. Tylko na tej instalce oczywiście. Kluczową kwestią jest możliwość jakkolwiek "ręcznej" naprawy starej instalacji, tylko nie mam pojęcia jak się za to wziąć ani z której strony.

    0
  • Pomocny post
    #8 02 Lis 2013 00:03
    WojtasJD
    VIP Zasłużony dla elektroda

    FaithNoMore napisał:
    komputer restartuje się po wczytywaniu windowsa XP

    F8 -> Wyłącz automatyczne uruchamianie... - jak będzie BSOD to wstaw fotkę.

    0
  • #9 02 Lis 2013 00:22
    FaithNoMore
    Poziom 9  

    BSOD pt Stop 0x0000007E, obstawiam wariant niekompatybilnych sterowników, popróbuje oczywiście podpowiedzi od microsoftu ale może na podstawie przytoczonej genezy błędy będzie mi ktoś w stanie doradzić szybciej niż zajmie mi sprawdzanie wszystkich opcji wg. faq microsoftu? Np. które konkretnie sterowniki w sys32/drivers mogę usunąć albo najlepiej podmienić żeby system miał szansę wstać?
    Naprawa systemu windows XP sp3 po zmianie sprzętu

    0
  • Pomocny post
    #10 02 Lis 2013 00:25
    WojtasJD
    VIP Zasłużony dla elektroda

    Jeszcze jak pamiętasz model poprzedniej płyty głównej + model CPU i obecne.

    0
  • #11 02 Lis 2013 00:28
    FaithNoMore
    Poziom 9  

    Niestety, poprzedniej konfiguracji nie pamiętam, chyba że gdzieś mogę znaleźć po nich ślad w systemie po przywróceniu standardowych sterowników to mogę pogrzebać z działającej tam instalki windy. Pewny jestem tylko co do tego że chipset był pod intele. A aktualnie to asus m2n68-am se2 i amd athlon X2 250.

    0
  • #12 02 Lis 2013 00:47
    WojtasJD
    VIP Zasłużony dla elektroda

    To będę strzelał, jeśli poprzednio miałeś CPU intela to można to podciągnąć pod KB:

    Komunikat o błędzie wyświetlany po uaktualnieniu komputera z procesorem innym niż Intel do systemu Windows XP z dodatkiem Service Pack 2 lub Windows XP z dodatkiem Service Pack 3: „STOP: 0x0000007E” napisał:
    Ten artykuł dotyczy sytuacji, w której komputer z procesorem innym niż Intel jest uaktualniany do systemu Windows XP z dodatkiem Service Pack 2 (SP2) lub Windows XP z dodatkiem Service Pack 3 (SP3). Następnie komputer jest uruchamiany ponownie. [...]
    Informacje techniczne w komunikacie o błędzie zatrzymania mogą zawierać różne parametry umieszczone w nawiasach, zależnie od konfiguracji komputera. Jednak w przypadku wystąpienia tego problemu pierwszy parametr ma zawsze wartość „C0000005”.
    [...]


    czyli możesz spróbować metody drugiej - wyłączyć intelppm spod konsoli odzyskiwania.

    0
  • #13 02 Lis 2013 01:13
    FaithNoMore
    Poziom 9  

    Nagle mam kłopot z konsolą odzyskiwania bo mnie pyta o hasło administratorskie o dziwo. (już z nim chwile walczyłem i koniec końców je wyczyściłem ale najwyraźniej konsola wie lepiej)

    W każdym razie ręcznie wywaliłem taki sterownik (intelppm) z plików systemowych i dorzuciłem tam sterownik amdPPM łudząc się że się uda, i się udało, odpaliła się winda niestety chce się instalować i tutaj jest problem, nie mogę nic kliknąć bo i klawiaturę i myszkę mam na usb. Oba nie chcą zareagować a nie posiadam pod ręką starych klawiatur i myszek na te koliste wtyczki... Możliwe że to przez dorzucenie tego pliku amd? Czy po prostu potrzebuje starej klawiatury i tyle?

    0
  • #14 02 Lis 2013 06:58
    WojtasJD
    VIP Zasłużony dla elektroda

    Sterownik się wyłącza a nie wywala. To, że tam skopiowałeś amdppm.sys nic nie dało bo i tak pewnie nie jest ładowany - trzeba zainstalować.
    Jak nie pamiętasz hasła to można załadować na chwilę gałąź obcego rejestru i na nim działać skoro masz obok drugiego Windowsa.
    Najprościej najpierw sprawdzić z PS/2, jak też nie działa to może coś z klasami myszy i klawiatury; jak nie to 'tylko' USB, HID.
    Porównaj z działającym systemem...

    0
  • #15 02 Lis 2013 18:09
    FaithNoMore
    Poziom 9  

    Niestety nie miałem innej opcji przez tajemne hasło administratora, które czasem jest a czasem znika i wszystko jest ok. Cóż, spodziewałem się że wrzucenie tam ręczne sterownika nic nie da.

    Pardon, ale jestem laikiem w kwestii przemierzania rejestrów, więc prosiłbym o łopatologiczne wytłumaczenie w jaki sposób mogę załadować rejestr z nowej instalki windowsa na starą?

    Tak jak wspomniałem, nie mam pod ręką sprzętu pod PS/2.

    @ edit
    Zamiast winXP na usb wrzuciłem płytkę i nie musiałem nic klikać ale co dziwne instalacja stanęła na 34 min do końca i nie chciała się ruszyć za nic w świecie.. Spróbowałem więc jeszcze raz odpalić z płytki winXP i naprawić istniejącą instalacje, skończyło się restart loopem, znowu. Jak się okazało powrócił sterownik intelppm do plików systemowych.

    Dodano po 5 [godziny] 50 [minuty]:

    Udało mi się wejść do konsoli i wyłączyć sterownik intelppm, dzięki temu też mogę odpalić instalacje windowsa, lecz jak poprzednio staje na 34 min do końca.

    Próbowałem już odpalać komputer w minimalnej konfiguracji sprzętowej tylko na zasilaniu i zintegrowanej grafice, nie pomogło.

    Chyba też już próbowałem wszystkiego z podpowiedzi microsoftu i nic nie pomogło.

    Jakiekolwiek pomysły? Jak się za ten rejestr zabrać żeby coś podziałać w tym kontekście?

    Dodam że klawiatura działa na początku instalacji (myszka nie) nawet raz odpaliło się okno "wykrywania i instalowania urządzeń", które oczywiście się zawiesiło, klawiatura przestaje reagować po chwili instalacji, gaśnie klawisz num locka itp.

    Dodano po 20 [minuty]:

    Dalej wyłączony jest ten sterownik a zaczęły się restart loopy po odpaleniu w trybie debuggowania, sprawdziłem BSOD i wygląda on oto tak
    Naprawa systemu windows XP sp3 po zmianie sprzętu
    Także dalej coś ze sterownikami..

    0
  • Pomocny post
    #16 02 Lis 2013 20:23
    WojtasJD
    VIP Zasłużony dla elektroda

    Ponownie - trzeba usługę/sterownik wyłączyć, plik może zostać.

    Z drugiego systemu WinKey + R: regedit [enter], zaznacz HKEY_LOCAL_MACHINE i z menu: Załaduj gałąź Rejestru...
    D:\Windows\System32\config\SYSTEM
    (D:\Windows <- trzeba skorygować jak masz inny)
    nazwa klucza np. FaithNoMore i przejdź do
    HKEY_LOCAL_MACHINE\FaithNoMore\ControlSet001\Services\Intelppm
    Start [REG_DWORD] 1 -> 4
    Po zmianach zaznaczasz FaithNoMore i z menu: Zwolnij gałąź Rejestru...

    Tą instalacją naprawczą skomplikowaliście tylko naprawę...

    Instalator przestaje odpowiadać, gdy do końca instalacji pozostaje 34 minuty
    czyli Shift+F10 i pliki możesz przejrzeć / podesłać no ale podobno klawiatura nie działa więc z drugiego komputera...

    BTW: Masz podłączony do tego drugi komputer z debugerem, że włączasz tryb debugowania?

    0
  • #17 03 Lis 2013 12:36
    FaithNoMore
    Poziom 9  

    Sterownik był cały czas wyłączony (i wg. konsoli odzyskiwania i w rejestrze od razu miał wartość 4). Gdzieś w kontekście zawieszania się instalacji na 34 minutach wyczytałem że można próbować odpalić w trybie debugowania albo VGA i podobno może pomóc, dlatego spróbowałem.

    Podsyłam setupapi i setupact, pnplog nie powstał a setuperr jest pusty. Klawiatura wyłącza się nagle w momencie "instalacji urządzeń" koło magicznej 34tej minuty, przez pierwsze minuty mogę normalnie operować.

    (zmieniłem rozszerzenie ponieważ format .log jest niedozwolony pod opcją dodaj załącznik)

    @ Jeszcze dorzucę pytanie - czy np. upgrade wersji windowsa do visty lub 7 miałby sens w tej sytuacji? Obawiam się że w takim przypadku pewnie przestały by działać wszystkie poinstalowane programy itp?

    0
  • #18 03 Lis 2013 20:57
    FaithNoMore
    Poziom 9  

    Nie wiem do końca jak, ale udało się w końcu przeprowadzić naprawę istniejącej instalacji i teraz pisze z tej niesamowicie walecznej instalki win XP. Mam nadzieje że żadne wadliwe sterowniki na tej instalce nie pozostały i wszystko będzie ok.

    Dziękuje wszystkim w tym temacie za pomoc i odporność na moją laickość w temacie! W szczególności dla WojtasaJD.

    Problem rozwiązany.

    0