Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

ATMEGA8 LCD 3310 - Atmega8 filtarcja napiecia i LCD od Nokii 3310

amostom 16 Lis 2013 09:26 1806 5
  • #1 16 Lis 2013 09:26
    amostom
    Poziom 9  

    Witam

    Zakupiłem jakiś czas temu LCD od Nokii 3310 i jest problem z nim tzn. długo trwało zanim doszedłem do tego iż owy wyświetlacz dziala dobrze jeśli nie ma kondensatorów ceramicznych (filtrujących)przy atmedze ale musi byc jeden przy zasilaniu wyświetlacza. Kiedy dodaje następne do atmegi kontrast maleje po trzech kondensatorach wogóle nic nie widać.No ale musza byc zeby mikrokontroler w miarę pracował stabilnie i byl odporny na zakłócenia. Podłączenie modułu RF pod te samo zasilanie tez powoduje spadek kontrastu. Próbowałem na innym zasilaniu ale jest tak samo. Czyżby wyświetlacz trefny ?
    Jakieś pomysły ?

    0 5
  • #3 17 Lis 2013 20:17
    amostom
    Poziom 9  

    Witam
    Oto moj schemat. wzorowalem sie ze strony http://hobby.abxyz.bplaced.net/index.php?pid=3&aid=10 lacznie z programem na tej stronie. Mozliwe ze uszkodzilem wyswietlacz bo przez przypadek podlaczylem 5v zamiast 3.3v. Aby wyswietlal kondensator moze byc tylko i wylacznie jeden 100nF ceramiczny na zasilaniu tego lcd. Wszystkie pozostale ktore powinny byc przy atmedze8 nie moga byc podlaczone poniewaz lcd sie wygasza. Podejrzewam ze go uszkodzilem.
    Acha lcd to nie jest wyciagniety z telefonu tylko gotowy modul (lcd z plytka); Pozdrawiam.

    ATMEGA8 LCD 3310 - Atmega8 filtarcja napiecia i LCD od Nokii 3310


    P.S. Dzieki za punkciki.

    0
  • #4 17 Lis 2013 21:20
    Piotrek_P
    Poziom 18  

    Ostatnio sprawdzałem dwa takie "moduły" i z premedytacją podłączałem je do 5V. Nic się z nimi nie stało. Okazało się jednak, że trzeba zmienić wartość kontrastu w programie bo piksele które miały być wygaszone, lekko "świeciły". Tak poza tym LCD śmiga :D . Testy robiłem na płytce EVB, więc kondki do filtracji są fabrycznie wlutowane. Natomiast przy LCD nie dawałem żadnego kondensatora bo już jakiś jest na płytce wyświetlacza. Napisz jeszcze jaką masz ustawioną wartość kontrastu. Ja dla 5V ustawiłem 0x40, a dla 3,3V daję 0x21.

    Pozdrawiam
    PP

    0
  • #5 18 Lis 2013 14:40
    M. S.
    Poziom 34  

    Chmm. "Przerobiłem" już kilka wyświetlaczy z Nokii 3310 i nigdy nie miałem problemów z zasilaniem, ani z 5V po redukcji, ani z 3,6V (li-ion). Ponadto zawsze zasilam je z portu procesora co pogarsza stabilność zasilania. Diabeł prawdopodobnie tkwi w innym szczególe.

    0
  • #6 18 Lis 2013 15:53
    michalko12
    Specjalista - Mikrokontrolery

    Sprawdź podłączenie masy, być może "blaszki" na złączu LCD od strony szkła przestały kontaktować. Kondensator 10uF nie powinien być elektrolityczny, jeśli masz tam elektrolityczny to zmień go na tantalowy ewentualnie dołącz 1uF ceramiczny. Sam 1uF ceramiczny też wystarczy.

    0