Elektroda.pl
Elektroda.pl
X
Relpol
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

pętla 4-20mA i za małe napięcie dla AI simatica?

czesiu 18 Lis 2013 13:26 6420 35
  • #1 18 Lis 2013 13:26
    czesiu
    Poziom 33  

    Mam następujący problem: przetwornik z wyjściem 4-20mA (4-przewodowy) spięty z wejściem prądowym sterownika siemens simatic (dokładnie jaki nie wiem). Prąd w pętli płynie prawidłowy, ale automatycy nie widzą sygnału (mają jakąś wizualizację). No i twierdzą że mój przetwornik ma za małe napięcie wyjściowe i dlatego ich siemens go nie widzi (podobno jak wpięli swój zadajnik to było ok).
    Pojechałem, rozpiąłem pętlę i mam na wyjściu 11,4V. Obciążyłem wyjście rezystorem 350omów (maksymalna wartość wg. dtr-ki) i 20mA spokojnie osiągam.
    Sprawdziłem opór ich wejścia AI łącznie z okablowaniem i wychodzi 30omów. Spiąłem znowu wszystko do kupy no i akurat przetwornik wystawiał ok 9,3mA, co dało na wyjściu spadek napięcia 0,27V. Moim zdaniem wszystko ok. Automatycy twierdzą że ich układ (czyli ten simatic) musi mieć przynajmniej 16V żeby dobrze działał i sugerują żebym dokupił separator z własnym zasilaniem i go zamontował.
    Moim zdaniem nie tędy droga i nie rozwiąże to problemu, ale nie wiem jak go rozwiązać. Dodam ze podłączałem wejście AI w obu biegunowościach i prąd przepływał taki sam, ale siemens prądu w obu przypadkach nie widzi i zdaje się że aktualnie pokazuje przekroczenie prądu wejściowego.
    Nie wiem czy wartość wejścia AI rzędu 30omów jest prawidłowa. Czy zgodzicie się ze mną że jak płynie prąd z zakresu 4-20mA to musi być dobrze?
    Dodam jeszcze że nie mam dostępu do sterownika (zakres prac kończył się na istniejącej listwie krosowej). Pozostaje mi albo kupić separator albo odbijać piłeczkę i tłumaczyć im że po mojej stronie jest ok.

    0 29
  • Relpol
  • #2 18 Lis 2013 13:48
    pawel_konin
    Poziom 20  

    czesiu napisał:
    Mam następujący problem: przetwornik z wyjściem 4-20mA (4-przewodowy) spięty z wejściem prądowym sterownika siemens simatic (dokładnie jaki nie wiem). Prąd w pętli płynie prawidłowy, ale automatycy nie widzą sygnału (mają jakąś wizualizację). No i twierdzą że mój przetwornik ma za małe napięcie wyjściowe i dlatego ich siemens go nie widzi (podobno jak wpięli swój zadajnik to było ok).
    Pojechałem, rozpiąłem pętlę i mam na wyjściu 11,4V. Obciążyłem wyjście rezystorem 350omów (maksymalna wartość wg. dtr-ki) i 20mA spokojnie osiągam.
    Sprawdziłem opór ich wejścia AI łącznie z okablowaniem i wychodzi 30omów. Spiąłem znowu wszystko do kupy no i akurat przetwornik wystawiał ok 9,3mA, co dało na wyjściu spadek napięcia 2,7V. Moim zdaniem wszystko ok. Automatycy twierdzą że ich układ (czyli ten simatic) musi mieć przynajmniej 16V żeby dobrze działał i sugerują żebym dokupił separator z własnym zasilaniem i go zamontował.
    Moim zdaniem nie tędy droga i nie rozwiąże to problemu, ale nie wiem jak go rozwiązać. Dodam ze podłączałem wejście AI w obu biegunowościach i prąd przepływał taki sam, ale siemens prądu w obu przypadkach nie widzi i zdaje się że aktualnie pokazuje przekroczenie prądu wejściowego.
    Nie wiem czy wartość wejścia AI rzędu 30omów jest prawidłowa. Czy zgodzicie się ze mną że jak płynie prąd z zakresu 4-20mA to musi być dobrze?
    Dodam jeszcze że nie mam dostępu do sterownika (zakres prac kończył się na istniejącej listwie krosowej). Pozostaje mi albo kupić separator albo odbijać piłeczkę i tłumaczyć im że po mojej stronie jest ok.


    Więc tak musisz mieć 24V DC dla 4mA(ponieważ jest to zasilanie z pętli prądowej) i 0 wartość pomiarową. Skoro kolega ma 12V na swojej pętli to faktycznie simatic może tego nie widzieć. Pomimo wysyłania wartości prądu.

    0
  • #3 18 Lis 2013 13:52
    czesiu
    Poziom 33  

    pawel_konin napisał:

    Więc tak musisz mieć 24V DC dla 4mA(ponieważ jest to zasilanie z pętli prądowej) i 0 wartość pomiarową. Skoro kolega ma 12V na swojej pętli to faktycznie simatic może tego nie widzieć. Pomimo wysyłania wartości prądu.

    Ale 12V jest przy rozpiętej pętli, jeżeli wejście AI ma opór 30omów to na tym oporniku przy 24V popłynie prąd 800mA. Mój przetwornik jest zasilany z 230VAC a do simatica idą tylko dwa przewody od pętli.

    0
  • Pomocny post
    #4 18 Lis 2013 13:54
    PROAT
    Poziom 13  

    Jak prąd płynie w pętli prawidłowy, to musi być ok, tym bardziej, że to przetwornik 4 przewodowy. Kiedyś miałem tak, że siemens S5 miał problem z przetwornikiem tyle że 2 przewodowym i faktycznie był potrzebny separator, bo impedancja wejściowa AI była zbyt duża aby popłynął prąd w pętli. Jednak jeżeli jest to 4p i po wpięciu amperomierza masz prąd z zakresu 4-20mA, to cudów nie ma, musi być dobrze. Pozostaje oczywiście kwestia podłączeń elektrycznych i konfiguracji modułu.

    0
  • Pomocny post
    #5 18 Lis 2013 13:56
    maurycy123
    Warunkowo odblokowany

    czesiu napisał:
    Mam następujący problem: przetwornik z wyjściem 4-20mA (4-przewodowy) spięty z wejściem prądowym sterownika siemens simatic (dokładnie jaki nie wiem). Prąd w pętli płynie prawidłowy, ale automatycy nie widzą sygnału (mają jakąś wizualizację). No i twierdzą że mój przetwornik ma za małe napięcie wyjściowe i dlatego ich siemens go nie widzi (podobno jak wpięli swój zadajnik to było ok).
    Pojechałem, rozpiąłem pętlę i mam na wyjściu 11,4V. Obciążyłem wyjście rezystorem 350omów (maksymalna wartość wg. dtr-ki) i 20mA spokojnie osiągam.
    Sprawdziłem opór ich wejścia AI łącznie z okablowaniem i wychodzi 30omów. Spiąłem znowu wszystko do kupy no i akurat przetwornik wystawiał ok 9,3mA, co dało na wyjściu spadek napięcia 2,7V. Moim zdaniem wszystko ok. Automatycy twierdzą że ich układ (czyli ten simatic) musi mieć przynajmniej 16V żeby dobrze działał i sugerują żebym dokupił separator z własnym zasilaniem i go zamontował.
    Moim zdaniem nie tędy droga i nie rozwiąże to problemu, ale nie wiem jak go rozwiązać. Dodam ze podłączałem wejście AI w obu biegunowościach i prąd przepływał taki sam, ale siemens prądu w obu przypadkach nie widzi i zdaje się że aktualnie pokazuje przekroczenie prądu wejściowego.
    Nie wiem czy wartość wejścia AI rzędu 30omów jest prawidłowa. Czy zgodzicie się ze mną że jak płynie prąd z zakresu 4-20mA to musi być dobrze?
    Dodam jeszcze że nie mam dostępu do sterownika (zakres prac kończył się na istniejącej listwie krosowej). Pozostaje mi albo kupić separator albo odbijać piłeczkę i tłumaczyć im że po mojej stronie jest ok.


    Specem w tej dziedzinie nie jestem więc to będzie tylko moje gdybanie.
    Jeżeli sterownik ma wejście 4-20 to powinien mierzyć prąd. Napięcie nie powinno go obchodzić. Jeżeli mierzyłeś prąd i był w granicach 4-20 to po Twojej stronie jest ok. Pytanie dlaczego sterownik tego nie widzi?

    Ps.
    Właśnie rozmawiałem ze znajomym który jest obcykany w sterownikach.
    1. Albo coś jest nie tak z wejściem.
    2. Albo wejście jest źle zaprogramowane.

    Jeżeli prąd płynie to wszystko jest ok.

    0
  • #6 18 Lis 2013 14:00
    czesiu
    Poziom 33  

    Zastanawiam się jeszcze czy wejścia analogowe siemensa są izolowane od masy, bo może wyjście mojego przetwornika ma jakiś potencjał względem uziemienia, i gdyby na drugim końcu było podobnie to mogłoby powstać zakłócenie sygnału.
    To by tłumaczyło czemu z bateryjnego zadajnika było ok. Albo tylko tak mówią a wcale zadajnika nie podpinali.

    0
  • #7 18 Lis 2013 14:05
    pawel_konin
    Poziom 20  

    maurycy123 napisał:
    czesiu napisał:
    Mam następujący problem: przetwornik z wyjściem 4-20mA (4-przewodowy) spięty z wejściem prądowym sterownika siemens simatic (dokładnie jaki nie wiem). Prąd w pętli płynie prawidłowy, ale automatycy nie widzą sygnału (mają jakąś wizualizację). No i twierdzą że mój przetwornik ma za małe napięcie wyjściowe i dlatego ich siemens go nie widzi (podobno jak wpięli swój zadajnik to było ok).
    Pojechałem, rozpiąłem pętlę i mam na wyjściu 11,4V. Obciążyłem wyjście rezystorem 350omów (maksymalna wartość wg. dtr-ki) i 20mA spokojnie osiągam.
    Sprawdziłem opór ich wejścia AI łącznie z okablowaniem i wychodzi 30omów. Spiąłem znowu wszystko do kupy no i akurat przetwornik wystawiał ok 9,3mA, co dało na wyjściu spadek napięcia 2,7V. Moim zdaniem wszystko ok. Automatycy twierdzą że ich układ (czyli ten simatic) musi mieć przynajmniej 16V żeby dobrze działał i sugerują żebym dokupił separator z własnym zasilaniem i go zamontował.
    Moim zdaniem nie tędy droga i nie rozwiąże to problemu, ale nie wiem jak go rozwiązać. Dodam ze podłączałem wejście AI w obu biegunowościach i prąd przepływał taki sam, ale siemens prądu w obu przypadkach nie widzi i zdaje się że aktualnie pokazuje przekroczenie prądu wejściowego.
    Nie wiem czy wartość wejścia AI rzędu 30omów jest prawidłowa. Czy zgodzicie się ze mną że jak płynie prąd z zakresu 4-20mA to musi być dobrze?
    Dodam jeszcze że nie mam dostępu do sterownika (zakres prac kończył się na istniejącej listwie krosowej). Pozostaje mi albo kupić separator albo odbijać piłeczkę i tłumaczyć im że po mojej stronie jest ok.


    Specem w tej dziedzinie nie jestem więc to będzie tylko moje gdybanie.
    Jeżeli sterownik ma wejście 4-20 to powinien mierzyć prąd. Napięcie nie powinno go obchodzić. Jeżeli mierzyłeś prąd i był w granicach 4-20 to po Twojej stronie jest ok. Pytanie dlaczego sterownik tego nie widzi?

    Ps.
    Właśnie rozmawiałem ze znajomym który jest obcykany w sterownikach.
    1. Albo coś jest nie tak z wejściem.
    2. Albo wejście jest źle zaprogramowane.

    Jeżeli prąd płynie to wszystko jest ok.

    Nie prawda w pętli 4-20mA musi płynąć 24V gdyż zasilanie i pętla prądowa płyną 2 kabelkami. Jedyne rozwiązanie to przeprogramowanie wejścia na 0-20mA wtedy oczywiście trzeba dostarczyć z zewnątrz zasilanie. Co wiąże się z dodatkowymi kabelkami i twój sygnał musi być odpowiednio przeskalowany 0mA (0) 20mA(max). I pewnie automatycy nie chcą się na to zgodzić gdyż w nowoczesnych systemach sterowania lepiej wykorzystać zasilanie+pętle prądową w 2 kabelkach i wszędzie się tak robi. Dodatkową zaletą pętli 4-20mA jest wykrywanie "signal wire break" tzw. Bad. Bardzo często wykorzystywane w np DCS.
    Pętle prądowa można zmierzyć również przy samym module AI(szeregowo mA) i sprawdzić napięcie voltomierzem. Ma być przy 4mA(0) przy 20mA(max) i zasilanie 24V.

    0
  • Pomocny post
    #8 18 Lis 2013 14:28
    ILSSystem
    Specjalista Automatyk

    Witam,
    Układ pomiarowy powinien wyglądać tak jak na załączonym obrazku.
    pętla 4-20mA i za małe napięcie dla AI simatica?

    0
  • #9 18 Lis 2013 14:49
    PROAT
    Poziom 13  

    Cytat:
    Nie prawda w pętli 4-20mA musi płynąć 24V gdyż zasilanie i pętla prądowa płyną 2 kabelkami.


    Nie prawda. Z prawa ohma wynika coś zupełnie innego. Napięcie jest odwrotnie proporcjonalne do impedancji przetwornika. A tak na marginesie prąd nie płynie o wartości 24V. Napięcie zasilania przetwornika pojawia się po rozerwaniu pętli i może to być 24V jak również mniej.

    Cytat:
    Jedyne rozwiązanie to przeprogramowanie wejścia na 0-20mA wtedy oczywiście trzeba dostarczyć z zewnątrz zasilanie.


    To już w ogóle bez sensu. Zakres wyjściowy przetwornika nic nie ma do zasilania przetwornika. Są przetworniki 0-20mA 2 i 4 przewodowe.

    0
  • Relpol
  • Pomocny post
    #10 18 Lis 2013 15:02
    excray
    Poziom 39  

    Cuda na kiju. Widzę że Ci automatycy to kolejni specjaliści elektronicy którym prawo oma jest obce. Pętla prądowa ma sprawdzać prąd a nie napięcie. A napięcie będzie wynikać z prawa oma i nie ma takiej opcji żeby przy 24V raz płynął prąd 5mA a innym razem 20mA.

    0
  • #11 18 Lis 2013 15:09
    pawel_konin
    Poziom 20  

    excray napisał:
    Cuda na kiju. Widzę że Ci automatycy to kolejni specjaliści ale prawo oma im obce jest. Pętla prądowa ma sprawdzać prąd a nie napięcie. A napięcie będzie wynikać z prawa oma i nie ma takiej opcji żeby przy 24V raz płynął prąd 5mA a innym razem 20mA.

    To niech kolega zinterpretuje figure 5.2 gdzie przetwornik ma zasilanie??
    A potem figura 5.3 gdzie zasilany jest przetwornik i czujnik w pętli.
    ILSSystem napisał:
    Witam,
    Układ pomiarowy powinien wyglądać tak jak na załączonym obrazku.
    pętla 4-20mA i za małe napięcie dla AI simatica?

    Jedyną prawidłową odpowiedzią jest w/w zamieszczony rysunek z dtr siemensa.

    0
  • #12 18 Lis 2013 15:11
    PROAT
    Poziom 13  

    Cytat:
    Cuda na kiju. Widzę że Ci automatycy to kolejni specjaliści ale prawo oma im obce jest. Pętla prądowa ma sprawdzać prąd a nie napięcie. A napięcie będzie wynikać z prawa oma i nie ma takiej opcji żeby przy 24V raz płynął prąd 5mA a innym razem 20mA.


    Do kogo pijesz?

    Jak do mnie to ci odpowiem. Prze zasilaniu przetwornika 24V prąd będzie się zmieniał od 4 do 20mA w zależności od wartości mierzonej, więc chyba jest taka opcja :D

    0
  • #13 18 Lis 2013 15:16
    pawel_konin
    Poziom 20  

    PROAT napisał:
    Cytat:
    Cuda na kiju. Widzę że Ci automatycy to kolejni specjaliści ale prawo oma im obce jest. Pętla prądowa ma sprawdzać prąd a nie napięcie. A napięcie będzie wynikać z prawa oma i nie ma takiej opcji żeby przy 24V raz płynął prąd 5mA a innym razem 20mA.


    Do kogo pijesz?

    Jak do mnie to ci odpowiem. Prze zasilaniu przetwornika 24V prąd będzie się zmieniał od 4 do 20mA w zależności od wartości mierzonej, więc chyba jest taka opcja :D

    Do której figury z dtr się odnosisz?? Co dla ciebie znaczy 4mA?? Chętnie posłucham...

    0
  • #14 18 Lis 2013 15:20
    excray
    Poziom 39  

    Nie rozumiem? Co mam tam interpretować? Sposób łączenia masy analogowej części? A co on ma tutaj do pętli prądowej?

    0
  • #15 18 Lis 2013 15:24
    pawel_konin
    Poziom 20  

    excray napisał:
    Nie rozumiem? Co mam tam interpretować? Sposób łączenia masy analogowej części? A co on ma tutaj do pętli prądowej?

    Kolega PROAT niech sobie zinterpretuje.
    Zostawiam dla potomnych trochę wiedzy.
    http://www.cciba.pl/www/artykul4.htm

    0
  • #16 18 Lis 2013 15:25
    excray
    Poziom 39  

    PROAT napisał:
    Do kogo pijesz?

    Jak do mnie to ci odpowiem. Prze zasilaniu przetwornika 24V prąd będzie się zmieniał od 4 do 20mA w zależności od wartości mierzonej, więc chyba jest taka opcja :D

    Teraz to już zupełnie się chyba wszyscy pogubiliśmy. Ja mówię o napięciu w pętli prądowej między zaciskiem M+ a M-, kolega o napięciu zasilającym czujnik. Ech...

    0
  • #17 18 Lis 2013 15:41
    PROAT
    Poziom 13  

    To wam odpowiem, bo chyba nie czujecie blusa

    Po 1) nie trzeba zasilać przetworników z 24V DC, nawet 2 przewodowych. W dtr od siemensa tego nie ma, a chyba by było?

    Mam na biurku kartę 7kb02, przetwornik ciśnienia aplisens AS 4-20mA i zasilam go w szereg zasilaczem 15V DC/2A, bo taki mam. Zarówno na amperomierzu jak i w step 7 widzę zmiany wartości mierzonych w pełnym zakresie, więc przestańcie gadać jakieś niestworzone historie.

    2) excray - napięcie na karcie AI w pętli prądowej między m+ - m- będzie się zmieniać, bo wystarczy że wydłużysz przewód łączący przetwornik z wejściem AI i zmienia się rezystancja całej pętli, a co za tym idzie U=I*R - nie mam racji? Inne prawo ohma mieliście?

    3) excray nie wiem po co dałeś link do separatorów. Separatry znam i czasami stosuję.

    0
  • #18 18 Lis 2013 15:43
    pawel_konin
    Poziom 20  

    excray napisał:
    PROAT napisał:
    Do kogo pijesz?

    Jak do mnie to ci odpowiem. Prze zasilaniu przetwornika 24V prąd będzie się zmieniał od 4 do 20mA w zależności od wartości mierzonej, więc chyba jest taka opcja :D

    Teraz to już zupełnie się chyba wszyscy pogubiliśmy. Ja mówię o napięciu w pętli prądowej między zaciskiem M+ a M-, kolega o napięciu zasilającym czujnik. Ech...

    Kto się pogubił ten się pogubił ale myślę że, artykuł wyjaśnił mam nadzieje i autorowi tematu również.
    Kto mówi o zasilaniu przetworników 24V patrz figura 5.2 dtr. Wejście AI i transducer zasilany z petli 4-20mA modułu AI Siemens który zasilamy jest L+ i M (24V) zasilacza wersja 2 przewodowa Siemens SM331 8AI 12bit.
    Jest mowa o zasilaniu transducera zewnętrznym napięciem L+ i M figura 5.3 wersja 4 przewodowa tego modułu w/w.

    0
  • #19 18 Lis 2013 16:02
    PROAT
    Poziom 13  

    Cytat:
    Kto się pogubił ten się pogubił ale myślę że, artykuł wyjaśnił mam nadzieje i autorowi tematu również.


    Zawsze można odpowiedzieć wymijająco, gdy brakuje argumentów merytorycznych.

    Inny test.

    Nadajnik sygnału APAR model AR910. Ustawiam 20mA i rozwieram końce. Napięcie na rozwartych końcach 13,8V, po podpięciu do AI, wszystko działa w całym zakresie. To jest najbardziej zbliżony układ do autora tematu. Nadajnik zasilany 230V z sieci, sposób podłączenia z dtr siemensa, tak jak u ILSsystem, rys. 5.3.

    Teza o 24V zostaje obalona.

    Później pomierzę napięcia M+, M-, żeby co poniektórych oświecić.

    0
  • #20 18 Lis 2013 16:04
    excray
    Poziom 39  

    PROAT napisał:
    excray - napięcie na karcie AI w pętli prądowej między m+ - m- będzie się zmieniać, bo wystarczy że wydłużysz przewód łączący przetwornik z wejściem AI i zmienia się rezystancja całej pętli, a co za tym idzie U=I*R - nie mam racji? Inne prawo ohma mieliście?

    Kolega PROAT mnie ewidentnie nie rozumie. Ja się z kolegą rękoma, nogami i resztą ciała zgadzam i podpisuję. Kolega pawel_konin wypisuje tutaj niestworzone rzeczy i mam propozycję - niech kolega pawel_konin na załączonej DTRce rozrysuje gdzie on mierzy te swoje 24V przy sygnale 4mA.

    0
  • #21 18 Lis 2013 16:11
    PROAT
    Poziom 13  

    ^^^^

    @excray

    Sorry, jakiś nerwowy dziś jestem. Po prostu się pogubiłem kto mi wciska kit z 24V/4mA.

    0
  • #22 18 Lis 2013 16:41
    pawel_konin
    Poziom 20  

    excray napisał:
    PROAT napisał:
    excray - napięcie na karcie AI w pętli prądowej między m+ - m- będzie się zmieniać, bo wystarczy że wydłużysz przewód łączący przetwornik z wejściem AI i zmienia się rezystancja całej pętli, a co za tym idzie U=I*R - nie mam racji? Inne prawo ohma mieliście?

    Kolega PROAT mnie ewidentnie nie rozumie. Ja się z kolegą rękoma, nogami i resztą ciała zgadzam i podpisuję. Kolega pawel_konin wypisuje tutaj niestworzone rzeczy i mam propozycję - niech kolega pawel_konin na załączonej DTRce rozrysuje gdzie on mierzy te swoje 24V przy sygnale 4mA.

    W swojej karierze automatyka miałem zawsze do czynienia z takim układem pętla 4-20mA i za małe napięcie dla AI simatica?
    w takim układzie zawsze miałem jak na rysunku.

    0
  • #23 18 Lis 2013 17:00
    excray
    Poziom 39  

    W przypadku prostych czujników rezystancyjnych tak rzeczywiście trzeba robić ale kolega ma moduł który sam zapewnia odpowiednie napięcie na wyjściu i nie trzeba dokładać żadnego zasilacza.

    Dodano po 2 [minuty]:

    czesiu napisał:
    Sprawdziłem opór ich wejścia AI łącznie z okablowaniem i wychodzi 30omów.

    OK
    czesiu napisał:
    Spiąłem znowu wszystko do kupy no i akurat przetwornik wystawiał ok 9,3mA, co dało na wyjściu spadek napięcia 2,7V

    To mi wychodzi 290om a nie 30.

    0
  • #24 18 Lis 2013 18:14
    ILSSystem
    Specjalista Automatyk

    Witam,
    Wydaje mi się, że trochę temat zboczył z toru...
    Zapomnieliśmy o kilku ważnych sprawach a możliwe że w nich jest problem:
    1. Fajnie by było otrzymać konkretny model przetwornika.
    2. Czy instalacja jest nowa? Czy działała przez długi czas w tej konfiguracji sprzętowej i niezmienionym programie PLC? Automatycy lubią nie chwalić się swoimi zmianami w programie... ;)
    3. Jakie ustawienie zworki (A,B,C,D) jest na wkładce z wejściami analogowymi ?? Jakie jest ustawienie w HW Config?
    4. Trzeba sprawdzić jaką wartość przyjmuje PIW - 32768 ? 0? 0-27648? Czy wartość się zmienia? Co mówi diagnostyka karty ( o ile w taką jest wyposażona) ?
    5. Czy na panelu/scadzie wartości są zmieniane z błędem/wcale...
    6. Jakie jest min i max w bloku skalowania a jaki jest zakres pomiarowy czujnika?

    Jeśli wcześniej układ pomiarowy działał poprawnie i nie było żadnych modyfikacji to możliwe są 3 usterki:
    - przetwornika
    - wejścia analogowego
    - okablowania
    Po kolei trzeba sprawdzić wszystkie z nich bez dostępu do PLC lub współpracy z automatykiem raczej się tego nie da zrobić...

    Pozdrawiam :)

    0
  • #25 18 Lis 2013 23:05
    czesiu
    Poziom 33  

    excray napisał:

    czesiu napisał:
    Sprawdziłem opór ich wejścia AI łącznie z okablowaniem i wychodzi 30omów.

    OK
    czesiu napisał:
    Spiąłem znowu wszystko do kupy no i akurat przetwornik wystawiał ok 9,3mA, co dało na wyjściu spadek napięcia 2,7V

    To mi wychodzi 290om a nie 30.


    Zmierzone napięcie wynosiło 0,27V. Źle napisałem w pierwszym poście, sorry.
    Rezystancja pętli (wejścia AI) 30omów.
    Czyli nie daję się wkręcać w separatory. Za dwa dni podjadę ze swoim zadajnikiem upewnię się.

    0
  • Pomocny post
    #26 19 Lis 2013 12:00
    tehaceole

    Poziom 28  

    To ja dorzucę swoje 3 grosze bo rozbawił mnie ten temat. Niech dwaj nerwowi Koledzy łaskawie wykonają na swoich biurkach doświadczenie polegające na dołożeniu do tego rysunku jeszcze jednej karty AI 4-20:

    pawel_konin napisał:

    W swojej karierze automatyka miałem zawsze do czynienia z takim układem

    Pytanie: co się wtedy stanie?
    Albo inaczej: jakie wskazania będą na obu kartach wejściowych?

    Oczywiście od razu mówię, że nie wszystkie karty 4-20 można łączyć szeregowo...

    0
  • #27 19 Lis 2013 15:25
    excray
    Poziom 39  

    tehaceole napisał:
    Niech dwaj nerwowi Koledzy łaskawie wykonają na swoich biurkach doświadczenie polegające na dołożeniu do tego rysunku jeszcze jednej karty AI 4-20:

    Ale co to ma wspólnego z sytuacją opisaną w tym temacie?

    0
  • #28 19 Lis 2013 15:39
    tehaceole

    Poziom 28  

    excray akurat nie do Ciebie "piłem" w tym poście :) Powiem, więcej: doskonale zrozumiałem co chciałeś Autorowi przekazać:)

    0
  • #29 21 Lis 2013 14:54
    czesiu
    Poziom 33  

    Jestem po kolejnym podejściu do problemu i wyciągam takie oto wnioski:
    -wejście AI omomierzem nie wykazało przejścia do masy/uziemienia
    -po wpięciu zadajnika (bateryjnego) w miejsce przetwornika pomiary są ok, czyli strona klienta wydaje się być poprawna ale uwaga: jeśli do tak pracującej poprawnie pętli dotknę tylko jeden przewód od mojego przetwornika mam od razu sygnalizację błędu na wizualizacji wskazującą przekroczenie prądu wejścia AI (a w owej pętli amperomierz ciągle wskazuje prawidłową wartość prądu<20mA)
    Okazuje się że wyjście mojego przetwornika (zasilanego z 230V) nie jest zupełnie izolowane od uziemienia i zakłóca sygnał. Różnica potencjałów między odpiętym przetwornikiem a pętlą prądową wynosiła 14V na zakresie AC i 8VDC, jednak włączony w to miejsce amperomierz wskazywał <0,1mA.
    Teraz słowo o moim przetworniku, jest to pompa dozująca grundfosa z panelem AR. Link do dtr-ki tu: http://www.google.pl/url?sa=t&rct=j&q...r0ivgtwuUBrgdb5ijnw&bvm=bv.56988011,d.ZGU
    Wykorzystuję wyjście prądowe z gniazda 2 (1 brązowy, 4 czarny).
    pętla 4-20mA i za małe napięcie dla AI simatica?
    Zauważcie że wyjście 1 brązowy to jednocześnie wyjście +5V względem nieużywanego wyjścia GND, a jak sprawdziłem wyjście GND jest wewnętrznie połączone z zaciskiem PE wtyczki i to może być przyczyną złego działania.
    Dodam że między brązowym a uziemieniem zmierzyłem 26VAC i 12VDC (czarny w powietrzu) a włączając w to miejsce amperomierz 0,64A AC i 0,24A DC.
    Teraz przyszło mi do głowy, że korzystam również z wejścia prądowego do zadawania sygnału (gniazdo 4) i tam też pin 1 (brązowy) jest "-" pętli prądowej i jednocześnie GND - więc pewnie też uziemiony.
    Jutro spróbuję zadać prąd z baterii na gniazdo 4 i zobaczę czy pętla wyjściowa zacznie działać poprawnie.
    Chyba będzie trzeba dołożyć jednak separator.
    Na koniec dodam że pompy są dwie i efekty na obu takie same.

    0
  • #30 21 Lis 2013 18:39
    PROAT
    Poziom 13  

    Masz po prostu różnice potencjałów między M- w Simaticu i wyjściem z przetwornika. Po zamknięciu obwodu płynie prąd wyrównawczy, nie mający nic wspólnego z sygnałem pomiarowym. W takim wypadku pozostaje założyć separator, który powinien być zresztą zawsze na styku sygnałów z dwóch różnych systemów.

    Pomyśl co by się stało, gdyby po czasie, Twój przetwornik uszkodził wejście AI. Byłoby wielkie przerzucanie odpowiedzialności między Tobą a fachmanami od PLC.

    0
  Szukaj w 5mln produktów