Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Sterowanie N mosfet bss138

tatanka 20 Lis 2013 11:26 2910 13
  • #1 20 Lis 2013 11:26
    tatanka
    Poziom 20  

    Sterowanie N mosfet bss138

    Potrzebuję uzyskać na wyjściu z procka zasilanego 3,3V PWM 400Hz +12V.
    Zrobiłem podłączenie jak na schemacie.
    Teraz zagadka. Teoretycznie powinno to działać, ale na wyjściu mam taką samą amplitudę ( ok 3,4V ) jak podawaną przez procek.
    Jeżeli bramkę:
    - zostawię w powietrzu mam 12V
    - dam do masy mam 0V
    - zasilę przez rezystor np 3k to amplitudę nadal mam 3,4V, ale od poziomu 4V

    P.S.
    Kilka tych mosfetów uszkodziłem podczas lutowania. Okazało się ze na grocie mam 80V~ względem masy urządzenia.

    0 13
  • #2 20 Lis 2013 11:32
    excray
    Poziom 39  

    Wszystko się zgadza. Dziwię się tylko że udało Ci się uzyskać tak duże (3,4V) napięcie na wyjściu. Dałeś źródło jako wyjście a zapomniałeś chyba że ten tranzystor wymaga ok. 3V różnicy GS aby zadziałać. W momencie jak zaczyna przewodzić podnosi się napięcie na źródle, GS spada i przestaje przewodzić. Na podstawie tych wartości można powiedzieć że tranzystor zaczyna przewodzić od GS równego 5-3,4=1,6V. Nieźle.

    0
  • #3 20 Lis 2013 12:24
    tatanka
    Poziom 20  

    Nie doczytałeś.
    Procek ma zasilanie 3,54V ( 5V - 2x0,7V na diodach )
    BSS138 to N mosfet logic level.
    Dlaczego jak bramka wisi w powietrzu mam 12V na wyjściu :?:

    0
  • #4 20 Lis 2013 12:33
    excray
    Poziom 39  

    Czy wiesz jak działa tranzystor mosfet? Dla mnie to jest oczywiście pytanie retoryczne bo już od pierwszego postu widzę że nie masz bladego pojęcia. I taka banalna sprawa jak "Dlaczego jak bramka wisi w powietrzu mam 12V na wyjściu?" jest dla ciebie niepojęta. Odsyłam do lektury podręcznika do elektroniki.

    0
  • #5 20 Lis 2013 12:40
    tatanka
    Poziom 20  

    Więc zamiast mnie naprowadzić, albo pomóc nabijasz sobie posty.

    0
  • #6 20 Lis 2013 12:45
    excray
    Poziom 39  

    tatanka napisał:
    Więc zamiast mnie naprowadzić, albo pomóc nabijasz sobie posty.

    A później je sprzedam na allegro. Pomogłem Ci już ale ty nie masz podstaw i nie rozumiesz tego co do ciebie piszę. Zaopatrz się w dobrą książkę. Polecam "Sztukę elektroniki" bo jest ciekawie napisana.

    0
  • #7 20 Lis 2013 13:02
    tatanka
    Poziom 20  

    Myślałem, że to dział dla początkujących.

    0
  • #8 20 Lis 2013 13:07
    excray
    Poziom 39  

    Nawet początkujący muszą mieć jakieś podstawy. Zadałeś tutaj kilka pytań które wynikają z braku podstawowej wiedzy więc albo nie powinieneś zabierać się za to albo zapoznaj się z tematem. Jak to sobie wyobrażasz jakby przyszli lekarze brali nóż i kroili pacjenta mówiąc że się nauczą w trakcie? Temat mosfetów jest bardzo dobrze wytłumaczony w książkach więc nie nadużywaj uprzejmości i bądź łaskaw zajrzeć do nich zamiast kazać mi je przepisywać. Nawet na wiki jest artykuł. Jak się zapoznasz to wróć, napisz co zrozumiałeś a czego nie i wtedy resztę Ci wytłumaczę.

    0
  • #9 20 Lis 2013 17:00
    mc_cezet
    Poziom 9  

    Cześć,
    Wydaje mi się, że brakuje Ci rezystora pull-down (między bramką a masą) - po stanie wysokim ładunek na bramce mosfeta nie ma gdzie odpłynąć, więc mosfet nadal przewodzi. Poza tym obciążenie powinno być "na górze" tzn między +12V, a drenem.

    0
  • #10 20 Lis 2013 19:23
    jarek_lnx
    Poziom 43  

    Cytat:
    Myślałem, że to dział dla początkujących.

    Litości, ile można, odpowiadałem w zbyt wielu podobnych tematach i trochę mnie to drażni.
    Słyszałeś kawał o dwóch blondynkach w autobusie?
    blondynka pyta kierowcę: czy dojadę tym autobusem do centrum?
    Kierowca: Nie.
    Na to druga blondynka: A ja.

    W tym temacie sytuacja jest analogiczna z tą różnicą że przed tobą było kilkaset podobnych tobie blondynek, które pytały o to samo, dlaczego MOSFET w układzie wspólnego drenu daje na wyjściu niskie napięcie, czy naprawdę uważasz że w twoim przypadku przyczyna będzie inna?

    Przyczyna jest prosta, tranzystor ma tylko trzy nóżki ;) więc jedna musi być wspólna dla obwodu wejścia i wyjścia, jeśli nie jesteś tego świadom, twoje układy nie będą działały.

    W tym układzie, żeby na wyjściu uzyskać 12V, na bramce musiał byś mieć 15V.

    0
  • #11 20 Lis 2013 23:29
    tatanka
    Poziom 20  

    Ja sam do wszystkiego dochodzę. Staram się sam rozwiązywać problemy i nie zawracać nikomu głowy.
    Tranzystor z kanałem P też mi tu raczej nie pomoże.
    Najprościej chyba zastosować transoptor.

    0
  • #12 21 Lis 2013 07:34
    jarek_lnx
    Poziom 43  

    Cytat:
    Ja sam do wszystkiego dochodzę. Staram się sam rozwiązywać problemy i nie zawracać nikomu głowy.

    Nie przyłożyłeś się do rozwiązania tego "problemu", podłączyłeś "na pałę", jeśli mi powiesz jakie są argumenty za i przeciw, żeby podłączyć źródło tranzystora do obciążenia, a jakie żeby podłączyć źródło do zasilania, oraz co decyduje o tym czy stosujemy kanał typu P lub N narysuję ci schemat :)

    Cytat:
    Tranzystor z kanałem P też mi tu raczej nie pomoże.

    Skąd wiesz, jeśli nie zadałeś sobie trudu żeby poznać działanie tranzystora.

    Cytat:
    Najprościej chyba zastosować transoptor.
    Też da się spieprzyć.

    0
  • #13 21 Lis 2013 10:09
    mc_cezet
    Poziom 9  

    tatanka napisał:
    Tranzystor z kanałem P też mi tu raczej nie pomoże.
    Najprościej chyba zastosować transoptor.


    Spokojnie da się bez transoptora: "wiedza tajemna"

    0
  • #14 21 Lis 2013 10:23
    tatanka
    Poziom 20  

    Problem jest taki, że potrzebuję wysyłać raz na jakiś czas dodatnie impulsy PWM 400Hz o amplitudzie ok 8V.
    Jeżeli podwieszę wejście sterowanego urządzenia bez mojego układu przez 1,4k do +12V to mam stały pobór ok 4mA. Po podłączeniu PWM amplitudę mam ok 4,75V i działa. Chcę uniknąć tego stałego poboru prądu.
    Sterowanie masą odpada.
    Tylko impulsy dodatnie.

    Po mojemu z kanałem P bez dodatkowego tranzystora też to nie poleci, bo napięcie na bramce będę mieć na poziomie -8V

    Po mojemu tak powinno być ok.
    Sterowanie N mosfet bss138

    BSS138 nadają się do lutowania tylko hotem. Uziemianie grota też nie pomaga. Uszkadzają się.

    0