Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Karta WiFi versus Sound Blaster

Jamie 26 Lis 2013 06:50 1860 14
  • #1 26 Lis 2013 06:50
    Jamie
    Poziom 19  

    Pojęcia nie mam do jakiego działu skierować ten temat...

    Z powodu niekompatybilnych z XP sterowników zmuszony byłem wymienić kartę PCI do radiówki.
    Zamienił stryjek - D-Link zwieszał komputer, natomiast TP-Link (TL-WN751ND v.2.0) zakłóca mi audio (SB Live! CT4830).
    W dołączonym pliku dźwiękowym odgłosy na początku są efektem włączania i wyłączania karty w panelu sterowania, dalej następuje fragment muzyczny z wkurzającym potrzaskiwaniem. Trzaski o różnej częstości i natężeniu występują losowo, niezależnie od rodzaju odtwarzanego pliku. Przy wyłączonej sieciówce problem nie występuje.
    Zaliczyłem już zmianę, lub reinstalację, sterowników ponad połowy urządzeń nim doszedłem do wniosku, że to ewidentnie sieciówka "sieje brudem".
    Najlepszym dowodem na winę sieciówki jest brak zakłóceń po wyłączeniu jej. I ewidentnie, bo z poprzednią akurat takich problemów nie było.
    Potem była próba zaekranowania karty niczym głowicy w.cz. - co nie przyniosło żadnych pozytywnych skutków. Najwyraźniej zakłócenia przedostają się przez złącze PCI.
    Odsunięcie karty wifi dalej od dźwiękówki nie jest możliwe - komputer to Dell GX620 i ma raptem dwa PCI.
    Zakup kolejnej karty jest bez sensu - nie ma gwarancji, że inny wytwór chińskich rączek nie będzie generował zakłóceń. Tym bardziej inwestowanie w droższą kartę.
    Prawdopodobnie zaraz padnie stwierdzenie, że to wina zasilacza ;) Nie przypuszczam. Zasilacz to OCZ StealthXstream2 80plus, półroczny - ponadto zasilał poprzednią sieciówkę, a problemu nie było.
    Może fachowcy z Elektrody znajdą jakieś rozwiązanie, może być niekonwencjonalne, bo mnie się skończyły pomysły - jednakowoż, porady typu:
    zrób formata, zmień komputer, i.t.p. proszę sobie podarować.
    I nie, nie mam żadnych wirusów na dysku ;)
    Gdyby potrzebne były jeszcze jakieś szczegóły dotyczące konfiguracji lub samego problemu - proszę pytać...

    0 14
  • #2 26 Lis 2013 10:35
    bogiebog
    Specjalista Sieci, Internet

    Jak to ekranowałeś ?

    Spróbuj cała płytkę do klatki faradaya, np folia alu między kartki papieru i zrób z tego pudełko.

    Spróbuj zaekranować kartę audio także.

    0
  • #3 26 Lis 2013 13:18
    ziolek2
    Poziom 17  

    odkręć antenkę - sprawdź efekty
    odkręć slot i sprawdź efekty

    0
  • #4 26 Lis 2013 22:52
    Jamie
    Poziom 19  

    bogiebog
    "Jak to ekranowałeś ?
    Spróbuj cała płytkę do klatki faradaya, np folia alu między kartki papieru i zrób z tego pudełko.
    Spróbuj zaekranować kartę audio także."


    Nie sprawdza się. Wyżej pisałem, że zaekranowałem sieciówkę jak głowicę w.cz. - czyli pudełko Faradaya - zakłócenia lecą sobie po magistrali PCI. Czyli bez sensu aresztować też Blastera...
    Już raczej jakieś filtrowanie, bodaj zasilania tej sieciówki - producent bardzo oszczędnie szafował podzespołami - ale nie bardzo wiem jak to rozwiązać.

    ziolek2
    "odkręć antenkę - sprawdź efekty
    odkręć slot i sprawdź efekty"


    Ziołek, bierz połowę ;)
    Po odkręceniu antenki nie ma interneta, zakłócenia są dalej. Zresztą nie używam tego śmiesznego czegoś jako antenki, antena jest na zewnątrz, prowadzona kablem od talerza na ścianie domu. A slota to chyba tylko opalarką da się wydłubać, bądź przytomny ;) Chyba, że cię nie zrozumiałem...

    0
  • #5 27 Lis 2013 09:42
    ziolek2
    Poziom 17  

    Slot, może źle się wyraziłem - maskownica złącza RP-SMA - z tego co widzę przykręcony dwoma śrubkami: http://www.jmt.bg/images/products/17958_33365.jpg

    ta blaszka z lewej,

    z antenką chodziło mi, żeby sprawdzić czy ona nie generuje zakłóceń, ale jeżeli po odłączeniu jest to samo to wykluczone.

    Miałeś możliwość sprawdzenia karty na innym sprzęcie? jakie efekty?

    Obejrzyj kondensatory na płycie głównej (komputera), szczególnie przy slotach PCI

    0
  • #6 27 Lis 2013 22:58
    Jamie
    Poziom 19  

    Wydaje mi się, że chodziło ci po prostu o "śledzia" - tylko on pełni tutaj rolę raczej dodatkowego ekranowania, poza mocowaniem karty.
    Tak, sprawdzałem na innych maszynkach - jest różnie, zależnie od konfiguracji sprzętowej. Czasem trzeszczy, czasem nie - akurat to czysto akademickie testy, bo chodzi o konkretny komputer, a w nim się dzieje, to co się dzieje...
    Kondensatory na płycie sprawdziłem, są w porządku. Oba sloty PCI są nieźle obsadzone na gałęziach zasilania sporymi elektrolitami - ostatecznie to Dell - szkoda, że nie dali kilku ceramików na wyższe częstotliwości... Zresztą gdyby był problem z kondensatorami, to na starej karcie też by były objawy - a nie ma, specjalnie przekładałem.
    Sama karta, jak chyba zauważyłeś, jest bardzo skromnie wyposażona - nie dopatrzyłem się bodaj jednego "poludzkiego" kondensatorka przy zasilaniu - teoretycznie, można by dołożyć, ale do takiego mikro PCB nie mam odpowiedniego sprzętu.
    Normalnie, ten TP-Link chyba jest porównywalny z większością dzisiejszego sprzętu - badziew i tyle... co nie znaczy, że mu odpuszczę ;)

    0
  • #7 28 Lis 2013 09:21
    ziolek2
    Poziom 17  

    Z tego co kojarzę te TP-Linki są budowane na atheros'ach wg mnie jednych z lepszych chipów i przy całym moim doświadczeniu z sieciami ze względów na wydajność, możliwości konfiguracyjne i balans między Tx, a RX preferowałbym TP-Link nad D-Link, ale o gustach się nie dyskutuje...

    Pytałem o kondensatory itp gdyż TP-Link mógłby mieć w teorii wyższy pobór prądu niż D-Link i przez to generować jakieś zakłócenia przy problemach z zasilaniem. Śledź ekranuje, ale przylega też do ekranu anteny.

    Możesz spróbować zmienić kanał transmisji i zobaczyć czy zakłócenia będą występowały, będziemy wtedy wiedzieli czy jest to pochodna samej transmisji czy działania zasilania samego układu karty, ale też powoli kończą mi się pomysły.

    0
  • #8 28 Lis 2013 09:52
    Jamie
    Poziom 19  

    Akurat ten śledź nie dotyka gniazda, ale mniejsza z nim.
    Możliwe, że atheros ma te wszystkie zalety, które wymieniłeś, nie zajmuję się zawodowo sieciami, więc wiele na ten temat powiedzieć nie mogę, z pewnością jest popularny sądząc z ilości wzmianek o nim w necie. Dla mnie, w tej chwili, najważniejsza jest jego właściwość zakłócania trzeszczeniem toru audio ;)
    Co do zasilania, to prądu raczej mu nie brakuje - OCZ ma 500W, jakieś ponad sto watt nadmiaru do mojej konfiguracji - może brać ile chce...
    Nie mam pojęcia jak zmienić kanał transmisji, mam same sterowniki do tej karty zainstalowane i XP to konfiguruje, ponieważ po zainstalowaniu całego pakietu do TP-Linka jakoś on się gryzie z systemem i nijak nie daję rady skonfigurować połączenia - chociaż według instrukcji to proste, jednak Windows jest innego zdania...

    0
  • #9 28 Lis 2013 10:18
    ziolek2
    Poziom 17  

    Kanał transmisji zmienisz w konfiguracji AP/Router'a.

    Zasilanie nie idzie do karty bezpośrednio z zasilacza, ale przez układy zasilania, kondensatory itp. na płycie głównej, dlatego o sam zasilacz nie pytałem.

    0
  • #10 28 Lis 2013 10:36
    Jamie
    Poziom 19  

    Nie używam routera, sygnał leci bezpośrednio z anteny do karty.
    Ale jeśli chodziło ci o ustawienie w programie obsługi karty, to wyżej wspominałem, że nie mam tego zainstalowanego...

    Ale wydajność prądowa zależy od mocy i kondycji zasilacza...

    0
  • #11 28 Lis 2013 10:45
    ziolek2
    Poziom 17  

    OK - od zewnętrznego dostawcy - rozumiem. Jak masz możliwość podłączenia do innego routera/AP, który mógłbyś skonfigurować to sprawdź, w najgorszym przypadku teethering z telefonu i porównać odgłosy.

    0
  • #12 28 Lis 2013 11:03
    Jamie
    Poziom 19  

    Podłączyć do routera nie mam możliwości, ale akurat siostrzeniec ma w pobliżu androida...

    Przy połączeniu przez smartfona - też trzeszczy :( Przestaje tylko po wyłączeniu karty w panelu sterowania.

    0
  • #13 28 Lis 2013 11:58
    ziolek2
    Poziom 17  

    jaki kanał był na androidzie, a jaki na sieci tej zewnętrznej (sprawdź w aplikacji inSSIDer)

    0
  • #14 28 Lis 2013 22:28
    Jamie
    Poziom 19  

    Numer kanału w praktyce jest bez różnicy - w mojej sieci kanał transmisji i tak jest przydzielany dynamicznie przez ISP, może być inny przy kolejnym połączeniu - nie ma korelacji z jakimś wybranym kanałem, trzeszczy na wszystkich.
    A ponieważ nawet przy odłączonym sygnale pracująca karta powoduje zakłócenia - to wszystko są czysto akademickie testy i raczej nie zbliżą mnie do rozwiązania problemu.

    PS: Twoja teoria na temat indukcyjnej interferencji w śledziu była.. hmm... bardzo oryginalna :D

    Edit: Ciekawa sprawa, podczas ściągania dużego pliku nie zatrzeszczało ani raz - gdy tylko pobieranie się zakończyło znów zaczęło potrzaskiwać - siła nieczysta, czy co?...

    Edit2: W ramach testu uruchomiłem Linuksa Mint Live - nie dość, że system automatycznie zainstalował sobie sterowniki do sieciówki, to jeszcze bez problemu zrobił redirect dźwięku do HDMI na mojej grafice. ŻADNEGO TRZESZCZENIA :!: Chociaż jest problem z obsługą czterech głośników, ale ponoć do obejścia w wersji zainstalowanej. Oj, coś mi się zdaje, że wcześniej czy później Windows wyląduje jako podrzędny drugi system...

    0
  • #15 16 Gru 2013 01:17
    Jamie
    Poziom 19  

    Edit 3: No więc, zrobiłem jeszcze kilka prób:
    1. Odinstalowałem oprogramowanie Live!, wymontowałem fizycznie kartę, włączyłem w BIOSie zintegrowaną dźwiękową, zainstalowałem do niej sterowniki - rezultat: nie trzeszczy, tyle, że integra nadaje się co najwyżej do odtwarzania dźwięków systemowych i niewiele ponad to...
    2. Ponieważ trafiła mi się okazja taniego zakupu SB Live! 5.1 (SB0100) - po wyłączeniu integry i oczyszczeniu systemu wmontowałem ją i zainstalowałem (z problemami, ale poszło) oprogramowanie dedykowane XP - rezultat: znów trzeszczy...

    Nie mam już nerwów do Blasterów, a tak dobrze grały pod Win98SE...

    Zamykam ten temat - gdyby którejś dobrej duszy wpadł jakiś pomysł dotyczący problemu - proszę o kontakt na PW.

    0
  Szukaj w 5mln produktów