Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Sampler Akai MPC 1000v2 - nie wstaje po zmianie firmware`u

neckuno 29 Lis 2013 12:08 1590 4
  • #1 29 Lis 2013 12:08
    neckuno
    Poziom 10  

    Witam serdecznie kolegów z forum.
    Posiadam sampler MPC1000, który niestety ostatnio sam na własne życzenie pochowałem, a stało się to w następujący sposób. Standardowo korzystałem z softu Free JJOS, który spisywał się doskonale. Pewnego dnia przyszedł mi do głowy głupi pomysł, na komputerze otworzyć plik .bin (który służy do zmiany oprogramowania w samplerze) za pomocą notepada. Moim oczom ukazały się różne linijki z krzaczkami oraz z różnymi komendami tekstowymi (które wyświetlają się na samplerze w trakcie pracy). Ja chcąc być mądry i kreatywny zmieniłem treść jednego słowa, które było w języku angielskim, na jego odpowiednik w języku polskim. Zapisałem zmiany w pliku .bin, skopiowałem na kartę CF, którą umieściłem w MPC po czym wykonałem procedurę update`u firmware`u. Ku mojemu zdziwieniu proces przebiegł prawidłowo o czym poinformował mnie komunikat "Update successful, please turn of and back on device" co też uczyniłem. Jaki był efekt? Po uruchomieniu sprzętu na ekranie nie ma nic więcej prócz podświetlenia. Osobiście doszedłem do wniosku, że to był z mojej strony głupi pomysł bo nie pomyślałem, że nadpisując plik w postaci .bin zmieniłem zupełnie jego strukturę, jednak zdziwiłem się, że nie ma czegoś takiego jak weryfikacja sumy kontrolnej po procesie wgrywania, co uniemożliwiło by wgranie niewłaściwego lub uszkodzonego oprogramowania.

    Trochę się rozpisałem, ale chciałbym przestrzec ludzi przed podobnymi pomysłami.
    Próbowałem przywracać urządzenie do ustawień fabrycznych (factory reset - klawisz "Erase" w momencie uruchamiania) jak również manualnego wgrywania firmware (klawisz "Window" w momencie uruchamiania), jednak to nie skutkuje gdyż sam proces flash`owania prawdopodobnie wymaga aby system był załadowany do pamięci. Znalazłem w instrukcji serwisowej, że istnieje przyrząd pod nazwą "MPC1000 Jig PC Flash Rom", który się wpina w złącze diagnostyczne urządzenia - przy jego pomocy mógłbym przywrócić urządzenie do życia, jednak prawdopodobnie takie rzeczy mają tylko autoryzowane serwisy AKAI, których u nas brak.

    Teraz pytania do kolegów.
    Czy wylutowanie kości rom z płyty głównej urządzenia i zaprogramowanie jej firmware`em zgranym z kości sprawnego urządzenia przyniosło by pozytywny efekt oraz czy jest ktoś na forum kto podjął by się takiego wyzwania? Sam nie byłbym w stanie tego zrobić gdyż nie mam ani odpowiedniego programatora, ani porządnej stacji lutowniczej (kość jest niestety typu SMD) ani drugiej sprawnej MPC. A może istnieje inny sposób aby poradzić sobie z moim problemem?

    Mam nadzieję, że nikogo nie zmęczyłem tym długim opisem, ale chciałem opisać jasno i przejrzyście czego dotyczy mój problem.

    Proszę o pomoc i serdecznie pozdrawiam!

    0 4
  • #2 03 Gru 2013 16:00
    q-link
    Poziom 7  

    A kontrolki się podświetlają jak podczas normalnej pracy empecetki?
    Spróbuj może przytrzymać shift i pokręcić jogiem tak jak się zmienia jasność ekranu, będziemy wiedzieli czy w ogóle jest żywa czy może padł tylko moduł odpowiedzialny za wyświetlanie. Jeśli tak mógłbyś spróbować może na "ślepo" wgrać jeszcze raz JJOS'a, nawet pokusiłbym się o wgranie wersji płatnej bez możliwości zapisu i później powrotu do JJOS Free.

    0
  • #3 04 Gru 2013 21:15
    neckuno
    Poziom 10  

    Witam,

    Cieszę się, że w końcu ktoś odpisał na mój temat bo jest jakaś mała nadzieja :)
    Jeśli chodzi o same kontrolki to niestety nie świecą, gdyby tak było to system by startował i faktycznie mógłbym zrobić coś na ślepo. Wydaje mi się, że to nie moduł od wyświetlania i sprawa jest nieco grubsza, próbowałem ustawić kontrast ale bezskutecznie. Mogę dodać jeszcze, że mam podłączony własnoręcznie dysk 2,5 cala. Adapter zrobiłem sam lutując gniazdo mini-ide bezpośrednio do wyprowadzeń na płytce podpierając się wykazem pinów w serwisówce. Wszystko działało jak należy. W każdym razie chciałbym poinformować, że gdy włączam przycisk zasilania dysk startuje tak jak zawsze, po wyciągnięciu dysku również empecetka nie wstaje.

    0
  • #4 05 Gru 2013 08:11
    q-link
    Poziom 7  

    Polatałem trochę po stronkach i widzę że poruszyłeś temat na mpc-forums. Masz serwisówkę więc pewnie wszystkich czarów próbowałeś też. :/ kurczę nie potrafię ci pomóc niestety. Opcja resetu biosu za pomocą zwarcia jakichś nóżek procka raczej też nie wchodzi w grę. Może spróbuj napisać do autora JJOS, podejrzewam że on zanim napisał ten system, kilkanaście razy też uwalił swój sprzęt. Daj znać jak coś więcej będziesz wiedział. Powodzenia!

    0
  • #5 05 Gru 2013 21:14
    neckuno
    Poziom 10  

    Kurczę też tak myślałem żeby napisać do tego gościa od JJOS czy jest jakaś możliwość żeby przywrócić moją MPC`tkę do życia, ale pomyślałem, że może mi nie odpisać bo mało kto zdradza swoje sekrety ucząc się na własnych błędach. Wiem, że ten gościu zanim sam zaczął pisać soft pod MPC pracował dla AKAI, ale postanowił stamtąd odejść i pokazać na co naprawdę stać te maszyny. W internecie niestety echo jeśli chodzi o ingerencję w software tych samplerów. No ale nic, trzeba będzie spróbować napisać, może akurat. Intryguje mnie jeszcze to gniazdo diagnostyczne, które znajduje się obok slotu od ramu. Ciekawe czy zwieranie poszczególnych pinów w gnieździe nie pozwala na wymuszenie jakieś trybu serwisowego/ukrytych opcji diagnostycznych tak jak według serwisówki czyni to ten magiczny PC Jig Flash ROM. Oczywiście jak uda mi się coś wymodzić sensownego to dodam jakiegoś posta tak dla potomnych :)

    Pozdrawiam

    0