Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Debian 7 - Serwer VPN PPTPD działa jak chce

04 Gru 2013 22:55 975 1
  • Poziom 14  
    Witam,
    W poniedziałek został uruchomiony u klienta serwer VPN w oparciu o PPTPD dla około 30 klientów zastępując serwer VPN na routerze CISCO który nie dawał już rady.

    Wszystko zrobiono na podstawie wypadkowej wielu instrukcji dostępnych w necie i na pierwszy rzut oka działał bez zarzutów.

    Po chwili okazało się że kilku klientów nie mogło się zalogować na swoje stare hasła ale po zmianie hasła na inne już działało.

    Jest jeden klient który gdy był router CISCO logował się zawsze bez problemów a przez ostatnie 2 dni udało mu się tylko raz. Otrzymuje komunikaty 619 i 807. Jest jeszcze kilka osób które mają takie problemy raz na 2-3 próby logowania.

    Serwer rackowy SUN nie jest przeciążony - CPU rzadko poza 1% wychodzi. Równolegle pracuje niewięcej jak 2-3 osoby na VPN a łącze to symetryk 6Mbps na netii.


    pptp-options:
    name pptpd
    refuse-pap
    refuse-chap
    refuse-mschap
    require-mschap-v2
    require-mppe-128
    ms-dns 192.168.14.102
    proxyarp
    nodefaultroute
    lock
    nobsdcomp


    pptpd-conf:
    localip 192.168.0.1
    remoteip 192.168.20.1-100



    chap-secrets (składnia)
    user pptpd pass *


    /var/log/messages
    Jedyne co mogłoby być niepokojące to kilka sekcji o kształcie:

    Dec 4 20:24:38 x-Router pppd[2800]: Plugin /usr/lib/pptpd/pptpd-logwtmp.so loaded.
    Dec 4 20:24:38 x-Router pppd[2800]: pppd 2.4.5 started by root, uid 0
    Dec 4 20:24:38 x-Router pppd[2800]: Using interface ppp1
    Dec 4 20:24:38 x-Router pppd[2800]: Connect: ppp1 <--> /dev/pts/1
    Dec 4 20:24:38 x-Router pppd[2800]: Hangup (SIGHUP)
    Dec 4 20:24:38 x-Router pppd[2800]: Modem hangup
    Dec 4 20:24:38 x-Router pppd[2800]: Connection terminated.
    Dec 4 20:24:38 x-Router pppd[2800]: Exit.

    IPTABLES na INPUT ma tylko dwa porty otwarte:
    ACCEPT tcp -- anywhere anywhere tcp dpt:ssh
    ACCEPT tcp -- anywhere anywhere tcp dpt:1723




    Co mogę spr? Reinstalować? Doinstalować? Zmienić?

    Ma ktoś jakieś pomysły lub chociaż podejrzenia?

    dziekuję
  • Poziom 19  
    Sprawdzałeś z wyższym MTU?