Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Konfiguracja FuseBitów do SD2IEC

J2 06 Gru 2013 17:59 675 0
  • #1 06 Gru 2013 17:59
    J2
    Poziom 8  

    Witam. Mam problem z zaprogramowaniem Atmega644p. Tworzę ten SD2IEC do Commodore 64. Pomyślnie wgrałem plik HEX, lecz mam problem z FuseBitami. Wszystkie potrzebne pliki znajduja się tutaj Znalazłem tam taką informację:

    # This file is included in the main sd2iec Makefile and also parsed
    # into autoconf.h.

    CONFIG_MCU=atmega644p
    CONFIG_LINKER_RELAX=n
    CONFIG_MCU_FREQ=8000000
    CONFIG_BOOTLOADER=y
    CONFIG_BOOT_DEVID=0x5053524c
    CONFIG_UART_DEBUG=n
    CONFIG_COMMAND_CHANNEL_DUMP=n
    # In case someone added a crystal to his board
    CONFIG_TURBODISK=y
    CONFIG_JIFFY_ASM=y
    CONFIG_FC3=y
    CONFIG_DREAMLOAD=y
    CONFIG_HARDWARE_VARIANT=3
    CONFIG_HARDWARE_NAME=mmc2iec
    CONFIG_SD_AUTO_RETRIES=10
    CONFIG_SD_DATACRC=y
    CONFIG_ERROR_BUFFER_SIZE=46
    CONFIG_COMMAND_BUFFER_SIZE=120
    CONFIG_BUFFER_COUNT=6
    CONFIG_EEPROM_SIZE=512
    CONFIG_EEPROM_OFFSET=512
    CONFIG_MAX_PARTITIONS=2

    Są to właśnie chyba dane do skonfigurowania FuseBitów, tylko jak ja mam to ustawić? Nie znam się na tym, a szybko chciałbym zbudować wyżej wskazany projekt, Prosiłbym o informację, co muszę pozmieniać w domyślnych ustawieniach FuseBitów Atmega644p lub jeszcze lepiej gotową informację o: lfuse, hfuse i efuse.
    Bardzo proszę o pomoc.

    0 0