Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

NAS QNAP i Synology - odzyskanie danych

Janusz 18 Gru 2013 02:37 4116 22
  • #1 18 Gru 2013 02:37
    Janusz
    Poziom 26  

    Mam kilka dysków z serwerów NAS - QNAP i Synology. Dyski nie pracowały w RAID.
    Dyski zostały ponownie sformatowane w NAS ( ponownie zainicjalizowane i utworzone nowe partycje ext4), dane nie nadpisane. Okazało się, że kopia zapasowa zamiast na dysku zewnętrznym za każdym razem zapisywała się na dysku wewnętrznym ?!
    Dane odzyskuję programem R-Studio pod Windowsem.
    Program znajduje pliki jedynie "po rozszerzeniach", "stare" partycje są nie do odtworzenia.
    Najbardziej zależy mi na zdjęciach - owszem program wszystkie je znajduje i odzyskuje z poprawną wielkością pliku jednak poprawnie wyświetlają się jedynie miniaturki.
    Zdjęcia po otwarciu są nieczytelne
    Czy jest sposób by odzyskać prawidłowe pliki?

    0 22
  • #3 18 Gru 2013 09:50
    helmud7543
    Poziom 42  

    Skoro nie jesteś pewien, gdzie się zapisywała kopia, to znaczy, że nie ma pewności czy dane nie zostały nadpisane. Jak R-Studio określa stan znalezionych partycji (jakim kolorem)?

    0
  • #5 18 Gru 2013 12:23
    Janusz
    Poziom 26  

    Format zdjęć jpg
    Kopia zapisywała się na pracujących dyskach, gdzie dane były wciąż dostępne, więc pliki nie mogły się nadpisywać.
    Zainstalowany był ponownie program obsługujący NAS a on zajmuje znikomą część dysku

    0
  • #6 23 Gru 2013 03:57
    Janusz
    Poziom 26  

    Odzyskiwałem wiele razy dane z dysków sformatowanych pod Windowsem i nie było nigdy problemów ze zdjęciami. Jeżeli się dało odzyskać to zawsze były to pliki prawidłowe.
    Tutaj żaden program nie daje rady.
    Czy nie dlatego, że programy 'Windowsowe" jednak mają problem z prawidłowym czytaniem partycji ext3 czy ext4?

    0
  • #7 23 Gru 2013 09:31
    michal_aniol
    Poziom 32  

    Windowsy mają problem, ale jak skanujesz po RAW to nie ma to znaczenia.

    Podejrzewam że jednak miałeś założonego RAID na tym Qnap i dlatego jest problem z odzyskaniem poprawnych danych. Jeśli to się potwierdzi, najpierw trzeba złożyć RAID, a potem dopiero wykopiować dane.

    0
  • #8 24 Gru 2013 06:32
    Janusz
    Poziom 26  

    Na pewno nie było RAID. Tego jestem pewien.
    Były zawsze dwa dyski z jednym Woluminem o rozmiarze sumy ich pojemności, na drugim NAS były to pojedyncze dyski.
    Do tej pory "maglowałem" jeden z dysków, dane owszem są, ale praktycznie wszystkie uszkodzone.
    Dysk jest sprawny, status SMART bez zastrzeżeń.
    Na dniach biorę się za następne.

    0
  • #10 24 Gru 2013 23:31
    Janusz
    Poziom 26  

    Miniaturki wyświetlają się poprawne.
    Rozmiar zdjęć prawidłowy
    Zdjęcia wyglądają jak pocięte w poziomie i te pasy poprzesuwane względem siebie.
    Na niektórych tylko połowa takiej treści, dolna połowa w kolorze zielonym.

    0
  • #11 25 Gru 2013 00:29
    michal_aniol
    Poziom 32  

    Te poziome pasy przesunięte względem siebie są z tego samego zdjęcia czy posklejane np. dwa różne?

    0
  • #12 25 Gru 2013 04:53
    Janusz
    Poziom 26  

    Z tego samego zdjęcia.
    Wiele z nich po otwarciu jak już wspomniałem w dolnej części jest w ogóle nieczytelna. Zielona treść lub kolorowe pasy widoczne jak obraz bez braku synchronizacji poziomej w starym telewizorze :cry:
    Trudno wyczuć czy jest to w całości treść tego samego zdjęcia, ale myślę że tak.
    Na wielu z nich są na całości pasy z poprzesuwaną treścią, ale na 100% z tego samego pliku.

    0
  • #13 25 Gru 2013 11:14
    michal_aniol
    Poziom 32  

    Hmm, wygląda jakby bloki danych zostały przesunięte o pewien offset.
    W przypadku pamięci flash tak często wyglądają zdjęcia, gdy nie ma korekcji ECC.

    0
  • #14 08 Lut 2019 18:52
    DeNiro83
    Poziom 9  

    Hi wszytkich. Pomoże ktoś? Mam TS-470PRO martwy :'( (brak opcji naprawy QNAP, FEN, EPA). Próbuje odzyskać z niego dane niestety był o najprawdopodobniej w RAID 6 (odczyt z mdadm)

    NAS QNAP i Synology - odzyskanie danych

    I tak jak kolega wyżej, nie mam pojęcia co wpisać w programie R-Studio w pola:
    - "number of rows"
    - block size

    Pomożecie?

    0
  • #15 09 Lut 2019 12:14
    kaleron

    Poziom 23  

    Dwa najbardziej prawdopodobne powody uszkodzeń zdjęć, to częściowe nadpisanie lub ich fragmentacja. Metadane starej struktury logicznej zostały zniszczone, więc program próbuje odszukać same pliki, a że robi to na oślep - skutkiem są uszkodzenia.

    A jeśli chodzi o drugie zagadnienie - parametry macierzy RAID można ustalić przeglądając zawartość dysków w hex-edytorze. Najłatwiej wykorzystując jakieś fragmenty danych, które ładnie wyglądają w ASCII - np. rekordy MFT.

    0
  • #16 09 Lut 2019 16:50
    DeNiro83
    Poziom 9  

    Rozumiem. Częściowo. U nie w sumie te dane nie zostały skasowane. Dyski wyglądają na ok, tylko urządzenie fizycznie się rozjechało. Jak podejrzeć dane na tych dyskach? Potrzebuje dosłownie jeden folder. A programy do odzyskiwania danych pokazują mi skasowane pliki z tego dysku.

    0
  • #17 11 Lut 2019 15:31
    kaleron

    Poziom 23  

    W macierzy dane masz rozproszone po dyskach, więc najpierw musisz poskładać macierz. Jakich programów używasz?
    W macierzy masz paski o stałej długości. Dane dzielone są na porcje odpowiadające rozmiarowi paska i zapisywane po kolei na kolejne dyski, z tym, że dodatkowo wyliczane są wartości pozwalające na odtworzenie brakującej zawartości w przypadku awarii dysku (w przypadku RAID 6 dwóch dysków). Jeśli znajdziesz sobie jakiś fajny fragment danych w hex-edytorze, to możesz sobie ustalić jakiej wielkości fragmenty są spójne, zobaczyć, gdzie urwany fragment jest kontynuowany i odsiać sobie informację nadmiarową. Na tej podstawie możesz sobie ustalić kolejność dysków, rozmiar paska i sposób synchronizacji macierzy. Potem te parametry możesz wpisać w jakiś automat, który złoży Ci obraz struktury logicznej. Skanowanie dysków pojedynczo różnymi programami tylko namąci Ci w głowie,

    0
  • #18 11 Lut 2019 20:32
    DeNiro83
    Poziom 9  

    Bardzo dziękuje za pomoc. Może to jakoś rozjaśni sytuację?
    NAS QNAP i Synology - odzyskanie danych NAS QNAP i Synology - odzyskanie danych NAS QNAP i Synology - odzyskanie danych

    0
  • #19 11 Lut 2019 20:43
    kaleron

    Poziom 23  

    Znasz parametry tej macierzy, czy po prostu podpiąłeś dyski i uruchomiłeś program? Bo mi się to co widzę na pierwszy rzut oka nie podoba.
    Jesteś w stanie zidentyfikować na którymś z tych dysków MBR? Niech to będzie nasz punkt wyjścia. Informacje z tablic GPT powinny nam pozwolić na ustalenie rodzaju i położenia partycji w adresacji LBA macierzy. Odnajdując partycje będziemy mieli jakieś dane, które ułatwią nam ustalenie parametrów macierzy. Musisz pamiętać, że adresacja LBA macierzy jest czymś innym od adresacji LBA poszczególnych dysków.

    0
  • #20 12 Lut 2019 00:43
    DeNiro83
    Poziom 9  

    Podpiełem dyski i zgodnie na moje zapytanie do QNAP na temat sprawdzenia systemu RAID otrzymałem:

    "Dzień dobry, niestety takie informację trzeba odczytać z dysku za pomocą mdadm.
    Poniżej przykład:

    mdadm -E /dev/sda3
    /dev/sda3:
    Magic : a92b4efc
    Version : 1.0
    Feature Map : 0x0
    Array UUID : 2d12ac04:a56ae82d:021ce94e:0022b012
    Name : 3
    Creation Time : Thu Dec 20 07:00:04 2018
    Raid Level : raid1
    Raid Devices : 2

    Avail Dev Size : 448952328 (214.08 GiB 229.86 GB)
    Array Size : 202028544 (192.67 GiB 206.88 GB)
    Used Dev Size : 404057088 (192.67 GiB 206.88 GB)
    Super Offset : 448952464 sectors
    Unused Space : before=0 sectors, after=44895368 sectors
    State : active
    Device UUID : 310872c6:750f3b37:a548cc53:60e32a0d

    Update Time : Thu Feb 7 12:50:43 2019
    Bad Block Log : 512 entries available at offset -8 sectors
    Checksum : a217f663 - correct
    Events : 38


    Device Role : Active device 0
    Array State : AA ('A' == active, '.' == missing, 'R' == replacing)"

    wysłałem wiec odpowiedz (pierwszy mój post w tym temacie).

    Wygląda na to że to RAID 6
    NAS QNAP i Synology - odzyskanie danych

    Powinny być ustawione inaczej?

    0
  • #21 12 Lut 2019 11:14
    kaleron

    Poziom 23  

    Tak - powinny być ustawione inaczej. Masz do wyboru zmieniać parametry macierzy na tzw. pałę albo samodzielnie ustalić parametry macierzy,.
    W tym drugim wariancie odłóż na razie automaty i użyj hex-edytora, bo bez przejrzenia zawartości dysków do niczego nie dojdziemy.
    Na razie wiesz, tylko to, co wyrzucił Ci program. W dodatku nie możesz być tego na 100 % pewny. Dziwne jest to, że masz w macierzy 4 dyski po 4 TB, a program nas informuje o macierzy 8 TB i dostępnych 4 TB. Może masz tę macierz skonfigurowaną na połowie dysków? A może coś się rozjechało i program kłamie? I prawdopodobnie te dyski masz w złej kolejności. Pierwszym dyskiem powinien być dysk zawierający MBR. Ty zaczynasz od Reeda- Solomona.
    64k = 128 sektorów LBA Sektory numerujemy od zera, więc LBA0 drugiego dysku powinno odpowiadać LBA128 macierzy.

    0
  • #22 12 Lut 2019 12:01
    DeNiro83
    Poziom 9  

    Jakąś zawartość widzę ale niestety nie najważniejszą, Co potrzebujemy odczytać hex-em?

    0
  • #23 12 Lut 2019 12:22
    kaleron

    Poziom 23  

    Najważniejszy jest w tej chwili MBR i tablice GPT. Na tej podstawie możesz określić typ, ilość i rozmieszczenie partycji.. Potem możesz sobie przeskanować te dyski i spróbować przyporządkować znalezione partycje do tego, co ustalisz na podstawie tablic GPT. Wtedy możesz ułożyć dyski we właściwej kolejności i jest duża szansa, że struktury logiczne Ci się same poskładają. Jeśli będzie coś nie tal, będziemy weryfikować rozmiar paska, a jak i to nie pomoże - pozostałe parametry macierzy.

    0