Elektroda.pl
Elektroda.pl
X
Relpol
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Nieprawidłowa praca tranzystorów bipolarnych przy regulacji napięcia 0-320V

Joker2 01 Sty 2014 18:33 3690 9
  • #1 01 Sty 2014 18:33
    Joker2
    Poziom 23  

    Witam wszystkich w Nowym Roku!

    Konstruuje liniowy regulator napięcia 0-320V na tranzystorach 2SC3886, którego obciążeniem jest grzałka. Końcówka mocy wygląda klasycznie. Jest to 8 tranzystorów z rezystorami wyrównującymi pracujących w układzie wspólnego kolektora (dla wspólnego emitera też próbowałem i występuje dokładnie ten sam problem).

    Schemat:
    Nieprawidłowa praca tranzystorów bipolarnych przy regulacji napięcia 0-320V

    Mój problem polega na tym, że powyżej napięcia zasilania 200V i prądu obciążenia powyżej około 1A końcówka mocy przewodzi i nie ma możliwości regulacji. Zwieram wtedy nawet wszystkie 8 baz tranzystorów do masy, a ona i tak przewodzi. Dopiero po wyłączeniu napięcia zasilania i ponownym włączeniu końcówka pracuje poprawnie i reguluje w niewielkim zakresie, powyżej którego znowu zaczyna przewodzić. Jeśli umieszczę równolegle z grzałką kondensator o niewielkiej pojemności (10-20u), aby wyeliminować możliwość wzbudzenia, to po próbie regulacji pali się któryś z tranzystorów końcówki.

    Układ zasilam z sieci po mostku i kondensatorze filtrującym, a napięcie zasilania reguluje za pomocą autotransformatora. Tranzystory są umieszczone na wydajnych radiatorach, których temperatura nie przekracza 40°C. Jeśli wartość napięcia skutecznego na wyjściu autotransformatora jest mniejsza niż 200V, to układ działa bardzo ładnie w całym zakresie.

    Podejrzewałem, że nie mieszczę się w zakresie pracy tranzystorów (charakterystyka napięcia kolektor-emiter w funkcji prądu kolektora, którą umieszczam), ale wszystko się zgadza i zgodnie z założeniami producenta przy 300V powinna wytrzymać około 4A.
    Nieprawidłowa praca tranzystorów bipolarnych przy regulacji napięcia 0-320V

    Rozrysowałem to sobie na wykresie:
    Nieprawidłowa praca tranzystorów bipolarnych przy regulacji napięcia 0-320V

    Na niebiesko cha-ka tranzystora wg producenta, na czerwono cha-ka w rzeczywistości przy obciążeniu 0,1A na tranzystor (czyli 0,8A dla całej końcówki) i napięciu zasilania 320V, także zapas jest bardzo dużo.

    Jakieś sugestie? Coś robię źle, bądź w ogóle nie zauważam jakiegoś problemu? Dodam, że grzałka ma pracować w urządzeniu bardzo wrażliwym na zakłócenia, także sterowanie za pomocą tyrystorów lub przetwornicy odpada (ewentualnie sterowanie grupowe tyrystorów i takie rozwiązanie prawdopodobnie zastosuje, jeśli nie znajdę rozwiązania wyżej opisanego problemu).

    Z góry dziękuję za pomoc i pozdrawiam.

    0 9
  • Relpol
  • #2 01 Sty 2014 18:57
    archanoid
    Poziom 25  

    Witam. Kolego, po co przy tej mocy pchasz się w regulator liniowy i jeszcze te napięcie. A nie lepiej będzie ci zrobić regulację PWM na 555 i przez driver najlepiej izolowany sterować jakimś tranzystorem IGBT.

    0
  • #3 01 Sty 2014 18:57
    jdubowski
    Specjalista - urządzenia lampowe

    Joker2 napisał:
    Konstruuje liniowy regulator napięcia 0-320V na tranzystorach 2SC3886, którego obciążeniem jest grzałka. Końcówka mocy wygląda klasycznie. Jest to 8 tranzystorów z rezystorami wyrównującymi pracujących w układzie wspólnego kolektora (dla wspólnego emitera też próbowałem i występuje dokładnie ten sam problem).

    Schemat:


    Na schemacie widzę układ wspólnego kolektora, i brakuje tam rezystora między emiterem a gorącą końcówka obciążenia.

    Joker2 napisał:
    Mój problem polega na tym, że powyżej napięcia zasilania 200V i prądu obciążenia powyżej około 1A końcówka mocy przewodzi i nie ma możliwości regulacji. Zwieram wtedy nawet wszystkie 8 baz tranzystorów do masy, a ona i tak przewodzi.


    Jakie jest napięcie na obciążeniu w takim stanie? Raczej nie większe niz 7V...

    Jak wygląda temperatura tranzystorów i jakiego radiatora używasz?

    Joker2 napisał:
    Podejrzewałem, że nie mieszczę się w zakresie pracy tranzystorów (charakterystyka napięcia kolektor-emiter w funkcji prądu kolektora, którą umieszczam), ale wszystko się zgadza i zgodnie z założeniami producenta przy 300V powinna wytrzymać około 4A.


    4A przy 300V? Policzyłeś moc traconą w tranzystorze?

    0
  • Relpol
  • #4 01 Sty 2014 19:25
    trymer01
    Moderator Projektowanie

    Ten wykres SOAR to skąd? - bo chyba nie jest on z datasheet 2SC3886 ? Jeśli tak to daj link do tego datasheet.
    A nawet jeśli, to dla Uce=300V masz tu Icmax= 0,1A (czytaj wykres dla DC) co dla 8 szt teoretycznie dałoby 0,8A, w praktyce trzeba to zmniejszyć do bezpiecznego 0,5A (nierówny rozpływ prądów w poszczególnych tranzystorach).

    Brak opornika miedzy bazami tranzystorów Q3-Q10 a gorącym końcem grzałki, podobnie oporniki B_E dla Q1 i Q2.

    Obejrzyj to oscyloskopem, czy się nie wzbudza.

    0
  • #5 01 Sty 2014 19:42
    Joker2
    Poziom 23  

    archanoid napisał:
    Witam . Kolego po co przy tej mocy pchasz się w regulator liniowy i jeszcze te napięcie. A nie lepiej będzie ci zrobić regulację PWM na 555 i przez driver najlepiej izolowany sterować jakimś tranzystorem IGBT .


    Zadaniem regulatora jest nagrzewanie do zadanej temperatury komory, w której bada się próbki piezoelektryczne. Próbowałem sterować triakiem (fazowo) i zakłócenia były 10x większe od sygnału pomiarowego. Przy regulacji PWM będzie podobnie...

    jdubowski napisał:
    Joker2 napisał:
    Konstruuje liniowy regulator napięcia 0-320V na tranzystorach 2SC3886, którego obciążeniem jest grzałka. Końcówka mocy wygląda klasycznie. Jest to 8 tranzystorów z rezystorami wyrównującymi pracujących w układzie wspólnego kolektora (dla wspólnego emitera też próbowałem i występuje dokładnie ten sam problem).

    Schemat:


    Na schemacie widzę układ wspólnego kolektora, i brakuje tam rezystora między emiterem a gorącą końcówka obciążenia.


    Tak brakuje tam rezystora. Z tym, że jak mi ta końcówka zaczyna przewodzić (powyżej 200V) to nie pomaga nawet zwarcie na krótko emitera tranzystora sterującego z gorącą końcówką obciążenia.


    jdubowski napisał:
    Joker2 napisał:
    Mój problem polega na tym, że powyżej napięcia zasilania 200V i prądu obciążenia powyżej około 1A końcówka mocy przewodzi i nie ma możliwości regulacji. Zwieram wtedy nawet wszystkie 8 baz tranzystorów do masy, a ona i tak przewodzi.


    Jakie jest napięcie na obciążeniu w takim stanie? Raczej nie większe niz 7V...

    Jak wygląda temperatura tranzystorów i jakiego radiatora używasz?


    Napięcie na obciążeniu w takim stanie jest zbliżone do napięcia zasilania (około 208V, poniżej chodzi dobrze). Z tym że jego przebieg na oscyloskopie bardziej przypomina widmo szerokie na około 50V, jakby coś się wzbudzało, stąd też wpadłem na pomysł dokładania kondensatorów baza-emiter, co nic nie pomagało i kolektor-emiter, co spowodowało spalenie któregoś z tranzystorów (za każdym razem). Tranzystory zachowują się jak wysterowane. I nie ma możliwości obniżenia napięcia.

    Temperatura radiatorów nie przekracza 40°C przy normalnej pracy (poniżej 200V i prądzie dochodzącym do około 2A - przy tym napięciu większy prąd ogranicza rezystancja grzałki).

    Poniżej zdjęcie zastosowanych radiatorów:
    Nieprawidłowa praca tranzystorów bipolarnych przy regulacji napięcia 0-320V





    Na zdjęciu są tylko 4 tranzystory. W tej chwili ilość jest podwojona.

    jdubowski napisał:
    Joker2 napisał:
    Podejrzewałem, że nie mieszczę się w zakresie pracy tranzystorów (charakterystyka napięcia kolektor-emiter w funkcji prądu kolektora, którą umieszczam), ale wszystko się zgadza i zgodnie z założeniami producenta przy 300V powinna wytrzymać około 4A.


    4A przy 300V? Policzyłeś moc traconą w tranzystorze?


    Jak przez obciążenie będzie płynąć 4A, to na nim odłoży się całe napięcie, a na tranzystorach kilka woltów. Największe straty są w połowie (połowa napięcia na tranzystorach i połowa na odbiorniku), wtedy straty mocy to około 250W, z czym układ chłodzenia radzi sobie bez problemu.

    trymer01 napisał:
    Ten wykres SOAR to skąd? - bo chyba nie jest on z datasheet 2SC3886 ? Jeśli tak to daj link do tego datasheet.
    A nawet jeśli, to dla Uce=300V masz tu Icmax= 0,1A (czytaj wykres dla DC) co dla 8 szt teoretycznie dałoby 0,8A, w praktyce trzeba to zmniejszyć do bezpiecznego 0,5A (nierówny rozpływ prądów w poszczególnych tranzystorach).

    Brak opornika miedzy bazami tranzystorów Q3-Q10 a gorącym końcem grzałki, podobnie oporniki B_E dla Q1 i Q2.

    Obejrzyj to oscyloskopem, czy się nie wzbudza.


    No właśnie, o to (pogrubione) też chciałem zapytać. Czy możliwe jest, że te tranzystory mają tak rozbieżne bety, że część jest obciążona dużo bardziej od pozostałych? Wykres z datasheeta link: http://pdf.datasheetcatalog.com/datasheet/sanyo/2SC3688.pdf tranzystory 2SC3688 w pierwszym poście przekręciłem nazwę...

    A ta druga charakterystyka rozrysowana przeze mnie w warunkach w jakich pracuje. Zgadza się przy Uce=300V mam Icmax=0,1A, ale przy max obciążeniu na złączu CE jest kilka woltów, a wysokie napięcie występuje na początku charakterystyki, gdzie prąd jest niewielki.

    Natomiast na oscyloskopie, no właśnie... wzbudza się i to bardzo.

    0
  • #6 01 Sty 2014 19:58
    jarek_lnx
    Poziom 43  

    Cytat:
    Zwieram wtedy nawet wszystkie 8 baz tranzystorów do masy, a ona i tak przewodzi.
    Chcesz powiedzieć że na kolektorze jest 320V, ma bazach 0 a na emiterach też powyżej 200V.
    To bardzo interesujące zjawisko, na sprawnym ani nawet częściowo uszkodzonym tranzystorze nie da się tego osiągnąć, tranzystory (wszystkie) musiały by zostać całkowicie zniszczone i to w dosyć nietypowy sposób (zwarcie C-E z rozwarciem bazy), nie jest prawdopodobne żeby wykazywały pozory poprawnej pracy.
    Skoro układ trochę działa podejrzewam ze jest jakiś gruby błąd, np układ niezgodny ze schematem, albo miernik podłączony nie tam gdzie trzeba.

    Cytat:

    Dodam, że grzałka ma pracować w urządzeniu bardzo wrażliwym na zakłócenia, także sterowanie za pomocą tyrystorów lub przetwornicy odpada
    Jak bardzo wrażliwym (µV? pA?) i w jakim paśmie częstotliwości?


    Cytat:
    Natomiast na oscyloskopie, no właśnie... wzbudza się i to bardzo.

    Co podajesz na wejście (bazę pierwszego tranzystora?)

    0
  • #7 01 Sty 2014 20:08
    archanoid
    Poziom 25  

    Kolego . Piszesz że przy przy sterowaniu fazowym miałeś duże zakłócenia. A jak dokonujesz pomiaru ?. Nie pisałem o sterowaniu fazowym gdyż aby uniknąć zakłóceń pomiar powinien być zsynchronizowany z sterowaniem . Najprościej pomiar dokonywany jest przy przejściu napięcia sieci przez zero gdy nie płynie prąd przez obciążenie . Jakie masz grzałki i do jakiej temperatury nagrzewasz komorę ?.

    0
  • #8 01 Sty 2014 20:24
    jdubowski
    Specjalista - urządzenia lampowe

    Jeśli się wzbudza to trzeba zastosować starą nmetodę walki ze wzbudzeniem - kondensator między bazą a kolektorem. przy wzbudzeniu miernik cyfrowy zaś może pokazywać głupoty, stąd twoje pomiary wykazujące napięcie tam gdzie go być może nie ma.
    Inna uwaga - jeśli PWM i sterowanie fazowe wykluczasz ze względu na zakłócenia to jest jedna wybitnie preferowana w takim przypadku metoda - sterowanie grupowe.

    1
  • #9 01 Sty 2014 20:24
    trymer01
    Moderator Projektowanie

    Joker2 napisał:

    No właśnie, o to (pogrubione) też chciałem zapytać. Czy możliwe jest, że te tranzystory mają tak rozbieżne bety, że część jest obciążona dużo bardziej od pozostałych? Wykres z datasheeta link: http://pdf.datasheetcatalog.com/datasheet/sanyo/2SC3688.pdf tranzystory 2SC3688 w pierwszym poście przekręciłem nazwę...

    To nie zależy od bety, ale od charakterystyki wejściowej Ic=f(Ube).

    Jeśli się wzbudza to pomiar napięć stałych (multimetrem) daje bzdurne wyniki, w rodzaju tych 200V - bo napięcia nie są stałe. Tak więc te pomiary nic Ci nie dają, wręcz Cię dezinformują. Tylko oscyloskop.

    A tego to ja nie rozumiem:
    Joker2 napisał:
    A ta druga charakterystyka rozrysowana przeze mnie w warunkach w jakich pracuje. Zgadza się przy Uce=300V mam Icmax=0,1A, ale przy max obciążeniu na złączu CE jest kilka woltów, a wysokie napięcie występuje na początku charakterystyki, gdzie prąd jest niewielki.

    Jeśli to regulator napięcia, to zadajesz mu na wejściu nominalne 320VDC ( a nie regulowane jak w próbach z autotransformatorem) a napięciem sterującym ustalasz napięcie wyjściowe.
    Domyślam się że grzałka 1kW dla napięcia 230V, więc ma oporność 53Ω i nie możesz jej dać więcej niż 230V (tylko mniej). Dla Uwy =230V, moc na tranzystorach P=(320-230)x4,35A=390W.

    Ja też sądzę, że wybrałeś sobie niewłaściwy sposób - należało zastosować triak z wyzwalaniem w zerze, regulacja grupowa.

    0
  • #10 16 Sty 2016 23:06
    jhusak
    Poziom 12  

    Odgrzeję temat, bo chyba warto. Wg mnie takie podejście (w pierwszym poście) jest zbyt na siłę. Nigdy bym nie zastosował takiego rozwiązania. Najlepsze są rozwiązania najprostsze. Najprostsze to sterowanie triakiem - właściwie nie jest potrzebny radiator, albo może malutki. W grę wchodzi też zwykły przekaźnik, który można sterować bezpośrednio z nogi mikrokontrolera (zwykła atmega daje 50 ma na nogę, co wystarczy do załączenia przekaźnika - większość właśnie tyle prądu pobiera przy 5V sterowaniu) . Taki przekaźnik będzie działał wieczność, ale będzie cykał.

    Grzałka to układ rezystancyjny z bardzo dużą inercją cieplną, więc PWM tu jak najbardziej zadziała i nie będzie wprowadzał zakłóceń, pod warunkiem, że wyłączamy grzałkę na czas pomiaru (jak koledzy wspomnieli). Częstotliwość bazowa może być rzędu 0.1HZ .. 1 Hz, w zupełności wystarczy, wszak temperatura jest wolnozmienna. Nie ma uzasadnienia stosowanie PWM o częstotliwości większej, niż częstotliwość w sieci - to nie jest silnik czy żarówka. :)


    Z takiej analizy wynika teza - wystarczy triak (+optotriak dla bezpieczeństwa) Reszta to logika + odpowiedni program. Schemat się upraszcza, wszystko wchodzi w pudełko od zapałek i działa bez pudła długie lata.

    A co do schematu - jest tu podstawowy błąd - tranzystory npn schodzą do masy (emiter do masy) - powinieneś użyć tranzystorów pnp. Nie pomoże wyłączanie tranzystorów poprzez ściąganie baz do masy - wówczas na bazie będzie prawie -230V . Pomyśl, co jest z napięciem na bazach względem emitera i że się to zachowuje jak dzielnik rezystorowy. Jaki jest spadek napięcia na dzielniku: spadek na tranzystorze (od praktycznie 0 do nieskończoności) + 0.27 oma / 8 i grzałce, która ma zapewne jakieś 60 omów. Czy jesteś pewien, że jest tam więcej niż 0.6v (ok. 2) przy włączeniu i poniżej 0.6V przy wyłączeniu w każdych warunkach?

    Ja widzę, że to trzeba zrobić normalnie, jeśli już iść tą drogą, czyli element wykonawczy to: zasilanie -> grzałka -> (rezystor -> tranzystor)x8 -> masa.
    Podukład sterujący też powinien mieć ustalony potencjał na bazach dzielnikami rezystorowymi, aby się właśnie nie wzbudzał i stabilnie pracował. Tego typu układów sterujących jest multum i nie jest tu wstydem skorzystać z gotowca, bo i aplikacja jest standardowa.

    Wtedy bazami tranzystorów wykonawczych sobie możemy sterować jak chcemy, wszystko działa pięknie bez grzałki, z grzałką, żarówką, itp.

    Moderowany przez trymer01:

    Regulamin, pkt 3.1.19

    0
  Szukaj w 5mln produktów