Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Czy można przyspieszyć skaner?

Agentlos 08 Kwi 2005 19:03 12402 83
  • #61 08 Kwi 2005 19:03
    WojtasJD
    VIP Zasłużony dla elektroda

    Agentlos napisał:

    Co do pomiarów to sprawdzilem te napięcie miedzy nogą 9 a masą czyli 8. Wynik to 27.1V.


    dobrze - idzie 'pelne' napiecie z zasilacza

    Cytat:

    Do silnika idzie 5 kabli.


    byc moze, ze to silnik unipolarny majacy cztery cewki - jedno wyprowadzenie to wspolne wyprowadzenia jednych koncow czterech cewek - tam pewnie idzie 27V ; pozostale cztery kabelki to drugie konce cewek idace do wyrowadzen ULNa (wykorzystane by byly 4 z 7 darlingtonow w ULN-ie).
    Gdy ULN nie jest wysterowany lub kompletnie uwalony to na kazdej tez panuje 27V.
    Gdyby plytka z ULN-em byla osobno - latwiej byloby go sprawdzic

    Cytat:

    Co masz na myśli pisząc uC? Chodzi o główny procesor?


    exactly 8-) - glowny i jedyny µ(micro)-C(controler) _skanera_.

  • #62 08 Kwi 2005 19:31
    Agentlos
    Poziom 25  

    Właśnie sprawdziłem napiecie miedzy masą a kablami idącymi do silnika. Efekt jest taki że wszystkie mają 27V... Czyli uwalony jest sterownik wózka, czy coś wcześniej może powodować, że na każdym kanale jest tyle Volt? Czy da się kupić ten element i ewentualnie jakie są jego koszta?

    Cytat:
    Gdy ULN nie jest wysterowany
    Co to znaczy wysterowany? Czy można go wysterować?

  • #63 08 Kwi 2005 20:05
    WojtasJD
    VIP Zasłużony dla elektroda

    nie koniecznie ULN musi byc uwalony; jesli nie jest wysterowany czyli nie ida impulsy z uC to jest calkiem normalne ze na wszystkich kabelkach jest 27V.
    uC podajac ne wejscie ULNa na chwile impuls wysoki zwiera na chwile jedno z wyprowadzen silnika do masy (mozliwe ze przez niewielki rezystor) powodujac krok silnika.
    W razie koniecznosci ULN powinien Cie wyniesc max 1..2zl detalicznie.

    Dalej nie napisales czy ULN jest na jednej plytce z uC. Co z napieciem zasilania uC, o przebiegu oscylatora nie wspomne. Oj przydaloby sie to zdjecie ...

  • #64 08 Kwi 2005 21:34
    Agentlos
    Poziom 25  

    Witam. Woczekaiwaniu na zdjecie wklejam do postu płytkę wykonaną w paincie. Gdy kolega da zdjęcie będzie widać jeszcze więcej. Ująłem najważniejsze elementy.

    Głupio mnie sie przyznać, lecz nie wiem jak sprawdzić to zasilanie...
    A ak na marginesie, co to są za elementy oznaczone jako "TP"?

  • Pomocny post
    #66 08 Kwi 2005 22:46
    WojtasJD
    VIP Zasłużony dla elektroda

    super fotki :wink: (nad ta wykonana w Paint-cie nie moge sie nadziwic)

    sprawdz napiecia na mniejszym 78D05 i wiekszym 7805 wzgledem masy.
    Przydaloby sie sprawdzic przebieg na nodze kwarcu (KTS12.0) :|

    TP1, TP2 - (Test Point) - punkty kontrolne dla naprawiaczy 8-)

  • #67 08 Kwi 2005 23:19
    dbd
    Poziom 15  

    mam jeszcze dośc ważną informacje :) wózek nie wróci na miejsce gdy górna pokrywa (z szybą) nie jest zatrzaśnieta. Czyli chodzi o ten czujnik, tak jak w odtwarzaczach CD - dopóki klapa jest otwarta laser sie nie właczy :) ale wystarczy oszukac czujnik ;)


    PS wie ktoś może dla czego duże Ć mi działa a małe "ci" nie?? alt działa, c działa, ale alt+c nie działa. Wie ktoś, czy mam zakładac nowy temat :roll:

  • #68 08 Kwi 2005 23:39
    WojtasJD
    VIP Zasłużony dla elektroda

    dbd napisał:
    mam jeszcze dośc ważną informacje :) wózek nie wróci na miejsce gdy górna pokrywa (z szybą) nie jest zatrzaśnieta. Czyli chodzi o ten czujnik, tak jak w odtwarzaczach CD - dopóki klapa jest otwarta laser się nie właczy :) ale wystarczy oszukac czujnik ;)


    a gdzie jest ten czujnik ? (sciagnalem 'skaner.rar' i widze tam transoptor szczelinowy na plytce wozka)

  • #69 09 Kwi 2005 00:14
    Agentlos
    Poziom 25  

    dbd - świetna fotka! Dziękuję za nią :-). Teraz to przynajmniej widać co i jak!

    Cytat:
    nad ta wykonana w Paint-cie nie moge się nadziwic
    Tak żle mi to wyszło? Babrałem się z tym 30 minut :lol: .
    Cytat:
    Przydaloby się sprawdzic przebieg na nodze kwarcu (KTS12.0)
    No będzie ciężko... Mam tylko tani miernik a raczej nim tego nie zmierzę. Ile wyniósł by mnie nowy kwarc?
    dbd - co do twojego problemu, to odinstaluj wszystkie dostępne klawiatury w opcje regionalne => języki zostaiwając tylko Polski programisty. Jeśli to nie pomoże, to możliwe jest że któryś z programów w tle wykożystuje "ć" jako skrót klawiszowy. Ja nie mogłem pisać "ą" bo mi program defragmentował RAM.
    Jeśli to nie pomoże, toznaczy że możesz miec virusika.

    Jeszcze jedno. Właśnie sprawdzilłem te tranzystory. masa to jest to szerokie u góry i środkowe na dole tak :-). Tak więc
    ten duży na:
    1 + masa => 7.6V oraz,
    2 + masa => 5.1V.
    Mały tranzystor:
    1 + masa => 7.6V
    2 + masa => 4.92V.
    Czyli praktycznie tyle samo.
    Co do tego transoptora szczelinowego w lampie czy jakos tak, to on na początek sprawdza, czy jest przejście.
    Jak jest to cofa do tyłu aż niie będzie przejścia, bo w obudowie, jest cypek w który się
    on wsuwa i zatrzymuje.

    Co do tych elementów, to czy wartości są poprawne?

  • Pomocny post
    #70 09 Kwi 2005 03:33
    WojtasJD
    VIP Zasłużony dla elektroda

    napiecia sa OK - daja po 5V

    przyjrzalem sie tez AMS34063 i elementom towarzyszacym na plycie i wychodzi ze on nie sluzy do podwyzszania napiecia dla lampy tylko do wstepnego obnizania 27V do 7.6V (przetwornica step-down) dla stabilizatorow 5V

    Cytat:
    Co do tego transoptora szczelinowego w lampie czy jakos tak, to on na początek sprawdza, czy jest przejście.
    Jak jest to cofa do tyłu aż niie będzie przejścia, bo w obudowie, jest cypek w który się
    on wsuwa i zatrzymuje.


    zgadza sie, ale dbd pisal cos o czujniku zamkniecia klapy (sam mam cos takiego, mozna informowac program zeby np automatycznie zaczal skanowanie po zamknieciu klapy), tyle ze nie czaje zwrotu "górna pokrywa (z szybą) " - wg mnie częsc z szyba normalnie jest skręcona z dolna a czescia ruchomą jest klapa (pokrywa).
    Jak jeszcze tego nie zrobiles to profilaktycznie zloz wszystko, podepnij do kompa i sprawdz.

  • #71 09 Kwi 2005 08:50
    Agentlos
    Poziom 25  

    Koledze dokładnie chodzi o odudowę z którą jest szyba, i na niej znajdyje się długi cypek, taki jak na rysunku który załączam. Co do czujnika zamkniecia klapy, to ja jak skanowałem dużo to bez górnej klapy z oświetleniem do przystawki do slajdów i nie zwracał na to uwagi, więc nie wiem o jaki czujnik chodzi, jak nie o ten co ma zatrzymać lampe aby zatrzymała się na swoim wyjściowym miejscu.
    bdb - jaki ty masz skaner? Dziwi mnie różnorodność elementów w naszych skanerach. Chyba że te lizby oznaczają nr.wyprodukowanego procesora itp. np. ja mam P98003 0038H a yt zaniast tego masz 0102H. Co to za numery? A w U9 masz 0BA8K54P a ja mam 09AD54P. Czy te numry cos oznaczają, czy to numery pożądkowe?

    I czy jeszcze coś się da zmierzyć? Czy to oznacza, że procesorma napięcie? Może kupić nowy kwarc, o mnierzyć nie da u mnie rad :-(?

  • #72 09 Kwi 2005 12:03
    WojtasJD
    VIP Zasłużony dla elektroda

    Agentlos napisał:
    Koledze dokładnie chodzi o odudowę z którą jest szyba, i na niej znajdyje się długi cypek, taki jak na rysunku który załączam.

    jak tak to rozumiem, wtedy wozek wlecialby gdzies nad plytke :wink:
    Cytat:

    np. ja mam P98003 0038H a yt zaniast tego masz 0102H. Co to za numery? A w U9 masz 0BA8K54P a ja mam 09AD54P. Czy te numry cos oznaczają, czy to numery pożądkowe?

    dbd ma nowszy skaner 0102H -> prod. scalaka 2-gi tydzien 2001 , 0038H -> 38-my tydzien 2000 ; oznaczenia ukladu Plusteka te same analogicznie ten mniejszy - prawdopodobnie przetwornik A/C
    Cytat:

    I czy jeszcze coś się da zmierzyć? Czy to oznacza, że procesorma napięcie? Może kupić nowy kwarc, o mnierzyć nie da u mnie rad :-(?

    bedziesz wymienial po kolei ? podpinales do kompa i sprawdzales czy cos sie dzieje ?

  • #73 09 Kwi 2005 12:45
    Agentlos
    Poziom 25  

    Schowany wózek, znajduje sie idelanie nad płytką. Do komputera jeszcze nie podłączałem, bo nie napisaliście, czy jest jakieś ryzyko, a pytałem o to na wcześniejszej stronie.

  • #74 09 Kwi 2005 13:05
    TONI_2003
    Moderator

    ... ale w jaki sposób został schowany ?
    Jeśli go ręcznie przesuniesz do środka to powinien po podaniu napięcia bez podpinania do komputera sam zaparkować .
    Jeśli tak jest i pozostałe płytki elektroniki dobrze posprawdzałeś to
    według mnie można już go po testować na kompie.

  • #75 09 Kwi 2005 13:16
    Agentlos
    Poziom 25  

    Mo ostastni komentazr był do:

    Cytat:
    jak tak to rozumiem, wtedy wozek wlecialby gdzies nad plytke Wink
    Wózek z lampą nie rusza sie. jak go postawie na środku tak stoi. Zaraz sprawdze, czy po podamnie napięcia i podłączeniu do kompa, zacznie się swiecić lampa od skanowania negatywów (nie powinna).

    Update:

    CUD!!!!! Wykrył poprawnie skaner!!! Po nacisnięciu na skanowanie negatywów, cofnał lampę do początku!!!! I zeskanował negatywów!! Teraz skanuje wszystko ciszej i bardzo dobrze. Jak mam Wam dziekować!!!! Sam nie wiem!!!

    Pamiętna data naprawienia: 13:12 9.04.2005
    Proszę nie zamykać tematu! Mój problem rozwiązany? A co ze skanerem _Predator_'a?
    Jeszcze zeskanuje winowajcę i załącze go w następnym poscie, dla potomnych!


    Witam. A oto winowajca :-). Troszke go przedwczoraj uszkodziłem przy wymianie na nowu, ale da się poznać. Muszę zmienić stery, bo na tych bardzo jasko wyszedł skan, a nie powiniem.

    TONI_2003, WojtasJD, Bbd - nie wiem na prawdę jak Wam dziekować! Jesteście świetni!

  • #76 09 Kwi 2005 15:14
    TONI_2003
    Moderator

    ... kolego Agentlos jeszcze tylko jedno pytanie dla Ciebie
    czy ten układ , a raczej jego wygląd na tym skanie to efekt awarii
    czy też Twej ingerencji w trakcie jego demontażu ?
    Pozdrawiam brać lutującą !

  • #77 09 Kwi 2005 18:22
    Agentlos
    Poziom 25  

    Element ten był przyczyną awari skanera. Zauważyłem na nim wypukłość i malutką białą kropeczkę. Zrobiła sie grudka. Teraźniejszy wyglą tego elementu to 2 godzinna praca nad nim. Mam tylko zwykłą lutownicę 30W i na szczęście dostałem odsysacz. Niestety nieco brutalna metodą, wyrywałem nogi cążkami (aż mnie się pokrzywiły i musiałem prostować), aby bo w jakiś sposób wyjąc i jest jak jest. Teraz w skanerku siedzi elegancko wlutowany nowy układ o jakim pisał na poprzedniej stronie WojtasJD czyli MC34063A.

    Teraz testuje skaner, i jak na razie jest dobrze. Dziwi mnie to, że skaner cofa wózek dopiero wtedy, gdy naciśnie się na prescana ub na skanowanie => wtedy wróci do początku, oraz aczne skanować aktualna stronę. Oczywiście chodzi o to, że pozostawie wózek na środku samemu go tam ustawiając. Czyli jendak same napięcie mu nie wystacza. potrzeba jeszcze czegos co mu każe ten wózek ruszeć :-).

    A tak jeszcze co do konserwacji skanera, to czym nasmarować rurkę po której porusza się skaner? Posmarowałe smarem do łożysk szybko obrotowych, lecz teraz sam nei wiem czy dobrze zrobiłem. Czy nie lepszy był by olejek silikonowy? Podobno nadaje się do takich rzeczy.

    Dodano po 2 [godziny] 48 [minuty]:

    Witam. No i mam problem... Mam jeszcze jedno pytanie. Silnik od skanera bardzo mocno się grzeje. Jest bardzo gorący! Powiem szczeże, że nawet paży :-(. A teraz napisze przez co. Mianowicie, wózek z lampą blokuje sie czasem, nie wiem z jakiego powodu, a silnik usuilnie rprobuje go posunąć. Gdy już skanuje skanuje bardzo łądnie. Nie mam żadnych zastrzeżeń Tylko czemu sie blokuje? Benę musiał go jeszcze raz rozkręcić... Czyżby silnik mógł sie uszkodzić? Przecież skaner skanuje poprawnie ? (jak oczywiscie zdoła wyjechać. Aż cały skaner się trzęsie a lampa nie drgnie...

  • #78 09 Kwi 2005 20:31
    dbd
    Poziom 15  

    sprawdź czy przypadkiem nie posmarowałeś paska zębatego, może się też zdayc, że jest troche za luźny. Sprawdź też szczeline między szybą a lampa (wózkiem) - mnie sie raz zablokował jak za mocno przycisnąłem skanowany zeszyt. Smar do łożysk powinien wystarczyc.

    p.s. AMSJ4063P ładnie by wyglądał jako pomiątkowy naszyjnik... pomyśl o tym :wink:

  • #79 09 Kwi 2005 21:16
    TONI_2003
    Moderator

    Agentlos napisał:
    Dziwi mnie to, że skaner cofa wózek dopiero wtedy, gdy naciśnie się na prescana ub na skanowanie => wtedy wróci do początku, oraz aczne skanować aktualna stronę. Oczywiście chodzi o to, że pozostawie wózek na środku samemu go tam ustawiając. Czyli jendak same napięcie mu nie wystacza. potrzeba jeszcze czegos co mu każe ten wózek ruszeć .

    Myślę że kolega dbd mógłby ten problem wyjaśnić ! Czyli jak jego skaner się zachowuje bo ja akurat miałem do czynienia ze skanerami innej firmy więc nie mogę i nie powinienem tego jednak tak samo traktować. Poza tym czasami właśnie może to być istotne jeżeli chodzi o samą pracę i grzanie się silnika bo nie wiadomo na razie tak do końca jaka jest tego przyczyna?

  • #80 09 Kwi 2005 22:14
    dbd
    Poziom 15  

    Wydaje mi sie że już tak jest z tym wracaniem wózka. Ja mam to samo - wraca dopiero na prescanie. Możesz ustawic prescan żeby uruchamiał sie automatycznie. Powinno sie wyswietlic "please wait while scanner resets". Prawdopodobnie wózek (skaner) czeka właśnie na ten sygnał (prescan/scan) i skoro nie ma tego sygnału to po co wracac wózek. To jest chyba zależne od firmy skanera :roll:. Tymczasowo nie mam skanera i tymczasowo nie moge dokładniej odpowiedziec na to pytanie.

  • #81 09 Kwi 2005 23:49
    Agentlos
    Poziom 25  

    Co do przyczyny grzania się silnika, to podejrzewam, że mógł się on zgrzać, przez to, że zrobiłem prescana, a sam wózek mimo prób zaklinował się w wyjściowym miejscu. Jeszcze nie wiem dla czego tak się dzieje... czyżby jakis paproch wleciał do środka? Nie umiem tego określić. Jak na razie skanuje dobrze poza tym felerem.

    A co do cofania wózka, to po zeskanowaniu cofa sie do początku, tylko jeśli ustawie go ręcznie na środku, to zanim nie naciśne Scan, lub Prescan, to nie powróci na miejsce startu. Witać taka marka.

  • #82 31 Sty 2006 17:27
    wojtekzak
    Poziom 11  

    Witam.
    Chciałbym zauważyć, że napięcie 32V bez obciążenia na zasilaczu jest chyba odpowiednie gdyż ja takie mam napięcie na moim zasilaczu przy skanerze Plustek OpticPro PT12 a raczej zasilacz mam sprawny, bo skaner prawie mi działa. Prawie bo raz go komp widzi i skanuje dobrze, a raz go nie widzi i pokazuje się właśnie ten komunikat:

    Pozdrawiam Wojtek

  • #83 31 Sty 2006 21:13
    Agentlos
    Poziom 25  

    Cytat:
    Prawie bo raz go komputer widzi i skanuje dobrze, a raz go nie widzi i pokazuje się właśnie ten komunikat:

    Czy czytałeś cały temat czy tylko częściowo?
    Pytam ponieważ na PIERWSZEJ stronie w poście z dnia 29 Mar 2005 18:19 zamieściłem dwa screen'y jeden taki jak ty i drugi co pokazuje się po naciśnięciu przycisku do wykrywania skanera (Scanner Utility). Odpowiedz na twoje pytanie jest zaraz po moim pytaniu:
    dbd napisał:

    masz racje, dziwne to jest... zdrowy rozum podpowiada, że wypadałoby zostawić "capture printer port" zaznaczone, ale goście od Plusteka myśleli inaczej. Być może jest to błąd w programowaniu (zamiast False wpisali True albo odwrotnie... nie wiem). Ja mam odhaczone i drukarka drukuje normalnie, nawet sama się włącza Smile a lampa w skanerze sie nie zapala.


    Czyli musisz po prostu odznaczyć w Scanner Utility pole [b]Capture Printer Port[b] i będzie działać. U mnie ustawienia zapisują się tylko na jedną sesję - gdy komputer sie zresetuje [b]Capture Printer Port[b] jest znów zaznaczone.

    Chciałbym dodać, że z tym błędem nie jest tak że raz widzi skaner a raz nie. Przynajmniej u mnie po wydrukowaniu czegokolwiek na drukarce skaner przestawał funkcjonować, oraz gdy zeskanowałem coś i wyłączyłem okno skanowaniu :D - kiedyś co pomyłkę lub wydrukowanie czegoś resetowałem komputer. Receptą jest powyższa metoda która działa :D.

    Pozdrawiam.
    Agentlos.

  • #84 14 Kwi 2006 08:26
    mumin66
    Poziom 10  

    Nawiążę do przyspieszenia. Ogólnie to jest nierealne ale mam pewien pomysł. Może nie da sie przyspieszyć samego skanowania przy kartce ale przy wielu... Mianowicie skaner po skanowaniu wraca na pozycję startową. I tu dwa pomysły:
    1. Przerobić elektronikę (moze tylko przełączać zasilanie silniczka?)/sterowniki by skanował dwuprzebiegowo (tzn. nie wracał do pozycji startowej tylko skanował)
    2. Przerobić elektronikę żeby szybciej wracała głowica (ew. dodać drugi napęd)

    3. kupić lepszy skaner ;-)

TME logo Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
TME Logo