Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Fibaro Fibaro
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Monitoring naszych instalacji OZE - www.PVmonitor.pl

putas 10 Sie 2016 18:26 146853 1491
  • #1231 10 Sie 2016 18:26
    mcz1
    Poziom 19  

    Sprawa jasna, poczekam do nowego softu. Jeszcze jedno pytanie. Mam wykorzystane wejście INP1D oraz INPD2D do zdalnego monitorowania działania pomp. Standardowo używamy tych wejść do liczników energii elektrycznej, a przydałoby się aby widzieć na tle wykresów temperatur działanie pomp na zasadzie wł/wył albo 0 - 1. Sterowanie pompami jest niezależna od lankontrolera, ale on przekazuje jedynie dane przez sieć.

  • Fibaro
  • #1232 15 Sie 2016 11:43
    PV_Albert
    Poziom 19  

    PV_Albert napisał:
    Walczę z wifi esp8266. Czy ktoś opanował wysyłanie na pvmonitor przez komendy AT?
    Nie chcę zagłębiać się w lule i tego typu pier... Czytam i zaczynam podejrzewać, że komendami AT też da się to zrobić.


    Udało się wysłać przy pomocy esp8266 i komend AT dane na pvmonitor.
    Testuje dwa dni wysyłkę co 3min i jak na razie bez jednego potknięcia.
    pvmonitor
    Komendy wysyłam przy pomocy arduino nano.
    Najprostsza sekwencja wygląda tak:

    AT+CIPSTART="TCP","77.232.78.68",80
    AT+CIPSEND= (liczba bajtów do wysłania)
    “>”
    GET /pv/get.php?idl=xxx&p=xxx&f1=17 HTTP/1.1\r\nHost: pvmonitor.pl\r\n\r\n
    AT+CIPCLOSE

    Po zamianie na kod wygląda tak:
    mySerial.println("AT+CIPSTART=\"TCP\",\"77.232.78.68\",80");
    delay(1500);
    mySerial.print("AT+CIPSEND="); mySerial.println(sendcommand.length());
    delay(500);
    mySerial.print(sendcommand);
    delay(1500);
    mySerial.println("AT+CIPCLOSE");

    Kilka uwag:
    Wiele pisze się o zapewnieniu dobrego zasilania 3.3V modułowi esp8266. Nie lekceważyłem tego, ale nie sądziłem że aż tak jest to istotne.
    Obecnie zasilam esp napięciem 3.5V i łącze bezpośrednio z arduino zasilanym 5V (wspólna masa), przy czym nadawanie do esp jest zrobione na dzielniku napięcia.
    Transmisja może być jednokierunkowa, czyli tylko nadawanie do esp.
    Obecnie używam dwukierunkowej i na dodatek w ramach testu używam bibliotekę SoftSerial. Spisuje się bez błędów.
    Dzięki metodzie z komendami AT nie musimy zajmować się pisaniem skryptów, zmianami firmware i innymi tego przygniatającymi kłopotami.
    Po prostu bierze się moduł od Chińczyka, wstawia w układ i już.
    Załączam prościutki program tzw. zaczepny.

  • Fibaro
  • #1233 19 Sie 2016 17:24
    wojtekosiek
    Poziom 10  

    Witam mam lk 2 soft 3.15 podpięty mam czujnik LA100-P według instrukcji z opornikiem 72 Ω ACS 5 i w polu Inp4 cały czas skacze wartość od 1 do 6 A a prąd jeszcze nie płynie przez czujnik Panowie poradźcie coś

  • #1234 19 Sie 2016 17:52
    idepopizze
    Poziom 31  

    @wojtekosiek
    A nie masz w pobliżu czujnika jakiegoś źródła pola magnetycznego (magnes, itp) ?
    Nie znam tego LA100-P ale zakładam że jest tam w nim coś podobnego do acs712

  • #1236 22 Sie 2016 21:42
    mcz1
    Poziom 19  

    Cytat:
    podpięty mam czujnik LA100-P według instrukcji z opornikiem 72 Ω ACS 5 i w polu Inp4 cały czas skacze wartość od 1 do 6 A a prąd jeszcze nie płynie przez czujnik
    Czy zasilanie czujnika jest dokładnie wyfiltrowane? Sprawdź miernikiem czy napięcie na oporniku jest zgodne z notą katalogową, ewentualnie pomierz miernikiem napięcie podawane na lankontroler. Może coś indukuje się na masie, albo masy obu zasilaczy nie są razem podłączone. Czujnik wymaga zasilania symetrycznego, a lankontroler wykrywa sygnał niesymetryczny, dodatni względem masy. Być może trzeba odwrotnie przełożyć drut przez czujnik.

  • #1237 22 Sie 2016 23:02
    wojtekosiek
    Poziom 10  

    mcz1 napisał:
    Cytat:
    podpięty mam czujnik LA100-P według instrukcji z opornikiem 72 Ω ACS 5 i w polu Inp4 cały czas skacze wartość od 1 do 6 A a prąd jeszcze nie płynie przez czujnik
    Czy zasilanie czujnika jest dokładnie wyfiltrowane? Sprawdź miernikiem czy napięcie na oporniku jest zgodne z notą katalogową, ewentualnie pomierz miernikiem napięcie podawane na lankontroler. Może coś indukuje się na masie, albo masy obu zasilaczy nie są razem podłączone. Czujnik wymaga zasilania symetrycznego, a lankontroler wykrywa sygnał niesymetryczny, dodatni względem masy. Być może trzeba odwrotnie przełożyć drut przez czujnik.

    Napięcie za opornikiem jest 1.6 V zasilanie LK 12 V

  • #1238 23 Sie 2016 22:17
    mcz1
    Poziom 19  

    Cytat:
    Napięcie za opornikiem jest 1.6 V zasilanie LK 12 V

    Czy podłączyłeś według instrukcji http://www.dacpol.eu/pl/przetwornik-pradu-z-z...t/przetwornik-pradowy_LA-100-P_LEM#dopobrania
    a dokładniej według schematu: Monitoring naszych instalacji OZE - www.PVmonitor.pl

    Jeśli przetwornik jest ok, a nie płynie prąd przez kabel przełożony przez przetwornik to napięcie na oporniku powinno być bliskie zeru. Według dokumentacji przy prądzie 100 A w prąd wyjściowy wynosi 50 mA, czyli jeśli masz opornik 72 omy, to napięcie na nim masz 3,6V w plus, albo w minus zależnie od kierunku prądu.[/img]

  • #1239 24 Sie 2016 00:30
    wojtekosiek
    Poziom 10  

    mcz1 napisał:
    Cytat:
    Napięcie za opornikiem jest 1.6 V zasilanie LK 12 V

    Czy podłączyłeś według instrukcji http://www.dacpol.eu/pl/przetwornik-pradu-z-z...t/przetwornik-pradowy_LA-100-P_LEM#dopobrania
    a dokładniej według schematu: Monitoring naszych instalacji OZE - www.PVmonitor.pl

    Jeśli przetwornik jest ok, a nie płynie prąd przez kabel przełożony przez przetwornik to napięcie na oporniku powinno być bliskie zeru. Według dokumentacji przy prądzie 100 A w prąd wyjściowy wynosi 50 mA, czyli jeśli masz opornik 72 omy, to napięcie na nim masz 3,6V w plus, albo w minus zależnie od kierunku prądu.[/img]


    Podłączony jest według schematu to wygląda że jest uszkodzony jurto puszczę przez niego 100A i sprawdzę napięcie za opornikiem

  • #1240 02 Wrz 2016 21:11
    206cc
    Poziom 16  

    Panowie a wiadomo kiedy pojawi się pomiar prądu za pomocą LA100-P w sofcie napisanym typowo pod fotowoltaike do Lan kontrolera V2

  • #1241 21 Paź 2016 14:09
    dadi3337
    Poziom 9  

    206cc napisał:
    Panowie a wiadomo kiedy pojawi się pomiar prądu za pomocą LA100-P w sofcie napisanym typowo pod fotowoltaike do Lan kontrolera V2


    A da reade tym mierzyc prąd zmienny???????
    Za inwerterem????

  • #1242 22 Paź 2016 22:00
    mcz1
    Poziom 19  

    Za inwerterem najprościej mierzyć moc prądu zmiennego za pomocą najprostszego licznika energii elektrycznej. Jeśli dodatkowo ma transmitować produkcję na pvmonitor.pl to musi mieć wyjście impulsów podłączone do wejścia lankontrolera.

    Cytat:
    A da reade tym mierzyc prąd zmienny???????
    Oczywiście LA100-p potrafi mierzyć prąd przemienny podając na swoje wyjście odpowiedni przebieg elektryczny będący dokładnym, chwilowym odzwierciedleniem płynącego prądu łącznie z jego kierunkiem.

  • Fibaro
  • #1244 23 Paź 2016 10:44
    januszo13
    Poziom 9  

    Czy majac inwerter Steca i monitoring przez ich portal moge przesyłac swojwe dane na PV monitor, inwerter mam podlaczony do swojej sieci lan

  • #1245 09 Lis 2016 21:20
    Thew_666
    Poziom 20  

    Witam kolegów,

    Oj nieładnie ostatnio zauważyłem kilka rzeczy na naszym serwerze, a mianowicie kosmiczne błędy np z instalacji i mocy paneli 4160Wp dzienna produkcja 60kWh
    i inne.

    Załączniki:
  • #1247 09 Lis 2016 21:30
    206cc
    Poziom 16  

    moze wczesniej nie miał internetu i dane są zsumowane z kilku dni jak net wrocił?

  • #1248 10 Lis 2016 07:06
    synology1
    Poziom 14  

    Potwierdzam to co kolega napisał Thew_666 u mnie też raz na jakiś czas fałszuje wynik występuje to w moim przypadku na zasilaniu z sieci.Co ciekawe że ten sam kontroler przesyła mi wyniki na mój serwer i na pv monitor i błąd pojawia się na pv monitorze .Nie jest to częste zawyżanie ale raz na jakiś czas być może w skali roku troszkę się uzbiera zawyżonych kW.
    Monitoring naszych instalacji OZE - www.PVmonitor.pl

    Thew_666 napisał:
    Witam kolegów,

    Oj nieładnie ostatnio zauważyłem kilka rzeczy na naszym serwerze, a mianowicie kosmiczne błędy np z instalacji i mocy paneli 4160Wp dzienna produkcja 60kWh
    i inne.

    z drugiej strony przecież nikt nie robi tego celowo,a administratorzy strony dużo roboty wykonali dając darmowe narzędzie dla użytkowników więc margines błędu zawsze będzie .

  • #1250 21 Lis 2016 01:30
    Lechu1968
    Poziom 1  

    Witam, mam pytanie - czy Lan Kontroler v2.0 będzie poprawnie zliczał z licznika Pafal 12EA5gw (6400 imp/kWh)? Maksymalna moc instalacji PV to 2,5 kW.

  • #1251 21 Lis 2016 14:03
    pawel123321
    Poziom 13  

    Witam
    Tak Będzie poprawnie zliczał, jedynie co to należy wpisać liczbę 6400 w ustawieniach INP4D
    Pozdrawiam

  • #1252 18 Gru 2016 23:14
    adamrex
    Poziom 12  

    Witam,
    Proszę o sprawdzenie czy dochodzą na pvmonitor pomiary temperatur dla wejść:
    Inp12 temperatura *C #23 - T_DZ_powrót (&f24=#23),
    Inp13 temperatura *C #24 - T_PC_powrót (&f12=#24),
    na moje konto GET /pv/get.php?idl=46&p=...............&f11=#21&f12=#24&f16=#20&f22=#22&f23=#19&f24=#23&f10=#34
    Ponieważ nie są kreślone na wykresie.

    Pozdrawiam, adamrex

  • #1253 28 Gru 2016 17:06
    ostanislaw
    Poziom 16  

    synology1 napisał:
    Witam chciałem zapytać odnośnie wyjścia impulsowego w liczniku .Obecnie wyjście impulsowe mam podłączone pod lan kontroler z tego co wyczytałem, to falownik ma wejście aby odebrać z wyjścia licznikowego impulsy czy moge takiego podłączenia dokonać co poniżej aby licznik dawał impulsy do lan kontrolera oraz do falownika.Licznik posiada normę zgodnie z falownikiem który może odbierać sygnały .Z góry dziękuje za pomoc.
    Monitoring naszych instalacji OZE - www.PVmonitor.pl


    Panowie przeczytałem cały temat i jeszcze kopę podobnych ale nie zauważyłem czy był ten problem rozwiązany.
    Mam sterownik Foniusa 6.0.3 i chcę podłączyć Lan kontroler 2.0 . Zależy mi na tym aby impulsy z licznika zużycia wysłać do obu tych urządzeń.
    Liczę na waszą pomoc

    Pozdrawiam
    ostanislaw

  • #1256 29 Gru 2016 19:17
    ostanislaw
    Poziom 16  

    Bilgo a ty u siebie wysyłasz dane o zużyciu do inwertera
    ?

  • #1257 29 Gru 2016 19:26
    BILGO
    Poziom 38  

    ostanislaw napisał:
    Bilgo a ty u siebie wysyłasz dane o zużyciu do inwertera

    Tak, tylko dane z SM (strażnik mocy) przez wejście impulsowe do Froniusa, a Datamananger z Froniusa wysyła na PVMonitor,pl przez usługę PUSH ;)

  • #1258 29 Gru 2016 20:04
    idepopizze
    Poziom 31  

    ostanislaw napisał:
    Czy taki sposób powielenia wyjścia impulsowego SO będzie



    Ja u siebie steruje tak urządzeniem przez PWM z tym, że jeden LED w szeregu jest klasyczny do podglądu i działa.

  • #1259 29 Gru 2016 20:23
    ostanislaw
    Poziom 16  

    Dzięki za odpowiedź jak tylko przyjdą części to robię wysyłanie zużycia. A trzecia dioda led jako podgląd impulsów to całkiem sprytne w końcu i tak prąd trzeba obniżać rezystorem. Myślę że napięcie zastosuję 24V bo mam już w kotłowni zasilacz stabilizowany stale pracujący.
    Pozdrawiam
    ostanislaw

  • #1260 29 Gru 2016 20:38
    BILGO
    Poziom 38  

    ostanislaw napisał:
    Myślę że napięcie zastosuję 24V bo mam już w kotłowni zasilacz stabilizowany stale pracujący.
    Tylko trzeba dobrać rezystor żeby prad był odpowiednim, na poziomie 20mA jeśli dobrze myślę ;)
    ostanislaw napisał:
    Dzięki za odpowiedź jak tylko przyjdą części to robię wysyłanie zużycia.
    A czy twój fronius nie ma wbudowanego Loggera ?

 Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME