Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Atmega8 bład przy połaczeniu

tobi1807 19 Sty 2014 00:02 762 2
  • #1 19 Sty 2014 00:02
    tobi1807
    Poziom 7  

    Witam,
    Jestem początkujący w programowaniu i ostatnio za pomocą programatora asp-USB zaprogramowałem mikro kontroler (dwie migające diody) atmega8l przy zewnętrzy kwarcu 8MHz. Następnie zmieniłem schemat połączeń i rezonator na 12 MHz i od tego momentu gdy próbuje wykryć mikro-kontroler za pomocą programu MKAVR kalkulator pojawia się błąd i nie mogę odnaleźć przyczyny tego, schemat jest poprawnie połączony. Po zasileniu mikro kontroler działa jak wcześniej był zaprogramowany.
    Atmega8 bład przy połaczeniu
    Czy wie ktoś może czego to jest powodem tego błędu?

    0 2
  • #2 19 Sty 2014 07:16
    emarcus
    Poziom 34  

    tobi1807 napisał:
    Witam,
    Jestem początkujący w programowaniu i ostatnio za pomocą programatora asp-USB zaprogramowałem mikro kontroler (dwie migające diody) atmega8l przy zewnętrzy kwarcu 8MHz. Następnie zmieniłem schemat połączeń i rezonator na 12 MHz i od tego momentu gdy próbuje wykryć mikro-kontroler za pomocą programu MKAVR kalkulator pojawia się błąd i nie mogę odnaleźć przyczyny tego,

    Czy wie ktoś może czego to jest powodem tego błędu?


    Podłącz go z rezonatorem 8Mhz do programatora, wtedy winieneś uzyskac komunikację.
    Następnie, aby Mega8 pracował z rezonatorem wyższym od 8MHz potrzebujesz zaprogramowac fuse CKOPT znajdujący się w 'Fuse Byte High'.
    Twój soft MKAVR ma taką automatyczną opcję, albo możesz to zrobic manualnie.
    Ta opcja nie przeszkadza w pracy z rezonatorem 8MHz.

    e marcus

    0
  • #3 19 Sty 2014 13:49
    tobi1807
    Poziom 7  

    Zmieniłem fuse i sprawdziłem układ i zadziałało.
    Dziękuje za pomoc, pozdrawiam

    0