Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

SEAGATE 1T - dysk 1T oprogramowanie widzi 2T

peet_peet 23 Sty 2014 07:40 1638 14
  • #1 23 Sty 2014 07:40
    peet_peet
    Poziom 8  

    Witam,
    Kupiłem nowy dysk SEAGATE ST1000DM003 1T, podpiąłem do systemu aby sklonować system i takie tam, ale w programach do klonowania, zarządzania partycjami itp. pokazuje mi że ma pojemność 2T. początkowo myślałem, że sprzedawca się pomylił i wydał mi większy dysk niż chciałem, ale naklejka na dysku ewidentnie mówi, że to 1T. BIOS też pokazuje że to 1T.
    No i mam problem, bo klonowanie nie wychodzi i nie wiem czy to nie jest wina tego, że ustawione parametry nie odpowiadają fizycznej pojemności czy też są inne problemy (np. EASEUS BAckup wywalił błąd braku pliku boot.ini, którego istotnie brakuje)

    Czy mogę go najpierw sformatować z automatu jak mi system pokaże a potem jeszcze raz ustawiać od nowa partycje aby sklonować dysk systemowy, czy też klonowanie musi się odbyć na czysty dysk ?

    0 14
  • #2 23 Sty 2014 08:21
    conan02

    Poziom 29  

    Klonowanie może być robione zarówno na czysty dysk, bez partycji jak i na używany z założonymi partycjami - ponieważ zmienia format dysku docelowego na taki jak źródłowego.
    Samą operację klonowania trzeba wykonać na innym sprzęcie - nie można klonować dysku z którego pracuje system. Jeśli jest taka potrzeba to użyć bootowalnego CD, np. Hiren's tools i w tym pakiecie jest program Raw Copy - wykonuje kopię posektorową całego dysku. O tyle jest inteligentny, że radzi sobie z różnymi pojemnościami dysków i nie pyskuje, że dyski nie są identyczne. Po kopiowaniu dysk docelowy jest zamienny z oryginałem i można z niego uruchomić system. Ważne, żeby podstawić go w ten sam port SATA co oryginał (musi być na tym samym adresie fizycznym urządzenia) - czyli przepiąć tasiemki.

    0
  • #3 23 Sty 2014 09:02
    peet_peet
    Poziom 8  

    Są dostępne programy, które robią to niejako spod Windowsa (w dużym uproszczeniu). Jeżeli nie przeszkodzi że dysk był już sformatowany i inaczej podzielony to może spróbuję go najpierw sformatować.
    Nadal jednak jest dla mnie zagadką dlaczego apki widzą 2T na dysku 1T ?

    0
  • #4 23 Sty 2014 09:13
    conan02

    Poziom 29  

    Może jest na nim założona partycja 2TB, sam dysk po modelu ma mieć 1TB.
    Nie szkodzi, że dysk był sformatowany. Można dla spokoju usunąć na nim tablicę partycji, choćby z menedżera dysków - usuwając wszystkie partycje.
    Jeszcze dobrze by było sprawdzić np. Crystal Disk Info jaki jest odczyt danych dysku (passport). Może dali uszkodzoną 2TB jako 1TB - sprawna w pierwszej połowie, przyklejając stosowną naklejkę. W Chinach już sporo potrafią kombinować, za trochę będziemy musieli się od nich uczyć.
    Kopiowanie dysku z żywego systemu nie ma sensu nie dlatego, że coś się nie da skopiować, tylko to, że dane na dysku w czasie pracy systemu ulegają ciągłym zmianom i w efekcie kopiowania mamy sieczkę danych na dysku docelowym różniącą się w czasie o godzinę lub więcej.

    0
  • #5 23 Sty 2014 09:36
    peet_peet
    Poziom 8  

    dysk jest nowy, wyjęty z opakowania.
    nie ma na nim żadnych partycji, nie był w związku z tym nawet formatowany.
    po prostu programy do obsługi partycji itd. pokazują że dostępne jest 2T
    i właściwie na tym skończyłem walkę z nim, bo nie wiem co z tym dalej zrobić, żeby czegoś nie popsuć.

    0
  • #7 23 Sty 2014 10:22
    peet_peet
    Poziom 8  

    problem w tym, że Seatool wcale go nie widzi !! myślałem że może to dlatego, że nie jest przygotowany (partycje, format itd.)

    0
  • #8 23 Sty 2014 10:30
    conan02

    Poziom 29  

    A powinien, nie ma znaczenia czy są partycje, czy nie ma. Powinien znaleźć dysk i informacje o nim zapisane w firmware dysku.

    0
  • #9 23 Sty 2014 11:34
    peet_peet
    Poziom 8  

    no to ciekawie zaczyna być...
    BIOS widzi poprawnie
    Disk Wizard widzi 2T
    SeaTool nie widzi wcale

    dziś postaram się go sformatować do jednej wielkiej partycji 100% dostępnej i zobaczymy co z tego wyjdzie... ewentualnie ugerade firmware bo jest wydane dla tego dysku

    jedna rzecz... czy system (Win XP Prof SP2) może mieć na to jakiś wpływ ?

    0
  • #10 23 Sty 2014 13:15
    rradek01
    Poziom 25  

    Dysk Segate 1TB a 2TB rózni się tak jakby grubością. To czuć 2 TB jest tak jakby grubszy.
    Jeżeli masz porównanie z jakimś innym dyskiem to wyczujesz w rękach jaką masz wersje dysku i co Ci Segate dało.


    Moderowany przez Matuzalem:

    0
  • #12 23 Sty 2014 18:04
    peet_peet
    Poziom 8  

    Robiłem co mogłem, ale nic z tego nie wyszło...
    System widzi dysk, właściwe oprogramowanie rozpoznaje model, numer seryjny, firmware.
    Odpaliłem instalator Win XP z nadzieją, że w procesie instalacji systemu uda mi się zrobić format... widział prawidłową ilość miejsca, nawet ustawił partycję, ale nie było opcji format tylko chciał mi gdzieś pliki na innym dysku zapisywać, więc zrezygnowałem... partycja została, ale i tak już w innych aplikacjach nie dało się jej sformatować.
    Nie mam już więcej pomysłów... jeszcze dziś postaram się zrobić coś SeaTool'em pod DOS... może nie da się oszukać.
    W ostateczności mam jeszcze opcję wpiąć go do innego kompa i zrobić na gotowo (partycja, format) ale czy jak wróci na swoje miejsce to już będzie ok, czy dalej będzie widziany jako większy ?



    UPDATE:
    dysk został sprawdzony, założona partycja i zrobiony pełen format... wszystko na innym kompie... czyli dysk jest OK.
    Co zatem może być nie tak, skoro BIOS go widzi, system jako taki też (w menadżer urządzeń, na złączach NVIDIA SATA i jako dysk) a nie widać go w Mój komputer ? nie widać go także w narzędziach administracyjnych !

    Dla porządku dodam, bo nie pamiętam czy pisałem... dysk systemowy też mam SATA i tu wszystko jest OK.
    Uaktualniłem sterowniki SATA dla płyty głównej. przy łączeniu dysków zamieniałem wszystkie kable, aby wykluczyć uszkodzenie po tej stronie.

    Ostatnią deską ratunku jest reinstalacja systemu, ale czy aby na pewno to jest źródło problemu ?


    płyta GA M68M-S2P


    UPDATE: HAPPY END: ROZWIĄZANE:


    No i w końcu opanowałem temat :)
    Powód problemów jest zadziwiający. Zazwyczaj szukając rozwiązania w podobnych problemach (nierozpoznawanie dysków SATA przez instalator Win XP) czytałem, że konieczne jest podanie zewnętrznych sterowników SATA dla płyty bo to wszystko przez ich brak. No to przygotowałem specjalną płytę instalacyjną z dołożonymi sterownikami NVidia SATA dla mojej płyty GIGABYTE (z pomocą nLite) i przystąpiłem do instalowania systemu na nowym dysku. Wcześniej taki manewr się prawie powiódł, bo udało się sformatować ten dysk i rozpocząć instalację (sam ją przerwałem bo chodziło mi tylko o format). Jakież było moje zdziwienie gdy instalator (po załadowaniu tych ekstra sterowników) pokazał mi nowy dysk jako 2T, ale napisał także że nie może uzyskać do niego dostępu. Wcześniej oryginalny instalator wykrywał dysk prawidłowo.
    Wniosek był tylko jeden: to musi być wina sterowników NVidia SATA.
    Zamieniłem płytki z wersji nLite na standard i wszystko wróciło do normy.

    nie kombinując dłużej odpaliłem stary system z drugiego dysku i wywaliłem sterownik NVidia na jednym z portów SATA i zainstalowałem zwykłe IDE (dla bezpieczeństwa nie na tym gdzie miałem dysk systemowy, bo w końcu działał), przepiąłem nowy dysk do gniazda SATA 3 i... i mam dysk 1T, który mogę sformatować, partycjonować i używać do woli...

    Reasumując zazwyczaj powodem problemów z dyskami SATA w Win XP był brak właściwych sterowników... u mnie problemem był ich nadmiar.
    Będę jeszcze sprawdzał czy już po zainicjowaniu dysku i pokazaniu go w systemie będzie możliwa podmiana sterowników znów na NVidię, ewentualnie poszukam nowszych ale już nie na stronie GIGABYTE (bo tam nowszych nie ma) tylko bezpośrednio NVidia.
    Efektami oczywiście się podzielę, gdyby ktoś jeszcze kiedyś trafił an podobny problem.

    0
  • #13 03 Wrz 2014 20:30
    baxjack
    Poziom 8  

    Kolego mam ten sam problem , który miałeś Ty .Ten sam dysk 1Tb i wszystko to samo z wielkością dysku i z programami.Mam pytanie , jeśli zainstaluje system od nowa to problem zniknie?

    0
  • #14 04 Wrz 2014 06:12
    peet_peet
    Poziom 8  

    Tak jak pisałem wcześniej... problemem były sterowniki dla płyty do XP. Odinstalowałem i jest OK. Reinstalacja systemu może nie pomóc bo w końcu załadują ci się te same sterowniki. musisz po prostu ustawić dla wejścia SATA gdzie podepniesz dysk zwykłe sterowniki IDE i po problemie.
    Oczywiście instalacja W7 poradzi sobie z tym inaczej bo już odpowiednio rozpozna i zaciągnie własne sterowniki.

    0
  • #15 04 Wrz 2014 16:47
    baxjack
    Poziom 8  

    Dzięki za pomoc , ale u mnie jak mi się zdaje brakuje sterownika.Mam 3 urządzenia sata , a ten dysk jest 4 urządzeniem.Menedżer w kontrolerach sata pokazuje mi 3 kontrolery czyli obsługują 3 sprzęty.Wgram sterownik ide i zobacze co będzie.Instalować windowsa i tak muszę , bo się krzaczy i może dodatkowo zainstaluję win 7.Jeszcze raz dzięki za pomoc.

    0