Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Połączenie PPPoE - Maska podsieci 255.255.255.255 po stronie WAN - Podział łącza

28 Lut 2014 17:56 3912 19
  • Poziom 9  
    Witam serdecznie.

    Wątek zakładam ponieważ od jakiegoś czasu jestem zmuszony korzystać w domu z internetu, w którym autoryzacja odbywa się poprzez PPPoE, jednakże po poprawnym zalogowaniu się do sieci i uzyskaniu parametrów połączenia, uzyskiwana jest maska 255.255.255.255, która jak wiadomo blokuje wszelki routing.

    Kiedy korzystam z łącza na pojedyńczym komputerze (skonfigurowane połączenie PPPoE w Windows) internet działa, działa również udostępnianie połączenia innym komputerom (ad-hoc z laptopa na WiFi kiedy ten czerpie internet z karty przewodowej).

    Problem pojawia się kiedy chcę używać tegoż łącza w domowej sieci LAN, po podłączeniu się do interfejsu WAN w routerze, połączenie PPPoE jest nawiązywane przez router, ale z wiadomych przyczyn spowodowanych maską podsieci nie następuje żadna wymiana pakietów.

    Moje pytanie brzmi, czy za pomocą bardziej zaawansowanego routera na przykład MT RB951-2n, którego akurat posiadam też w domu można obejść problem tej felernej maski podsieci, uruchamiając na nim coś w rodzaju VPN, tak by działał podobnie do komputera z włączonym udostępnianiem połączenia internetowego.

    Sam nie jestem aż w takim stopniu obeznany w konfiguracji urządzeń MT. Czy w ogóle istnieje możliwość, dzielenia łącza z taką maską?

    Z góry dziękuję za pomoc.
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Specjalista Sieci, Internet
    Do tego wystarczy zwykły router z obsługą PPPoE. Adres WAN jest na routerze a komputery dostają adresy lokalne z sieci 192.168.1.0 z maską 255.255.255.0 i komputery widzą się między sobą.
  • Specjalista Sieci, Internet
    Nie rozumiem czemuś się uczepił tej maski. Połowa komputerów i routerów na sieci ma PPP i maskę 255.255.255.255 i nikomu to nie przeszkadza.

    Daj schemat sieci i napisz co chcesz osiągnąć.
  • Poziom 9  
    Problem tej maski polega na tym, że nie pozostawia ona przestrzeni na adres rozgłoszeniowy oraz adres sieci, przez co router NAT nie jest w stanie odpowiednio kierować pakietów, tak na moja logikę, eksperymenty i posiadaną wiedzę to biorę.

    Do tego tablica routingu, w MT oraz innych routerach z TP-LINKA pokazuje, że to co wychodzi kierowane jest na adres 0.0.0.0.

    Bezpośrednio po przyłączeniu kabla WAN z routera do komputera i odpaleniu połączenia PPPoE internet działa. Dodam, że nie jest to też kwestia adresów MAC, ponieważ próby klonowania i podmian przeprowadzałem.

    Zamieszczam schemat mojej sieci:

    Połączenie PPPoE - Maska podsieci 255.255.255.255 po stronie WAN - Podział łącza

    Adresacja po stronie lan:

    Router/Brama: 192.168.1.1
    AP: 192.168.1.2
    Drukarka: 192.168.1.3

    Komputery oraz urządzenia przyłączone do WiFi korzystają z DHCP w puli 192.168.1.100 - 192.168.1.200.

    Adresacja po stronie WAN/PPPoE:

    Adres IP: 10.0.5.50
    Maska: 255.255.255.255
    Brama: 10.0.5.50

    Po stronie WAN adresacja przypisywana jest automatycznie.

    To co chcę osiągnąć to po prostu możliwość korzystania z tego łącza w obrębie całej sieci LAN, gdyż tak jak pisałem Internet działa tylko kiedy używam go na jednym komputerze - kabel który powinien być wpięty w WAN routera przyłączam bezpośrednio do komputera i łącze się poprzez PPPoE z komputera.

    Kiedy chcę podzielić to łącze i łączyć się z PPPoE routera pakiety pomiędzy LAN i WAN nie są wymieniane.
  • Specjalista Sieci, Internet
    Podłącz

    (internet) ==== (router) ==== (komputer)

    - pokaż status stronę z routera
    - z komputera okno cmd.exe, wpisz
    ping 8.8.8.8
    ping 192.168.1.1
    tracert -d 8.8.8.8
    ipconfig /all

    wklej wydruki do sekcji SPOILER.
  • Specjalista Sieci, Internet
    Podłącz kabel do komputera i daj wynik z ipconfig/all
    Podłącz do WAN TPlinka, ustaw połączenie PPPoE, i daj screen ze statusu routera.
  • Poziom 22  
    Maska 255.255.255.255 oznacza, iż jest to połączenie typu point-2-point. Klient autoryzuje się na serwerze PPPoE i ten decyduje gdzie ma mieć dostęp.
    Strzelam w ciemno, że Twój dostawca blokuje tzw. podwójny NAT, bo dostawca ma NAT i Ty też próbujesz go ustawić lub akurat dostawca blokuje tę adresację, którą masz w sieci LAN (192.168.1.0/24).
  • Poziom 9  
    A więc tak:

    Status z routera:
    Połączenie PPPoE - Maska podsieci 255.255.255.255 po stronie WAN - Podział łącza

    Oraz wyniki wprowadzonych poleceń:
    Spoiler:


    C:\Users\Uzytkownik0>ping 8.8.8.8

    Badanie 8.8.8.8 z 32 bajtami danych:
    Upłynął limit czasu żądania.
    Upłynął limit czasu żądania.
    Upłynął limit czasu żądania.
    Upłynął limit czasu żądania.

    Statystyka badania ping dla 8.8.8.8:
    Pakiety: Wysłane = 4, Odebrane = 0, Utracone = 4
    (100% straty),

    C:\Users\Uzytkownik0>ping 192.168.1.1

    Badanie 192.168.1.1 z 32 bajtami danych:
    Odpowiedź z 192.168.1.1: bajtów=32 czas<1 ms TTL=64
    Odpowiedź z 192.168.1.1: bajtów=32 czas<1 ms TTL=64
    Odpowiedź z 192.168.1.1: bajtów=32 czas=1ms TTL=64
    Odpowiedź z 192.168.1.1: bajtów=32 czas<1 ms TTL=64

    Statystyka badania ping dla 192.168.1.1:
    Pakiety: Wysłane = 4, Odebrane = 4, Utracone = 0
    (0% straty),
    Szacunkowy czas błądzenia pakietów w millisekundach:
    Minimum = 0 ms, Maksimum = 1 ms, Czas średni = 0 ms

    C:\Users\Uzytkownik0>tracert -d 8.8.8.8

    Śledzenie trasy do 8.8.8.8 z maksymalną liczbą 30 przeskoków.

    1 * * * Upłynął limit czasu żądania.
    2 * * * Upłynął limit czasu żądania.
    3 * * * Upłynął limit czasu żądania.
    4 * * * Upłynął limit czasu żądania.
    5 * * * Upłynął limit czasu żądania.
    6 * * * Upłynął limit czasu żądania.
    7 * * ^C

    C:\Users\Uzytkownik0>ipconfig/all

    Konfiguracja IP systemu Windows

    Nazwa hosta . . . . . . . . . . . : KOMPUTERWIN100
    Sufiks podstawowej domeny DNS . . :
    Typ węzła . . . . . . . . . . . . : Hybrydowy
    Routing IP włączony . . . . . . . : Nie
    Serwer WINS Proxy włączony. . . . : Nie

    Karta Ethernet Połączenie lokalne:

    Sufiks DNS konkretnego połączenia :
    Opis. . . . . . . . . . . . . . . : Realtek PCIe GBE Family Controller
    Adres fizyczny. . . . . . . . . . : 94-DE-80-38-0D-76
    DHCP włączone . . . . . . . . . . : Tak
    Autokonfiguracja włączona . . . . : Tak
    Adres IPv6 połączenia lokalnego . : fe80::fcfa:43a7:2f75:e53e%11(Preferowane)

    Adres IPv4. . . . . . . . . . . . . : 192.168.1.100(Preferowane)
    Maska podsieci. . . . . . . . . . : 255.255.255.0
    Dzierżawa uzyskana. . . . . . . . : 28 lutego 2014 20:09:39
    Dzierżawa wygasa. . . . . . . . . : 28 lutego 2014 22:17:01
    Brama domyślna. . . . . . . . . . : 192.168.1.1
    Serwer DHCP . . . . . . . . . . . : 192.168.1.1
    Identyfikator IAID DHCPv6 . . . . : 244637312
    Identyfikator DUID klienta DHCPv6 : 00-01-00-01-19-A6-FE-16-94-DE-80-38-0D-76

    Serwery DNS . . . . . . . . . . . : 193.189.76.10
    192.168.1.1
    NetBIOS przez Tcpip . . . . . . . : Włączony

    Karta tunelowa Teredo Tunneling Pseudo-Interface:

    Stan nośnika . . . . . . . . . . .: Nośnik odłączony
    Sufiks DNS konkretnego połączenia :
    Opis. . . . . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Adres fizyczny. . . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP włączone . . . . . . . . . . : Nie
    Autokonfiguracja włączona . . . . : Tak

    Karta tunelowa isatap.{B00FDDFE-B41D-4170-BFFF-72D972FBE893}:

    Stan nośnika . . . . . . . . . . .: Nośnik odłączony
    Sufiks DNS konkretnego połączenia :
    Opis. . . . . . . . . . . . . . . : Karta Microsoft ISATAP #2
    Adres fizyczny. . . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP włączone . . . . . . . . . . : Nie
    Autokonfiguracja włączona . . . . : Tak

    C:\Users\Uzytkownik0>


    I ipconfig/all bez routera:
    Spoiler:


    C:\Users\Uzytkownik0>ipconfig /all

    Konfiguracja IP systemu Windows

    Nazwa hosta . . . . . . . . . . . : KOMPUTERWIN100
    Sufiks podstawowej domeny DNS . . :
    Typ węzła . . . . . . . . . . . . : Hybrydowy
    Routing IP włączony . . . . . . . : Nie
    Serwer WINS Proxy włączony. . . . : Nie

    Karta PPP InternetWAN:

    Sufiks DNS konkretnego połączenia :
    Opis. . . . . . . . . . . . . . . : InternetWAN
    Adres fizyczny. . . . . . . . . . :
    DHCP włączone . . . . . . . . . . : Nie
    Autokonfiguracja włączona . . . . : Tak
    Adres IPv4. . . . . . . . . . . . . : 10.0.5.57(Preferowane)
    Maska podsieci. . . . . . . . . . : 255.255.255.255
    Brama domyślna. . . . . . . . . . : 0.0.0.0
    Serwery DNS . . . . . . . . . . . : 193.189.76.10
    NetBIOS przez Tcpip . . . . . . . : Wyłączony

    Karta Ethernet Połączenie lokalne:

    Sufiks DNS konkretnego połączenia :
    Opis. . . . . . . . . . . . . . . : Realtek PCIe GBE Family Controller
    Adres fizyczny. . . . . . . . . . : 94-DE-80-38-0D-76
    DHCP włączone . . . . . . . . . . : Tak
    Autokonfiguracja włączona . . . . : Tak
    Adres IPv6 połączenia lokalnego . : fe80::fcfa:43a7:2f75:e53e%11(Preferowane)

    Brama domyślna. . . . . . . . . . :
    Identyfikator IAID DHCPv6 . . . . : 244637312
    Identyfikator DUID klienta DHCPv6 : 00-01-00-01-19-A6-FE-16-94-DE-80-38-0D-76

    Serwery DNS . . . . . . . . . . . : fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    NetBIOS przez Tcpip . . . . . . . : Włączony

    Karta tunelowa isatap.{ED05A871-279F-47EB-BBB7-3C3DD524AD31}:

    Stan nośnika . . . . . . . . . . .: Nośnik odłączony
    Sufiks DNS konkretnego połączenia :
    Opis. . . . . . . . . . . . . . . : Karta Microsoft ISATAP
    Adres fizyczny. . . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP włączone . . . . . . . . . . : Nie
    Autokonfiguracja włączona . . . . : Tak

    Karta tunelowa Teredo Tunneling Pseudo-Interface:

    Sufiks DNS konkretnego połączenia :
    Opis. . . . . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Adres fizyczny. . . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP włączone . . . . . . . . . . : Nie
    Autokonfiguracja włączona . . . . : Tak
    Adres IPv6. . . . . . . . . . . . : 2001:0:9d38:6abd:3800:2718:f5ff:fac6(Pref
    erowane)
    Adres IPv6 połączenia lokalnego . : fe80::3800:2718:f5ff:fac6%12(Preferowane)

    Brama domyślna. . . . . . . . . . : ::
    NetBIOS przez Tcpip . . . . . . . : Wyłączony

    Karta tunelowa isatap.{B00FDDFE-B41D-4170-BFFF-72D972FBE893}:

    Stan nośnika . . . . . . . . . . .: Nośnik odłączony
    Sufiks DNS konkretnego połączenia :
    Opis. . . . . . . . . . . . . . . : Karta Microsoft ISATAP #2
    Adres fizyczny. . . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP włączone . . . . . . . . . . : Nie
    Autokonfiguracja włączona . . . . : Tak

    C:\Users\Uzytkownik0>


    Myślę, że to co kolega napisał o podwójnym NAT ma sens, blokada adresacji po stronie LAN raczej nie wchodzi w grę gdyż próbowałem to rozwiązać już na różnych - z tym samym skutkiem.

    Dziękuję za dotychczasowe odpowiedzi i zaangażowanie się :)
  • Specjalista Sieci, Internet
    Spróbuj ustawić jeszcze w tym routerze. przy PPPoE na Advanced i podać "ISP Specified IP Address:" wpisując tam ip: 10.0.5.57

    U Ciebie widać problem z adresem IP i bramą bo są te same. U mnie na "dwóch internetach" przez PPPoE te adresy są różne.
  • Specjalista Sieci, Internet
    Wypróbuj inne (mniejsze) wartości MTU w PPP ustawienach routera.
  • Poziom 9  
    Niestety koledzy, ani ustawienie adresu IP w polu "ISP Specified IP adress", ani zmniejszenie MTU nie przyniosły rezultatu. Połączenie PPPoE nadal jest, ale brak wymiany jakichkolwiek pakietów.

    Zastanawiam się tylko na jakiej zasadzie działa udostępnianie połączenia w Windows - poprzez zastosowanie komputera mogę sobie już to swobodnie dzielić i wszystko śmiga, problem polega na tym, że nie chcę stawiać do prostej domowej sieci... serwera :D, to Windowsie to chyba jest jakiś VPN, co nie?

    Jestem przekonany, że admin w jakiś sposób zabezpieczył sieć przed routerami, mógł nastawić jakieś blokowanie podwójnych NATów, jak wspomniał kolega TooMeeK.

    Przypominam też, że mam do dyspozycji routerboard MT 951-2n, czy któraś z jego magicznych możliwości może być kolegom pomocna? :)
  • Specjalista Sieci, Internet
    Model router ?

    Dodano po 21 [sekundy]:

    Spróbuj

    ping -i 129 8.8.8.8

    Oprogramowanie routera najnowsze ?
    Także spróbuj reset routera do ustawień fabrycznych i ponowna konfiguracja.
  • Poziom 9  
    Model routera to TP-LINK WR543G. Wgrany jest w nim najnowszy firmware, były już próby fabrycznego resetu i ponownej konfiguracji. Testowałem też to łącze na routerze TP LINK WR740N - rezultat identyczny, oraz na MikroTiku, który posiadam z NATem nastawionym na maskaradę - to samo.

    Wynik badania ping -i 129 8.8.8.8: upłynął limit czasu żądania, 100% straty.
  • Poziom 9  
    Pingi bez routera:
    Spoiler:
    Microsoft Windows [Wersja 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. Wszelkie prawa zastrzeżone.

    C:\Users\Uzytkownik0>ping 8.8.8.8

    Badanie 8.8.8.8 z 32 bajtami danych:
    OdpowiedŸ z 8.8.8.8: bajtów=32 czas=102ms TTL=46
    OdpowiedŸ z 8.8.8.8: bajtów=32 czas=94ms TTL=46
    OdpowiedŸ z 8.8.8.8: bajtów=32 czas=101ms TTL=46
    OdpowiedŸ z 8.8.8.8: bajtów=32 czas=98ms TTL=46

    Statystyka badania ping dla 8.8.8.8:
    Pakiety: Wysłane = 4, Odebrane = 4, Utracone = 0
    (0% straty),
    Szacunkowy czas błšdzenia pakietów w millisekundach:
    Minimum = 94 ms, Maksimum = 102 ms, Czas œredni = 98 ms

    C:\Users\Uzytkownik0>


    Niestety, router WR740N był pożyczony tylko na jakiś czas od znajomego celem przetestowania, nie posiadam już go obecnie do dyspozycji.

    Co ciekawe postanowiłem nieco powęszyć... u paru sąsiadów zakładałem na tym łączu routery z TP-LINKA, WR340G o ile sobie dobrze przypominam, i wszystko śmigało, odwiedziłem dziś jednego z nich i zabrałem ze sobą swojego MikroTika - PPPoE, NAT ustawiony w maskaradzie - wpiąłem się pod kabel WAN sąsiada i internet zaczął śmigać - na moim loginie i haśle, i na moim adresie IP 10.0.5.57.

    Różnica polega na tym, że sąsiad łączy się z tą siecią poprzez łącze 5GHz, a ja z kolei jestem przyłączony do innej stacji bazowej używając łącza WiMax... zabezpieczenia...?
  • Specjalista Sieci, Internet
    No to zostaje ci zwrócenie się do dostawcy.

    Pokaż jeszcze (w konfiguracjie bez router)

    tracert -d 8.8.8.8
  • Poziom 9  
    Wynik polecenia tracert bez routera:

    Spoiler:
    Microsoft Windows [Wersja 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. Wszelkie prawa zastrzeżone.

    C:\Users\Uzytkownik0>tracert -d 8.8.8.8

    Œledzenie trasy do 8.8.8.8 z maksymalnš liczbš 30 przeskoków.

    1 24 ms 79 ms 80 ms 10.0.0.1
    2 54 ms 74 ms 79 ms 172.10.10.1
    3 41 ms 74 ms 104 ms 88.199.233.29
    4 52 ms 79 ms 79 ms 88.199.239.185
    5 53 ms 84 ms 78 ms 88.199.219.2
    6 77 ms 80 ms 78 ms 213.248.97.117
    7 97 ms 99 ms 98 ms 80.91.245.248
    8 96 ms 99 ms 99 ms 80.91.254.253
    9 97 ms 99 ms 98 ms 213.248.89.38
    10 96 ms 104 ms 127 ms 72.14.238.46
    11 97 ms 99 ms 98 ms 72.14.234.237
    12 96 ms 95 ms 99 ms 209.85.254.116
    13 * * * Upłynšł limit czasu żšdania.
    14 148 ms 99 ms 96 ms 8.8.8.8

    ŒŚledzenie zakończone.

    C:\Users\Uzytkownik0>
  • Specjalista Sieci, Internet
    Podłącz komputer przez router i pokaż

    ping 10.0.0.1
    ping 172.10.10.1
  • Poziom 9  
    Niestety, pingi nie przechodzą przez router.

    Spoiler:
    Microsoft Windows [Wersja 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. Wszelkie prawa zastrzeżone.

    C:\Users\Uzytkownik0>ping 10.0.0.1

    Badanie 10.0.0.1 z 32 bajtami danych:
    Upłynął limit czasu żądania.
    Upłynął limit czasu żądania.
    Upłynął limit czasu żądania.
    Upłynął limit czasu żądania.

    Statystyka badania ping dla 10.0.0.1:
    Pakiety: Wysłane = 4, Odebrane = 0, Utracone = 4
    (100% straty),

    C:\Users\Uzytkownik0>ping 172.10.10.1

    Badanie 172.10.10.1 z 32 bajtami danych:
    Upłynął limit czasu żądania.
    Upłynął limit czasu żądania.
    Upłynął limit czasu żądania.
    Upłynął limit czasu żądania.

    Statystyka badania ping dla 172.10.10.1:
    Pakiety: Wysłane = 4, Odebrane = 0, Utracone = 4
    (100% straty),

    C:\Users\Uzytkownik0>
  • Specjalista Sieci, Internet
    Najlepiej jak zwrócisz się do dostawcy, bo dostajesz złą adresację na bramę domyślną.