Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

AT90s2313 - Ustawienie parametrów portu COM w PC w DOS

zipzap 05 Mar 2014 09:04 1155 9
  • #1 05 Mar 2014 09:04
    zipzap
    Poziom 14  

    Witam,
    W sumie to nie wiedziałem gdzie mam opisać mój problem więc może to jest dobre miejsce.
    Mam emulator eprom AVT270. Bardzo fajne urządzenie tylko że jest na LPT. Zbudowałem sobie przejściówkę na usb z wykorzystaniem konwertera USB-COM i AT90S2313. Aby wszystko ładnie działało muszę dodać sterowanie linią CTS na RS232. I tu jest problem. Nie mogę zmusić komputera, żeby odpowiednio ustawił port. Wysyłając dane poprzez program terminala z opcją włączenia uzgadniania RTS/CTS wszystko ładnie działa. Natomiast ustawianie z konsoli poleceniem mode zawodzi. Moje polecenie wygląda tak:

    mode com5: 9600,n,8,1,octs=on

    Bez octs=on transmisja działa ale bez uzgadniania. octs=on traktowane jest jako nieprawidłowy parametr.

    Proszę o pomoc i wskazanie gdzie się mylę w wypisywaniu komendy sterującej.
    Z góry dziękuję.
    P.

    0 9
  • #3 05 Mar 2014 10:08
    zipzap
    Poziom 14  

    No to teraz jestem zakręcony. Używam win7 (64 bit jeśli to ma znaczenie) i stworzyłem sobie plik .bat, w którym pierwsza linia ustawia mode portu, a druga wysyła daną. Czy zatem ten mój niby DOS w Win7 ma nową wersję mode czy nie? Jeśli ma to jak wpisać te parametry żeby było poprawnie?

    0
  • #4 05 Mar 2014 10:16
    BlueDraco
    Specjalista - Mikrokontrolery

    Użyj helpa - wyświetli Ci wszystkie opcje.

    0
  • #5 05 Mar 2014 10:28
    mickpr
    Poziom 39  

    Tytuł postu: Ustawienie parametrów portu COM w PC w DOS
    DOS - to nie Windows 7
    Popraw tytuł postu.

    Wpisz tak:

    Kod: bash
    Zaloguj się, aby zobaczyć kod

    0
  • #7 05 Mar 2014 10:31
    mickpr
    Poziom 39  

    zipzap napisał:
    Wpisuję jak podałem wcześniej i wywala zły parametr,.
    Wpisz jak podałem. W moim przypadku to działa (Windows 7 x64 Professional).

    0
  • #9 05 Mar 2014 10:35
    mickpr
    Poziom 39  

    zipzap napisał:
    A dlaczego nie chciało działać z n,8,1?
    Bo działa tak jak chce Microsoft - dokładnie tak jak napisał kolega BlueDraco - wystarczyło zajrzeć w help (mode /?).

    0