Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

HP dm1 4310sw - Instalacja obrazu systemu z partycji Recovery

chlodvick 15 Mar 2014 00:59 2964 8
  • #1 15 Mar 2014 00:59
    chlodvick
    Poziom 6  

    Witam.
    To mój pierwszy post tutaj więc witam wszystkich.
    Zwykle znajdowałem tu rozwiązania moich problemów w trybie „offline” i do tej pory nie potrzebowałem rejestracji. Jednak ostatnio strasznie namieszałem i proszę o pomoc w sprzątaniu.
    Posiadam Notebook HP dm1 4310sw Windows 8 x64.
    Po porządkach na dysku usunąłem niechcący jedną z partycji zarezerwowanych przez system. Zacząłem kombinować z różnymi metodami naprawy po czym uznałem, że sformatuję sobie dysk i odpalę instalację od nowa. Nie zrobiłem pendrive’a z recovery „no bo przecież wystartuję sobie z partycji recovery i będzie git” – stupid! :-)
    Sformatowałem cały dysk poza partycją recovery i… nie wystartowała tak łatwo.
    Szukałem trochę na forum (i nie tylko) i wiele się dowiedziałem, ale i tak postanowiłem założyć ten temat.
    Nie znalazłem informacji jakie rozmiary domyślnie powinny mieć partycje systemowe w moim przypadku. Ściągnąłem Windows 8.1 Enterprise, utworzyłem te partycje od nowa diskpartem i mam nadzieje, że wystarczy na nich tyle miejsca:
    WindowsRE – 500MB; EFI – 300MB; MSR – 128MB; Partycja na Windows -(reszta dysku- ok.680GB); Recovery (zostało nie ruszane)-14,5GB
    HP dm1 4310sw - Instalacja obrazu systemu z partycji Recovery
    Załączę jeszcze listę wszystkich plików z partycji Recovery (Reco.txt)
    To jest stan istniejący. Partycję Recovery mam zapisaną na innym nośniku + dodatkowo zrobiłem obraz clonezillą.
    Teraz potrzebuję uruchomić programem DISM obraz install.wim z partycji Recovery i postawić go na partycji systemowej. Dodatkowo jeżeli jest to konieczne będę musiał przenieść jakieś dane z Recovery na inne partycje systemowe (WindowsRE, EFI)
    Zrobiłem tak:
    X:\>dism /Apply-Image /ImageFile:\\?\GlobalRoot\Device\Harddisk0\Partition5\preload\install.wim /Index:1 /ApplyDir:C:\
    bcdboot C:\Windows /l pl-PL
    wpeutil reboot
    Kopiowanie obrazu programem dism się powiodło ale przy bcdboot C:\Windows /l pl-PL wyskoczył błąd (Failure when attempting to copy boot file) więc sformatowałem partycję z Windowsem jeszcze raz.
    I teraz pytanie: Co zrobiłem źle?
    Mój cel to: uruchomić system, utworzyć pendrive Recovery tak jak zaleca HP i ponownie już z pendrive’a Recovery uruchomić instalację poprzez F11 (na wszelki wypadek żeby sprawić jak działa i ewentualnie nadpisać jakieś moje pomyłki świeżym systemem). Później wydzielę z partycji c: jakieś miejsce na inne dane.
    Z góry dzięki za pomoc.

    0 8
  • #2 15 Mar 2014 09:32
    WojtasJD
    VIP Zasłużony dla elektroda

    chlodvick napisał:
    Ściągnąłem Windows 8.1 Enterprise
    32-bit | 64-bit :?:
    Podeślij z woluminu RECOVERY po spakowaniu pliki [T:]\boot\BCD.Backup.0001 oraz [T:]\EFI\Microsoft\Boot\BCD (literka T na podstawie spisu plików).

    Dobrze kombinowałeś, trochę zmodyfikujmy - spod WinRE:
    diskpart [enter]
    DISKPART> sel disk 0
    DISKPART> sel part 2
    DISKPART> assign letter=S
    DISKPART> sel part 4
    DISKPART> assign letter=W
    dism /Apply-Image /ImageFile:\\?\GlobalRoot\Device\Harddisk0\Partition5\preload\install.wim /Index:1 /ApplyDir:W:\
    bcdboot W:\Windows /l pl-PL /s S: /f UEFI
    wpeutil reboot

    0
  • #3 15 Mar 2014 15:36
    chlodvick
    Poziom 6  

    Witam.
    Windows 8.1 Enterprise oczywiście 64-bit. W załączniku są pliki o które prosiłeś.
    Zastosowałem się do Twoich porad i po wpisaniu komend nagle widzę logo HP :-)
    Jednak mam jeszcze jedną sprawę: Po ponownym uruchomieniu wyświetla się ekran: Administrator Zapraszamy, a po nim błąd:
    HP dm1 4310sw - Instalacja obrazu systemu z partycji Recovery
    Zaraz zacznę grzebać w googlu ale może wiesz co to?

    Po kliknięciu OK dostaję następny błąd:
    (nie mogę dodać drugiego zdjęcia)
    na oknie "Instalator systemu Windows" mam czerwonego X przy "Preparing software installation", a pogrubione jest "Installation softwares". Okno błędu jest takie same jak poprzednio (ta sama ścieżka) ale dotyczy pliku: HideEXE.vbs

    0
  • #4 17 Mar 2014 07:36
    WojtasJD
    VIP Zasłużony dla elektroda

    Ok, przydałoby się abyś zajrzał w install.wim (można za pomocą 7-Zip) - jakie masz foldery w obrazach pod każdym indeksem oraz wynik z:
    dism /Get-WimInfo /WimFile:T:\preload\install.wim

    0
  • #5 17 Mar 2014 21:44
    chlodvick
    Poziom 6  

    Co do install.wim mam 4 indeksy. Podam screeny z 7z z każdego z głównych folderów. Jeżeli będziesz potrzebował zajrzeć jeszcze głębiej to spróbuję otworzyć je rekurencyjnie w konsoli i przesłać wynik w postaci tekstowej.
    Tak na marginesie, jeżeli ktoś miałby problem z otwarciem pliku install.wim programem 7z, należy użyć wersji alpha 9.30 albo wyżej.
    HP dm1 4310sw - Instalacja obrazu systemu z partycji Recovery
    HP dm1 4310sw - Instalacja obrazu systemu z partycji Recovery
    HP dm1 4310sw - Instalacja obrazu systemu z partycji Recovery
    HP dm1 4310sw - Instalacja obrazu systemu z partycji Recovery
    HP dm1 4310sw - Instalacja obrazu systemu z partycji Recovery
    Co do wyniku polecenia:

    Cytat:
    dism /Get-WimInfo /WimFile:T:\preload\install.wim

    To mam coś takiego:
    Spoiler:

    Deployment Image Servicing and Management tool
    Version: 6.3.9600.16384

    Details for image : T:\preload\install.wim

    Index : 1
    Name : MinimizedImage
    Description : <undefined>
    Size : 13,729,323,831 bytes

    Index : 2
    Name : PureOSApp
    Description : <undefined>
    Size : 5,417,999,661 bytes

    Index : 3
    Name : Drive-C
    Description : <undefined>
    Size : 22,239,387,807 bytes

    Index : 4
    Name : Drive-C:
    Description : <undefined>
    Size : 24,520,911,110 bytes

    The operation completed successfully.

    1
  • Pomocny post
    #6 17 Mar 2014 23:18
    WojtasJD
    VIP Zasłużony dla elektroda

    O właśnie, o to chodziło.
    Jak widzisz \System.sav nie ma w indeksie 1 install.wim, pomocne są też nazwy obrazów więc
    spróbowałbym przywrócić z indeksu 4 (najpojemniejszy) lub z 1 + 2 (minimized image) czyli tak (dodane jest też formatowanie):

    diskpart [enter]
    DISKPART> sel disk 0
    DISKPART> sel part 2
    DISKPART> assign letter=S
    DISKPART> format fs=FAT32 quick label=SYSTEM
    DISKPART> sel part 4
    DISKPART> assign letter=W
    DISKPART> format fs=NTFS quick
    dism /Apply-Image /ImageFile:\\?\GlobalRoot\Device\Harddisk0\Partition5\preload\install.wim /Index:4 /ApplyDir:W:\
    bcdboot W:\Windows /l pl-PL /s S: /f UEFI
    wpeutil reboot


    lub

    diskpart [enter]
    DISKPART> sel disk 0
    DISKPART> sel part 2
    DISKPART> assign letter=S
    DISKPART> format fs=FAT32 quick label=SYSTEM
    DISKPART> sel part 4
    DISKPART> assign letter=W
    DISKPART> format fs=NTFS quick
    dism /Apply-Image /ImageFile:\\?\GlobalRoot\Device\Harddisk0\Partition5\preload\install.wim /Index:1 /ApplyDir:W:\
    dism /Apply-Image /ImageFile:\\?\GlobalRoot\Device\Harddisk0\Partition5\preload\install.wim /Index:2 /ApplyDir:W:\
    bcdboot W:\Windows /l pl-PL /s S: /f UEFI
    wpeutil reboot


    Można by było wyciągnać i wywołać skrypty co by poleceń nie klepać ale skoro już poszliśmy dosyć daleko to można powalczyć.

    0
  • #7 18 Mar 2014 16:46
    chlodvick
    Poziom 6  

    WojtasJD jesteś czarodziejem i jak się kiedyś spotkamy to stawiam piwo :-)
    Zastosowałem się do opcji pierwszej (indeks 4) i system hula aż miło :-) Nie dałbym rady bez Twojej pomocy. Jeszcze raz dzięki.
    Ale mam jeszcze jedno pytanie. Czy nie wiesz może jak sprawić żeby system zobaczył partycję Recovery? Próbuję zrobić pendrive'a Reco, ale Hp Recovery Manager mówi, że partycja Recovery została usunięta, a F11 podczas startu systemu wogóle nie działa. Wydaje mi się, że po tych wszystkich machlojkach system zgubił gdzieś ścieżkę do tej partycji.

    Dodano po 30 [minuty]:

    Przepraszam, że tak post pod postem ale poradziłem sobie. Zamiast szukać pomocy trzeba było pogłówkować. Zdjąłem z partycji Recovery flagi "hide" i "diag" i jest dobrze. Także temat pewnie do zamknięcia.
    WojtasJD jeszcze raz serdecznie dziękuję za pomoc i pozdrawiam.

    0
  • #8 18 Mar 2014 20:46
    WojtasJD
    VIP Zasłużony dla elektroda

    Tak, oryginalnie wolumin RECOVERY chyba ma literę D: i jest partycją OEM. Jak przywrócisz ponownie (bo chyba tak zamierzałeś) to możesz - po wszystkim - wrzucić widok okna Zarządzanie dyskami.
    Powinieneś też mieć działające WinRE (pierwsza partycja 500 MiB)...

    0
  • #9 19 Mar 2014 17:05
    chlodvick
    Poziom 6  

    Tak jak mówisz. RECOVERY to partycja OEM, D:
    Na początku lekko przecholowałem z partycjami WindowsRE i EFI - ja przydzieliłem dla nich odpowiednio 500MB i 300MB. Po reinstalacji z Recovery, HP ustaliło, że mają mieć 400MB i 260MB - zawsze to 140MB oszczędności :-)
    Z resztą zobacz sam.
    Screen z Zarządzania dyskami:
    HP dm1 4310sw - Instalacja obrazu systemu z partycji Recovery
    Recovery z dysku (F11) jeszcze nie sprawdziłem (od wczoraj mielę aktualizacje :-)) ale myślę, że chyba powinno działać. To już mało istotne ale jeżeli Cię to interesuje to mogę sprawdzić i napisać.

    Potwierdzam, Recovery poprzez klawisz F11 podczas uruchamiania działa. Także po zabiegach przeprowadzonych według tego tematu komputer jest doprowadzony do stanu z przed uszkodzenia systemu. System jest przywrócony, partycja Recovery działa i można utworzyć pendrive'a odzyskiwania. Dziękuję za pomoc koledze WojtasJD.
    Temat do zamknięcia.

    0