Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Dziwne zachowanie układu z tyrystorem

krasnalex 22 Mar 2014 19:25 1881 8
  • #1 22 Mar 2014 19:25
    krasnalex
    Poziom 9  

    Witam!
    Jestem w trakcie budowy małej zgrzewarki. Jako sterownika użyłem gotowego microkontrolera Arduino Nano do którego wsad chętnie udostępnię zainteresowanym ale najpierw chciałbym uruchomić moją nową zabawkę. Zgrzewarka jest już ukończona w 99%, problem pojawił się podczas prób zgrzewania, mianowicie na biegu jałowym wszystko działa idealnie słychać jak się załącza trafo na wszystkich zakresach (czasy zgrzewania 10ms, 50ms, 100ms) , podczas wcześniejszych prób używałem żarówki 15W. Podczas próby zgrzewania tyrystor załącza i zostaje w stanie przewodzenia tak długo jak zwarte są elektrody na zgrzewanych blaszkach, po rozerwaniu elektrod tyrystor rozłącza. I tu zwracam się z prośba do zaawansowanych kolegów elektroników o pomoc.

    Moc trafo to 1000W
    Tyrystor to CMA30E1600PB z Igt 28mA
    R 10,11 użyłem z zapasem 830Ohm ( i tu podejrzewam leży problem, nie chcialem usmażyć tyrystora bo dla mnie to najdroższy element mojej zgrzewarki :))

    Dziwne zachowanie układu z tyrystorem

    0 8
  • #2 22 Mar 2014 21:27
    2293657
    Użytkownik usunął konto  
  • #3 22 Mar 2014 21:32
    fuutro
    Poziom 43  

    Transformator może za bardzo mieszać i stąd problem. To, że tam jest mostek to nic, napięcie jest w 100% tętniące wiec jest ok tylko przesuniecie fazowe nie pozwala we właściwym czasie zmaleć prądowi do wartości, przy której tyrystor się wyłączy.

    Tu może być podpowiedź na rozwiązanie problemu.

    0
  • #4 23 Mar 2014 07:16
    jarek_lnx
    Poziom 43  

    Obciążenie indukcyjne zwiększa szybkość narastania napięcia na tyrystorze w chwili wyłączenia, przez co może nie starczyć czasu na wyłączenie, spróbuj ograniczać układem gasikowym RC.

    0
  • #5 23 Mar 2014 07:30
    archanoid
    Poziom 25  

    Witam. Taki układ sterowania transformatorem nie jest najlepszym rozwiązaniem. Transformator jak wiadomo ma dość znaczną indukcyjność i wyłączenie tyrystora przy przejściu napięcia sieci przez zero nie następuje, gdyż indukcyjność transformatora wymusza przepływ prądu. Jak byś włączył oscyloskop równolegle do tyrystora to zobaczysz że podczas zgrzewania napięcie nigdy nie spada do zera, a tym samym nie ma możliwości wyłączenia tyrystora. Lepszym rozwiązaniem jest włączenie dwóch tyrystorów przeciw-równolegle. Polecam lekturę:
    Link rozdział 5.4 od strony 71.

    0
  • #7 23 Mar 2014 09:12
    krasnalex
    Poziom 9  

    Witam i dziękuje.


    jarek_lnx napisał:
    Obciążenie indukcyjne zwiększa szybkość narastania napięcia na tyrystorze w chwili wyłączenia, przez co może nie starczyć czasu na wyłączenie, spróbuj ograniczać układem gasikowym RC.


    Będę najpierw próbował z układem gasikowym. Poza tym znalazłem w domu mały 40 amperowy SSR, więc następnie spróbuje z nim. Poczytam jeszcze i coś na pewno z tego wyjdzie.

    jdubowski napisał:
    Ja bym jeszcze radził sprawdzić czy problem nie tkwi w sterowaniu (Arduino) i w tym celu zastąpiłbym ten układ bateryjką z rezystorem.



    Z Arduino jest wszystko ok. Mam jeszcze zainstalowaną Led jak kontrolkę czasu impulsu i tu wszystko jest OK


    W wolnej chwili będę dalej próbował i podzielę sie wynikami.

    0
  • #8 25 Mar 2014 20:19
    krasnalex
    Poziom 9  

    Witam
    Problem rozwiązany, po kilku nieudanych próbach z gasikami wziąłem się za budowę układu na dwóch tyrystorach. Układ oparty o 2 tyrystory 2N6504 połączonych na przemian równolegle działa tak jak powinien oczywiście z separacją na MOC3041 . Jeden tyrystor nie radził sobie u mnie z prądem powyżej 5A

    Dodano po 3 [minuty]:

    jdubowski napisał:
    Witam . Taki układ sterowania transformatorem nie jest najlepszym rozwiązaniem . Transformator jak wiadomo ma dość znaczną indukcyjność i wyłączenie tyrystora przy przejściu napięcia sieci przez zero nie następuje gdyż indukcyjność transformatora wymusza przepływ prądu . Jak byś włączył oscyloskop równolegle do tyrystora to zobaczysz że podczas zgrzewania napięcie nigdy nie spada do zera , a tym samym nie ma możliwości wyłączenia tyrystora. Lepszym rozwiązaniem jest włączenie dwóch tyrystorów przeciw-równolegle . Polecam lekturę Link rozdział 5.4 od strony 71.



    Fajna lektura dziękuje za pomoc.

    Dodano po 2 [minuty]:

    W wolnej chwili zaprezentuje moją zabawkę w akcji i przyszykuje wsad do Arduino.

    0
  • #9 01 Lut 2016 11:03
    gacek_mb
    Poziom 10  

    Witam
    Ja również zbudowałem zgrzewarkę z identycznym sterowaniem tyrystora,i mam ten sam problem a mianowicie tyrystor nie rozłącza mi trafa. Pytanie moje jak połączyć dwa tyrystory na przemian równolegle aby zadziałało, i jak to połączyć z MOC3041 i jakie oporniki tam zainstalować.Proszę o jakiś schemacik.

    Pozdrawiam

    0