Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Zgrzewarka impulsowa ZI 500C -nowy sterownik na NE555 -czy dobry schemat

predziol 15 Kwi 2014 00:47 4248 4
  • #1 15 Kwi 2014 00:47
    predziol
    Poziom 2  

    Witam
    Wiele lat korzystam z dobrodziejstw forum i przyszedł czas na mój pierwszy temat.Trochę się gubię gdzie wkleić temat.
    Otrzymałem do naprawy zgrzewarkę impulsową ZI 500C -zgrzewarka do folii 1500W.
    Uszkodzeniu uległ sterownik -płytka PCB (powypalane ścieżki, przegrzany laminat od rezystorów 5W, niedziałający stabilizator). Układ wykonany na dwóch układach UCY74121. Schemat udało mi się znaleźć jednak trochę w kilku szczegółach różni się od schematu "ściągniętego" z płytki, inne wartości niektórych elementów itp. Postanowiłem iść na skróty i wykonać sterownik na popularnych NE 555. Zadanie wydawało się banalnie proste ale jednak nie przewidziałem kilku szczegółów. Przeszukując forum, literaturę itp. udał mi się stworzyć schemat i działający prototyp (trochę na płytce uniwersalnej, trochę w pajączku).
    Zgrzewarka impulsowa ZI 500C -nowy sterownik na NE555 -czy dobry schemat
    Pokrótce chciałbym przedstawić zasadę działania (może się komuś przyda) oraz poprosić o ocenę zastosowanych rozwiązań.
    Układ ma za zadanie:
    1) uruchomić elektromagnes (tyrystor TYR1) dociskając zgrzewne elementy
    2) po chwili załączyć grzałkę (tyrystor TYR) -zgrzewanie
    3) wyłączyć grzałkę
    4) po odpowiednim odstępie czasu zwolnić elektromagnes
    Układy US1 i US2 pracują w standardowym układzie monostabilnym, rezystory R3+ PR2, kondensator C3 (dla US1) oraz R7+PR4, kondensator C6 (dla US2) decydują o czasie zadziałania układów, parametry obliczone i przetestowane. PR1 -potencjometr podwójny (umieszczony na obudowie) pozwala na regulację czasu zgrzewania.
    PROBLEM 1
    Zgrzewarkę uruchamia się pedałem nożnym (przycisk ze stykiem NO) i tu pojawił się pierwszy problem. Co by się stało jak by operator nie zwolnił nogi z pedału - US1 nie zwolnił by elektromagnesu po zadanym czasie. Znalazłem rozwiązanie pozwalające wyzwolić US1 impulsem -dodanie kondensatora C3, rezystora R1 oraz diody D1. Obszar zaznaczony na schemacie "A". Wzór jaki znalazłem -czas wyzwalania Twyzw=0,4*R1*C3, odpowiedni czas by nie doszło do tak jakby drgania styku to 30ms, dla R1=1kΩ wychodzi 75µF, dałem 100µF i działa OK.
    Podobne rozwiązanie zastosowałem pomiędzy układami US1 i US2 (R6,D2, C5) konieczne gdyż stan wysoki na wyjściu z US1 (powodujący trzymanie elektromagnesu) i podany na US2 nie pozwolił by na wyłączenie grzałki w zadanym czasie. Rozwiązanie działa.Obszar zaznaczony na schemacie jako "B".
    PROBLEM 2
    Opóźnienie w czasie zadziałania grzałki po zadziałaniu elektromagnesu (obszar zaznaczony jako "C") uzyskałem stosując układ taki jak w oryginalnym sterowniku czyli R4, R5, PR3, C4, T1 (wartości zgodne z oryginałem). Tranzystor T1 zaczyna się otwierać po czasie jak kondensator zostanie naładowany poprzez rezystory do napięcia przewodzenia bazy TR1 czyli coś ok. 0,6V. Układ działa powodując ok 0,5s opóźnienia jednak zmieniając nastawę PR3 nie dostrzegam zmian czasu opóźnienia (być może są ale niezauważalne).
    PROBLEM 3 - najważniejszy który niby rozwiązany ale czy poprawnie. W oryginalnym sterowniku wykorzystuje się wyjście z układu 74121 zanegowane czyli stan niski w czasie odliczania. W czasie oczekiwania jest stan wysoki podany na tranzystor który zwiera bramkę tyrystora do masy oraz rezystor sterujący. W stanie niskim tranzystor zamknięty i prąd oraz napięcie podane na bramkę tyrystora. Rozwiązanie na pewno poprawne (oprócz tego że na zwartym rezystorze wydziela się trochę mocy, co po latach spowodowało przegrzanie ścieżek i laminatu). W rozwiązaniu na NE555 nie ma zanegowanego wyjścia więc trzeba jakoś inaczej. Czy moje rozwiązanie jest poprawne? Czy można dodatkowo zapobiec uszkodzeniu tyrystora. Czytałem, że można dać kondensator równolegle z anodą-katodą, diodę bramka-katoda. Testując układ wyzwalania zaobserwowałem, że przy wartości rezystancji R9 - 50Ω dioda led na obudowie (równolegle na wyjściu na grzałkę) ledwo świeci. Przy 30Ω tyrystor otwarty. Obecnie testuję bez obciążenia, (wiadomo że prąd wyzwalania jest mniejszy przy wzroście napięcia anoda-katoda) ponieważ całej maszyny nie przywiozłem tylko zasilacz ze sterownikiem. Jak będę miał gotowy prototyp przyjdzie i na to czas.
    Chciałbym się upewnić czy nie popełniłem błędu w przypadku sterowania tyrystorami. Wszelkie uwagi i komentarze mile widziane.

    0 4
  • #2 15 Kwi 2014 01:16
    rumcajs2
    Poziom 13  

    W jaki sposób chcesz wyłączyć raz załączony tyrystor?

    0
  • #3 15 Kwi 2014 07:48
    predziol
    Poziom 2  

    Sterownik jest zasilany napięciem stabilizowanym +5V, natomiast sam układ wykonawczy napięciem +50V ale napięciem wyprostowanym tętniącym, więc tyrystor wyłącza się w momencie gdy odcięty jest prąd bramki oraz gdy napięcie anoda katoda tyrystora spada do 0V.

    0
  • #4 15 Kwi 2014 09:38
    PiotrPitucha
    Poziom 33  

    Witam
    Trzy uwagi do układu istniejącego:
    - układ C może generować zbyt wolno narastające przebiegi by wyzwolić drugi 555, dlatego C5 powinien być nienaturalnie dużej pojemności, myślę że ponad 100µF
    - tranzystor w opóźnieniu jest przewymiarowany, jakikolwiek BC zamiast istniejącego BD, dobrze byłoby gdyby miał duże β
    - trochę dziwnie sterujesz tyrystory, dałbym wtórniki emiterowe i potem z emitera na bramkę rezystor szeregowy.
    Teraz uwaga na temat koncepcji, ponieważ to typowy proces sekwencyjny to dałbym zamiast timerów licznik startowany pedałem i zatrzymywany ostatnim impulsem w sekwencji, myślę że CD4017 załatwiłoby sprawę, oczywiście jeśli znasz wymagane czasy.
    A w dobie procesorów po kilka złotych możesz zrobić to jeszcze prościej, nawet jeśli programowanie Ci obce to w sieci natknąłem się na program który z drabinki stosowanej w PLC robi wsad do Atmegi ( i nie tylko ).
    Pozdrawiam

    0
  • #5 16 Kwi 2014 00:27
    predziol
    Poziom 2  

    Dziękuję za podpowiedzi. Jeśli chodzi o kondensator C5 to próbowałem najpierw właśnie 100µF i działało. Obecnie mam wlutowany 10µF i też działa. Kondensator C3 na pewno pozostanie 100µF.
    Tranzystor w opóźnieniu najpierw zastosowałem BD135 jednak obecnie mam BC107 (jak w oryginalnym sterowniku -nie zauważyłem jakiejś różnicy). Co do wtórnika.. całe popołudnie i wieczór spędziłem na testach. Na studiach (elektrotechnika) całkiem sprawnie liczyłem punkty pracy tranzystorów jednak teraz wszystko uleciało z pamięci a minęło 8 lat. Wtórnik czyli układ ze wspólnym kolektorem mam nadzieje ze poprawnie zlutowałem wg schematu:
    Zgrzewarka impulsowa ZI 500C -nowy sterownik na NE555 -czy dobry schemat
    R9 - tak jak wcześniej trzy równolegle połączone rezystory 100Ω czyli wypadkowo 33Ω (przy dwóch tyrystor nie załączał). Co się okazało w takim układzie nie zadziałało. Badając spadki napięcia stwierdziłem że tranzystor się w pełni nie otwiera,, napięcie emiter-kolektor ok 2,5V, więc rezystor R8 -560Ω zbocznikowałem takim samym -wypadkowa rezystancja 265Ω -układ nie zadziałał. Zdziwiło mnie niskie napięcie podawane na bramkę tyrystora ok 1,5 V. Zacząłem zwiększać napięcie zasilające stabilizatorem i przy ok 7,5V zapaliła się dioda sygnalizująca otwarcie tyrystora. No w końcu :) coś do przodu. Podłączyłem obciążenie w postaci czajnika elektrycznego 2kW czyli przy 50V zasilania w przybliżeniu 0,5kW -nie działa. Po dłuższych próbach i pomiarach zniechęcony powróciłem do wcześniejszego układu czyli od plusa rezystory 33Ω na kolektor, emiter na bramkę tyrystora. Układ z obciążeniem działa przy 5V. Jeszcze może pogłówkuję, na dzisiaj koniec.
    Co do zastosowania mikroprocesora jestem jak najbardziej za, jednak miało być szybko i tanio. Programowałem na studiach w asemblerze 81C51, a w technikum w BASCOMIE jednak brak programatora oddalił ten pomysł. Tak czy inaczej niezależnie od układu sterowania, ukłąd wykonawczy bedzie podobny jak nie taki sam. Z tyrystorem oprócz laboratorium w szkole nie miałem jeszcze styczności, z triakami owszem ale tam stosowałem optotriaki i zawsze działało, fakt elementy te były na niższe prądy.

    0