Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

MCP2551 - Odbiór jest nadawania brak.

karol75 07 Maj 2014 09:16 2325 5
  • #1 07 Maj 2014 09:16
    karol75
    Poziom 16  

    Schemat podłączenia MCP2551
    MCP2551 - Odbiór jest nadawania brak.
    Dalej jest połączenie do MCP2515 i AT91SAM7S256

    Mogę odbierać ramki z samochodu (500kbit) i wszystko ok.
    Problem w tym że nic nie przechodzi od MCP2515 przez MCP2551 dalej.

    Połączyłem dwa identyczne układy (na schemacie widać 1 diodę) i diody na lini TX migają, a diody na lini odbiorczej jiż nie.
    Podejżałem stan pinu 1 układu MCP2551 i przebieg na oscyloskopie wygląda podobnie do tego
    MCP2551 - Odbiór jest nadawania brak.
    Więc MCP2515 nadaje.

    Pytanie co jest nie tak, czy mam uszkodzony MCP2551 w obydwu układach.
    To trochę dziwne ponieważ obydwa z samochodu odbierają dane, a podłączone na stole już nie, czyli brak nadawania. Ale co może być przyczyną tego?


    Proszę mi nie przenosić wątku, dyskusja jest ściśle związana z innymi wątkami na tym forum.

  • #2 07 Maj 2014 17:05
    Loker
    Poziom 37  

    Skoro już się uparłeś na takie dopasowanie poziomów napięć to sprawdź, czy wszędzie masz wymagane pull-up'y.

    Q3 zbędny - wystarczyłby dzielnik rezystancyjny. A jeśli byś użył np. MCP2562, to dopasowanie w ogóle zbędne ;)

  • #3 08 Maj 2014 08:27
    karol75
    Poziom 16  

    Loker napisał:
    Skoro już się uparłeś na takie dopasowanie poziomów napięć to sprawdź, czy wszędzie masz wymagane pull-up'y.

    Wszędzie to znaczy gdzie?
    Ponieważ Ja odbieram, gorzej z wysyłaniem.
    Dioda odbiorcza świeci się do dość mocno, a nadawcza cały czas świeci słabo, a podczaz nadawania się rozjaśni i dalej słabo, moze tutaj mam problemy?

    Oto cała część dotycząca podłączenia do samochodu i zasilanie brane z gniazda OBD

    MCP2551 - Odbiór jest nadawania brak.

    Zasilanie oparte na LM2596 więc nie powinno być z tego tytułu problemu.

    MCP2551 - Odbiór jest nadawania brak.


    Loker napisał:
    Q3 zbędny - wystarczyłby dzielnik rezystancyjny. A jeśli byś użył np. MCP2562, to dopasowanie w ogóle zbędne ;)

    Zadbali bardziej o ESD.
    Co do dopasowania MCP2515 pracunje na 3,3V wolałem dopasowywać 2 linie niż 4 (SPI).


    Wygląda na to że miałem uszkodzony MCP2551 po wymianie jest transmisja za MCP2551.
    Niestety nie mam odpowiedzi ze strony samochodu. Czy ktoś wie może jak z jakiego adresu nalezy wysłać zapytanie do ECU aby odpowiedział.
    według tego
    http://en.wikipedia.org/wiki/OBD-II_PIDs
    powinien to być adres 0x7DF ale u mnie nie odpowiada (samochód to nissan Micra 2003r).
    Fragment ksiązki pokazujący jak powinna wyglądać ramka.
    MCP2551 - Odbiór jest nadawania brak.

    Jeszcze jedno
    schemat
    MCP2551 - Odbiór jest nadawania brak.
    Chodzi mi o zabezpieczenie Lini CAN ta część z prawej (trafiło mi już 2 MCP2551)
    rezystory chcę włożyć 60R pytanie jakiego kontensatora użyć i jaką diodę urzyć ?
    Dodatkowo Linia TXD Ma rezystor podciągający(chyba o niego ci chodziło)jakiej wielkości powinien on być 10k?
    A może całkowicie tak?
    MCP2551 - Odbiór jest nadawania brak.

  • #4 10 Maj 2014 15:14
    cichu
    Poziom 2  

    Witam,
    Troszkę się podepnę pod temat. Moje pytanie jest takie - mam do dyspozycji STM32f107 i dwa rodzaje transcieverów CAN: MCP2551 oraz L9616. Obydwa działają na 5V. Zamierzam się troszkę nimi pobawić i stąd pytanie: jeżeli STM32f107 będzie działał pod 3.3V a transciever CAN pod 5V czy jest potrzebne "coś" między nimi? W niektórych źródłach piszą, że nie ma z tym problemu. Układ będzie zasilany z USB, nie z OBD2 - FT232 do komunikacji z PC planuję na pokładzie. I jeszcze jedno pytanko co do OBD2 - przeglądałem już różne projekty związane z ODB2 np. na ELM327 itp. - i nie wiem czy powinno się GND z OBD2 wraz z masą całego układu łączyć? Jak to powinno wyglądać?
    Pozdrawiam

  • #5 11 Maj 2014 15:06
    alagner
    Poziom 25  

    Co do napięć - sprawdź czy używane przez CAN porty są w 5V tolerant. wtedy raczej problemu nie będzie. W drugą stronę - sprawdź czy transceiver CANa ma zakresy napięć wejściowych, które STM będzie w stanie pokryć.

  • #6 14 Lip 2014 08:08
    karol75
    Poziom 16  

    Rozwiązanie to wymiana MCP na nowy

 Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME