Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel - zamiana 2 formuł na 1 skrypt

hrabia64 13 Maj 2014 15:17 525 0
  • #1
    hrabia64
    Poziom 12  
    Witam,

    Chciałbym prosić o zamianę poniższych 2 formuł na 1 skrypt.

    -------------
    1 Formuła
    -------------

    W kolumnie "C" formuła umieszczona jest w komórkach od C5 do C30.

    Proszę zwrócić uwagę na "RESET=0" - ta komenda "zamraża" wartość komórki,
    jeśli jest spełniony warunek (w danej komórce pojawia się napis "OK" i już nie znika).

    =JEŻELI(ORAZ(RESET=0;C5="OK");"OK";JEŻELI.BŁĄD(JEŻELI(ORAZ(Arkusz1!$D5<>"";Arkusz1!$D5*1>=WYSZUKAJ.PIONOWO(Arkusz1!$B5;Arkusz2!$A$5:$D$29;3;PRAWDA));"OK";"");""))


    -------------
    2 Formuła
    -------------

    Założenia podobne jak w poprzedniej formule.

    W kolumnie "D" formuła umieszczona jest w komórkach od D5 do D30.

    Proszę zwrócić uwagę na "RESET=0" - ta komenda "zamraża" wartość komórki,
    jeśli jest spełniony warunek (w danej komórce pojawia się napis "OK" i już nie znika).

    =JEŻELI(ORAZ(RESET=0;D5="OK");"OK";JEŻELI.BŁĄD(JEŻELI(ORAZ(Arkusz1!$F5<>"";Arkusz1!$F5^0,5^2<=WYSZUKAJ.PIONOWO(Arkusz1!$B5;Arkusz2!$A$5:$D$29;4;PRAWDA));"OK";"");""))


    Z góry dziękuję za pomoc.