Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Raspberry Pi v2 + Barracuda - Raspberry Pi reset podczas dostępu do dysku

dikoj 21 Maj 2014 10:52 2409 8
  • #1 21 Maj 2014 10:52
    dikoj
    Poziom 9  

    Witam,

    Sprzęt:
    Raspberry Pi v2
    Seagate Barracuda 250GB

    Podłączenie:
    Raspberry Pi v2 z oprogramowaniem XBMC (raspbmc). Podłączona pod USB kieszeń z własnym zasilaniem z dyskiem Seagate Barracuda 250GB 3,5''. Nic innego nie jest podłączone przez USB - sterowanie pilotem TV - HDMI-CEC. Sieć przez LAN.

    Problem:
    Do tej pory wszystko było ok. Raspberry od razu po włączeniu wykrywał dysk, prawidłowo odtwarzał filmy.
    Po ostatnim update Raspberry zaczęły się dziać dziwne rzeczy. Podczas dsotępu do dysku następuje reset mailnki. Dzieje się to w różnych mometach. Raz od razu, raz na poziomie drugim katalogów, raz podczas próby odtworzenia filmu, a niekiedy normalnie odtwarza film.
    Po restarcie resetuje się też do fabrycznych ustawień rozdzielczość i kalibracja ekranu. Reszta ustawień pozostanie niezmieniona.

    Nie wiem czy to problem ostatniego update-u malinki (google nic nie mówi na ten temat), dysku czy kieszeni.
    Czy macie jakieś propozycje na rozwiązanie problemu?

    0 8
  • #2 21 Maj 2014 14:26
    GrandMasterT
    Poziom 23  

    Spotkałem się z podobnym problemem, gdy w czasie lub tuż po update po prostu skończyła się karta SD.
    U mnie objawiało się to w ten sposób, że praktycznie każda większa akcja w systemie plików (i co dziwne, bez znaczenia, czy dysk czy karta) dawała sporą szansę na zwis lub automatyczny reset. W obu przypadkach w syslogu były tony wpisów o błędach wejścia/wyjścia, może zajrzyj tam i zobacz czy nie ma jakichś informacji.

    0
  • #3 21 Maj 2014 21:24
    dikoj
    Poziom 9  

    Pisząc - "skończyła" karta masz na myśli awarię czy zapełnienie karty?

    Gdzie szukać syslogu?

    0
  • #4 21 Maj 2014 22:08
    młody14
    Poziom 36  

    Mówiąc 'skończyła' ma na myśli to że się skończyła :-)
    Pamięci tego typu mają ograniczoną ilość zapisów i odczytów bloków.

    0
  • #5 21 Maj 2014 22:25
    GrandMasterT
    Poziom 23  

    Dokładnie, zanim przeniosłem cały system na HDD (karta SD wykorzystywana tylko do bootowania) zajechałem 2 karty w dość krótkim czasie. Pierwsza karta, na której najwięcej się 'bawiłem', padła w niecały miesiąc.
    Syslog jest pewnie jak to zwykle bywa, w /var/log/syslog

    0
  • #6 22 Maj 2014 11:32
    dikoj
    Poziom 9  

    Shit! Mam nadzieję, że to nie koniec karty. Kupiłem droższą, szybszą.
    Wieczorem sprawdzę log i spróbuję postawić system na nowej karcie.
    Da się zainstalować RaspBMC w sposób jak opisałeś - boot z karty, system na dysku?

    0
  • #7 22 Maj 2014 15:53
    GrandMasterT
    Poziom 23  

    Podobno da się, jest to nawet na liście 'Main features' systemu, aczkolwiek nie sprawdzałem. Na HDD przeniosłem raspbiana.
    Trochę się rozpędziłeś z tym kupowaniem karty, trzeba było najpierw posprawdzać wszystkie logi, bo może przyczyna leży gdzieś indziej (i może i tak info jakieś będzie w logach).

    Ponadto, jeśli by przerabiać system na jedynie boot z karty + reszta z HDD, to w zasadzie wystarczy najtańsza karta.
    Nie wiem jak wygląda to w przypadku raspbmc, raspbiana da radę zainstalować nawet na jakiejś małej karcie, byleby 'boot' się zmieścił.
    Ja zrobiłem to kopiując obraz z większej karty, oczywiście nie zmieścił się, ale i tak skasowałem wszystko za pierwszą partycją.
    Karta najgorszego sortu, używana tylko przy starcie, więc jej wydajność ma marginalne znaczenie, podczas pracy praktycznie nic nie jest z niej odczytywane ani zapisywane.

    0
  • #8 22 Maj 2014 20:56
    dikoj
    Poziom 9  

    Sprawdziłem log. Niestety nic z tego nie rozumiem. Plik ma ponad 2MB i otwarty przez notatnik tworzy wielki ciąg niezrozumiały dla mnie.

    Kartę sprawdziłem programem Victoria i nie wykrył żadnych błędów.

    Wstrzymuję się na razie przed przeinstalowaniem systemu na obecnej karcie i użyciem nowej karty, bo trochę się namęczyłem konfigurując XBMC i wtyczki.

    0
  • #9 26 Maj 2014 07:49
    dikoj
    Poziom 9  

    Po kilku testach dysku, kart, ponownych instalacji itp, okazało się, że winne jest oprogramowanie. Kluczowym okazał się test przerzucenia na nową kartę obrazu systemu z obecnie uzywanej karty. Sytuacja z resetem się powtarzała. Po świeżej instalacji na tej samej karcie wszystko działa poprawnie.

    Brak zachowywania kalibracji obrazu został poprawiony w najnowszym update rasbmc.

    0